SmartMotion Backups hang for a long period of time. |
Problem:
SmartMotion hang and the percentage of complete showing no progress for a long period of time.
Cause:
The problem is due to the severely damaged file system on one of the VM disks that caused the file system integrity check running on the disk takes a long time. Which literally blocked the reading of the disk and other healthy disks of other VMs, and thus hang the SmartMotion Backups.
If there is such a virtual disk that caused the file system integrity check running on the disk takes a long time, one should find a fsck process consuming large amount of CPU time on the vmPRO appliance, like this sample process:
USER PID %CPU %MEM VSZ RSS TTY STAT START TIME COMMAND
...
root 12001 92.8 5.6 75496 72156 ? R 09:09 217:31 /sbin/dosfsck -p /dev/mapper/e05d417.614177p1
The name of the process could be dosfsck, ntfsck, or e2fsck, depending on the type of file system on the disk.
Using the device ID, for instance e05d417.614177 in the above example, one can correlate it to the disk file (and then VM) by checking it out in the vm_proxy_fs log, like so:
# grep -A1 e05d417.614177 /var/log/vm_proxy_fs
2014-08-30 09:09:37.342736: usage of /tmp/e05d417.614177.panstorage (/vmfs/volumes/3946f36b-ff070480/AUT_Win2003_FAT(2)/AUT_Win2003_FAT_9-000015.vmdk): size 524288000, used 4096
2014-08-30 09:09:37.457599: pan_dev_open /10.30.242.86/AUT_Win2003_FAT87 5/AUT_Win2003_FAT_9-flat.vmdk using direct datastore path /vmfs/volumes/3946f36b-ff070480/AUT_Win2003_FAT(2)/AUT_Win2003_FAT_9-000015-delta.vmdk
Solution:
If the customer encounters the problem, the customer can either removing the VM from backup (un-export the VM), or disabling the file system integrity check using the following steps:
1. On vmPRO GUI, click on Configure > Advanced Settings... to bring up 'Configure Advanced Settings' dialog.
2. Uncheck 'Enable the file system integrity check during backup.' to disable the file system integrity check.
Then reboot the vmPRO appliance and restart the backup policy.
(Note: This information came from vmPRO Bug 6279 and Bug 5808.)
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