Quiesced snapshot backup of VSS enabled virtual machine fails

SR information: SR 1627822

 

Product / Software Version and Configuration: vmPro 3.1.1 (SmartMotion), Windows 2008 R2 VM with VSS enabled

 

Problem Description: Quiesced snapshot backup of VSS enabled VM fails 

 

Overview

 

Customer was concerned after virtual machine backup using VSS failed

 

Symptoms/Troubleshooting

 

While quiesing a virtual machine for backup using Volume Shadow Copy Service (VSS), the snapshot creation fails.

 

Following errors messages are reported:

 

In the SmartMotion log (/var/log/smartmotion) you see:

 

smartmotion/ERROR:: Tomato.py:345 Error in copying file '/export/folder_name/vm_name/vm_name-flat.vmdk': Cannot create snapshot 'Quantum: 56dda376e34411e297eeefde8330a7fd' for VM 'vm_name':ApplicationQuiesceFault: An error occurred while quiescing the virtual machine. See the virtual machine's event log for details. The guest OS has reported an error during quiescing. The error code was: 2 The error message was: custom quiesce script failed. : Input/output error.  Return code: 5

 

In the vm_proxy_fs log (/var/log/vm_proxy_fs) you see:

 

ERROR [thread:140683625084672, where:/usr/local/pancetera/bin/snapshot_operations.pm:84, error:5] cannot create snapshot 'Quantum: 56dda376e34411e297eeefde8330a7fd' for VM 'vm_name':ApplicationQuiesceFault: An error occurred while quiescing the virtual machine. See the virtual machine's event log for details. The guest OS has reported an error during quiescing. The error code was: 2 The error message was: Custom quiesce script failed. : Input/output error

 

The Windows' Event Viewer Application log for the virtual machine may show:

 

Event ID: 1000             

Event Source: Application Error

Description:             

              Faulting application name: QuantumVSS.exe, version: 0.0.0.0, time stamp: 0x5138bf27

              Faulting module name: QuantumVSS.exe, version: 0.0.0.0, time stamp: 0x5138bf27

              Exception code: 0xc0000005

              Fault offset: 0x00000000000095f9

              Faulting process id: 0x1db8

              Faulting application start time: 0x01ced1ce0159a501

              Faulting application path: %11

              Faulting module path: %12

              Report Id: %13

 

Note: Observe that the QuantumVSS.exe version info is missing as well as the faulting "application" and "module" paths.

 

The virtual machine's vmware.log contains error message similar to:

 

"... SnapshotVMXTakeSnapshotComplete: Snapshot xxxx failed: Failed to quiesce the virtual machine ..."

 

Cause

 

Issue appears to be caused by improperly installed QuantumVSS agent

 

Solution/Workaround

 

  • Verify that latest version of vmPro software is installed and running on your vmPro appliance, currently version 3.1.2.
  • Verify that the latest VMware Tools is installed on the Windows VM
  • Uninstall QuantumVSS agent from the Windows' virtual machine as follows:

 

"Program Files\VMware\VMware Tools\backupScripts.d\QuantumVSS.exe" uninstall

               

  • Re-install QuantumVSS agent and re-try the backup. The quiesced snapshot backup should work properly. If not, escalate to SES.

 



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