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Introduction

muCommander - Quantum Edition was modified to address issues with how
local file systems handle reading and writing files. Since local file systems tend
to do more than simply read and write files, system performance can be
negatively impacted, especially with the size files that Scalar LTFS handles on a
regular basis.

WARNING: Only the version of muCommander available from Quantum
should be used with Quantum libraries. Any other version of
muCommander will not work as intended.

muCommander - Quantum Edition is intended to be used as a simple file
browser where users drag and drop files from one file system to another. Only
the features and functionality listed in this document are supported by
Quantum. All other questions pertaining to muCommander should be directed
to www.mucommander.com.
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Install muCommander - Quantum Edition

Install muCommander
for Windows

Install muCommander
for Mac

Quantum uses a modified version of muCommander as the recommended file
browser for Windows, Linux and MacOS. Some native file browsers and
applications will attempt to perform hidden file reads to gather file information
for user presentation causing unexpected tape mounts and severe performance
issues. Quantum’s version of muCommander eliminates these issues.
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Go to http://www.quantum.com/serviceandsupport/
softwareanddocumentationdownloads/sltfs/index.aspx

Select the Downloads tab.

From the list of downloads, click the Download button for the
muCommander - Quantum Edition. A popup window displays.

Select the | Accept checkbox.
Click Accept.
The .zip file will download through your web browser.
Save the .zip file to your local machine.
Extract the contents of the file. The .zip file contains:
¢ the muCommander - Quantum Edition .exe
¢ the muCommander - Quantum Edition user instructions

Double-click the muCommander.exe file and follow the instructions to
complete the installation.

When installation is complete, refer to the document included in the .zip file
for basic instructions on how to setup and use muCommander - Quantum
Edition.

Prior to downloading the .dmg file, you must set your security and privacy
settings.

Change Security and Privacy Settings for the Mac v10.9 and higher

1
2

Under the Apple menu, select System Preferences.

Click the Security & Privacy icon. The Security & Privacy screen displays.

Install muCommander - Quantum Edition
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< S Security & Privacy Q

m FileVault  Firewall  Privacy

A login password has been set for this user =~ Change Password...

Require password = 5 seconds ﬂ after sleep or screen saver begins
Show a message when the screen is locked

Disable automatic login

Allow apps downloaded from:

Mac App Store
Mac App Store and identified developers
© Anywhere

~
[l Click the lock to prevent further changes. Advanced... ?

Select the General tab.

4 Click the Lock icon in the lower left of the screen and enter the password for

your computer if necessary.

In the Allow apps downloaded from: area, select Anywhere. A
confirmation dialog appears.

6 Click the Allow From Anywhere button.

Close the window.

Download muCommander for Mac

1
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Go to http://www.guantum.com/serviceandsupport/
softwareanddocumentationdownloads/sltfs/index.aspx

Select the Downloads tab.

From the list of downloads, click the Download button for the
muCommander - Quantum Edition. A popup window displays.

Select the | Accept checkbox.

Click Accept.

The .dmg file downloads to your Downloads folder.

From the Downloads folder, double-click the file to begin the download.
When complete, a drive icon will display on your desktop.

Double-click the .dmg drive icon. A window displays with the
muCommander icon.
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10 Drag the muCommander icon to your Applications folder.

11 When installation is complete, refer to the document included in the .dmg
file for basic instructions on how to setup and use muCommander -
Quantum Edition.

Install muCommander 1 Go to http://www.quantum.com/serviceandsupport/
for Linux softwareanddocumentationdownloads/sltfs/index.aspx

2 Select the Downloads tab.

3 From the list of downloads, click the Download button for the
muCommander - Quantum Edition Linux version. There are two different
versions so choose the one that applies to your version of Linux. A popup
window displays.

4 Select the | Accept checkbox.
5 Click Accept. The .tar.gz file downloads to your selected folder.
6 Extract the files to the necessary destination.

Open a command line and type ./mucommander.sh. The application is installed
and muCommander - Quantum Edition is opened.
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Configure muCommander - Quantum Edition

Connect to the SLTFS
Appliance

Caution: It is recommended that users do not use an already mapped
network connection to the Scalar LTFS Appliance and then connect
through muCommander - Quantum Edition. Users should only
connect to the SLTFS Appliance through the muCommander -
Quantum Edition using the instructions listed in this section.

Figure 1 Connect to Server
screen

DNS Name or IP Address
of Scalar Library

Note: SMB is the only protocol supported in muCommander - Quantum
Edition. However, do not use the SMB tab when configuring
muCommander - Quantum Edition.

After installing the application, you must first set up basic configuration to the
Scalar LTFS Appliance. To complete the configuration:

1 Launch muCommander - Quantum Edition.

2 Select Go > Connect to Server. The Connect to Server screen displays.

r {# Connect to server > . " CEXT)

-

(HTTP | NFS | S3 | SFTP | SMB | VSPHERE |
SLTFS [ FTP [ HDF S ]

Protocol |smb v

Servg v

Share |/ScalarLTFS/ I

Username ’ |

Password ’ |
Store login and password (only this session)

[] Enter samba credentials to access files

Server URL: slitfs:smb://10.20.174.248/ScalarLTFS/

Connect Cancel

Configure muCommander - Quantum Edition
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Select the SLTFS tab.

Note: You cannot use the SMB tab to connect to the SLTFS Appliance in
muCommander - Quantum Edition.

Connect to an SLTFS
iBlade

From the Protocol drop-down menu, select SMB.

5 In the Server field, type in the IP address or DNS name for the Scalar LTFS

Appliance or Scalar library that contains an iBlade.

In the Share field, type in /ScalarLTFS/.

7 Enter your user name and password to access the SLTFS Appliance.

Click Connect. You are now connected to SLTFS.

If the library you are connecting to has an SLTFS iBlade installed, you will be
prompted to select the IP address of the iBlade.

r \
{8 NAS Blade configuration 'd_hj

NAS Blade |0 v

NAS Blade (0) Data path |10.1.1.2 v

OK Cancel

Connect to the SLTFS
Appliance Using
Remote Authentication

From the NAS Blade drop-down menu, make sure 0 is selected.

From the NAS Blade (0) Data path drop-down menu, select the IP address
of the configured iBlade on your library.

Click OK.

If remote authentication is enabled for SLTFS, you must use your Samba
credentials to connect to the SLTFS appliance. To complete your login to SLTFS,
follow steps 1-7 in the Connect to the SLTFS Appliance procedure and then:

1 Select the Enter samba credentials to access files check box. At the

bottom of the Connect to Server screen, the Samba login and Samba
password fields display.

Configure muCommander - Quantum Edition
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Figure 2 Connect to Server
. . . \
screen with Samba {& Connect to server u
HTTP | NFS | S3 | SFTP | SMB | VSPHERE |
SLTFS [ FTP [ HDFS [
Protocol |smb v
Server v

Share |/ScalarLTFS/ |

Username |admin |

Password Io"""o ]
Store login and password (only this session)

'Enter samba credentials to access ﬁles

Enter login in format "domain\username" without quotes

Samba login | I

Samba password | |

Server URL: sitfs:smb://10.20.218.136/ScalarLTFS/

Connect Cancel

2 Enter your Samba login credentials.
3 Click Connect. You are now connected to the Scalar LTFS Appliance.

4 If you have remote authentication enabled and you don’t enter your Samba
credentials, after clicking Connect, a screen displays asking you to enter in
your Samba credentials.

Configure muCommander - Quantum Edition 7
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Figure 3 Samba
Authentication screen

&

(:) Auth

Authentication ﬂ

entication failed

Logon failure: unknown user name or bad password.

Connect as

Server
Login

Password

5 Enteryo

{0 Guest
@ User

sltfs:smb://10.20.169.28/ScalarLTFS/

|Guest] |

| |

[ ] Store login and password (weak encryption)

| OK ” Cancel l

ur Samba credentials and click OK. You are now connected to the

Scalar LTFS Appliance.

Note: To turn off remote authentication, from the SLTFS GUI, select Tools >
Remote Authentication. Uncheck the Enable Filesystem ACLs check

box.

Basic Features and Functionality

Since muCommander - Quantum Edition is a 3rd party application that has been

modified by

Quantum, not all features and functionality are supported by

Quantum Service. The following are the only features and functionality

supported b

y Quantum. For all other questions, contact muCommander using

their website: www.mucommander.com.

Display Folders in a To select a source or destination folder to display in the non-Scalar LTFS panel:

Panel

1 Click the Path button next to the Path field. It will list the current folder you

are displaying and when clicked, will drop-down a list of available mapped
drives and volumes.

Figure 4 Path Button

5=

C

2 From the drop-down list, select the drive, folder or volume you want to

display i

n the panel.

Basic Features and Functionality



Figure 5 Path Button options

Navigating within a
Panel

Table 1 Navigation options

muCommander - Quantum Edition User’s Guide

I SLTFS ||

&, Local Disk (C:)
o3 D:
L# jeurcuri (\\qguantum.com\nam_user) (H:)
L@ jecurcurio (\\fileO1dn\public) (R:)
@ public (\\file01dn) (S:)
=Y
=L
A jcurcuri

No bookmark

&) Network shares
‘3.'7‘ Bonjour services

SMB...
ETP...
SFIP...
HTTP...
NFS...
SLTFS..
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3 Navigate within the panel until you find the desired files.

Navigating within a panel in muCommander - Quantum Edition is not much
different than working with Windows Explorer or the Finder on MacOS. The
following lists and briefly describes some of the ways to navigate within a panel.

Double-click a folder,
drive or volume

This is the most basic way to
open a folder, drive or volume

Using the up green
arrow button @

Clicking this button displays the
folder, drive or volume one level
back in your path

Using the right and left '
green arrow buttons Q@ @

Clicking these button moves you
forward or backward within the
folders, drives or volumes you
have already visited

Basic Features and Functionality
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Figure 6 muCommander -
Quantum Edition window

@& sltfs:smb://10.20.218.136/ScalarLTFS/ - muCommander [ESHEDEL X ]
File Mark View Go Bookmarks Window Help

d © © 0 @ B & 2 = 8 9 L @ ¢ = @*

Eic: |[causers\ [ sirs | [sitts:smbi10.20.218.1 TFS!

Ex! Name = |S(...|Ph..JMo..J Size { Date ]Per... Name ~ | i [ State | Size { Date B

@ . <DIR> 11/03/14 09:56 AM = (@) <DIR>  12/31/69 05:00 PM

[Z All Users <DIR= 10/12/1509:15 AM drwx || TapeGroup1 = ready <DIR> 10/15/1501:54 PM drw-

(& Default <DIR> 07/14/09 01:07 AM drwx | | TapeGroup2 = ready <DIR> 10/15/1501:54 PM drw-

(X3 DefaultUser <DIR> 07/14/09 01:07 AM drwx

[ Public <DIR> 07/14/09 01:12 AM drwx

= win7 <DIR> 12/31/69 05:00 PM drwx

g desktop.ini 1KB 07/13/09 10:54 PM -rwx

0 of 2 selected [ [Free:8.7 1B

View [F3] Edit [F4] I Copy [F5] I Move [F6] | ) Make dir [F7] | Delete [F8] | D Refresh [F9] | @ Close window [F10] ‘

The updated window shows new columns that provide media and volume state
information. The State column displays the following values:

* available
* degraded

e vaulted
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Figure 7 Offline icon

Opening a New
Window

Use Shortcut Buttons

Figure 8 Command Bar

Volume Group Names
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The window also shows what media and volumes are offline by displaying a red
X on the folder icon.

Since the recommended size of the files in Scalar LTFS is quite large, users of
muCommander - Quantum Edition can take advantage of opening new
windows to perform multiple read/writes concurrently.

To open a new window in muCommander - Quantum Edition:

1 Select File > New Window. A duplicate of the currently open window
displays.

You can now drag and drop more files on SLTFS that will be read/written
concurrently.

Caution: If you're using multiple windows to do concurrent I/O, do not read
or write to the same SLTFS volume. This can negatively impact
system performance.

muCommander - Quantum Edition provides various shortcut buttons in the
Command Bar at the bottom the window allowing users to perform basic
functions quickly.

[\_j Copy [F5] Make dir [F7] @ Delete [F8] @ Refresh [F9] _‘3 Close window [F10]

Volume group names are restricted to 255 characters and can only be changed
from a file browser, such as muCommander - Quantum Edition. Volume group
names also cannot use the following special characters:

o /MFYI> < |\

Basic Features and Functionality
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Search for Files It is possible to search for files using muCommander - Quantum Edition. To
perform a search:

1 Select File > Find File. The Find File screen displays.

Figure 9 Find File screen

{@® Find file - ' - )

Pattern:

I |

Root folder:
Isltfs:smb://10.20.218.136/ScalarLTFS/ |

Search recursive:

Search results:

Clear history Move results into panel I Run H Cancel l

" 4

2 In the Pattern field, type the name of the file you want to search for.

3 Click Run. The results display in the Search results area of the Find File

screen.
Copying Files in the SLTFS allows for ‘fast copy’ of files from the SLTFS window to any location on a
SLTFS Window host.

Caution: The ‘fast copy’ feature is only available for Windows OS.

1 In the SLTFS window, select the file(s) you want to copy. To select multiple
files, hold down the Ctrl key while selecting the files. The selected files will
display in red.

2 Click the Copy (F5) button. The Copy window displays.
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r& Copy ~ Ingp— =)

Copy selected file(s) to :
C:\Users\jcurcuri\5_5GB.0

Default action when file exists :

[_] Skip errors

[_] verify data integrity
Use 'faster copy' feature

> 1 file(s) Copy Cancel

" =

3 Verify the number of files you want to copy by click the File(s) button.
4 Click Copy.

Note: If you do not see the ‘Fast Copy’ option, you are not connected to the
Scalar LTFS appliance or Scalar library correctly. Go back to Connect to
the SLTFS Appliance on page 5 and reconnect to the appliance or
library that contains an iBlade.

Basic Features and Functionality 13
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Made in the USA. Quantum Corporation provides this publication “as is” without warranty of any kind, either express or
implied, including but not limited to the implied warranties of merchantability or fitness for a particular purpose. Quantum
Corporation may revise this publication from time to time without notice.

COPYRIGHT STATEMENT

© 2017 Quantum Corporation. All rights reserved. Your right to copy this manual is limited by copyright law. Making copies
or adaptations without prior written authorization of Quantum Corporation is prohibited by law and constitutes a
punishable violation of the law.

TRADEMARK STATEMENT

Quantum, the Quantum Logo, Backup. Recovery. Archive. It's What We Do., Be Certain, Be Quantum Certain, DLT, the DLT
Logo, DLTSage, DLTtape, the DLTtape Logo, DXi, DXi Accent, Dynamic Powerdown, FastSense, FlexLink, GoProtect, GoVault,
iLayer, Lattus, MediaShield, Optyon, Pocket-sized., Well-armored., Preserving the World's Most Important Data. Yours., Q-
Cloud, Quantum Certain, Quantum Certainty, Quantum vmPRO, Scalar, SDLT, SiteCare, SmartVerify, StorageCare, StorNext,
Super DLTtape, SuperLoader, and Vision are either registered trademarks or trademarks of Quantum Corporation and its
affiliates in the United States and/or other countries. All other trademarks are the property of their respective owners.
Products mentioned herein are for identification purposes only and may be registered trademarks or trademarks of their
respective companies. All other brand names or trademarks are the property of their respective owners. Quantum
specifications are subject to change.

14 Basic Features and Functionality



	muCommander - Quantum Edition User Guide for MacOS, Linux and Windows
	Contents
	Introduction
	Install muCommander - Quantum Edition
	Install muCommander for Windows
	Install muCommander for Mac
	Change Security and Privacy Settings for the Mac v10.9 and higher
	Download muCommander for Mac

	Install muCommander for Linux

	Configure muCommander - Quantum Edition
	Connect to the SLTFS Appliance
	Connect to an SLTFS iBlade
	Connect to the SLTFS Appliance Using Remote Authentication

	Basic Features and Functionality
	Display Folders in a Panel
	Navigating within a Panel
	Opening a New Window
	Use Shortcut Buttons
	Volume Group Names
	Search for Files
	Copying Files in the SLTFS Window



