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Preface

xTalk Management Console is a software application designed to allow 
customers to evaluate tape device health and determine when a device 
needs to be sent for service or repair. 

xTalk Management Console provides media and device diagnostic tools, 
the ability to view general analysis information, and the ability to quickly 
update application software and device firmware.

You can download the latest version of this application from the 
Quantum Web site at: 

http://www.quantum.com/ServiceandSupport/SoftwareandDocument
ationDownloads/Index.aspx. 

Audience This manual is written for users of xTalk Management Console.

Purpose This document provides information about how to use the features of 
xTalk Management Console including:

• Understanding and using the program

• Customizing the program

• Getting updates

• How to get help when problems arise
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Preface
Document Organization This document is organized as follows: 

• Chapter 1, Environment and Main Window, provides an overview of 
xTalk Management console. It describes the layout of the main 
window, including selection and results panels, menu commands, 
and toolbar buttons.

• Chapter 2, Using the Results Panel, describes the functions and 
features of the Results Panel, which displays results of actions 
performed.

• Chapter 3, Shortcuts, describes the keyboard and right-click shortcuts 
available to you.

• Chapter 4, Setting Preferences, explains how to customize views and 
automated information.

• Chapter 5, Getting Updates, explains how to update xTalk 
Management Console software, and to update device firmware, 
including how to make a firmware update tape.

• Chapter 6, Running a Test or Task, explains how to determine if a 
device is ready to be tested, how to run a test or task, and how to 
abort a test or task.

• Chapter 7, Log Files, explains how to create log files and open log 
files. It also explains how to enable or disable automatic log file 
creation.

• Chapter 8, Viewing Media Data, explains how to view information 
stored on the tape.

• Chapter 9, Viewing TapeAlerts, provides information about 
TapeAlert flags and how to view them.

• Chapter 10, FA Data Files, explains how to generate and view failure 
analysis (FA) data files.

• Chapter 11, General Device Commands, details commands that are 
not covered in other chapters.

• Chapter 12, Using Push Pins, provides instructions on how to keep 
dialog boxes open by enabling and disabling “push pins.” 
xTalk Management Console for Windows User’s Guide ix
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• Chapter 13, Getting Help, lists the kinds of help you can access and 
how to get it.

• Appendix A, Specifications, lists the minimum PC requirements 
needed to run xTalk Management Console, as well as supported 
operating systems, host bus adapters, and devices.

This document concludes with a glossary and a detailed index.

Notational Conventions This manual uses the following conventions:   

Related Documents Refer to the appropriate product manuals for information about your 
hard disk drive, tape drive, or cartridges.

Contacts Quantum company contacts are listed below.

Quantum Corporate Headquarters 0

To order documentation on xTalk Management Console or other 
products contact:

Quantum Corporation
141 Innovation Drive
Irvine, CA  92617
(949) 856-7800
(800) 284-5101

Note: Notes emphasize important information related to the main 
topic.

Caution: Cautions indicate potential hazards to equipment and are 
included to prevent damage to equipment.
xTalk Management Console for Windows User’s Guide x
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Technical Publications 0

To comment on existing documentation send e-mail to:

doc-comments@quantum.com

Quantum Home Page 0

Visit the Quantum home page at: 

http://www.quantum.com

Getting More Information or 
Help 

More information about this product is available on the Service and 
Support Web site at 
http://www.quantum.com/ServiceandSupport/Index.aspx. The Service 
and Support Web site contains a collection of information, including 
answers to frequently asked questions (FAQs). You can also access 
software, firmware, and drivers through this site. 

For further assistance, or if training is desired, contact: 

Quantum Technical Assistance Center in the USA:     800-284-5101

For additional contact information, go to: 
http://www.quantum.com/AboutUs/ContactUs/Index.aspx.

To open a Service Request, go to: 
http://www.quantum.com/ServiceandSupport/eSupport/Index.aspx.    

For the most updated information on Quantum Global Services, please 
visit: 
http://www.quantum.com/ServiceandSupport/Contacts/Worldwide/I
ndex.aspx.
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Chapter 1

1Environment and Main Window

When you start xTalk Management Console, it displays the main 
window. This chapter describes the following features and functions of 
the xTalk Management Console environment and main window:

• Layout of the Main Window

• Menu

• Toolbar

• Device Selection Panel

• Script Selection Panel

• Script Description Panel

• Results Panel

• Status Bar

• Exiting xTalk Management Console

Layout of the Main Window 1

Figure 1 shows the layout of the main window. 

You can change the size of the panels by placing your cursor over a 
border, or “splitter bar.” When the cursor changes to a set of parallel 
xTalk Management Console for Windows User’s Guide 1



Chapter 1  Environment and Main Window
Layout of the Main Window
lines, you can click and drag the border to where you want it. When you 
exit xTalk Management Console and reopen, your border settings are 
saved. 

Figure 1  Main Window
   

Menu

Device
Selection

Panel

Toolbar

Results 
Panel

Status Bar

Script
Selection

Panel

Script
Description

Panel
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Menu
Menu 1

Across the top of the main window is a menu containing tasks and 
commands, all of which are explained in detail in this document. For 
more information about a specific command, use the Contents or Index to 
locate where in this document a command is described in detail. 

Toolbar 1

The toolbar is a line of buttons immediately under the menu. The buttons 
on the toolbar allow you to perform standard tasks or commands. Click 
on a device in the Device Selection Panel and then click a toolbar button.

To view the full name of a button, place your cursor directly over the 
button. The name appears directly below the button. 

To view a description of what the button does, place your cursor over a 
button and read the description in the Status Bar (see Status Bar on 
page 9).

For more information on using these commands, use the Contents or 
Index to find where a specific command is described in detail. 
xTalk Management Console for Windows User’s Guide 3
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Toolbar
The toolbar button icons are shown below, in order of appearance on the 
toolbar.   

Note: Not all buttons are available for all device types.

Toolbar Button 
Icon

Button Name and 
Description

For More 
Information see...

    
Save. Saves the contents 
of the Results Panel to a 
file.

Saving the Contents 
of the Results Panel 
on page 14

    
Rescan Bus. Rescans the 
SCSI bus and displays a 
list of devices found in 
the Device Selection 
Panel.

RESCAN on page 56

    
Inquiry Information. 
Displays a dialog box 
containing information 
about the selected 
device. 

INQUIRY 
INFORMATION on 
page 55

    
Test Unit Ready. Queries 
the device to determine if 
it is ready to run a test or 
task and displays the 
result in a dialog box.

Checking Device 
Readiness on 
page 32

 
Show MAM Information. 
View the information 
stored in the medium 
auxiliary memory.

Viewing Medium 
Auxiliary Memory 
(MAM) on page 42
xTalk Management Console for Windows User’s Guide 4



Chapter 1  Environment and Main Window
Toolbar
    
Collect Failure Analysis 
Data. Saves failure 
analysis data to a file that 
can be used by support 
personnel for 
troubleshooting.

Generating an FA 
Data File on page 47

    
Generate EEPROM 
Buffer. Collects drive 
information from the 
EEPROM and saves it to 
a file.

GENERATE 
EEPROM BUFFER on 
page 54

    
Generate Trace Buffer. 
Collects drive status 
information from the 
trace buffer and saves it 
to a file. 

GENERATE TRACE 
BUFFER on page 54

    
Abort. Stops the 
currently running test or 
task at the earliest 
opportunity.

Aborting a Test or 
Task on page 35

    
Run. Starts and runs the 
selected test or task on 
the selected device.

Running a Test or 
Task on page 34

    
Clear. Clears all data 
from the Results Panel. 

Clearing the Contents 
of the Results Panel 
on page 15

Toolbar Button 
Icon

Button Name and 
Description

For More 
Information see...
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Toolbar
    
Firmware Update. 
Transfers a new 
firmware image file to 
the device.

Updating Device 
Firmware on page 29

    
Write FUP Tape. Creates 
a firmware update tape. 

Creating a Firmware 
Update (FUP) Tape 
on page 33

    
Create DLTSage WORM 
Tape. Creates a write-
once read-many tape for 
certain DLT devices and 
media combinations.

CREATE DLTSAGE 
WORM TAPE on 
page 57

   
Retension. Forwards the 
tape to EOM, then 
rewinds to BOM. 

RETENSION on 
page 57

    
Park. Parks the drive 
arm. 

PARK on page 61

Unpark. Unparks the 
drive arm. 

UNPARK on page 63

    
Help. Opens the online 
User’s Guide.

 

Access the Users 
Guide on page 60

Toolbar Button 
Icon

Button Name and 
Description

For More 
Information see...
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Device Selection Panel
Device Selection Panel 1

The Device Selection Panel displays a list of SCSI devices connected to 
your computer, as detected by xTalk Management Console when it scans 
the bus. 

From this panel you can select a device on which to view information or 
run a test, task, or command.    

Displayed Information 1 The Device Selection Panel displays the model, serial number, product 
revision, and vendor of all devices in four columns. Use the horizontal 
scroll bar at the bottom of the Device Selection Panel to view all the 
columns. You can change the size of the columns by clicking and 
dragging the vertical column dividers. 

For more specific information about an individual device, place your 
mouse over a device and a box will briefly appear displaying the 
following information: model, vendor, serial number, revision, HBA ID, 
SCSI ID, and LUN ID. 

In addition, the status bar lists the HBA ID, SCSI ID, LUN ID, model, and 
serial number for the selected device (see Status Bar on page 9). 

Selecting a Non-Supported 
Device 1

xTalk Management Console does not support all device types. If you 
select a non-supported device, xTalk Management Console displays this 
message: 

xTalk does not support this device. Please refer to the xTalk help file 
for a list of all the supported devices.

For a list of supported devices, see Supported Devices on page 70.

Note: You may only select one device at a time.
xTalk Management Console for Windows User’s Guide 7
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Script Selection Panel
When No Devices Are 
Detected 1

If no devices are detected by the bus scan, the following message is 
displayed:

No devices have been detected. Please inspect your system’s cables 
and device terminators. Also, be sure you have installed the latest 
device driver for your tape product. If you feel you received this 
message by error try re-scanning the SCSI bus. You may need to close 
and restart the application.

Click OK and follow the instructions in the message.

When Connected Devices 
Don’t Display 1

If you have properly connected a device to the bus and it does not display 
in the Device Selection Panel, try re-scanning the bus (see RESCAN on 
page 56). Sometimes it takes the operating system a little longer to 
recognize a new device, causing the bus scan not to see the device. You 
may need to rescan the bus several times, or you may need to close and 
restart xTalk Management Console. 

Script Selection Panel 1

The Script Selection Panel displays a list of tests and tasks (scripts) that 
you can run on a selected device. The scripts are listed functionally as 
follows:

• Full Diagnostics – A long test, or series of tests, that takes more than a 
few minutes to complete (for example, Device_Health_Check). Full 
diagnostics are used to determine any problems that a device may be 
having.

• Individual Tests – A series of operations strung together to accomplish 
a specific function. The Full Diagnostics script, 
Device_Health_Check, is composed of individual tests that can be 
run separately to find specific issues without running the full health 
check. 

• Device Tasks – Short, usually one-step operations. These are not tests, 
but are used to engage or view the characteristics of a device. 

The list of available tests/tasks changes depending on the device 
selected.
xTalk Management Console for Windows User’s Guide 8
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Script Description Panel
Once you select a device and a test or task, you are ready to run the test or 
task (see chapter 6, Running a Test or Task). 

 

Differences Between 
Scripts and Commands 1

Some commands available through the menu and toolbar buttons 
perform the same function as scripts in the Script Selection Panel. You can 
use either method; however, using the menu commands or toolbar 
buttons generally provides more information and help in dialog boxes, 
whereas the script usually displays more information in the Results 
Panel. 

Script Description Panel 1

The Script Description Panel is directly below the Script Selection Panel. 
When you click on a test or task, a description of what that script does 
displays in the Script Description Panel. 

Results Panel 1

The right-most vertical panel is the Results Panel, which displays 
information about the command, test, or task you are running. You can 
search, comment on, and save the contents of this panel (see chapter 2, 
Using the Results Panel). 

Caution: The scripts displayed in the Script Selection Panel for your 
use are .xcs files stored in the Scripts folder. Do not change 
these .xcs files! If you alter one of these .xcs files in any 
way, you will not be able to run that script again. To 
restore functionality of that script, you will be required to 
reinstall the xTalk Management Console executable. 
xTalk Management Console for Windows User’s Guide 9
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Status Bar
Status Bar 1

The Status Bar runs along the bottom of the window and displays 
information about xTalk Management Console and the selected device as 
follows, in this order along the bar: 

Section Description of Displayed Information

xTalk status 
information

Current status of xTalk Management Console 
(usually displays “Ready,” meaning it is ready to 
perform a command or run a script). Also provides 
a description of menu commands and toolbar 
buttons when you place the cursor over the item. 
When you run a test or task and generate a log file, 
the status bar displays the path of the log file (see 
Generating and Saving Log Files on page 37). 

Host ID Host bus adapter identifier. Not available for all 
interface types.

Target ID/
Tape ID

SCSI ID: SCSI ID of the selected device.
Tape ID: Tape number of the selected device.  

LUN ID Logical Unit Number of the selected device. Not 
available for all interface types.

Primary
Secondary
Channel

GoVault designations that provide information 
similar to Target ID/Tape ID and LUN ID. 

Device label The type of device selected for testing.

Device serial 
number

Serial number of the selected device.

Application 
state

The current status of the test, task, or command 
that you are running (for example, Idle or 
Running). 

Iteration 
Counter

The progress of the current operation; for example, 
if writing to tape, this shows the number of blocks 
written and the total number of blocks to be 
written in the current operation (40/250). 
xTalk Management Console for Windows User’s Guide 10
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Exiting xTalk Management Console
Show/Hide Status Bar 1 You can decide whether or not you want the Status Bar to appear in the 
main window. To show or hide the Status Bar:

1 From the menu bar, select View. 

2 Click Status Bar.

As soon as you click the selection, its status changes; for example, if 
the window currently displays the Status Bar, when you click Status 
Bar, the Status Bar immediately disappears from the window. 

Exiting xTalk Management Console 1

To exit xTalk Management Console, do one of the following:

• Choose File > Exit, from the menu.

• Click the X in the upper right corner of the xTalk Management 
Console window. 

Note: If the status bar is showing, the option is checked. If 
hidden, the option is unchecked.
xTalk Management Console for Windows User’s Guide 11
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2Using the Results Panel

The Results Panel displays results of the command, test, or task you are 
running, including error messages. 

This chapter discusses the things you can view and do with the 
information displayed in the information panel as follows:

• Displayed Information

• Using Verbose Mode

• Saving the Contents of the Results Panel

• Sending the Contents of the Results Panel 

• Clearing the Contents of the Results Panel

• Searching the Results Panel 

• Adding Comments to the Results Panel   

• Copying Information from the Results Panel 
xTalk Management Console for Windows User’s Guide 12
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Displayed Information
Displayed Information 2

The information about each script you run is displayed consecutively in 
the Results Panel, until you clear the contents (see Clearing the Contents 
of the Results Panel on page 15) or exit xTalk Management Console (see 
Exiting xTalk Management Console on page 11). 

The information in the Results Panel is displayed in several colors. You 
can change some of these colors using the Preferences dialog box (see 
Change Color of Items on page 27).    

Using Verbose Mode 2

Verbose Mode is a feature that allows you to view all the information on 
every command: what is sent to and from the device, the command 
status, and all the information it returns. This information is displayed in 
the Results Panel and it is the same information that is sent to the log file 
if you enable automatic log file generation (see Generating and Saving 
Log Files on page 37). 

This amount of information can be useful for diagnostic purposes; 
however, you may not want to see all this information all the time, so you 
can decide at any time to enable or disable Verbose Mode by toggling 
between Verbose Mode and Standard Mode. 

To enable/disable Verbose Mode, press <Ctrl+Alt+V>. A dialog box 
appears telling you whether Verbose Mode is enabled or disabled. 

The default setting for Verbose Mode is disabled. If you shut off xTalk 
Management Console, the system reverts to disabled the next time you 
log on, and you must press <Ctrl+Alt+V> again to enable it. 

Item Color

Comment Green

Background White
xTalk Management Console for Windows User’s Guide 13



Chapter 2  Using the Results Panel
Saving the Contents of the Results Panel
Saving the Contents of the Results Panel 2

You can save the entire contents of the Results Panel to a .txt file any time 
the status bar shows the system is Idle.

Saving data to a new text file 2

To save the contents of the Results Panel to a new text file:  

1 Do one of the following:

• Choose File > Save As from the menu.

• If you have not saved the contents of the Results Panel yet, click 
the Save button on the toolbar.

The Save xTalk Log File dialog box opens.

2 Browse to and select the location where you want to save the file; 
name the file; and click Save. 

The information is saved to the file in the location you specify.

Notice that the location and filename now appear in the xTalk 
Management Console Windows title bar. This file is now considered 
active and the only way to make it non-active is to exit xTalk 
Management Console or Save As to a new file. 

If you change the contents of the Results Panel, you can either:

• Continue to Save to this active file, which overwrites the current 
contents (see Saving data to the active text file, below) or 

• Save the data to a new file by selecting File > Save As again. This 
new file then becomes the active file. 

Saving data to the active text file 2

To save data to the currently active text file, do one of the following:

• From the menu bar select File > Save.

• From the toolbar, click the Save button.
xTalk Management Console for Windows User’s Guide 14
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Sending the Contents of the Results Panel
The most recently created file stays active until you exit xTalk 
Management Console. 

Sending the Contents of the Results Panel 2

This option allows you to e-mail the contents of the Results Panel to 
someone. You may do this manually any time the status bar shows the 
system is Idle. 

To send a view:

1 Choose File > Send View from the menu bar,.

An e-mail message opens. The contents of the Results Panel are 
placed into a .txt file and attached to the e-mail. The subject line of the 
e-mail is “xTalk Management Console Log File.” The e-mail is 
addressed to support@quantum.com.

2 Address and send the e-mail. 

Clearing the Contents of the Results Panel 2

This option allows you to clear all data from the Results Panel. To clear, 
perform one of the following actions:

• Choose Edit > Clear View from the menu

• Click the Clear button on the toolbar.

Note: xTalk Management Console will only Save to an existing file if 
the file is closed. If the file is open, no new changes will be 
saved.
xTalk Management Console for Windows User’s Guide 15
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Searching the Results Panel
• Right-click anywhere in the Results Panel and select Clear View from 
the pop-up menu.   

Searching the Results Panel 2

To find a specific word or string of characters in the Results Panel:

1 Do one of the following:

• Choose Edit > Find from the menu.  

• Type the keyboard shortcut <Ctrl+F>.

• Right-click anywhere in the Results Panel and select Find from 
the pop-up menu.

2 Enter the text you want to find. 

3 Click Find Next.

The first instance of the item you are searching for is highlighted in 
the Results Panel.

4 To find the next instance of the item, click the Find Next button again.

5 Once you close the window, you can search for the last searched-for 
item by doing one of the following:

• Choose Edit > Find Next from the menu.

• Press the <F3> key. 

Note: Clearing the view removes information from the Results 
Panel. However, it does not close the active file (see Saving the 
Contents of the Results Panel on page 14). If you perform a 
save after clearing the view, you will overwrite the contents of 
the active file with NOTHING. Make sure you want to do this. 
xTalk Management Console for Windows User’s Guide 16
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Adding Comments to the Results Panel
Adding Comments to the Results Panel 2

While you cannot change any of the data in the Results Panel, you can 
enter comments at the end of the displayed text. 

You can also run a number of consecutive tests or tasks and add 
comments after each one.   

To add a comment to the Results Panel:  

1 Do one of the following:

• Choose Edit > Add Comments To Window from the menu.

• Right-click in the Results Panel and select Add Comments to the 
window.

The Comment dialog box opens.

2 Click in the Comment dialog box and enter your comments.

3 Click Apply.

The comment appears in the Results Panel at the end of the displayed 
text, and disappears from the Comments dialog box.

4 When finished commenting, click Done.  

Note: You can keep the Comments dialog open in the window as 
you perform other operations by using the Push Pin feature 
(see chapter 12, Using Push Pins). 

Note: You can change the color of the comments using the 
Preferences dialog box (see Change Color of Items on 
page 27).    
xTalk Management Console for Windows User’s Guide 17
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Copying Information from the Results Panel
Copying Information from the Results Panel 2

You can copy information from the Results Panel to paste into another 
application (you cannot alter the contents of the Results Panel itself). To 
copy information from the Results Panel:

1 Select the information to copy by doing one of the following:

• Use your mouse to select the information you want to copy.

• To select all the information, right-click anywhere in the Results 
Panel and choose Select All from the pop-up menu.

2 Copy the information by doing one of the following:

• Choose Edit > Copy from the menu.   

• Right-click anywhere in the Results Panel and choose Copy from 
the pop-up menu.

The data is copied to the Windows clipboard, and you can now paste 
it into another application.      
xTalk Management Console for Windows User’s Guide 18
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3Shortcuts

There are a number of shortcuts you can use instead of menu commands 
and toolbar buttons:

• Keyboard Shortcuts

• Right-click Shortcuts

• Double-click Shortcuts

Keyboard Shortcuts 3

If you are more comfortable and efficient using the keyboard, you can use  
keyboard shortcuts to issue certain commands. The following table 
shows commands and the shortcut for each.      

Command Keyboard Shortcut

Abort script <Ctrl+A>

Copy <Ctrl+C>

Find <Ctrl+F>

Find Next <F3>
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Right-click Shortcuts
Right-click Shortcuts 3

You can execute a number of common commands by right-clicking a  
device or in the results panel and then selecting what you want to do 
from the menu that appears upon right-click. The following table 
describes these actions:     

View online User’s Guide (this 
document)

<Shift+F1>

Inquiry <Ctrl+I>

Run script <Shift+R>

Save <Ctrl+S>

Test unit ready <Ctrl+T> 

Right-click this Available menu choices

A device in the Device 
Selection Panel

• Inquiry Information

• Test Unit Ready

• Medium Auxiliary Memory 
(MAM)

• Media Compatibility

• FUP Drive

Anywhere in the Results 
Panel

• Clear View

• Copy

• Select All

• Find

• Add Comments to the window

• Preferences   

Command Keyboard Shortcut
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Double-click Shortcuts
Double-click Shortcuts 3

You can avoid clicking the Run button by double-clicking the script you 
want to run on a selected device.
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4Setting Preferences

The Preferences dialog box allows you to perform the following 
activities:

• Generate Log File

• Show Splash

• Show Startup Caution

• Load Count Threshold 

• Configure Update Wizard – Update Check 

• Folders

• Change Color of Items

• Return to Default Settings

To set preferences, follow these steps:

1 Select View > Preferences from the menu.

The Preferences dialog box shows the options that are available to 
you (see figure 2).          

Note: If the sub-items are not displayed, click the plus sign to the 
left of the category. 
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Figure 2  Preferences Dialog 
Box 
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General Setup
2   Follow the instructions below for setting each condition.

3 When finished, do one of the following:

• Click Apply to accept all changes and close dialog box, or 

• Click Cancel to close the dialog box without accepting any 
changes. 

General Setup 4

Generate Log File 4 When selected, this feature enables automatic log-file generation after 
every script has completed. The log files are stored in the directory listed 
in the Log Folder section of the Preferences dialog box. 

The information saved to the log file is often more than what is displayed 
in the Results Panel (unless you have Verbose Mode enabled — see Using 
Verbose Mode on page 13). This can be useful for debugging. 

Show Splash 4 Show Splash displays xTalk Management Console splash screen at 
startup (see figure 3). To disable this screen, deselect the option. (You can 
also select the “Don’t show this screen again” box at the bottom of the 
splash screen when it displays).

Note: To reset preferences to default settings click Defaults (see 
Return to Default Settings on page 27).
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General Setup
Figure 3  Splash Screen
   

Show Startup Caution 4 Show Startup Caution displays a Caution screen at startup (see 
figure 4). To disable this Caution, deselect the option. (You can also select 
the “Don’t show this screen again” check box at the bottom of the Caution 
screen.)
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Load Count Threshold
Figure 4  Caution Screen
  

Load Count Threshold 4

This feature is currently disabled.

Configure Update Wizard – Update Check 4

This feature is currently disabled.

Folders 4

The Folders section displays the default path to the Logs folder, the 
FAData folder, and the Scripts folder. This information is read-only. You 
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Change Color of Items
can use the path information to find where these files are located on your 
system.  

Change Color of Items 4

Color Items allows you to change the color for information displayed in 
the Results Panel. (The default colors are listed in Displayed Information 
on page 13.)

To change a color setting:

1 Click the square showing the color you want to change.

xTalk displays a color selection chart.

2 Click the color you want to use.

Return to Default Settings 4

To remove preference settings and return to default values, click the  
Defaults button. A dialog box opens asking if you are sure you want to set 
the application to its default state. If you do, click Yes. 

Note: You always have the option to save files elsewhere; this just 
shows you the system default.
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5Getting Updates

This chapter shows you how to update xTalk Management Console and 
device firmware. It covers the following topics:

• Updating xTalk Management Console

• Updating Device Firmware

• Creating a Firmware Update (FUP) Tape

Updating xTalk Management Console 5

To update xTalk Management Console:

1 Go to the following Web site and download the xTalk Management 
Console executible file to your computer. 

http://www.quantum.com/ServiceandSupport/
SoftwareandDocumentationDownloads/Index.aspx

2 Double-click the executible file. 

The installer deletes previous versions of xTalk Management Console 
system files and replaces them with with the latest version. Any user-
created files that are not part of the install package (for example, 
scripts, log files, FA dumps) remain intact.   
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Updating Device Firmware
The installation includes the latest versions of:

• xTalk Management Console application software

• Help files

• Test scripts

• Release notes (to access the Release Notes, select Help > Read Me from 
the xTalk Management Console menu bar)

     

Updating Device Firmware 5

This option updates the firmware image; that is, it transfers a new 
firmware image file to the device.

To update the firmware image, follow these steps:

1 Download the latest firmware image file to your PC from the 
following Web site:   

http://www.quantum.com/ServiceandSupport/
SoftwareandDocumentationDownloads/Index.aspx

2 Select the device you want to update from the Device Selection Panel.

3 If the device you want to update is a tape drive, remove the tape 
cartridge completely from the device. 

Note: Previous versions of xTalk Management Console included a  
feature that automatically searched the Web for the latest 
firmware updates and installed them upon startup. This 
feature has been disabled. Instead, you must go out to the 
Web, find the latest firmware version, and download it to your 
PC yourself (see step 1 below). Future releases will include the 
automatic Web search-and-install feature. 
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Updating Device Firmware
4 If the device you want to update is a GoVault™ device, be sure the 
hard drive cartridge is loaded in the unit. 

5 Do one of the following:

• Choose Commands > FUP Drive from the menu.

• Click the FUP Drive button on the toolbar.

 xTalk displays a Warning message (see figure 5).  

Note: You cannot load firmware onto a password-protected 
GoVault cartridge unless the password has been entered 
using the GoVault System Application since the last power 
up or cartridge insertion. If the GoVault cartridge is 
password protected, make sure the GoVault System 
Application is installed on the same computer as xTalk 
Management Console. 

The GoVault System Application prompts you for the 
password and allows access to the cartridge. If the 
GoVault System Application is not installed, you will not 
be prompted for the password and you will receive error 
messages when trying to load firmward. 

You can download the GoVault System Application from 
the installation CD that came with your GoVault, or from  
http://www.quantum.com/ServiceandSupport/
SoftwareandDocumentationDownloads/GoVault/Index.aspx.

Note: For GoVault drives only, the last two sentences of the error 
message are incorrect. This will be fixed in future versions 
of xTalk. 
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Updating Device Firmware
Figure 5  Firmware Update 
Warning

6 Click OK. 

7 GoVault devices only: A dialog box opens warning you that xTalk will 
force a system reboot when the firmward update is complete (see 
figure 6). Click OK.

Figure 6  GoVault System 
Reboot Message

8 A dialog box opens allowing you to browse for the firmware image 
file. Locate the firmware image file on your PC that you want to 
install and click Open.
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A dialog box opens telling you the update is about to start, as follows: 

Your device will now start the firmware update. This will take up 
to 8 minutes to complete. Please wait for the firmware update 
process to be completed before making any changes to the state 
of  your system or power.

9 Click OK.

The firmware update begins. A Warning message opens stating:

Your device is being updated with firmware. DO NOT disturb 
the device for a period of 8 minutes, even if your computer stops 
functioning. The device will complete the firmware update once 
it has started, without the assistance of the computer or SCSI bus. 

Progress is shown via text and a status bar. When the image file has 
completed transfer onto the device, the following message displays in 
a dialog box: “The drive has completed the firmware update 
procedure.”  

10 Click OK.

11 GoVault devices only: A brief  message displays, stating “the system 
will now reboot.” Then your computer automatically reboots. 

Error Messages 5 If you get an error message during the firmware update process, click OK 
in the error dialog box. Another dialog box opens listing the Sense Key, 
Additional Sense Code (ASC), Additional Sense Code Qualifier (ASCQ), 
and a description of the error. Fix the problem and click OK.     
xTalk Management Console for Windows User’s Guide 32



Chapter 5  Getting Updates
Creating a Firmware Update (FUP) Tape
Creating a Firmware Update (FUP) Tape 5

This option allows you to write a firmware image onto a data cartridge to 
be used as a firmware update (FUP) tape. 

To write a FUP tape:

1 Select a device from the Device Selection Panel.

2 Do one of the following:

• Choose Commands > Write FUP Tape from the menu.

• Click the FUP Tape button on the toolbar.

A warning message appears stating: “You are about to permanently 
overwrite data on this tape. Click OK to select the image file or click 
Cancel to discontinue the FUP tape operation.”

3 Click OK.

The Open dialog box opens.

4 Browse to and select a firmware image file.

5 Click Open.

The tape rewinds. A dialog box opens reminding you to “write 
protect this tape before attempting to use it to update firmware in a 
drive.” 

6 Click OK.

The firmware image is written to the data cartridge. When complete, 
a dialog box displays this message: “FUP tape operation complete.”

7 Click OK.      

Note: This feature can only be used with tape drives. Not all tape 
drives support this feature. 

Note: When the FUP tape operation is complete, you can use the 
tape to update the firmware in other tape devices. For 
instructions, refer to the tape drive’s product manual.      
xTalk Management Console for Windows User’s Guide 33



Chapter 6

6Running a Test or Task

When you run a test or a task, xTalk Management Console sends a script 
to the device telling it to perform the specified action. This chapter covers 
the following test/task related functions:

• Checking Device Readiness

• Running a Test or Task

• Aborting a Test or Task 

Checking Device Readiness 6

This option queries the device to determine if it is ready to run a test or 
task. This option also clears check condition buffers.

To determine whether a device is ready:

1 Select a device from the Device Selection Panel.

2 Do one of the following:

• Choose Commands > Test Unit Ready from the menu.

• Click the Ready button on the toolbar.

As the device readiness is checked, the status displays briefly in a 
dialog box. Then another dialog box opens, telling you if the device is 
ready or not.  
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Checking Device Readiness
3 Proceed as follows:  

If the device is... This happens: Do this:

Ready The Test Unit Ready 
dialog box opens, 
stating, “Your drive 
is ready to run a test 
or task. Click OK, 
select a test/task, and 
then click the ‘Run’ 
button to select and 
run a script.”

Click OK to close the 
dialog box, return to 
xTalk main window, 
and begin running a 
test or task normally 
(see Running a Test 
or Task, below). 

Not ready The Test Unit Ready 
dialog box opens, 
stating, “Your device 
is not ready to run a 
test or task. Click 
View Error to 
determine the 
problem or OK to 
return to the 
application.”

Click OK to return to 
xTalk main window, 
or click View Error to 
display a dialog box 
that contains check 
conditions and a brief 
description of the 
error. Click OK to 
close the dialog box

Fix the error and try 
again.  
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Running a Test or Task
Running a Test or Task 6

To run a test or task:

1 Select the device on which you want to run the test or task from the 
Device Selection Panel.

2 Select the script you want to run from the Script Selection Panel, or 
click a toolbar button (if you click a button, skip step 3).

3 Start the test or task by doing one of the following:

• Click the Run button on the toolbar.

• Double-click the test or task.        

4 Follow the instructions displayed in the Results Panel or in any 
dialog box that may open regarding the test or task.

xTalk runs the test or task, displaying the results in the Results Panel. 

5 For information on how to save these results or send them to a 
recipient, see the following sections:

• Chapter 7, Log Files   

• Saving the Contents of the Results Panel on page 14

• Sending the Contents of the Results Panel on page 15  

Note: If the test or task will take a long time to complete, a dialog box 
opens telling you how long it will take. You can click Yes to 
continue or No to stop.  

Note: If a TapeAlert exists, xTalk Management Console displays the 
TapeAlert dialog box (see chapter 9, Viewing TapeAlerts). The 
test or task may or may not continue running, depending on 
the severity of the TapeAlert.    
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Aborting a Test or Task
Aborting a Test or Task 6

This option allows you to stop a running test or task before it reaches 
completion. 

 To abort a test:

1 Click the Abort button on the toolbar.

A dialog box opens asking, “Are you sure you want to abort this 
test?”

2 Click OK.     

Note: The Abort function is only available for scripts, not 
commands. The Abort function is available only when a script 
is running.

Note: If the device is executing certain operations, the abort signal 
may not stop the test until the operation is complete.  
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7Log Files

Log files are records of individual tests or tasks performed.  This chapter 
describes the following operations:

• Generating and Saving Log Files 

• Viewing Log Files

• Sending a Log File to a Recipient    

Note: A log file contains the results of a script (and some commands) 
performed. This may be different than the information 
displayed in the Results Panel (unless you have Verbose Mode 
enabled -- see Using Verbose Mode on page 13). Saving the 
contents of the Results Panel is different than saving a log file 
(see Saving the Contents of the Results Panel on page 14). 
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Generating and Saving Log Files
Generating and Saving Log Files 7

You can set xTalk Management Console to automatically generate a log 
file for each script (and some commands) you run. To do this, you must 
manually enable the Generate Log File feature in the Preferences dialog 
box (see Generate Log File on page 24). The default setting is not 
enabled; that is, xTalk Management Console will not automatically create 
log files unless you tell it to.  

The log files are stored where indicated in the Preferences dialog box (see 
Folders on page 26). The filename and path are also displayed in the 
Status Bar once the log file has been saved.    

The log file name includes these components:

• Application name (xTalk)

• Date (for example,  01-15-2006)

• Time (24 hour clock) (for example, 143230)

• Device serial number (for example, HV0053Q) (this item may or may 
not be present)  

• A .txt extension

Put together, the log file name looks like this: xTalk_09-19-
2006_143230_HV0053Q.txt.  

Viewing Log Files 7

To view the contents of a log file: 

1 Locate the directory in which the log files are stored. The default  
location is indicated in the Preferences dialog box (see Folders on 
page 26).

2 Double-click the file you want to open.

Using standard Windows commands, you can print or delete the selected 
file.  
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Sending a Log File to a Recipient 7

You can send a log file to a recipient any time you like. To send a log file:

1 Choose File > Send Log from the menu.

The Select Log File dialog box opens.

2 Browse to and select the log file you want to send. 

3 Click Open.

An e-mail message opens. The log file is attached to the e-mail and 
“xTalk Management Console Log File” appears in the e-mail Subject 
line. The e-mail is addressed to support@quantum.com.

4 Type any message and send the e-mail.     
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8Viewing Media Data

This chapter describes how to view the following media information:

• Viewing Media Compatibility

• Viewing Medium Auxiliary Memory (MAM)  

Viewing Media Compatibility 8

The Media Compatibility Tool allows you to see the following for each 
drive type:

• Recommended media

• Compatible media

• Compatible cleaning media

To open the Media Compatibility Tool:

1 Select a device from the Device Selection Panel.

2 Do one of the following:

• Choose View > Media Compatibility from the menu. This opens the 
Media Compatibility Tool main page, from which you can select 
any drive (see figure 7).

Note: This chapter applies only to tape drives.
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Viewing Media Compatibility
• Select a device, then right-click in the Device Selection Panel and 
select Media Compatibility from the pop-up menu. This opens the 
Media Compatibility Tool to the page corresponding to the 
selected device (see figure 8).

3 When you are finished viewing, close the Media Compatibility Tool 
window.

Figure 7  Media Compatibility 
Tool Main Page
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Viewing Media Compatibility
Figure 8  Media Compatibility 
Tool Device Page
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Viewing Medium Auxiliary Memory (MAM)
Viewing Medium Auxiliary Memory (MAM) 8

Information about the device, the medium, and the host is stored directly 
on the tape in the medium auxiliary memory (MAM). 

To view the information stored in MAM:

1 Select a device from the Device Selection Panel.

2 Do one of the following:

• Click the MAM button on the toolbar.

• For DLT devices: Choose Commands > View Medium Auxiliary 
Memory (MAM) from the menu.

• For LTO devices: Choose Commands > Generate Medium Auxiliary 
Memory (MAM) from the menu.

One of the following happens:

If the selected device is an LTO device:

The MAM data is saved to a.bin file. A dialog opens telling you the 
filename and location of this file. The filename includes the device 
serial number. Click OK. This file is in ASCII text and will be difficult 
to read. However, you can e-mail this .bin file to Quantum Support 
for diagnosis (mail to support@quantum.com). Process is complete;  
none of the following steps apply to LTO devices. 

If the selected device is a DLT device:

The MAM dialog box opens (see figure 9). Continue to step 3.

3 Click one of the tabs to view the information. The tabs are as follows:  

• Device Data to view standard device type attributes

• Medium Data to view standard medium type attributes 

• Host Data to view standard host type attributes  

4 When finished viewing, click OK.

Note: This command is not available for all device types.

Note: Not all tabs are available for all device types.  
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Viewing Medium Auxiliary Memory (MAM)
Figure 9  MAM Dialog Box  
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9Viewing TapeAlerts

TapeAlert flags indicate the results of a tape drive’s ongoing self 
diagnosis, allowing you to monitor the tape drive's behavior. When a 
TapeAlert flag is detected, it is displayed in the TapeAlert dialog box.  

You can view the TapeAlert dialog box under the following conditions:

• Before running any test or task, xTalk Management Console checks 
for TapeAlert flags. If it detects them, it displays them in the TapeAlert 
dialog box. If the TapeAlert is critical, you have the option to abort 
the script. 

• When finished running a test or task, if xTalk Management Console 
detects one or more TapeAlerts, it displays the TapeAlert dialog box.  

Note: This feature is not available for the following devices:  
DLT 7000, DLT 8000, DLT1, VS80, VS160, GoVault. 
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Figure 9  TapeAlert Dialog Box

The TapeAlert dialog box lists all possible TapeAlerts. To the left of 
the TapeAlert is an icon depicting the severity of the TapeAlert for 
this device. Problem TapeAlerts are at severity levels of Warning or 
Critical. The Severity column tells you if the TapeAlert is a Warning 
or Critical. If a TapeAlert was detected at startup or before beginning 
a test or task, it is displayed in the area beneath the list of TapeAlerts.     

Level of Severity Definition Color

OK No problem Green

Warning Possible loss of data Yellow

Critical Possible loss of data requiring 
user intervention, service call, 
or both

Red
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Use the TapeAlert dialog box as follows:

1  Use the scroll bar to scroll through the list of TapeAlerts to see which 
ones are Warning or Critical. 

2 Click on a “Warning” or “Critical” TapeAlert to read information and 
instructions. 

Information about the selected TapeAlert displays in the area beneath 
the list of TapeAlerts (see figure 10). 

Figure 10  Viewing a Warning 
TapeAlert

3 When finished viewing, click OK to exit. 

4 If the TapeAlert is detected before the script runs, and the TapeAlert 
is “Critical,” a second dialog box opens asking if you wish to 
continue runing the script. Click Yes or No as desired. 

5 Follow the instructions that were given in the TapeAlert dialog box.
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TapeAlerts are specific to the tape drive; for additional information on a 
TapeAlert, refer to the product manual and/or SCSI interface guide for 
the tape drive.    
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A Failure Analysis (FA) data file provides a “snapshot” of the current 
state of a selected device. This information can be used by service 
personnel to analyze or troubleshoot device problems.  

This section provides instructions on:

• Generating an FA Data File

• Sending an FA Data File to a Recipient

Generating an FA Data File 10

You use the FA Data Collection Wizard to generate FA data files. The FA 
Data Collection Wizard queries the tape drive, retrieves diagnostic and 
core data, and compresses it into a file. The default filename consists of  

Note: FA data cannot be gathered for all device types. The FA Data 
features described in this section work with the following 
device types: SDLT 220, SDLT 320, SDLT 600, DLT-S4, VS-160, 
DLT-V4. Some other device types allow you to generate FA 
data in the form of a trace buffer (see GENERATE TRACE 
BUFFER on page 54) or an EEPROM buffer (see GENERATE 
EEPROM BUFFER on page 54).  
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the device serial number with a .dmz or .dmp extension, depending on 
device type  (for example, JK00DA8.dmz). 

To generate an FA data file:

1 Select a device from the Device Selection Panel.

2 Do one of the following:

• Choose Commands > Failure Analysis Data from the menu.

• Click the FA Data button on the toolbar.   

The FA Data Collection Wizard opens, stating, “Welcome to the FA 
Data Collection Wizard. It will help you generate FA Data. Click 
’Next’ when ready.”

3 Click Next.  

The second dialog box opens, displaying a default filename and 
location where the FA Data file will be saved. 

4 Do one of the following:

• To save to the listed filename and location, click Next. 

• To save to a different location or filename, click Browse. The FA 
Data Filename dialog box opens. Choose a new filename and/or 
location, then click Open. You return to the previous dialog box, 
with your chosen filename and path listed. Click Next.

An information-gathering dialog box opens asking for information 
about you and the problem with the device.

5 Fill out the information requested and click Next.

Note: You can also select the appropriate FA Data or FA Dump 
script (depending on device type) from the Script Selection 
Panel then click the Run button on the toolbar. However, 
running this  script instead of the Wizard has several 
differences:

•The script leads you through slightly different dialogs.

•Status information is displayed in the Results Panel 
rather than in dialog boxes.

•You cannot send the file immediately after generating (as 
described in Sending Immediately After Generating on 
page 50).
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A dialog box opens stating, “The FA Data Wizard is ready to collect 
the requested information. Click ‘Start’ when ready.” 

6 Click Start.

The FA data file is generated saved to the specified location. This may  
take several minutes. 

If the FA data collection is successful, a message states, “The  FA Data 
Collection Wizard has successfully collected the device data” (see 
figure 11).  

At this point, you have the option to send the FA Data file to a 
recipient (see Sending an FA Data File to a Recipient).

7 If you choose not to send the FA data file, click Exit.

Figure 11  FA Data Collection 
Successful

If the FA data collection fails, the message in the dialog box states, 
“FA Data collection failed. Click ‘Back’ to try again. If this continues, 
verify your SCSI cabling, termination, and firmware version for your 
product.” Click Back or Exit.    
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Sending an FA Data File to a Recipient 10

You can send FA Data files via e-mail in two ways:

• Sending Immediately After Generating

• Sending Any Time

Sending Immediately After 
Generating 10

After you successfully generate an FA Data file using the FA Data 
Collection Wizard, you have the option to immediately send the file to a 
recipient as follows:

1 Select the Send FA Data to recipient checkbox (see figure 12).

When you select the checkbox, the Exit button changes to Send.

Figure 12  Sending FA Data To 
a Recipient

2 Click Send.

An e-mail message opens. The FA data file is attached to the e-mail 
and “xTalk Management Console FA Data File” appears in the e-mail 
Subject line. The e-mail is addressed to support@quantum.com. 

3 Type a message and send the e-mail.

The dialog box closes once you send the e-mail. 
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Sending Any Time 10 You can send an FA Data file to a recipient any time you like as follows:

1 Select File > Send FA Data from the menu.

The Select FA Data File dialog box opens.

2 Browse to and select the FA data file you want to send. 

3 Click Open.

An e-mail message opens. The FA data file is attached to the e-mail 
and “xTalk Management Console FA Data File” appears in the e-mail 
Subject line. The e-mail is addressed to support@quantum.com.

4 Type a message and send the e-mail.   
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11General Device Commands

This chapter details general device commands that are not covered in 
other chapters of this manual. For additional information about SCSI 
commands, refer to the SCSI reference manual for the device you are 
testing.

 This chapter discusses the following commands:

• Compression Mode – Viewing and Setting

• Compression Status – Viewing and Setting

• CREATE DLTSAGE WORM TAPE

• GENERATE EEPROM BUFFER

• GENERATE TRACE BUFFER

• INQUIRY INFORMATION

• PARK

• Removable Storage Settings

• RESCAN

• RETENSION

• UNPARK

Note: Some device types may not support all of these commands. If a 
selected device does not support a listed command, the 
command will not appear in the menu or toolbar, or it will 
appear but be greyed out.  
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Compression Mode – Viewing and Setting
Compression Mode – Viewing and Setting 11

This feature is currently not functional. 

Compression Status – Viewing and Setting 11

When compression is enabled, the tape drive compresses data at a 2:1 
ratio (the tape drive compression bit is set to 1). 

When compression is disabled, the system does not compress data (the 
tape drive compression bit is set to zero). 

You can view and set compression status for the selected device as 
follows:     

VIEW CURRENT STATUS 11 You can see whether compression is enabled or disabled for a particular 
device by doing the following: 

1 Select a device from the Device Selection Panel.

2 Select Commands > Compression Status > View Current Status from 
the menu. 

The current status is displayed in the Results Panel. 

ENABLE/DISABLE 
COMPRESSION STATUS 11

You can enable or disable the compression status by doing the following:

1 Select a device from the Device Selection Panel.

2 Select Commands > Compression Status from the menu.

3 Choose either Enable or  Disable from the menu.

The new status is displayed in the Results Panel. 

Note: For LTO devices only, you can also set the compression mode, 
which overrides the compression status (see Compression 
Mode – Viewing and Setting on page 56). 
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CREATE DLTSAGE WORM TAPE
When you exit xTalk Management Console and log back in, the 
compression status remains where it was when you exited.  

CREATE DLTSAGE WORM TAPE 11

This command sets a tape cartridge to be DLTSage WORM compatible  
[formats the tape cartridge as write-once read-many (WORM)].    

To perform this command:

1 Select a device from the Device Selection Panel.

2 Insert a blank tape cartridge that contains no data and wait for the 
drive to come ready. 

3 Do one of the following:

• Select Commands > DLTSage WORM Tape from the menu.

• Click the DLTSage WORM button on the toolbar.

• You may also select the Create_DLTSate_WORM_Tape task from 
the Script Selection Panel and click the Run button. This will 
perform the operation without bringing up the Wizard. All 
results are displayed in the Results Panel.

The DLTSage WORM Wizard dialog box opens (see figure 14).

Note: This command only works on media that does not already 
have data written on it. It works on the following device and 
tape combinations:
• SDLT 600 with a Super DLTtape II cartridge
• DLT-S4 with a Super DLTtape II or Super DLTtape III 

cartridge   
• DLT-V4 with a DLTtape VS1 cartridge
xTalk Management Console for Windows User’s Guide 54



Chapter 11  General Device Commands
CREATE DLTSAGE WORM TAPE
Figure 13  DLTSage WORM 
Wizard 

4 Click Format.

The tape cartridge is formatted as a DLTSage WORM cartridge. 

After the cartridge has been successfully formatted, the dialog box 
message tells you so.

5 Click Exit to return to xTalk Management Console. 

Note: If the cartridge has already been formatted with DLTSage 
WORM, a dialog box opens stating “This is a DLTSage 
WORM cartridge” and displays the DLTSage WORM 
signature. 

Note: If the media is not blank, a dialog box opens stating it 
cannot be used to create a DLTSage WORM cartridge.
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GENERATE EEPROM BUFFER
GENERATE EEPROM BUFFER 11

The GENERATE EEPROM BUFFER command collects drive information 
from the electrically erasable programmable read-only memory 
(EEPROM) and saves this information to a .bin file.   

To perform this command:

1 Select a device from the Device Selection Panel.

2 Do one of the following:

• Choose Commands > Generate EEPROM Buffer from the menu.

• Click the EEPROM button on the toolbar.

The EEPROM data is saved to a .bin file, written in ASCII text. The 
name and path are displayed in a dialog box. The name of the file is 
the EEPROM_<device serial number>.bin. 

You can open this .bin file, but you will not be able to easily read the 
file since it is in ASCII text. However, you can e-mail the file to 
Quantum Support for diagnosis (mail to support@quantum.com).

3 Click OK to exit.  

GENERATE TRACE BUFFER 11

The GENERATE TRACE BUFFER command collects current drive status 
information from the trace buffer and saves it to a .bin or .svm file.    

To perform this command:

1 Select a device from the Device Selection Panel.

Note: This command is only available for LTO tape drives.

Note: This command is only available for DAT and LTO tape drives.
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INQUIRY INFORMATION
2 Do one of the following:

• Select Commands >  Generate Trace Buffer from the menu.

• Click the Trace button on the toolbar.

DAT trace buffer data is saved to a .bin file. LTO trace buffer data is 
saved to an .svm file. The files are written in ASCII text. The name and 
path are displayed in a dialog box. The name of the file is 
ChannelTrace Buffer_<device serial number>.svm (for DAT) or Trace 
Buffer_<device serial number>.svm (for LTO). 

You can open the .bin and .svm files using a text editor. More 
commonly, however, you will e-mail the file to Quantum Support for 
diagnosis (mail to support@quantum.com).

3 Click OK to exit.  

INQUIRY INFORMATION  11

The INQUIRY INFORMATION command retrieves information about the 
device from the device firmware and displays it in a dialog box. 

To display information about a device:

1 Select a device from the Device Selection Panel.

2 Do one of the following:

• Select Commands > Inquiry Information from the menu

• Click  the Inquiry button

The Inquiry dialog box opens, with tabs displaying various data. The 
following tabs may be displayed (not all tabs are available for all 
devices).

• Standard Data

• Vendor Unique Data

• Vital Product Data

• Log Information (DAT 72  and DDS-4 devices only)

3 Click the tab to view the information you want.

4 To close the dialog box, click OK.  
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PARK
PARK 11

The PARK command parks the drive arm. Before performing this 
command you must first remove the tape cartridge completely from the 
device.  

To perform this command:

1 Select a device from the Device Selection Panel.

2 Click the Park button on the toolbar.

Removable Storage Settings 11

Removable Storage is a Microsoft® media-management product that 
comes bundled with Windows 2000 and later operating systems. When 
Removable Storage is running, it can interfere with xTalk Management 
Console operations. Therefore, Removable Storage should always be OFF 
when xTalk Management Console is running. 

You can turn Removable Storage on or off at your convenience using 
Microsoft Management Console (refer to Microsoft documentation for 
how to do this). 

Regardless of how you set Removable Storage, whenever you open xTalk 
Management Console, Removable Storage turns OFF. When you shut 
down xTalk Management Console, Removable Storage returns to the 
state it was set at before you opened xTalk Management Console.   

Note: This command is only available for LTO full-height tape 
drives.
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RESCAN
RESCAN 11

When you launch xTalk Management Console, it scans the bus for 
devices before opening. These devices are then displayed in the Device 
Selection Panel.

If you want to scan the bus at any other time, do one of the following:

• Click the Rescan button on the toolbar. 

• Select Commands > Rescan from the menu.

Any new devices found are displayed in the Device Selection Panel.   

RETENSION 11

The RETENSION command causes the tape to move from its current 
position to the end of media (EOM), then rewinds to the beginning of 
media (BOM), to remove excessive tension or slackness on the tape. 

To perform this command:

1 Select a device from the Device Selection Panel.

2 Click the Retension button on the toolbar. 

The tape retensioning begins. This process takes several minutes. 
Status is shown by a series of asterisks displayed in the Results Panel. 
Each asterisk represents 2 seconds. Each line of 30 asterisks equals 
one minute. 

When complete, “Retension complete” displays in the Results Panel.

Note: If you add new devices, it may take the operating system a 
little while to complete recognition. If the bus scan misses an 
attached device, try the rescan again -- you may need to rescan 
the bus more than once to display all the devices, or you may 
need to restart xTalk Management Console.  

Note: This command is only available for LTO tape drives.
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UNPARK
UNPARK 11

The UNPARK command unparks the drive arm. Before performing this 
command you must remove the cartridge completely from the device.  

To perform this command:

1 Select a device from the Device Selection Panel.

2 Click the Unpark button on the toolbar.

        

Note: This command is only available for LTO full-height tape 
drives.
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12Using Push Pins

A push pins is a feature available in some dialog boxes that allows you to 
keep the dialog box open when it would normally close. When you 
enable the push pin, the dialog box stays open on your computer screen 
until you disable the push pin or manually close the dialog box. This is 
helpful if you want to look at the information in the dialog box while 
using other xTalk features or commands. You can continue to update 
information in the open dialog box by clicking anywhere inside the 
dialog box to activate it. 

If you do not enable the push pin, xTalk closes the dialog box when you 
click anywhere outside it. 

• Enabling the Push Pin and Attaching the Dialog Box

• Disabling the Push Pin and Closing the Dialog Box
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Enabling the Push Pin and Attaching the Dialog Box 12

To enable the push pin and attach the dialog box, click the disabled (side-
facing) push pin icon located in the dialog box (see figure 13). 

Figure 13  Disabled Push Pin
  

The push pin is now enabled. The icon changes to look like it is pushed in 
(see figure 14). Notice that you cannot close the dialog box when the push 
pin is enabled.

Figure 14  Enabled Push Pin

Disabling the Push Pin and Closing the Dialog Box 12

To disable the push pin and close the dialog box do one of the following:

• Click the enabled push pin (see figure 14). The push pin is now 
disabled. The icon changes to the side-facing push pin (see figure 13). 
Now you can click outside the dialog box and it will close.

• Click Close or Cancel in the dialog box.

• Click the X in the upper right corner of the dialog box. 

When you reopen the dialog box, the push pin is disabled.  
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13Getting Help

The Help feature offers a number of features. You can:

• Access the Users Guide (the manual you are currently reading)

• Use the Help Menu to perform a number of other tasks

Access the Users Guide 13

To access online help (the User’s Guide you are currently reading), do one 
of the following:

• Select Help > Online User’s Guide from the menu.

• Click the Help button on the toolbar.

• Type the keyboard shortcut <Shift+F1>.  
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Use the Help Menu
Use the Help Menu 13

To access other Help features, choose Help from the menu. Then select the 
option you want:  

Option Description

About xTalk Provides version and copyright information. 

Check for xTalk  
Updates

Currently disabled.

Contact Support Opens the Quantum Web site, 
www.quantum.com, where you can find contact 
information for Customer Support. 

Online User’s 
Guide

Opens the xTalk Management Console for 
Windows  User’s Guide (the manual you are 
currently reading).

Read Me Opens the xTalk Management Console Release 
Notes.

Send Feedback Opens an e-mail addressed to xTalk 
Management Console developers allowing you 
to e-mail feedback regarding xTalk 
Management Console. 
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ASpecifications

This section covers the following:

• Minimum PC Requirements

• Supported Operating Systems

• Supported Interfaces

• Supported Host Bus Adapters

• Supported Devices

Minimum PC Requirements 1

You  need the following, at a minimum, to run xTalk Management 
Console:

• Pentium-class PC (300 MHz or higher recommended) 

• Administrator Privileges on the system (required)

• 128 MB of RAM (256 MB or greater is recommended) 

• 30 MB of available hard-disk space

• Microsoft Internet Explorer 5 or higher
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Supported Operating Systems
• Super VGA monitor with screen resolution set to at least 1024 x 768, 
small fonts setting (recommended)

• Adobe® Acrobat Reader (version 5.0 or later)

• Supported operating system (see Supported Operating Systems) 

Supported Operating Systems 1

The xTalk Management Console software runs on the following 
operating systems:  

Supported Interfaces 1

xTalk Management Console supports the following interfaces:

• Small Computer System Interface (SCSI)

• Serial Attached SCSI (SAS)

• Serial Advanced Technology Attachment (SATA)

• Fibre Channel (FC)

• Universal Serial Bus (USB)

Operating System Versions

Microsoft Windows® 2000 (SP 2)

2003 Server

XP 

Vista
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Supported Host Bus Adapters
Supported Host Bus Adapters 1

xTalk Management Console is designed to support all standards-
compliant host bus adapters. 

Supported Devices 1

xTalk Management Console supports the following devices: 

 

• DAT 40 (DDS-4) 

• DAT 72 

• DAT 160

• DLT1 

• DLT 7000 

• DLT 8000 

• DLT-S4

• DLT-V4 

• DLT VS80

• DLT VS160 

• GoVault™

• LTO-1 

• LTO-2 

• LTO-2 HH 

• LTO-3 

• LTO-3 HH

• SDLT 220 

• SDLT 320 

• SDLT 600   
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Glossary

A ASC   Additional sense code

ASCQ   Additional sense code qualifier

ATA   Advanced Technology Attachment. A type of disk drive that 
integrates the drive controller directly on the drive itself. 

B BOM   Beginning of media

BOT   Beginning of tape

C CUP   Code update (used interchangeably with FUP)

E EEPROM   Electrically erasable programmable read-only memory

EOD   End of data (last data position)

EOM   End of medium

EOT   End of tape

F FA   Failure analysis

FC   Fibre Channel

FUP   Firmware update (used interchangeably with CUP)
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G GUI   Graphical user interface

H HDD   Hard disk drive

L LBA   Logical block address

LUN   Logical unit number

M MAM   Medium auxiliary memory

N NOP   No operation

S SAS   Serial Attached SCSI

SATA   Serial ATA (see ATA). An evolution of the Parallel ATA physical 
storage interface. Serial ATA is a serial link (a single cable with a 
minimum of four wires creates a point-to-point connection 
between devices).

Script   The instructions sent to the device when you run a test, task, or 
command.

SCSI   Small computer systems interface

W WORM   Write-once read-many. Applies to tape cartridges. Does not 
allow erasure of data once it is written to the tape.
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Index
A

abort button 35
aborting a test, task, or script 35

B

buttons. See toolbar

C

clear view 15–16
clearing Results Panel 15–16
colors, changing settings 27
commands

See specific commands by name
differences between scripts and 

commands 8
general tape device commands 

52–57
commenting in results panel 17

compression status 53
copying information from results 

panel 18

D

default settings 27
device information 55
device selection panel 6–7

displayed information 6
selecting non-supported devices 

7
devices

non-supported 7
supported 64

dialog boxes, staying open 58–59
downloading. See updating
drive information 55

E

EEPROM buffer
generating (LTO) 54

e-mailing. See sending
ending a test, task, or script 35
exiting 11

F

FA data files 26, 47–51
generating 47–49
location of 26
saving 26
sending 50–51

firmware, updating 29–31
folders, viewing paths to 26
FUP drive 29–31
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Index
G

GENERATE EEPROM BUFFER 54
GENERATE TRACE BUFFER 54–55

H

help 60–61

I

icons. See toolbar
INQUIRY INFORMATION 55

K

key strokes. See shortcuts, keyboard

L

log files 24, 26, 36–38
auto-generating 24
generating 24, 37
location of 26
saving 26, 37
sending 38
viewing 37

M

main window 1–10
MAM, viewing 42

media 39–41
compatibility 39–41

media compatibility tool 39–41
medium auxiliary memory, viewing 

42
menu 3

N

non-supported devices 7

O

operating systems, supported 63

P

preferences 22–27
See specific preferences by name
setting 22–27
viewing 22

push pins, using 58–59

R

removable storage services, 
enabling and disabling 56

RESCAN the SCSI bus 56
results panel 9, 12–18, 27

adding comments to 17
clearing 15–16
colors, changing 27
copying 18
displayed information 13

saving 14–15
searching 16
sending contents of 15

RETENSION 57
return to default settings 27
run button 34
running a test or task 34

S

save 14–15
save as 14–15
saving results panel 14–15
scan SCSI bus 56
script description panel 9
script selection panel 8
scripts

altering 8
differences between scripts and 

commands 8
location of 26

SCSI bus
rescanning 56

searching, results panel 16
sending

FA data files 50–51
log files 38
results panel contents 15
view 15

settings
changing 22–27
return to default settings 27

shortcuts 19–20
keyboard 19–20
right-click 20

show splash screen at startup 24–25
show startup caution 25–26
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Index
software, updating 28–29
specifications 62–64
splash screen, showing and hiding 

24–25
starting a test or task 34
startup caution, showing and 

hiding 25–26
status bar 9–10

show/hide 10
stopping a test, task, or script 35
supported devices 64
supported operating systems 63

T

TapeAlerts 43–46
viewing 43–46

tasks. See tests/tasks
TEST UNIT READY 32–33
tests. See tests/tasks
tests/tasks 32–35

aborting 35
determining device readiness 

32–33
running 34

toolbar 3–6
trace buffer, generating 54–55

U

unsupported devices 7
updating 28–31

application 28–29
firmware 29–31
help files 28–29
release notes 28–29

scripts 28–29
software 28–29
xTalk Management Console 28–

29
updating xTalk 26

V

verbose mode 13
viewing

log files 37

W

WebUpdate Wizard 26
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