Supported Browsers and Device Operating Systems

Use a supported browser so that the StorNext Connect website and StorNext Connect display and work properly. Unsupported browsers typically render poor formatting on the screen. In addition, make sure you have applied all updates and security fixes issued for the browser or device.

All browser displays must be 1024 in width or higher.

Tablets and iOS devices do not support the download of installation bundles, the management of clients, or the ability to export chart data.

Browser/Device OS

StorNext Connect

Android 4.0 or later

Requires a minimum of 2 GB RAM

Android 5.0.x

(with Chrome on tablets)

Requires a minimum of 2 GB RAM

Chrome current version

Edge current version

Firefox current version

IE 11

iOS 10

Mac OS Safari 9.1 or later