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Preface

This guide contains information and instructions necessary for the 
normal operation and management of the Scalar LTFS Appliance. This 
guide is intended for system administrators, operators, or anyone 
interested in learning about or using the Scalar LTFS Appliance after its 
initial installation and configuration.

Audience This manual is written for Scalar LTFS Appliance operators and system 
administrators.

Note: It is useful for the audience to have a basic understanding of 
UNIX and backup/recovery systems.

Document Organization Following is a brief description of chapter contents.

• Chapter 1, Introduction provides the product overview, lists system 
requirements, and describes the system’s features and benefits.

• Chapter 2, Best Practices describes best practices for installing the 
system, operating the system, and configuring the system.

• Chapter 3, Logging On and Navigation provides instructions for 
logging on, depicts the navigational flow of GUI, and provides a 
picture of the Home screen.
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• Chapter 4, Configuring the Appliance provides instructions for 
configuring the appliance. 

• Chapter 5, System Media Operations describes how to manage files 
and media using the Scalar LTFS Appliance.

• Chapter 6, Maintaining the System provides procedures for tasks 
available under the GUI Tools menu, including requesting a system 
configuration record, backing up and restoring your system 
configuration, capturing a system snapshot, updating firmware, 
and reviewing and resolving diagnostic tickets. Finally, this chapter 
discusses reports and logs available to help maintain system 
integrity.

• Chapter 7, Reports provides details on all the reports available for 
viewing and for sending.

• Chapter 8, Troubleshooting provides a list of frequently asked 
questions, identifies known issues by category—server hardware, 
library tape drive, and software, and provides a list of system alerts. 

• Appendix A, User Roles provides a listing of functions available 
based on the assigned user role.

• Glossary provides a list of terms used throughout this document 
and their definitions.

The following formats indicate important information:

Note: Note emphasizes important information related to the main 
topic.

Caution: Caution indicates potential hazards to equipment or data.

WARNING: Warning indicates potential hazards to personal safety.

• Right side of the system — Refers to the right side as you face the 
front of the component being described.

• Left side of the system — Refers to the left side as you face the front 
of the component being described.
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Product Safety 
Statements

Quantum will not be held liable for damage arising from unauthorized 
use of the product. The user assumes all risk in this aspect.

This unit is engineered and manufactured to meet all safety and 
regulatory requirements. Be aware that improper use may result in 
bodily injury, damage to the equipment, or interference with other 
equipment.

WARNING: Before operating this product, read all instructions and 
warnings in this document and in the system, safety, and 
regulatory guide.
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Related Documents The following Quantum documents are also available for the Scalar LTFS 
Appliance:
 

Release Notes are also provided for this product. The Release Notes 
provide a list of any known issues and work-arounds, and compatibility 
information.

For the most up to date information on the Scalar LTFS Appliance, see:

http://www.quantum.com/ServiceandSupport/Index.aspx

Document 
No. Document Title

6-67516-xx Scalar LTFS Appliance Site Planning and Installation 
Guide
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Supported Operating 
Systems and Internet 
Browsers

The Internet browser software is not supplied with the Scalar LTFS 
Appliance; you must obtain and install it independently. For a list of 
supported Internet browsers and operating systems, see System 
Requirements on page 3.

Contacts Visit the Quantum home page at: 

http://www.quantum.com

Getting More 
Information or Help

StorageCare™, Quantum’s comprehensive service approach, leverages 
advanced data access and diagnostics technologies with cross-
environment, multi-vendor expertise to resolve backup issues faster and 
at lower cost. 

Accelerate service issue resolution with these exclusive Quantum 
StorageCare services:

• Service and Support Web site - Register products, license 
software, browse Quantum Learning courses, check backup 
software and operating system support, and locate manuals, FAQs, 
firmware downloads, product updates and more in one convenient 
location. Benefit today at:

 http://www.quantum.com/ServiceandSupport/Index.aspx

• eSupport - Submit online service requests, update contact 
information, add attachments, and receive status updates via e-
mail. Online Service accounts are free from Quantum. That account 
can also be used to access Quantum’s Knowledge Base, a 
comprehensive repository of product support information. Sign up 
today at:

http://www.quantum.com/osr

For further assistance, or if training is desired, contact the Quantum 
Customer Support Center:

United States 800-284-5101 (toll free)
949-725-2100

EMEA 00800-4-782-6886 (toll free)
+49 6131 3241 1164
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Worldwide End-User 
Product Warranty

For more information on the Quantum Worldwide End-User Standard 
Limited Product Warranty:

http://www.quantum.com/pdf/QuantumWarranty.pdf

Training Available To make the best use of your Scalar LTFS Appliance, online training is 
available at www.quantum.com/ServiceandSupport/
StorageCareLearning/Index.aspx

APAC +800 7826 8887 (toll free)
+603 7953 3010

For worldwide support:
http://www.quantum.com/ServiceandSupport/Index.aspx
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Chapter 1
Introduction

This chapter introduces Scalar LTFS Appliance, including:

• Product Overview on page 1

• Available Hardware Configurations on page 2

• System Requirements on page 3

• Graphical User Interface (GUI) Description on page 4

• Features and Benefits on page 4

• License Key Implementation on page 5

Note: Make sure to take the online training for the Scalar LTFS to 
make the best use of your product. The online training is 
available at www.quantum.com/ServiceandSupport/
StorageCareLearning/Index.aspx

Product Overview

The Scalar LTFS Appliance is a file system that presents a Quantum tape 
library as an NAS share. This appliance makes files viewable as if they 
Quantum Scalar LTFS Appliance User’s Guide 1
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Available Hardware Configurations
resided on your local disk and allows users to drag and drop files 
directly to and from a tape cartridge.

This appliance provides large file portability so that you can quickly and 
easily retrieve large files, whether they are active or archived, from your 
library, exchange files with other organizations (inside and outside of 
your company) for collaborative and sequential work-flow applications, 
and drag and drop files to and from tape.

Available Hardware Configurations

The Scalar LTFS Appliance can be ordered in the following 
configurations (see table below). For configuration guidelines, refer to 
Chapter 4, Configuring the Appliance. 

Table 1  Scalar LTFS 
Configurations

Scalar LTFS Appliance Configuration
Rack Space 
Required

Scalar LTFS 1 GbE SAS Appliance
5 x 1 GbE Ethernet ports
2 x 6 Gbps SAS ports

2u

Scalar LTFS 1 GbE FC Appliance
5 x 1 GbE Ethernet ports
2 x 8 Gbps Fibre Channel ports

2u

Scalar LTFS 10 GbE SAS Appliance
2 x 10 GbE Ethernet ports
1 x 1 GbE Ethernet port
2 x 6 Gbps SAS ports

2u

Scalar LTFS 10 GbE FC Appliance
2 x 10 GbE Ethernet ports
1 x 1 GbE Ethernet port
4 x 8 Gbps Fibre Channel ports

2u
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System Requirements

This section lists the system requirements and a description of each 
requirement.

Requirement Description

Use with library Scalar i40, Scalar i80, Scalar i500, 
Scalar i6000, Dell ML6000

Drives HP LTO-5 and LTO-6
IBM LTO-5, LTO-6 and LTO-7

Library Connectivity Fibre channel
SAS

Network Connectivity Recommended minimum 1GbE

Media LTO-5 or later

Operating System Tested operating systems
CIFS
• Windows Server 2003
• Windows Server 2008
• Windows Server 2012
• Windows 7

• Mac OS X 10.7
NFS v4
• Linux RHEL 5.6
• Linux Ubuntu 10.4

Internet Browsers Tested Internet Browsers:
• Firefox 18.0.2, 19.0, 26.0, 

40.0.3
• Chrome 18.0, 25.0.x, 32.0.x, 

45.0.x
• Internet Explorer 8.0.x, 9.x
• Safari 5.0.6

Adobe Flash Player • 10 or higher
Quantum Scalar LTFS Appliance User’s Guide 3
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Supported Libraries and Drives

The Scalar LTFS Appliance supports the following Scalar Libraries and 
drives:

Graphical User Interface (GUI) Description

You configure and manage the appliance using the GUI. To learn more 
about accessing and using the GUI, refer to Chapter 3, Logging On and 
Navigation.

Features and Benefits

Library Drive

Scalar i40/i80 HP LTO-5 and LTO-6 (FC and SAS)

Scalar i500 HP LTO-5 and LTO-6 (FC and SAS)
IBM LTO-5 and LTO-6 (FC)

Scalar i6000 HP LTO-5 and LTO-6 (FC)
IBM LTO-5, LTO-6 and LTO-7 (FC)

Dell ML6000 IBM LTO-5 and LTO-6 (FC and SAS)

Product Features Customer Benefits

NAS bridge to tape library Enables broad market access to tape technology without the use 
of a backup or archive application

Can span multiple libraries Saves investment for multiple library environments 
4 Quantum Scalar LTFS Appliance User’s Guide
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License Key Implementation

All Scalar LTFS Appliances use drive licenses to enable access to a 
number of tape drives. A Scalar LTFS Appliance can only access the 
number of tape drives matching the number of drive licenses that are 
installed on the appliance. Users accessing the Scalar LTFS Appliance 
should be less than or equal to the number of drives licensed on the 
partition to ensure optimal performance. If there are too many users 
performance can be degraded, leading to errors and possible system 
time outs.

Presents cartridge level 
addressability

Easy project level container management 

Intuitive web-based interface User friendly operation reduces IT support burden 

Library partition support Can differentiate departmental files 

Mirrored disk storage of index Maintains high availability in the event of hard drive failure 

Index backup function Enables quick recovery of index in the event of unit failure or 
replacement 

Appliance based Simplifies set up and use; reduces IT support cost; Assures 
expected performance 

Supports HP & IBM drives Protects user legacy investment and maintains choices for future 

Scalable model Performance and tape drive license upgrades keeps initial 
investment manageable while offering needed growth over time 

Stackable Multiple appliance will naturally appear in NAS presentation of 
file system

Volume Groups Allows management of multiple media/volumes under one folder 
providing easily scalable storage capacity.

File Spanning Spanning of files across multiple media/volumes making storage 
management easier.

Product Features Customer Benefits
Quantum Scalar LTFS Appliance User’s Guide 5
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License Key Implementation
Each appliance ships with a two (2) drive license installed on the 
appliance. 

Additional drive licenses can be added to a maximum of eight (8) tape 
drive licenses per appliance. Any additional drive licenses ordered with 
the appliance must be installed separately.

The table below provides examples of how your licenses are used with 
your library.

Note: Any drives that are installed but not licensed can be used as fail 
over drives in case of a drive malfunction.

If you purchased: And your library has: Then

2 tape drive licenses 2 LTO-5 or higher tape drives All tape drives can be accessed via 
the appliance.

2 tape drive licenses 4 LTO-5 or higher tape drives 2 tape drives can be accessed via the 
appliance.

4 tape drive licenses 10 LTO-5 or higher tape drives 4 tape drives can be accessed via the 
appliance
6 Quantum Scalar LTFS Appliance User’s Guide



Chapter 2
Best Practices

This chapter defines the term best practice and lists the known best 
practices for installing, configuring, and operating the Scalar LTFS 
Appliance.

What is a Best Practice? on page 7

Client Side File System Configuration on page 8

Installation on page 18

Software Configuration on page 18

Operations on page 18

Library on page 24

What is a Best Practice?

A best practice is a method or technique that has consistently shown 
results superior to those achieved with other means and is used as a 
benchmark. In addition, a best practice can evolve to become better as 
improvements are discovered. Best practice is a refined method of 
operation that multiple organizations can use.
Quantum Scalar LTFS Appliance User’s Guide 7
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Client Side File System Configuration

NFS Mount Options It is recommended to use NFS on Linux to prevent data corruption. The 
following details the proper command and timeout (timeo) settings for 
the fstab:

#.#.#.#:/ScalarLTFS /ScalarLTFS   nfs4 
timeo=12000,mountproto=tcp,users,rw,hard,intr,bg,rsi
ze=1048576,wsize=1048576 0 0

For command line, use the following command and timeout settings:

mount -o rsize=1048576,wsize=1048576,timeo=12000 
172.16.10.10:/ScalarLTFS /<dir>

For optimum performance, modify the /etc/fstab file on your host 
server (not the Scalar LTFS Appliance) by changing the IP or DNS name 
of the Scalar LTFS Appliance to 10.20.226.107.

Some LTO-5 tape operations (space, locate, read) can take 20 minutes to 
complete successfully. The timeo value, expressed in deciseconds, 
equates to 20 minutes.

• Operations that complete more quickly are unaffected (in particular,     
they are in no way delayed by this timeout value)

• This specification will prevent NFS from retrying commands that 
cause long-running tape operations prematurely, and may avert 
stale file handle errors.

Note: NFS mount options are unsupported on Mac OS.

NFS Hard Mounts Hard mounts are the preferred option when communicating with NFS 
servers because they will preserve data transfers in the event of a server 
failure. If the host ‘hangs’ during a hard mount, the user should restart 
the Scalar LTFS Appliance. Any I/O requests sent during the reboot will 
complete after the Scalar LTFS Appliance restarts.
8 Quantum Scalar LTFS Appliance User’s Guide
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Directory Visibility - 
Windows 7

File directories should always be set to details or list mode to make file 
transfers as easy as possible.

To view Scalar LTFS directories in Windows 7: 

1 Set the current directory to Details or List mode.

Figure 1  Folder display options

2 Go into Organize >Folder and Search Options and select the View 
tab.
Quantum Scalar LTFS Appliance User’s Guide 9
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Figure 2  Folder Options 
window

3 Click the Apply to Folders button.

4 A confirmation box displays asking if you want to apply the view 
options to all the sub-folders. Click Yes.

Figure 3  Folder Views 
confirmation dialog box

Directory Visibility - 
Mac OS

To view Scalar LTFS directories in Mac OS:

1 Select the LTFS directory.
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2 Select View > as List.

Figure 4  Selecting as List from 
the View menu

3 Select View > Show View Options.

Figure 5  Selecting Show View 
Options from the View menu 

4 From the View Options window, select the Always open in list 
view check box.
Quantum Scalar LTFS Appliance User’s Guide 11



Chapter 2: Best Practices
Client Side File System Configuration
Figure 6  View Options 
window

5 Close the window to apply changes.

Note: Mac users will have to apply these settings to each directory. 
Subdirectories will not inherit properties of their parent 
directory.

Directory Visibility - 
Linux

To view Scalar LTFS directories in Linux using a file browser:

1 Select the LTFS directory.

2 Select Edit > Preferences.
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Figure 7  Edit menu options

3 From the View tab of the File Management Preferences window, 
select List View from the View new folders using: drop-down 
menu.
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Figure 8  File Management 
Preferences window

4 Click Close.

WORM Write Once Read Many (WORM) media is not compatible with the LTFS 
format. WORM media cartridges have only a single partition, while LTFS 
requires cartridges to be formatted with two partitions.

Concurrent Volume 
Group Access 
Limitations with NFS 
and CIFS

Avoid creating more mounted volume groups than available drives. 
When the number of accessed volume groups exceeds the number of 
drives, the drives are said to be oversubscribed. 

If a file access request is received on a volume in a partition that has no 
available drives, the following occurs:

• If the file transfer protocol is CIFS, a file system error (EAGAIN) is 
returned indicating that the resource is temporarily unavailable.
14 Quantum Scalar LTFS Appliance User’s Guide
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The user can retry the operation in hopes that a drive has become 
available.

• If the file transfer protocol is NFS, the operation is automatically 
retried. However, the order of file operations may not be preserved 
if several operations are accessing volume groups in that partition.

NFS File Fragmentation NFS uses file caching and multiple simultaneous data transfer threads to 
increase performance when writing data to disk. NFS does not keep file 
data in order, because this is not important for disk storage devices.

Since NFS is not designed to write files to tape, writing file sectors out 
of sequence to a tape device causes lower transfer rate when the file is 
read due to the fragmentation of the file on the tape. Because of this, 
Quantum recommends transferring data to the Scalar LTFS file system 
using direct I/O, which will bypass the NFS caching layer and write the 
data directly to the tape device.

Quantum also recommends the following options:

• When using vendor-supplied or off-the-shelf applications, specify 
direct I/O access when the application supports it

• When using in-house applications to write data to Scalar LTFS, 
amend open system calls to specify direct I/O

• Send application output to STDOUT and direct it through the Linux 
standard ‘dd’ command. Specify the option “bs=512k 
oflags=direct” to block data for LTFS and send it using direct I/O

• If none of the previous options are available, write files to a local 
disk and use the ‘dd’ command to copy the files to LTFS

Note: Writing files using direct I/O takes more time than using NFS, 
but greatly increases the read performance when the file is 
needed in the future.

Note: The Scalar LTFS Appliance does not support the use of NFS with 
Mac or Windows OS.
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Maximize CIFS 
Performance

For CIFS, a Windows Registry setting can be modified to help prevent 
network time-outs when moving files over CIFS. This prevents errors 
occurring on the initial mount of the media. The SessTimeout value 
defaults to 45 seconds. Quantum recommends you increase the value to 
3600 seconds.

Caution: It is recommended that before attempting to modify a 
Windows Registry, that users backup the existing registry in 
case the modifications cause issues with their host.

1 From the Windows Start menu, click Run. The Run window displays.

2 Type REGEDIT, and click OK. The Registry Editor window displays.

Figure 9  Registry Editor 
window

3 Locate the following registry key: 

HKEY_LOCAL_MACHINE/System/CurrentControlSet/
Services/LanmanWorkstation/Parameters
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Figure 10  SessTimeout value

4 Set the value of SessTimeout to 3600. 

5 If SessTimeout value does not exist, create it as a new REG_DWORD 
value.

a Right click in the Registry Editor window. Select New > DWORD 
value.

b Name the new value SessTimeout.

c Right click SessTimeout > Modify. The DWORD Value window 
displays.

Figure 11  DWORD Value 
window

d In the Value Data field, type 3600.

e Click OK.

Note: After editing the SessTimeout value, the host should be 
restarted to update to the new settings.
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Network Busy Error - 
CIFS

For CIFS, if all tape drives are mounted the next request for an 
unmounted volume will fail, producing an EAGAIN error code and 
display a Network Busy error. To avoid this error, users need to allow a 
tape drive to become available before attempting to access an 
unmounted volume.

Installation

Known Good Tape Before library resources are added to the Scalar LTFS Appliance, it is 
recommended that a known good tape be created with non-critical 
customer data. This tape will provide data that is easily verifiable by the 
customer to help isolate media and drive issues if any occur after the 
initial installation of Scalar LTFS. 

Software Configuration

Quantum recommends the following:

• After attaching media, ensure you save your configuration. Refer to 
the configuration matrix in your release notes.

• Media is set to discovered media with the state of auto-attachable 
by default.

Operations

Quantum recommends the following:

• If you want to use file spanning, SLTFS should only have a single 
partition configured for a single appliance.
18 Quantum Scalar LTFS Appliance User’s Guide



Chapter 2: Best Practices
Operations
• If you want to configure more than one partition:

• you must only have a single volume per volume group

• you must deselect the Scratch Enabled check box on the Volume 
Group window

• Partitions should be configured to pair drive types with their specific 
media (i.e. LTO-5 drives with LTO-5 media) and avoid mixing.

• Each partition should have a minimum of two (2) drives and ideally 
one more drive than the number of active volume groups contained 
in the partition. The additional drive allows for higher system 
performance as a result of less wait time for an available drive.

• File editors or utilities that overwrite parts of a file should not be 
used. Only write full files to a volume group.

• If ‘Scratch Enabled’ is selected for a volume group ensure the 
scratch pool is kept populated by available media.

• If a volume group becomes temporarily unavailable as a result of a 
power outages or other job failures, run a Volume Group Repair.

• Any failed Replication or Merge of a volume group will need a 
Volume Group Repair job run to restore the volume group to it’s 
state prior to the replication or merge job.

Note: Volume Group Repair jobs can take a considerable amount 
of time to complete. It is recommended that repair jobs be 
done when the appliance is idle.

• It is highly recommended to run a Volume Group Replication job on 
any volume group that has a Reclamation Rating or Fragmentation 
Rating above 7.

• Any aborted media export jobs should have a Volume Group 
Repair job run to get the media state back to Attached and 
Available.

• For best performance, volumes should be limited to a maximum of 
1 million files and the system should be limited to 1 billion files.

• When troubleshooting system operations, your first step should be 
to check the diagnostic tickets and follow the resolutions listed. If 
following the resolution steps doesn’t solve the problem, check the 
hardware manufacturers’ web sites for available firmware updates. 
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This is especially important for attached tape drives. Work with a 
service representative to install new drive code if available.

• At any given time for each attached partition, the number of active 
users writing or reading files to/from LTFS volumes should be less than 
or equal to the number of drives on the partition. If there are too 
many users, performance can be degraded to where users 
experience delays and possibly time-outs due to contention when 
several users try to access the same drive.

Note: Windows and Mac clients accessing LTFS volumes will 
receive an error, and will need to reissue the I/O.

Note: If clients are accessing Scalar LTFS using NFS, if there are no 
available resources, NFS will automatically retry the file 
system operation. However, there is no way to control the 
access order if multiple users are attempting to access 
resources.

• Create a work-flow that minimizes contention among users for 
access to the same  volume groups. When multiple concurrent users 
try to access the same volume group, performance degrades as the 
drive rethreads the media searching for data in various tape 
locations.

• Each volume group should be confined to a single user since multi-
user access can lead to performance issues, fragmented media, 
reduced drive availability and tape shoe-shining.

• Avoid editing files that reside on tape. Move files to local storage, 
edit them, and copy them back to tape at regular intervals.

Caution: On Windows 7, users may see a Properties Lost dialog 
while copying files. Disregard this dialog since there is 
no impact to the data transfer.

Caution: When working with video files on Windows 7, ensure 
that the Duration column is not visible when selecting 
the file. This could cause a full file reload, delaying the 
opening of the file.
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Caution: When a tape reaches capacity a user will be unable to 
delete individual files from the tape. To create space to 
add files, the tape will need to be reformatted after all 
required data has been copied to a different tape.

• Viewing individual volume groups through the file system will not 
display the amount of free space available. Users must view the 
media through the GUI to see the amount of free space available.

• Creating folders or directories on a volume group can take longer 
than expected after I/O is completed because the tape must be 
positioned to a different location to write the necessary folder or 
directory information.

• The nature of LTFS is such that deleted files are not erased from the 
volume group, but are merely removed from the index of files on 
the tape. This maintains the pointers between files to permit better 
access to data on the tape. However, it means that deleting files 
does not recover storage space on tape.

• Ensure that the appliance displays the accurate time. Use NTP for 
settings on the Date and Time window.

• Use personalized account user IDs to track who made system 
changes. Require any users who have access to generic IDs to use 
the sudo command to access the generic ID.

• Format only blank media or media that contains data that can be 
recovered from another source.

Caution: Formatting media irrevocably destroys all data existing on 
the tape.

• Avoid introducing non-LTFS volume groups into a partition that is 
managed by Scalar LTFS. This prevents human error by which an 
operator may mistakenly request a format operation through Scalar 
LTFS of a volume group that contains non-LTFS data.

• If resource files are being used on a MacOS it is recommended that 
the Finder not be used because it will automatically access these 
resource files, causing slower system performance and higher tape 
usage.

• It is known that with some native file browsers and applications will 
attempt to perform hidden file reads to gather file information for 
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user presentation. This can cause unexpected tape mounts and 
severe performance issues if the user attempts to read or write data 
to this tape at the same time. 

To avoid these behaviors when using native file browsers (i.e. Finder 
on MacOS and Explorer on Window OS):

• Use Quantum’s version of muCommander on Mac and 
Windows systems (for information on installing muCommander, 
see the Scalar LTFS Release Notes)

• Use the command line interface for Linux systems

• It is recommended that users on a Windows platform disable the 
Mouse Over Open Folder option:

a Right-click on the Start button.

b Select Properties.

c Click Customize.

d Uncheck the Open sub-menus when I pause on them 
with the mouse pointer option.

e Click OK.

f Click OK.
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Special Characters Avoid the following special characters in file and directory names:

• / :” * ? > < | \

Attaching/Formatting 
Large Number of Media

It is recommended that any volumes that need to be accessed quickly 
should be attached/formatted in a small group so these volume will not 
be randomly queued in the system. 

Recovering Storage 
Space

To recover storage space after deleting files from a tape:

1 Copy the entire volume group, including its directory structure and 
files, to local storage.

2 Reformat the tape.

3 Copy the files back from local storage back to the tape.

Alternatively, the volume group can be replicated using a volume group 
replication job. The volume group replication also precludes the need 
for local disk storage for the replication.

Reassign Control of a 
Partition to a Different 
Scalar LTFS Appliance

1 Stop all I/O to the SLTFS appliance.

2 Login to Scalar LTFS.

3 Wait until all media are unmounted from all drives in the partition 
which is being reassigned. 

4 Select Configuration > Partitions.

5 Take the partition offline and detach it.

6 Make any necessary cabling or library configuration changes in 
order for the second Scalar LTFS appliance to access the partition.

7 Login to the second Scalar LTFS appliance. 

8 From the Configuration screen, select Partitions.

9 Attach and bring the partition online, as well as at least one drive.
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Quantum recommends the following:

Library Service Tickets • Monitor your Scalar tape library for any new tickets. These tickets 
may indicate early issues and tape alerts related to Scalar LTFS media 
and drives.

Caution: These alerts cannot be ignored or data loss is a possibility.

Tape library tickets are coded as follows:

• Blue: Severity 3 Diagnostic Tickets. Action: Issue should be noted. 
Resolve tickets according to resolution

• Yellow: Severity 2 Diagnostic Tickets. Action: Resolve tickets 
according to resolution. System impact is likely

• Red: Severity 1 Diagnostic Tickets. Immediate attention is required. 
Action: Resolve ticket according to Diagnostic Resolution

Adding/Removing 
Libraries/Drives

It may become necessary for a user to add a drive or a new partition. If 
this is the case, during this operation users will want to avoid any action 
that conflicts with a drive’s I/O functions. To add a drive or library, 
complete the following steps:

1 Cable the drive/library to the Scalar LTFS appliance.

2 Using the Scalar LTFS GUI, unmount all drives by selecting 
Configuration > Partitions.
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Figure 12  Partitions window

3 De-select the check box for each drive in the Online column and 
click Apply.

4 Go to Operations > Media and ensure that all media have been 
unmounted. Media will no longer have a check mark in the 
Mounted column.

Figure 13  Media window
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5 Once all the drives are unmounted, go to Operations > Partitions. 
The new drive/library will appear.

Note: It may take up to two minutes from the time the last drive was 
unmounted for the new drive/library to appear in the 
Partitions window.

Note: Scalar LTFS does not support attaching new hardware while the 
appliance is active (‘hot plugging’). The Scalar LTFS Appliance 
must be rebooted to guarantee that the new library or drive 
will display properly.

To remove a library/drive:

1 Stop all I/O on host devices.

2 Wait for all tape drives to dismount which is dependent on the Idle 
Volume Timeout setting (Configuration > System).

3 Once all media is unloaded, take the partition offline and detach it.

4 Remove the cable from the partition to the appliance. The partition 
will disappear from the GUI within 10 minutes.

Barcode Display For Scalar LTFS to detect incompatible media types in the system, it is 
important that your library is setup to show the entire or extended 
barcode, specifically the L5 or L6 at the end of the barcode. Review your 
library’s documentation for instructions on how to set this option 
properly.
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This chapter includes the following information:

• Logging On to Scalar LTFS Appliance on page 27

• Navigating in the Graphical User Interface (GUI) on page 29

• Menu Tree on page 36

• Navigational Tools on page 38

• Logging Off on page 38

Note: The information you see in your Web browser window depends 
on your user role. You can only view and work with information 
and devices accessible by your assigned role. 

Logging On to Scalar LTFS Appliance

Follow the steps below to log on to Scalar LTFS Appliance:

1 Launch a supported Web browser on a workstation that has 
network access to the server. See System Requirements on page 3 
for a list of supported browsers.
Quantum Scalar LTFS Appliance User’s Guide 27



Chapter 3: Logging On and Navigation
Logging On to Scalar LTFS Appliance
2 In the Web browser address box, type the IP address or host name 
of the Scalar LTFS Appliance server, and then press Enter. The Login 
window displays.

Figure 14  Login Window

Note: Since the Scalar LTFS Appliance uses HTTPS, users may get a 
warning displayed alerting them to this. Users should 
proceed and disregard the warning.

Note: If the Login window does not display, verify that the IP 
address is correct. Also verify that you are using a 
supported Web browser with Adobe Flash 10 or higher 
installed. Then try again. If you are still unable to access the 
Login window, contact your system administrator.

3 Type the Username and Password.

Note: The default username is admin and the default password is 
password.

4 If you are using LDAP for authentication, make sure the Use 
Remote Authentication check box is selected. This will only be 
displayed if Remote Login is enabled.
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5 Click Log on. After a successful login, the Home window displays 
(see Figure 15 below).

If you are unable to log on, verify that your username and password 
are correct, then try again. 

Navigating in the Graphical User Interface (GUI)

The GUI runs in a Web browser window using the Flash Player Plugin. 
Figure 15 depicts the Scalar LTFS Appliance Home screen. After logging 
on to appliance, the Home screen displays.

Figure 15  Home Page
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The tables below describes the Home screen components.

Table 2  Home Page: Media List

Column Description

Barcode The ASCII (characters and numbers) that identifies the unique piece of media. This 
code is displayed on the media as a printed array of varied rectangular bars and 
spaces that can be scanned and read for object identification.

Volume Group A collection of one or more media into a single volume.

Mounted Indicates media is loaded in a drive.

State The current state of the media:
Auto-attachable - indicates the media is available for auto-attaching to a volume 
group
Attached - indicates the media is attached to a VG
Sequestered - indicates the media is unavailable
Vaulted - indicates the media is unavailable and is not physically in the library
Pending attach - indicates the media is in the process of being attached
Pending format - indicates the media is in the process of being formatted
Preparing for export - indicates the media is being prepared for export
Ready for export - indicates the media is ready for export
Pending export - indicates the media is in the process of being exported

Repair in progress - indicates the media is in the process of being repaired
Merging volume groups - indicates the media is in the process of being merged
Verifying - indicates the media is in the process of being verified
Busy reclaiming - indicates the media is in the process of being reclaimed
Busy repairing - indicates the media is in the process of being repaired
Operation in progress - indicates the media is in the process of being replicated

Physical State The location and availability of media through the tape library. Options include:
• Available - media is in an accessible partition
• Offline - media is in an unaccessible partition
• Vaulted - media has been removed from a partition
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VG State Empty - indicates the volume group is empty
Ready - indicates the volume group is available and ready to be accessed
Unavailable - indicates the volume group is not ready to be accessed
Pending Export - indicates that the volume group is in the process of being 
exported and is unavailable
Pending Replication - indicates that the volume group is in the process of being 
copied and is unavailable
Pending Repair - indicates that the volume group is in the process of being 
repaired and is unavailable
Pending Merge - indicates that the volume group is in the process of being 
merged with another volume group and is unavailable
Vaulted - indicates that the volume group has been removed from the system

Reason Indicates what caused a state transition.

Partition The serial number for the partition or partition name.

Comment Allows users to add any additional information about what is on the tape 
cartridge.

Files The number of files contained on the physical tape cartridge.

Used Amount of physical space used on the tape cartridge.

Free Amount of physical space available on the tape cartridge.

Open Diagnostic Tickets Area

Ticket Unique ticket number generated by Scalar LTFS.

Severity Green: Operating system has no warnings or diagnostic tickets
Blue: Severity 3. Action: Issue should be noted. Resolve tickets according to 
resolution
Yellow: Severity 2. Action: Resolve tickets according to resolution. System Impact
is likely
Red: Severity 1. Immediate attention is required. Action: Resolve ticket according 
to Diagnostic Resolution

Component The component that failed.

Opened Indicates the date and time the ticket was opened.

Column Description
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Summary Ticket ID and description.

Job Queue Area

Job ID A unique identifier generated by SLTFS.

A visual representation of the current state of a job.

Source Dependent on the Job Event and can be a barcode or volume group.

Event What is being done to the specific media. Values include: attach, assign, sequester, 
import, export, format, prepare for export, replicate, repair, merge, publish, 
subscribe, verify and safe repair.

State The job states include:
New - indicates the job has not been launched
Complete - indicates the job has completed
Completed with an exception - indicates the job has completed with an 
exception
Failed - indicates the job has completed with a failure condition - see job GUI page 
for additional details
Job failed to start - indicates the job could not start due to a failure condition - 
see job GUI page for additional details
Mounting media - indicates the job is in the process of mounting a media
Unmounting media - indicates the job is in the process of unmounting a media
Importing - indicates the job is in the process of importing a media
Exporting - indicates the job is in the process of exporting a media
Formatting - indicates the j0b is in the process of formatting a media
Copying - indicates the job is in the process of copying files
Moving - indicates the job is in the process of moving files
Mapping - indicates the job is in the process of mapping a media
Checking - indicates the job is in the process of checking a media of data 
coherency
Publishing - indicates the job is in the process of publishing files as part of 
replication
Subscribing - indicates the job is in the process of subscribing to replication files
Paused; file system busy - indicates the job could not start due to a busy file 
system

Column Description
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Table 3  Window Navigation 
Components

State (cont) Paused; IE slot unavailable - indicates the job could not find an I/E slot to use and 
will retry shortly - while paused, a job cancellation is accepted
Paused; drive unavailable - indicates the job could not find a drive to use and will 
retry shortly - while paused, a job cancellation is accepted
Paused; scratch pool empty - indicates the scratch pool is currently empty and 
will retry shortly - while paused, a job cancellation is accepted
Verifying - indicates the job is in the process of verifying a replica volume as part 
of replication
Canceled - indicates the job has been canceled by the user or by an unexpected 
restart

Destination Used for job events where media is being moved to a different volume group: 
assign, merge, replication and safe repair.

Started The date and time the job was initiated.

Column Description

Window Component Description

Header bar The header bar at the top of the window shows the title of the GUI 
(Quantum Scalar LTFS), the appliance’s serial number, the date, 
time and time zone, the status of the system, the user that is 
logged in, and the Home, Help and Logout buttons. The Date/
Time display is the date and time from the server, updated every 
minute to indicate the GUI is still communicating with the server. 
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Figure 16 on page 35 depicts the Main Navigation Panel that is used to 
navigate through the Graphical User Interface (GUI). It is anchored on 
the left side of the page and functions as an accordion style menu with 
the top options consisting of, Configuration, Operations, Tools, Reports, 
Service, and Help. The currently selected menu item is expanded to 
display sub-options.

Status The Status icon uses color to communicate the health of the 
system:

Green = Operating system has no warnings or diagnostic 
tickets
Blue = Low Priority. Action: Issue should be noted. Resolve 
tickets according to resolution
Yellow = Medium Priority. Action: Resolve tickets according to 
resolution. System Impact is likely
Red = High Priority. Immediate attention is required. Action: 
Resolve ticket according to Diagnostic Resolution

Clicking the Status icon displays the Diagnostic Tickets screen.

Home Returns you to the home screen.

Messages Opens the System Message screen. The number in the lower right 
indicates how many unread messages are waiting to be addressed.

Help Opens the help system.

Log Off Ends the session and returns the browser Login window.

Who’s Logged In Indicates the current user's user name and role.  An (R) preceding 
'User' indicates the current user has remote logged in via LDAP.

Window Component Description
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Figure 16  Main Navigation 
Panel

Main Navigation Panel Description

Configuration This area contains all the user settings for the system, including 
system configuration, notifications, licenses, date and time, 
network configuration, users, partitions, and volume groups.

Operations Expanded by default, this area contains options for operations on 
the system, including exporting, job queue, volume groups, 
utilities and media options such as attaching, formatting and 
sequestering.

Tools This area contains links for e-mailing and downloading the 
configuration record, saving and restoring system configuration, 
capturing a snapshot, updating firmware, updating security, 
enabling remote authentication and working with diagnostic 
tickets and messages.

Reports This option provides the Component Information, Configuration 
Record, Diagnostic Ticket, Media, Media Count, Messages and 
Volume Group Reports.
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Menu Tree

The following pictorial depicts the options available for each menu 
selection.

Service This area is visible on the navigation menu only if the user is 
logged on with the service user ID.

Help This area contains a link to the Help About Scalar LTFS window, 
including version numbers as well as the appliance’s serial number 
and how to register the appliance.

Refresh Located at the bottom of the Navigation Panel, clicking this button 
updates the current screen you are viewing.

Main Navigation Panel Description
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Figure 17  Main Menu 
Selections
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Navigational Tools

The Scalar LTFS Appliance provides a rich interface for working with 
information. Keep the following concepts in mind while working in 
Scalar LTFS Appliance:

Tooltips

Tables

Quantum Device Names

Tooltips Tooltips (small pop-up windows) appear next to many fields 
throughout the Scalar LTFS Appliance GUI to provide helpful 
information. Hovering over these displays details about the field. 
Clicking tooltips opens a window that stays open while you work and 
gives you access to other tooltips.

Tables You can sort tabular data based on any of the available column 
headings. For example, on the Home Page, click the State column 
heading to sort all storage devices according to it’s state. Or click the 
Type column heading to sort all drives according to their type.

Quantum Device Names Scalar LTFS Appliance refers to Quantum libraries by their product ID or 
family name, including Scalar i40, Scalar i80, Scalar i500, and Scalar 
i6000 libraries

Logging Off

When you are done working with the Scalar LTFS Appliance, click 
Log Off on the upper right of the window to end your session. 
Users can also select the Operations > Logoff menu to display the 
Logoff page.
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This chapter provides instructions for configuring the appliance using 
the GUI. 

System Configuration on page 40

Adding Notifications on page 43

Entering Licenses on page 45

Configuring Date and Time on page 46

Configuring the Network on page 48

Configuring Users on page 51

Configuring Partitions on page 55

Configuring Volume Groups on page 59

The first time you log into the Scalar LTFS Appliance, a setup wizard 
prompts you to configure the appliance and assists you with the initial 
configuration. Refer to the Quantum Scalar LTFS Site Planning and 
Installation Guide for information about initial system setup.

Note: If you chose to cancel out of the Setup Wizard, you can 
configure the appliance at any time using the GUI. However, 
you will not be able to access the Setup Wizard again.

To view the GUI menu tree options, see Main Menu Selections on 
page 37.
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System Configuration

Configure your system settings to set session time-outs, set permissions 
for the Quantum service user, set up e-mail accounts for system mail, 
and enter contact information.

1 From the navigation panel, click Configuration > System. The 
System Configuration screen displays.

Figure 18  System 
Configuration Window

Configure User Sessions You can set your desired session inactivity time-out from 5 minutes to 8 
hours. The default session timeout is 2 hours. Once set, the currently 
logged in session automatically logs out after that period of inactivity.
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In addition, use this window to allow or prohibit the Quantum service 
user to access the GUI in case of issues. The default setting is to allow 
Quantum service to access the GUI.

1 In the Session Inactivity Time-out field, select a value from the 
drop-down menu.

2 Set the Quantum service user access.

• To allow the Quantum service user to access the GUI in case of 
issues, leave the check box blank in the Lock Out Service User 
field.

•  To prohibit access, click the Lock Out Service User check box.

The box displays the check mark and the label states Enabled. 
The Quantum service user is locked out.

3 Use the Tab key to move to the Configure System Settings section of 
the window.

Configure System 
Settings

There is an Idle Volume Timeout setting that will automatically 
dismount media that has been inactive for a specified time. The default 
timeout is 30 minutes and the settings can range from 30 minutes to 8 
hours.

Note: The Idle Volume Timeout setting indicates when SLTFS will 
timeout during I/O operations. It does not apply to 
maintenance operations, such as formatting tapes.

Use the Metadata Retention Timeout drop-down box to select the 
length of time metadata will be retained by the system for exported 
volumes. The settings range from off to no expiration. The default 
setting is no expiration.

Finally, the Maximum Files per Volume drop-down box allows you to 
set the maximum number of files for a specific volume group. 1 million 
files is the default but the setting can range from 100,000 to 15 million 
files.

When finished, use the Tab key to move to the Configuring E-Mail 
section of the window.
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Configuring E-Mail Once an e-mail account is configured, recipients may receive e-mail 
generated by the appliance, including snapshots, diagnostic ticket 
notifications and reports.

To receive these notifications from the Scalar LTFS Appliance, indicate 
the desired server and the sender’s email address using the System 
Configuration screen. The system uses this server to send e-mail.

1 Type the following information:

Note: The login account name and password are optional. If 
configured, e-mails generated by the appliance will be sent 
with authorization. Authorization may be required by the 
SMTP server to send notifications outside of the company's 
domain.

2 Use the Tab key to move to the Contact Information section of the 
screen.

Contact Information The contact information must be completed to register the appliance.

1 Type the contact information for the appliance, including First 
Name, Last Name, Company Name, Phone Number (optional), E-
Mail Address, and System Description.

2 Click Apply.

SMTP Server Type the name of the SMTP server where e-
mail messages should be sent.

Senders E-mail 
Address

Type the e-mail address of the sender of 
system notifications, for example, 
myaltfs@companyname.com.

Login Account Name 
(optional)

Type the name.

Password (optional) Type the password.

Confirm Password Confirm the password.
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Adding Notifications

Using the Notifications window, you can set up e-mail addresses for 
recipients who should receive system notifications for diagnostic tickets 
generated by the system, and specify the type of tickets received based 
on severity level.

1 Click Configuration > Notifications. The Notifications screen 
displays.

Figure 19  Notifications 
Window

Adding a Receiver 1 Complete the Name, Phone and E-mail Address fields.

Note: In the Name field, type the text that will appear in the e-
mail subject line, for example Scalar LTFS.

2 For the receiver you are about to add, in the Enable Notifications 
area, select the check boxes for the type of notifications you want to 
enable.
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A check mark displays in the Messages and/or Tickets column in the 
table. Once enabled, this e-mail address will receive appropriate 
system and diagnostic ticket notifications as they are generated.

Note: Only email addresses created manually can receive system 
message notifications.

3 From the Ticket Level drop down menu, choose the urgency of the 
notification:

The Level column will display the type of tickets sent to the receiver.

4 Click Apply. The receiver’s information appears in the table on the 
right.

5 To add another receiver, return to step 1.

Modifying a Receiver 1 On the table listing the current receivers (on the right), highlight the 
row to be changed.

2 Use the fields on the left to change receiver information as desired.

3 Click Apply. The receiver’s updated information appears in the table 
on the right.

Deleting a Receiver 1 On the table listing the current receivers, highlight the row to be 
deleted.

2 Click Delete. The message Are you sure you wish to delete the 
receiver from the system? is displayed.

3 Click Yes. The receiver record is deleted.

If you choose: You receive:

Severity 1 High priority tickets

Severity 2 High and medium priority tickets

Severity 3 All priority tickets—high, medium, and low.
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Entering Licenses

License Keys are purchased along with the system and additional license 
keys may be purchased at any time. You can purchase licenses for 1, 2, 
4, or 8 tape drives. For additional information about license key 
implementation, refer to License Key Implementation on page 5.

1 Copy and paste this number for reference and save to a safe 
location on your computer.

2 From the navigation panel, click Configuration > Licenses. The 
Licenses screen displays.

Figure 20  Licenses Window

3 In the Enter New License Key field, type the license key.

4 Click Apply.
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Configuring Date and Time

The Scalar LTFS Appliance supports user-defined and NTP date and time 
settings. Use this window to set or update the date and time settings 
and set the time zone settings.

1 From the navigation panel, click Configuration > Date and Time. 
The Date and Time screen displays.

Note: The default setting is NTP.
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Figure 21  Date and Time 
Window 

NTP Settings 1 If not already checked, click the Use NTP box to select.

The Use NTP box displays a check mark and the label changes to 
Enabled. Five NTP address fields are enabled and the date and time 
settings (on the left) are grayed out. 
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Note: To enter date and time manually, refer to Manually Entering 
Date and Time Settings on page 48.

2 Type a least one valid NTP address. The system checks for a valid 
server from the top entry down until one is found.

3 In the Time Zone Settings section, review selection to ensure 
correct. As needed, select correct time zone from drop down menu.

4 In the Time Format section, select the time display format—12 hr 
Format or 24 hr Format.

5 Click Apply.

Manually Entering Date 
and Time Settings

1 From the Select Date calendar, select today’s date.

2 In the Enter Time field, type the time in 24 hour notation, for 
example 3:00 p.m. is 15:00.

3 In the Time Zone Settings section, review selection to ensure 
correct. As needed, select correct time zone from drop down menu.

4 In the Time Format section, select the time display format—12 hr 
Format or 24 hr Format. 

5 Click Apply.

Configuring the Network

Your network administrator should provide you with the IP address 
information. Prior to configuring your network, review the Ethernet 
Configuration Tips below.

Caution: Make sure you enter the correct IP address information 
and that you write this information down. If you enter 
the incorrect IP address information and reboot, you 
will not be able to access the system except via the 
service port.
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Ethernet Configuration 
Tips

• You need only one ETH connection to configure the network.

• The IP address must be unique for each Ethernet port while the 
subnet should be unique. The subnet and gateway address 
entered for the first Ethernet port is copied over to subsequent 
Ethernet port fields. Change as appropriate.

1 From the navigation panel, click Configuration > Networks. The 
Networks screen displays.
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Figure 22  Networks Window 

2 In the Host Name and Default Information portion of window, 
type the following information:

a Type the Host Name used to identify the Scalar LTFS system.

b Type the DNS Address and the Default Gateway Address you 
want to use to join the Scalar LTFS to your network.
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Caution: If you selected NTP that contains host names, you must 
specify a DNS Address. See Configuring Date and Time 
on page 46.

3 In the IPV4 Information portion of screen in the Eth1 - 1Gb 
through Eth3 - 10Gb fields, type your static IP address information 
for Eth1 through Eth3 as cabled.

Note: Depending on the SLTFS model, there will be either 3 or 5 
Ethernet settings available for configuration.

Note: Ethernet ports will only display if a cable is attached to the 
corresponding port on the Scalar LTFS Appliance.

Caution: The Ethernet IP Address must be unique and the 
Subnet Mask should be unique for each ETH port to 
enhance performance.

Note: The Trash icon clears all network data for the active Eth 
tab. Each time network data is cleared, the Scalar LTFS 
Appliance network is restarted.

4 Click Apply. The message Are you sure you wish to change the 
systems network settings? displays.

5 Click Yes to confirm.

Configuring Users

Out of the box, the Scalar LTFS Appliance comes configured with the 
following user accounts: 

• One Service user for use by Quantum service only. You can disable 
this user account if you desire. 

• One default Administrator account. You cannot disable this user 
account, but you can change the password.
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Based on the role — administrator or user — you have certain 
permission levels in the GUI appliance. Refer to Appendix A, User Roles 
for a detailed list of permissions.

Note: For administrators, the user configuration page allows them to 
add, modify and delete users. For users, the user configuration 
page allows them to only change their password.

To configure a user account:

1 From the navigation panel, click Configuration > Users. The Users 
screen displays.

Figure 23  Users Window 

2 Based on desired task, go to: 

Adding a User on page 53
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Modifying an Existing User on page 53

Deleting a User on page 54

Changing a Password on page 54

Adding a User 1 In the User Information fields, type the following: 

2 Click Apply. The added user is displayed in the Current Users table.

Modifying an Existing 
User

1 In the Existing User table on the right side of the screen, highlight 
the user row you want to modify.

2 Make the changes to the role, as defined above in the Adding a User 
section.

3 Click Apply.

Name Type the user’s name.
Note: Only a single administrator with the 

admin name is allowed but multiple 
users can be created that have the 
administrator role.

Role From the drop down menu, select the desired 
role of admin or user.
Best Practice: Use personalized account user 
IDs if you want to track who made system 
changes.

Password Type the password. Passwords must be at least 
6 characters in length and cannot contain the 
following characters:
• _ @ . - * \
Note: The Name and Password cannot be 

same.

Confirm Password Retype the password.
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Deleting a User Note: You cannot delete the admin or service user.

1 In the Existing User table on the right side of the screen, highlight 
the user row you want to delete.

2 Click Delete, and then click Yes to confirm.

Changing a Password A user may only change their own password. In the event a user has 
forgotten their password, an administrator must recreate the user’s 
account by deleting the user and adding them back into the system.

Administrator password:

1 In the Existing Users table on the right side of the screen, select 
your user name.

2 Enter the new password in the Password field. Passwords must be 
at least 6 characters in length can cannot contain the following 
characters:

• _ @ . - * \ 

3 Reenter the new password in the Confirm Password field.

4 Enter in the current password in the Enter your Current Password 
field.

5 Click Apply. A dialog box displays confirming that you want to 
change the password.

6 Click Yes to confirm.
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User password:

1 Enter the new password in the Password field.

2 Retype the new password in the Confirm Password field.

3 Type in your current password in the Enter your Current Password 
field.

4 Click Apply. A dialog box displays confirming that you want to 
change your password.

5 Click Yes to confirm.

6

Configuring Partitions

Before you work with partitions on the Scalar LTFS Appliance, ensure 
you have configured library partitions, generated a list of partition 
names and serial numbers from your Scalar library and using this list, 
identified the partitions that you want to attach to the appliance.

1 From the navigation panel, click Configuration > Partitions. The 
Partitions screen displays.
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Figure 24  Partitions Window

The Partitions table, as shown in Figure 24 displays all partitions 
that have been physically attached via Fibre Channel, I/O blade, or 
SAS and exposed to the host.

Table 4 on page 56 and Table 5 on page 57 describe the data on the 
on the Partitions window.

Note: Columns marked with the  icon are editable.

Table 4  Partitions Table 
Descriptions Partitions Table 

Column Description

Attached Check box to attach the partition.
Uncheck the box to detach the partition.

Name Type the name of the partition.
Note: Quantum recommends that you name 

the partition with the same name as 
identified in the library.
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Table 5  Partitions Drives Table 
Descriptions

2 Attach each partition by row by clicking the Attached check box. A 
check mark displays.

Online Check box to bring partition online.
If unchecked, partition is offline. If offline, you 
cannot access files on this media.

Serial Number The tape library identifier from the from library 
medium changer. This logical serial number is a 
combination of the library serial number and a 
Logical Library letter (for example, LLA, LLB, 
LLC).

Product ID The product name of your library.

Drives The number of drives within the partition.

Media The number of media within the partition.

Slots The number of storage slots in the partition.

I/E The number of I/E slots in the partition.

Partitions Table 
Column Description

Partition Drives 
Table Column Description

Serial Number Drive serial number.

Online Check the box to bring a drive online.
Uncheck the box to take a drive offline. If the 
take offline, you cannot drag files to this 
media.

Vendor ID ID of the drive vendor.

Product ID Product name of the tape drive.

Media If loaded, identifies the media.
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3 Rename the partition using the same name as the library partition. 
In the Name column, click the current name to highlight it and type 
the new partition name.

4 Place the partition in an Online or Offline status. 

• To place the partition online, click the check box. The partition is 
accessible by the appliance.

Note: The Scalar LTFS Appliance automatically sets the 
partition to Online when it is first attached.

• To keep the partition offline, ensure check box is unchecked. The 
partition is not accessible by the appliance.

If the drive has media loaded, you would see the barcode in the 
Partition Drives area at the bottom of screen.

Importing/Exporting 
Media from an LTFS 
Partition

Imported media have three different designations:

• Discovered - this is new media, unformatted and added to the 
library. Discovered media will appear in a Sequestered state upon 
import into SLTFS

• Scratch - this is formatted media with no data

• Volume Group Assigned - this is media that has been previously 
assigned to a volume group

1 Import or export media as required, using the library GUI, front 
panel of the library or other hardware facilities available on the 
library.

Note: Media put into the library’s I/E station will automatically be 
moved to an empty slot in the library. Any media not 
previously in SLTFS will be added to the discovered pool. 
Media previously in SLTFS will be returned to it’s home slot 
if possible.
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2 Put the partition online at the Scalar LTFS GUI. Scalar LTFS will 
reserve the media changer for that partition again (or will leave the 
partition offline if it cannot). Attached volumes in the now-online 
partition will reappear.

However, adding a Scalar LTFS library to an existing partition is more 
complex. If the drive or appliance does not gracefully support partitions, 
you may have to recycle the appliance to make the new library visible.

Configuring Volume Groups

A volume group is a collection of one or more media that is presented 
to end users and applications as a directory in the file system. Before 
using the Scalar LTFS Appliance, at least one volume group of media 
must be configured. Each volume group can be configured in one of 
two ways:

• One piece of media in the volume group; each piece of media is 
presented as a directory in the file system. Limiting volume groups 
to single volumes makes it easy to understand the files contained on 
each piece of media. 

• Multiple pieces of media in the volume group; all media in the 
volume group are presented as one directory. The capacity of the 
directory is only limited by the number of media in the volume 
group. If the volume group is configured to use scratch media, the 
volume group will pull additional media as needed thereby 
increasing the capacity of the volume group. When a volume group 
is configured with multiple pieces of media, the appliance will span 
files across tapes as needed.

Note: Single media and multi-media volume groups can both be 
configured within the same appliance.

There are a number of considerations when deciding how to configure 
volume groups (using single or multiple pieces of media per volume 
group). Each configuration can both simplify and complicate certain 
aspects of using the appliance. 

• Managing directory capacity: Volume groups with one piece of 
media require end users to manage the capacity of each directory as 
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each directory/media has a limited capacity. Configuring volume 
groups with multiple media can simplify use of the system for end 
users or enable applications to use the system because directory 
capacities are not limited by the capacity of one piece of media.

• File location: With single media volume groups the location of files 
on tapes is known and it may make it easier on the system 
administrator to manage media.

• Media operations: Most media operations are conducted on the 
entire volume group. For example, exporting a volume group means 
all media in the volume group must be exported. These operational 
considerations should be taken into account when defining volume 
groups with multiple pieces of media.

1 From the navigation panel, click Configuration > Volume Group. 
The Volume Group screen displays.

Figure 25  Volume Group 
Window

Table 6 on page 61 describes the data on the Volume Group window.
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Table 6  Volume Group 
Configuration

Volume Group Table 
Column Description

Action Displays a button to either create or remove a volume group. The Create 
button only appears in the first row and the Remove button only appears in 
volume groups that have no media assigned.

Volume Group Displays the name of the volume group.

State The current state of the media:
Auto-attachable - indicates the media is available for auto-attaching to a 
volume group
Attached - indicates the media is attached to a VG
Sequestered - indicates the media is unavailable
Vaulted - indicates the media is unavailable and is not physically in the 
library
Pending attach - indicates the media is in the process of being attached
Pending format - indicates the media is in the process of being formatted
Preparing for export - indicates the media is being prepared for export
Ready for export - indicates the media is ready for export
Pending export - indicates the media is in the process of being exported
Repair in progress - indicates the media is in the process of being repaired
Merging volume groups - indicates the media is in the process of being 
merged
Verifying - indicates the media is in the process of being verified
Busy reclaiming - indicates the media is in the process of being reclaimed
Busy repairing - indicates the media is in the process of being repaired
Operation in progress - indicates the media is in the process of being 
replicated

Online An editable field that indicates whether the volume group is online.

Media Indicates the number of media assigned to the volume group.

Reason Describes the state the volume group is in.

Comment An editable field allowing administrators to add comments about the 
volume group.
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Create a Volume Group Volume groups can be created manually or when your Scalar LTFS 
firmware is upgraded or initially installed (see Scalar LTFS Installation 
and Planning Guide). Any volume groups created during installation or 
upgrade will use the media barcode as the name. Changes to a volume 
group name can only be done through a file system interface, such as 
Explorer or muCommander - Quantum Edition.

2 At the top row of the table, click in the box in the Volume Group 
column next to the Create button in the Action column.

3 Type the name of the new volume group.

4 Click Create. The button changes to an Add button.

5 Click Add. A dialog displays indicating that your new volume group 
has been created.

Once a volume group has been created, you must assign media or 
merge it with another volume group(s) to use it. See Assign Media to a 
Volume Group on page 79.

Modify a Volume Group You can change some settings for a volume group. You can take a 
volume group offline, make it scratch tape enabled, add a comment or 
change its free threshold. See Table 6 on page 61 for definitions.

Scratch Enabled An editable field allowing administrators to set the volume group to 
automatically get blank media when necessary.

Free Threshold An editable field allowing administrators to set a threshold percentage for 
volume groups. An alert is generated when a volume group exceeds this 
threshold. Scratch media needs to be available when this threshold is 
exceeded.

Files Indicates the number of files in a volume group.

Used Indicates the amount of physical space used in the volume group.

Free Indicates the amount of physical space available in the volume group.

Volume Group Table 
Column Description
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1 From the navigation panel, click Configuration > Volume Group. 
The Volume Group screen displays.

2 Select the volume group you want to modify by clicking anywhere 
in its row.

3 Modify the necessary fields.

4 Click Modify. A dialog box displays indicating the modification was 
successful.

Remove a Volume 
Group

Note: Volume groups can only be removed if there are no media 
assigned.

1 From the navigation panel, click Configuration > Volume Group. 
The Volume Group screen displays.

2 Select the volume group you want to remove by clicking anywhere 
in its row.

3 Click the Remove button. A dialog displays to confirm you want to 
remove the volume group.

4 Click Yes. The volume group is removed from the list.
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System Media Operations

This chapter describes how to manage media using the Scalar LTFS 
Appliance.

Export Volume Groups on page 66

Use the Job Queue on page 67

Shut Down /Log Off System on page 69

Managing Media on page 71

Assign Media to a Volume Group on page 79

Use Volume Group Utilities on page 84

Registering the Appliance on page 89

Note: To ensure the most up-to-date system information, the Refresh 
button on the Main Screen should be used periodically.
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Export Volume Groups

Note: Once an export is in progress, there is no way to cancel the job. 
It must finish and then the exported volumes must be 
physically removed from the I/E station and the door closed. 
Then the media can be put back into the I/E station. SLTFS will 
automatically import the media back into the partition.

1 From the navigation panel, click Operations > Export. The Export 
screen displays.

Figure 26  Export Window

2 From the Volume Groups Available for Export area, select the 
volume group(s) you want to export media from.

Note: Optional information can be entered in the Location 
column. Place the cursor in the Location field and type. 
When finished, click Apply.
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3 Click Apply. In the Media Available for Export area, you will see a 
list of media from the volume group(s) you selected.

Note: If tapes from the Volume Group are mounted, the export 
may take some time to complete. Check the Job Queue for 
status on the export.

4 Select the media you want to export to the I/E station.

5 Click Apply. The selected media is set to Pending Export in the Job 
Queue. See Use the Job Queue on page 67 for more information.

Note: Once a single piece of media is in Pending Export, the 
remaining media in that volume group must be exported 
as well before the volume group can be available again.

6 To complete the volume group export, you must physically remove 
the tapes from the library’s I/E station. If the tapes are not removed, 
the media will stay in the Pending Export state until they are. This 
means that the volume group will not appear in your file system 
browser and be unavailable until the media are removed.

Use the Job Queue

Job Queue Table 
Column Description

Cancel Job Indicates which job(s) to be canceled. The check 
box is enabled when a job is able to be 
canceled.

Job ID A unique identifier created when a function is 
initiated by the system.

A visual representation of the state of a job.

Source Indicates the volume group or media the job is 
being performed on.

Event Indicates what the job is performing.
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1 From the navigation panel, click Operations > Job Queue. The Job 
Queue screen displays a complete list of all jobs initiated in the last 
24 hours.

Figure 27  Job Queue Window

State The state of the job.

Destination Indicates where the job/media is going. This is 
an optional field based on job type. If given, 
this is the destination volume group.

Started Indicates when the job was begun.

Progress Where in the process the job is.

Reason Indicates why the job failed.

Ended Indicates when the job was completed.

User Indicates who initiated the job.

Job Queue Table 
Column Description
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2 If you want to see a different range of jobs displayed, select a 
different value from the Include jobs completed within: drop-down 
box. The possible options include:

• 24 hours

• 2 days

• 3 days

• 1 week

• 2 weeks

• 1 month

• 2 months

• 3 months (all)

Note: All jobs are automatically deleted from the system after 90 
days.

Cancel a Job 1 From the navigation panel, click Operations > Job Queue. The Job 
Queue screen displays a complete list of all jobs initiated in the last 
24 hours.

2 Select the check box in the Cancel Job column for the job you want 
to cancel. Job can only be canceled when they are in the following 
states:

• paused; IE slot unavailable

• paused; drive unavailable

• paused; scratch pool empty

3 Click Apply.

Shut Down /Log Off System

Use the Log Off screen to shut down system, restart the system, or log 
off and leave the system running.
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1 From the navigation panel, click Operations > LogOff / Shutdown. 
The LogOff screen displays.

 

2 Based on desired task, go to:

Logging Off System on page 70

Shutting Down System on page 70

Restarting System on page 71

Logging Off System To log off the current user:

1 In the Log Off section, click Log Off. The current user is logged out 
and the Login window displays.

Shutting Down System To shutdown the system:
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1 In the Shutdown/Restart section, click Shutdown System. The 
system is shut down on the Linux system and ready to be powered 
off.

Restarting System To restart the system:

1 In the Shutdown/Restart section, click Restart System. The system 
is restarted automatically.

Managing Media

Before you can work with media, you must first add a partition. Refer to 
Configuring Partitions on page 55.

1 Ensure the partition has been configured.

2 From the navigation panel, click Operations > Media. The Media 
screen displays.
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Figure 28  Media Window

This window displays the status and information known about each 
piece of media or cartridge in the system. The table below describes 
each column in the Media table.

Note: The amount of free space on an individual volume can only be 
determined through the Scalar LTFS GUI. You can not see any 
volume details through the file system.
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Table 7  Operations Media 
Description

Column Description

Select Select any/all media you want to attach, format, or sequester by clicking 
check box and clicking appropriate button.

Barcode The barcode associated with the physical media. The last two digits of the 
barcode that indicate the tape generation number, for example L5, are not 
displayed.

Volume Group A collection of one or more media into a single volume.

Mounted A check mark is displayed in this column if the media is mounted in a drive.

State The current state of the media:
Auto-attachable - indicates the media is available for auto-attaching to a 
volume group
Attached - indicates the media is attached to a VG
Sequestered - indicates the media is unavailable
Vaulted - indicates the media is unavailable and is not physically in the 
library
Pending attach - indicates the media is in the process of being attached
Pending format - indicates the media is in the process of being formatted
Preparing for export - indicates the media is being prepared for export
Ready for export - indicates the media is ready for export
Pending export - indicates the media is in the process of being exported
Repair in progress - indicates the media is in the process of being repaired
Merging volume groups - indicates the media is in the process of being 
merged
Verifying - indicates the media is in the process of being verified
Busy reclaiming - indicates the media is in the process of being reclaimed
Busy repairing - indicates the media is in the process of being repaired
Operation in progress - indicates the media is in the process of being 
replicated
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Physical State The location and availability of media through the tape library. Options 
include:
• Available - media is in an accessible partition
• Offline - media is in an unaccessible partition
• Vaulted - media has been removed from a partition

VG State Empty - indicates the volume group is empty
Ready - indicates the volume group is available and ready to be accessed
Unavailable - indicates the volume group is not ready to be accessed
Pending Export - indicates that the volume group is in the process of being 
exported and is unavailable
Pending Replication - indicates that the volume group is in the process of 
being copied and is unavailable
Pending Repair - indicates that the volume group is in the process of being 
repaired and is unavailable
Pending Merge - indicates that the volume group is in the process of being 
merged with another volume group and is unavailable
Vaulted - indicates that the volume group has been removed from the 
system

Reason The Scalar LTFS Appliance handles this field. It is the reason for the last state 
transition, such as user requested or auto-attach policy.

Partition The partition to which the media belongs. If unknown, the serial number 
displays. 

Comment An editable column that allows users to save information about the media.

Files The number of readable files contained on the physical tape cartridge. 

Used Amount of space used on the tape cartridge.

Free Amount of space available on the tape cartridge.

Media Details
When media is highlighted in the Media table, the details for that media display in the following fields.

Imported Date and time the media was imported into system.

Attached Date and time the media was attached.

Column Description
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Exported Date and time the media was exported from the system.

Location Indicates the location of the volume group.

Metadata Expiration Date and time a vaulted media will be deleted from the system.

Reason The Scalar LTFS Appliance handles this field. It is the reason for the last state 
transition, such as user requested or auto-attach policy.

Type Media type, LTO-5, LTO-6 or LTO-7.

Used % Percentage of space used on the tape cartridge.

Free % Percentage of space available on the tape cartridge.

Used Blocks The amount of space used on the tape cartridge in raw data format.

Free Blocks The amount of space available on the tape cartridge in raw data format.

Total Blocks Sum total of Used, Free and System blocks.
Note: This number can change based on compression and tape errors.

Block Size The actual size of the block used on the tape cartridge.

Reclamation Rating Indicates, on a scale from 1 to 10, number of overhead blocks on the media. 
The higher the rating is, the more overhead blocks are on the media.

Fragmentation Rating Indicates, on a scale from 1 to 10, how fragmented files are on a media. The 
higher the rating is, the more fragmented the data.

General Options

Capacity Percentages Graph showing the used and free space on the media.

Apply Filter Drop down list of filters that may be applied to the list of volumes.

Edit Filter Allows for the creation or modification of media filters.

Media Display Options include:
• Show Vaulted Media
• Show Attached Media
• Show All Media

Column Description
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Use the Media screen to do the following:

Attach Media to Scalar LTFS Manually on page 76

Format Media Manually in Scalar LTFS on page 77

Detach Media from Scalar LTFS on page 77

Edit Files on Tape Cartridges on page 77

Edit Files on Tape Cartridges on page 77

Writing Request and No Space Condition on page 78

Attach Media to Scalar 
LTFS Manually

Media may be attached manually when they are in either the sequester 
or auto-attachable state. When attached, they will be attached to the 
volume group with which they were previously associated. Media in the 
discovered media pool, that have not previously been associated with a 
volume group, will be attached to a new volume group. The new 
volume group will use the barcode as its name.

1 In the Select column, check the box next to the media to be 
attached.

2 Click Attach. The State field displays the change.

The message Are you sure you wish to change the media 
settings? displays.

3 Click Yes. The data on this tape is now available for downloading 
and manipulation.

Auto-attach Media to 
Scalar LTFS

Auto-attaching media is a means to extend the space availability (e.g. 
capacity) of an existing volume group without user intervention.    
Media will be auto-attached by SLTFS when scratch-enabled is set on a 
volume group (see Assign Media to a Volume Group on page 79). As 
data is written and media reaches capacity, SLTFS will attach additional 
media, as needed, from the scratch pool as long as media are available. 
Users are responsible for maintaining an adequate number of media in 
the scratch pool.
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Adding Media to the 
Scratch Pool

Formatting media moves them to the scratch pool and allows them to 
be used for volume group operations. New media added to the system, 
in the discovered media pool, may be formatted. Media already 
attached may be sequestered and formatted.

Format Media Manually 
in Scalar LTFS

Media can only be formatted if they are in the Sequestered state or the 
Auto-Attachable state. Sequestered media that belong to a VG will lose 
it's allegiance to that volume group after formatting. After a format 
completes, the media will enter the Auto-attachable state and become a 
member of the Scratch Pool.

WARNING: Formatting media containing data erases all data!

1 In the Select column, check the box next to the media to be 
attached.

2 Click Format. A dialog box displays confirming you want to format 
the selected media.

3 Click Yes. The tape is formatted for use with the Scalar LTFS.

4 A dialog box displays indicating the media settings were changed.

5 Click OK.

Detach Media from 
Scalar LTFS

1 To detach media from Scalar LTFS, export the media from your 
library. See Importing/Exporting Media from an LTFS Partition on 
page 58.

The media is detached and vaulted automatically from Scalar LTFS.

Edit Files on Tape 
Cartridges

Before making changes to files contained on the tape cartridge, we 
recommend that you copy the files to your hard drive. When you are 
finished, you can copy the files back to tape.

1 Using Windows Explorer, go to the IP address location for 
ScalarLTFS. The tape cartridges that are part of the partition are 
listed by barcode. 

2 Copy the files you want to change to your hard drive.
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3 As desired, copy and paste files onto the tape.

Note: No feedback is provided in Windows Explorer on an initial read 
or write of a file until the tape containing the file has been 
loaded and positioned. This can take several minutes 
depending on the tape library and other activity in the system.

Writing Request and No 
Space Condition

When writing to a specific medium, users may encounter a ‘no space’ 
condition that indicates the medium is running out of space. However, 
unlike other file systems, this does not mean that there is no space left 
anywhere in the file system. It just indicates that there is no space left 
on the specific medium.
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Assign Media to a Volume Group

1 From the navigation panel, click Operations > Volume Group 
Assignment. The Volume Group Assignment screen displays.

Figure 29  Volume Group 
Assignment screen

Column Description

Select Select a source volume group to list the media available to assign or merge. 
The check boxes will be enabled when the volume group and its media are in 
the appropriate states.

Volume Group The volume group name that is going to have media assigned from or 
merged with another volume group.
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State The current state of the media:
Auto-attachable - indicates the media is available for auto-attaching to a 
volume group
Attached - indicates the media is attached to a VG
Sequestered - indicates the media is unavailable
Vaulted - indicates the media is unavailable and is not physically in the 
library
Pending attach - indicates the media is in the process of being attached
Pending format - indicates the media is in the process of being formatted
Preparing for export - indicates the media is being prepared for export
Ready for export - indicates the media is ready for export
Pending export - indicates the media is in the process of being exported
Repair in progress - indicates the media is in the process of being repaired
Merging volume groups - indicates the media is in the process of being 
merged
Verifying - indicates the media is in the process of being verified
Busy reclaiming - indicates the media is in the process of being reclaimed
Busy repairing - indicates the media is in the process of being repaired
Operation in progress - indicates the media is in the process of being 
replicated

Mounted A check mark is displayed in this column if the media is mounted in a drive.

Media Indicates the number of media contained in the volume group.

Sequestered Media Indicates the number of media sequestered in the volume group.

Offline Media Indicates the number of media offline in the volume group.

Reason The Scalar LTFS Appliance handles this field. It is the reason for the last state 
transition, such as user requested or auto-attach policy.

Comment An editable column that allows users to save information about the media.

Scratch Enabled Indicates if the volume group is configured to automatically acquire a blank 
tape when necessary.

Files The number of readable files contained on the physical tape cartridge. 

Used Amount of space used on the tape cartridge.

Column Description
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State The current state of the media:
Auto-attachable - indicates the media is available for auto-attaching to a 
volume group
Attached - indicates the media is attached to a VG
Sequestered - indicates the media is unavailable
Vaulted - indicates the media is unavailable and is not physically in the 
library
Pending attach - indicates the media is in the process of being attached
Pending format - indicates the media is in the process of being formatted
Preparing for export - indicates the media is being prepared for export
Ready for export - indicates the media is ready for export
Pending export - indicates the media is in the process of being exported
Repair in progress - indicates the media is in the process of being repaired
Merging volume groups - indicates the media is in the process of being 
merged
Verifying - indicates the media is in the process of being verified
Busy reclaiming - indicates the media is in the process of being reclaimed
Busy repairing - indicates the media is in the process of being repaired
Operation in progress - indicates the media is in the process of being 
replicated

Mounted A check mark is displayed in this column if the media is mounted in a drive.

Media Indicates the number of media contained in the volume group.

Sequestered Media Indicates the number of media sequestered in the volume group.

Offline Media Indicates the number of media offline in the volume group.

Reason The Scalar LTFS Appliance handles this field. It is the reason for the last state 
transition, such as user requested or auto-attach policy.

Comment An editable column that allows users to save information about the media.

Scratch Enabled Indicates if the volume group is configured to automatically acquire a blank 
tape when necessary.

Files The number of readable files contained on the physical tape cartridge. 

Used Amount of space used on the tape cartridge.

Column Description
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Free Amount of space available on the tape cartridge.

Media Area
Displays the media currently assigned to a volume group or available for assignment to a volume 
group.

Select Indicates which media are available for assignment or merge. If a non-
scratch, non-discoverable volume group is selected in the Volume Group 
area, all media in that volume group are pre-selected in the Media area and 
available for assignment. All media with data must be selected to complete 
a merge. Optionally, you may deselect the empty media and any blank 
media will remain in the source volume group.

Barcode Indicates the barcode of the media being assigned or merged.

Mounted A check mark is displayed in this column if the media is mounted in a drive.

State The current state of the media:
Auto-attachable - indicates the media is available for auto-attaching to a 
volume group
Attached - indicates the media is attached to a VG
Sequestered - indicates the media is unavailable
Vaulted - indicates the media is unavailable and is not physically in the 
library
Pending attach - indicates the media is in the process of being attached
Pending format - indicates the media is in the process of being formatted
Preparing for export - indicates the media is being prepared for export
Ready for export - indicates the media is ready for export
Pending export - indicates the media is in the process of being exported
Repair in progress - indicates the media is in the process of being repaired
Merging volume groups - indicates the media is in the process of being 
merged
Verifying - indicates the media is in the process of being verified
Busy reclaiming - indicates the media is in the process of being reclaimed
Busy repairing - indicates the media is in the process of being repaired
Operation in progress - indicates the media is in the process of being 
replicated

Column Description
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2 In the Select column, click the check box for Scratch Media. In the 
Media area, a list of available media will be listed.

3 Click the check box next to each piece of media you want to add to 
the volume group.

4 In the Destination Volume Group area, click the check box for the 
volume group you want to assign the media to.

5 Click Apply. A confirmation dialog will appear confirming that the 
media is in process of being assigned to the volume group.

6 If you want to check the status of the media assignment, see Use 
the Job Queue on page 67.

Physical State The location and availability of media through the tape library. Options 
include:
• Available - media is in an accessible partition
• Offline - media is in an unaccessible partition
• Vaulted - media has been removed from a partition

Reason The Scalar LTFS Appliance handles this field. It is the reason for the last state 
transition, such as user requested or auto-attach policy.

Partition Indicates the partition the media is assigned to.

Empty A check mark is displayed in this column if the media is empty. 
Note: After upgrading Scalar LTFS, the system will not know if media is 

empty until it has been mounted.

Files Indicates the number of files on the media.

Used Amount of space used on the tape cartridge.

Free Amount of space available on the tape cartridge.

Destination Volume Group Area

Select Check the box for where you want the media assigned or the volume group 
you want to merge with.

Volume Group Indicates the volume group the media or volume group will be assigned to.

Column Description
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Use Volume Group Utilities

1 From the navigation panel, click Operations > Volume Group 
Utilities. The Volume Group Utilities screen displays.

Figure 30  Volume Group 
Utilities Window

Column Description

Select Select the volume group you want to replicate or repair by clicking check 
box.

Volume Group The volume group name that is going to be replicated or repaired.
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State The current state of the media:
Auto-attachable - indicates the media is available for auto-attaching to a 
volume group
Attached - indicates the media is attached to a VG
Sequestered - indicates the media is unavailable
Vaulted - indicates the media is unavailable and is not physically in the 
library
Pending attach - indicates the media is in the process of being attached
Pending format - indicates the media is in the process of being formatted
Preparing for export - indicates the media is being prepared for export
Ready for export - indicates the media is ready for export
Pending export - indicates the media is in the process of being exported
Repair in progress - indicates the media is in the process of being repaired
Merging volume groups - indicates the media is in the process of being 
merged
Verifying - indicates the media is in the process of being verified
Busy reclaiming - indicates the media is in the process of being reclaimed
Busy repairing - indicates the media is in the process of being repaired
Operation in progress - indicates the media is in the process of being 
replicated

Mounted A check mark is displayed in this column if the media is mounted in a drive.

Media Indicates the number of media contained in the volume group.

Empty Media Indicates the number of blank media contained in the volume group.

Sequestered Media Indicates the number of media sequestered in the volume group.

Offline Media Indicates the number of media offline in the volume group.

Reason The Scalar LTFS Appliance handles this field. It is the reason for the last state 
transition, such as user requested or auto-attach policy.

Comment Displays any additional comments about the volume group.

Scratch Enabled Indicates if the volume group is configured to automatically acquire a blank 
tape when necessary.

Column Description
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Free Threshold Indicates the percentage of capacity that the system will notify the user that 
the volume group is filling up.

Files The number of readable files contained on the physical tape cartridge. 

Used Amount of space used on the tape cartridge.

Free Amount of space available on the tape cartridge.

Media Area
Displays the media currently assigned to a volume group or available for assignment to a volume 
group.

Barcode Indicates the barcode of the media being assigned or merged.

Mounted A check mark is displayed in this column if the media is mounted in a drive.

State The current state of the media:
Auto-attachable - indicates the media is available for auto-attaching to a 
volume group
Attached - indicates the media is attached to a VG
Sequestered - indicates the media is unavailable
Vaulted - indicates the media is unavailable and is not physically in the 
library
Pending attach - indicates the media is in the process of being attached
Pending format - indicates the media is in the process of being formatted

Preparing for export - indicates the media is being prepared for export
Ready for export - indicates the media is ready for export
Pending export - indicates the media is in the process of being exported
Repair in progress - indicates the media is in the process of being repaired
Merging volume groups - indicates the media is in the process of being 
merged
Verifying - indicates the media is in the process of being verified
Busy reclaiming - indicates the media is in the process of being reclaimed
Busy repairing - indicates the media is in the process of being repaired
Operation in progress - indicates the media is in the process of being 
replicated

Column Description
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Note: When a volume group is selected, the radio buttons for the 
available utilities are enabled. If a radio button is not enable, 
mouse-over the radio button to see why.

Note: Safe repair or replication cannot be performed on empty 
volume groups.

Physical State The location and availability of media through the tape library. Options 
include:
• Available - media is in an accessible partition
• Offline - media is in an unaccessible partition
• Vaulted - media has been removed from a partition

Reason The Scalar LTFS Appliance handles this field. It is the reason for the last state 
transition, such as user requested or auto-attach policy.

Partition Indicates the partition the media is assigned to.

Empty Indicates the volume group is empty.

Reclamation Rating The Reclamation Rating is an  indicator,  on a scale from 1 to 10. The higher 
the rating is, the more overhead  blocks are on the media. 

Fragmentation Rating The Fragmentation Rating is an indicator,  on a scale from 1 to 10, of how 
fragmented files are on a media. The higher the rating is, the more 
fragmented the data. 

Files Indicates the number of files on the media.

Used Amount of space used on the tape cartridge.

Free Amount of space available on the tape cartridge.

Utilities

Safe-Repair The selected volume group must contain at least one sequestered volume. 

Repair The selected volume group must have scratch enabled, be in the unavailable 
state and all constituent volumes must be online. 

Replicate The selected volume group must be in the ready state and all constituent 
volumes must be online. 

Column Description
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Replicate a Volume 
Group

Volume groups can be copied using the SLTFS interface. However, be 
aware that to copy a volume group, you will need two available drives 
and, depending on the size of the volume group, a considerable amount 
of time to complete the copy.

1 Select the volume group you want to copy by clicking the check box 
in the Select column.

2 Select the Replication radio button.

3 Type a name for the new volume group in New Volume Group 
field.

4 You can select the Verify Option check box if you want SLTFS to 
verify that the volume group has been copied.

5 Click Apply. The volume group has been initiated. This is a long 
running process and progress may be monitored from in the job 
queue. To view your new volume group, see Configuring Volume 
Groups on page 59.

Note: Replication cannot occur if the volume group contains empty 
media. The Replication radio button will be unavailable in this 
instance.

Repair a Volume Group Note: To repair a volume group, it must have at least one media in 
Sequestered state.

1 Select the volume group you want to repair by clicking the check 
box in the Select column.

2 Select the Repair radio button.

3 Click Apply. The repair has been initiated. Once the media has been 
repaired, the volume group will try to attach the repaired media.

Safe Repair a Volume 
Group

Note: To repair a volume group, it must have at least one media in 
Sequestered state or it failed a job request (ex. merge, 
replication) or is needed to restore a volume group that is in 
Ready for Export state.
88 Quantum Scalar LTFS Appliance User’s Guide



Chapter 5: System Media Operations
Registering the Appliance
1 Select the volume group you want to safe repair by clicking the 
check box in the Select column.

2 Select the Safe Repair radio button.

3 Type a name for the new volume group in New Volume Group 
field.

4 Click Apply. The safe repair has been initiated. If successful, the 
media that was repaired will now reside in the new volume group. If 
you want to return the media to its original volume group, you will 
have to assign manually. A repair or attach can be attempted on the 
volumes in the new volume group in order to resolve issues with the 
sequestered volumes.

Registering the Appliance

To register the appliance:

1 From the navigation panel, click Help > Register Appliance. The 
Register Appliance screen displays.

The information displayed in this window is the same as 
information you entered on the System Configuration screen. 

2 Review the information displayed.

• To change information displayed, click No.
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• Select the Configuration > System menu. Refer to System 
Configuration - Contact Information on page 42.

• To accept the information displayed, click Yes. The appliance is 
registered.
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This chapter provides procedures for tasks available under the GUI Tools 
menu, including:

Capture Snapshot Data on page 91

Review and Resolve Diagnostic Tickets on page 93

System Messages on page 95

Configure Remote Authentication on page 98

Save and Restore an LTFS Configuration on page 101

Security on page 103

Update Firmware on page 105

Capture Snapshot Data

Snapshot files can be used as a troubleshooting tools. They depict the 
current system configuration, any log files, and existing diagnostic 
tickets. 

1 From the navigation panel, click Tools > Capture Snapshot. The 
Capture Snapshot screen displays.
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Figure 31  Capture Snapshot 
Window

Capture a Snapshot 1 Click Capture Snapshot.

2 Select a location to save the file, type the desired name, and click 
Save.

Download Component 
Log Collection

Note: This request may take several minutes to complete.

1 Click Download Component Log Collection.

2 Select a location to save the file, type the desired name, and click 
Save.

Download an Extended 
Snapshot

An Extended Snapshot contains information on any log generated by 
the Scalar LTFS Appliance. This log is available only for download since 
the log file size can exceed 2 Gb. Only retrieve an extended snapshot 
under the direction of your service support representative.

1 Click Download Extended Snapshot.

2 The file will download via your browser.

3 When complete, select where you want to save the file.
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Review and Resolve Diagnostic Tickets

If the system encounters an issue, a diagnostic ticket is generated. The 
issue could be informational or require resolution. You have the option 
of resolving and closing tickets or closing without resolution.

For a complete list of active diagnostic tickets, see the Scalar LTFS 
Maintenance Guide.

1 From the navigation panel, click Tools > RAS Tickets. The 
Diagnostic Tickets screen displays the open diagnostic tickets.

Figure 32  Tools Diagnostic 
Tickets
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The following information is displayed for each diagnostic ticket:

2 To include closed tickets in the display, click the box Include Closed 
Tickets in Display.

3 Identify the diagnostic ticket you want to resolve. 

4 Resolve the diagnostic ticket:

Heading Description

Ticket Unique ticket number generated by LTFS. 

Closed If closed, a check mark appears in the column.

Severity • Blue: Low Priority. Action: Issue should be 
noted. Resolve tickets according to 
resolution

• Yellow: Medium Priority. Action: Resolve 
tickets according to resolution. System 
Impact is likely

• Red: High Priority. Immediate attention is 
required. Action: Resolve ticket according to 
Diagnostic Resolution

Opened At Date and time ticket was opened

Summary Ticket ID and description

Diagnostic Ticket Details

Details Additional information about the ticket

Reporter 
Component

The component that generated the ticket

Component hardware or software

Component 
Instance

Unique ID for instance

Closed By User that closed the ticket

Closed At Date and time ticket was closed

Comment User comment
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a Click the Resolution button to read resolution steps. An HTML 
document opens containing resolution steps.

b If the situation cannot be resolved, you are instructed to contact 
technical support. 

5 Once a resolution is determined, take one of the following actions:

• To close the ticket now, click Close. The Diagnostic Tickets 
window displays, with the ticket no longer in the list. 

• To leave the ticket open for future troubleshooting, click Exit. 
The ticket remains on the list.

• You can also close all tickets at once by clicking the Close All 
Tickets button. 

Caution: Be careful when pressing the Close All button. This 
closes all diagnostic tickets even if they are not 
resolved. It is recommended that each diagnostic ticket 
be individually viewed, analyzed, and closed. 

Note: Tickets that were automatically closed are designated as 
Canceled.

System Messages

Heading Description

Select Select any/all media you want to close and click the Close button.

Opened At Date and time message was opened

Created By Indicates whether the message was system generated (ALTFS) or custom.
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Create a Custom 
System Message

1 From the navigation panel, click Tools > Messages. The System 
Messages screen displays.

Message Displays the following system messages:
• A500 - Admin message
• M100 - Volume exceeded recommended number of files
• M101 - Vaulted file not available for read
• M102 - Vaulted file not available for write
• M103 - Volume group low capacity threshold reached
• M104 - Scratch pool low capacity threshold reached
• M105 - No drives available
• M106 - Write failed due to no space remaining
• M107 - Rename failed
• M108 - File/Directory collision

Duplicates How many times this message has been generated for this open message 
ID with the same reference.

Last Occurrence The date and time a duplicate message was previously generated.

Closed By User that closed the message.

Closed At Date and time message was closed.

Heading Description
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Figure 33  System Messages 
Window

2 In the Compose Message area, enter the message in the field 
provided.

3 Click Submit Message. Your message is added to the System 
Message list.

Close a System 
Message

Note: Closed messages are automatically deleted from the system 
after 90 days.

1 From the navigation panel, click Tools > Messages. The System 
Messages screen displays.

2 Click the check box in the Select column for the message(s) you wish 
to close.

3 Click Close. The messages are removed from the System Message 
list.
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Configure Remote Authentication

Remote Authentication provides the ability to connect to an LDAP or 
Active Directory server in order to obtain credentials for logging in and/
or for enabling ACLs. In order to enable ACLs, the LDAP or Active 
Directory service must be provided by a server which is a domain 
controller (e.g., a Windows server running Active Directory).

Note: Prior to configuring SLTFS for remote authentication, the 
network settings should be complete. For more details, see 
Configuring the Network on page 48.

1 From the navigation panel, click Tools > Remote Authentication. 
The Remote Authentication screen displays.

Figure 34  Remote 
Authentication Window
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2 In the Connection Settings area, enter the LDAP/Active Directory 
domain server in the Primary Server field.

3 Complete the Alternate Server and Port fields as needed. The 
default port is 389.

4 Enter the domain name of the principal user in the Principal field. 
The principal user is any user who is authorized to add a system to 
the LDAP or Active Directory domain. This user may be a network 
administrator and may not necessarily be an actual user of the SLTFS 
file system.

5 In the Search Settings area, complete the following fields:

• User DN: When ACLs are enabled, this field specifies the 
container where domain users are located in the LDAP hierarchy.

• Group DN: When ACLs are enabled, this field specifies the 
container where security groups are located in the LDAP 
hierarchy.

• User Group: When ACLs are enabled, this field specifies the 
security group which domain users must be a member of in 
order to have user access rights to the Scalar LTFS file system. 
User access rights grant users the right to access volumes, 
folders, and files, contingent upon the contents of the ACLs 
associated with the file system object. Membership is indicated 
by a “memberOf” attribute for the user which contains the DN 
of the security group.

• Admin Group: When ACLs are enabled, this field specifies the 
security group which domain users must be a member of in 
order to have administrator access rights to the Scalar LTFS file 
system. Administrators can always modify volumes, folders, and 
files, as well as their security settings, regardless of the content 
of the ACLs associated with the file system object. Membership 
is indicated by a “memberOf” attribute for the user which 
contains the DN of the security group.

6 Click Apply. The remote authentication settings are saved.

Test Configuration 
Settings

1 In the Test area, you can test the configuration as well as users.

• To test the configuration:
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a Simply click the Test Configuration button. A confirmation 
dialog will appear confirming either a success or failure.

• To test user access:

a Enter a user name and password. You must use the LDAP 
canonical name (display name; not the login name). The 
password is the user’s regular password.

b Click the Test User button. A confirmation dialog will 
appear confirming either a success or failure.

Enable/Disable Access 
Control List (ACL)

ACLs are lists of permissions attached to file system objects, which can 
be used to grant or restrict access to Scalar LTFS volumes, directories, or 
files. When ACLs are enabled, Scalar LTFS joins a domain and grants or 
restricts access to domain users according to their membership in 
domain security groups. Administration of ACLs associated with file 
system objects is done with standard tools (e.g., the Security tab on 
Windows Explorer).

To enable or disable ACLs:

1 From the navigation panel, click Tools > Remote Authentication. 
The Remote Authentication screen displays.

2 At the top of screen, select/deselect the Enable File system ACLs 
check box.

3 Click Apply. A confirmation dialog will appear confirming either a 
success or failure.

On apply, the samba configuration is changed. If Enable File 
system ACLs is checked, this may fail if an IP address is supplied 
rather than a hostname. However, the hostname cannot be 
obtained from reverse DNS lookup or if the network settings or 
principal credentials are not correct. In case of failure to enable 
ACLs, an error is reported, any other changes to the page will be 
saved, but ACLs will not be enabled.
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Save and Restore an LTFS Configuration

You can save your current configuration and restore it as needed at a 
later date. The configuration you save includes a current image of the 
system. 

Save the Current 
Configuration

1 From the navigation panel, click Tools > Save or Restore. The Save 
or Restore screen displays.

Figure 35  System Save or 
Restore Window

2 Click Save Configuration. The Processing....Please Wait message 
and the Select Location for Download window displays.

Note: The saved system configuration filename contains a .qtm 
suffix.
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3 Save the current configuration to your desired network location.

Restore a Saved 
Configuration

Restore Guidelines

You can restore a saved configuration to your appliance as long as the 
current firmware and serial number on the appliance is the same version 
that was used to save the configuration. Refer to examples below for 
further clarification.

Note: The saved image will not be allowed to install if the Quantum 
serial number on the appliance does not match the Quantum 
serial number in save/restore image.

Examples

• If you saved a configuration at firmware version 1, and then 
upgraded the firmware version to 2, the Restore attempt will fail. In 
this case, we ask that customers contact a Quantum service 
representative to have their appliance firmware downgraded to the 
appropriate version. The customer can then proceed with restoring 
the saved configuration.

• If you saved a configuration at firmware version 1, and your 
firmware version is still version 1, the restore will proceed normally.

Restore Procedure

A saved configuration remembers exactly what was in SLTFS at the time 
it was saved. After the save, files are added to or removed from media 
and partitions may have changed. So after performing a restore, the 
Scalar LTFS Appliance needs to discover the changes to media files and/
or partitions.

1 From the navigation panel, click Tools > Save or Restore. The Save 
or Restore screen displays.

2 Navigate to the location of the saved configuration.

3 Click Restore Configuration. The configuration is restored to that 
saved version.

4 The Scalar LTFS Appliance then restarts. This should take 
approximately 30 minutes.
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5 All media should be sequestered and then attached in each 
partition. This ensures that each piece of media is read and the 
SLTFS internal database can be made current with what files/
partitions exist now.

Caution: If the system restart takes longer than 30 minutes, the 
user should review the diagnostic ticket because there 
could be a problem with the Scalar LTFS Appliance.

Security

Manage IP Addresses The Tools > Security menu option provides a way for you to manage 
the IP addresses you want to interface with the Scalar LTFS server. If you 
do not specify an IP address (which means the IP address list is empty,) 
all IP address have access to the /ScalarLTFS/ directories. If you populate 
the IP address list by specifying one or more IP address, only the IPs 
entered are allowed access to the /ScalarLTFS/ directories. (There is no 
limit to the number of IP addresses in the list.)

Use the Tools > Security menu option to add new IP addresses, delete 
IP addresses you no longer need, or export the list of addresses to the 
Scalar LTFS server.
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Figure 36  Security window

Note: Since you cannot modify an IP address you have already 
entered, if there is a change to an existing IP address you must 
first delete the original IP address and then add the new IP 
address.

Add an IP Address To add a new IP address:

1 Choose Security from the Tools menu.

2 At the IP field, enter the IP address you want to add.

3 Click Add. The IP address will be added to the list on the right side 
of the window.

Delete an IP Address To delete an IP address:

1 If you have not already done so, choose Security from the Tools 
menu.
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2 Select from the list on the right side of the window the IP address 
you want to delete.

3 Click Delete. The IP address will be removed from the list on the 
right side of the window.

Export the IP Address 
List

Whenever you add or delete IP addresses you should also export the 
revised list to the Scalar LTFS server. (You will receive a warning message 
if you make changes on this screen and then attempt to exit without 
exporting the revised IP address list.)

To export the IP address list:

1 If you have not already done so, choose Security from the Tools 
menu.

2 Click Export. The list of IP addresses is exported to the Scalar LTFS 
server. Only the IP addresses in the list have access to the Scalar LTFS 
directories.

Update Firmware

1 Download the latest firmware from the Quantum Support Web site, 
and save it to your desired location.

2 Extract the .FW file from the zip file and save it to a location.

3 From the navigation panel, click Tools > Update Firmware. The 
Update Firmware screen displays,
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Figure 37  Tools Update 
Firmware Window

Caution: Before firmware can be updated, Open Diagnostic 
Tickets must be 0. Loaded Drives must be 0—this check 
ensures that no data is being moved between the 
library and the appliance.

4 Click Browse to locate the .FW file, and click Update Firmware. A 
progress window displays and the firmware is updated.
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Scalar LTFS allows you to email or download seven different reports. 
They include:

• Component Information Report on page 107

• Configuration Record Report on page 110

• Diagnostic Ticket Report on page 112

• Media Report on page 115

• Media Count Report on page 119

• Message Summary Report on page 120

• Volume Group Capacity Report on page 121

Component Information Report

A component is defined as hardware or software that is part of the 
Scalar LTFS system. The Component Information screen displays a 
summary of the appliance’s hardware and software status. There are 
four tabs available:

• Cluster Raid

• Mother Board
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• Fabric Hardware (only available on fibre channel appliances)

• Network

Use this information to view the status of Ethernet ports, and to read 
any diagnostic messages indicating that a component has failed. 

1 From the navigation panel, click Reports > Component 
Information. The Component Information screen displays.
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Figure 38  Component 
Information Report

2 To send the component information report via e-mail, first select 
either the text or xml radio button.

3 Click Send. A dialog box displays.

4 Type the e-mail address and click E-Mail Report. 

5 To download the report, click Save. A Save As dialog box displays.
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6 Navigate to where you want the report saved and click Save.

Configuration Record Report

The Configuration Record depicts the current configuration of your 
Scalar LTFS Appliance. You can review configuration information from 
the following seven (7) tabs:

• Partitions/Drives (default)

• Volumes

• Volume Groups

• Licenses

• Users

• Network

• Notifications

1 From the navigation panel, click Reports > Configuration Record. 
The Configuration Record screen displays.
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Figure 39  Configuration 
Record Window

2 To send the configuration record report via e-mail, select a File 
Format:

• Text - sends a .txt file to the specified e-mail address

• XML - sends a .xml file to the specified e-mail address

3 Click Send. A dialog box displays.

4 Type the e-mail address and click E-Mail Report. 

5 To download the report, select a File Format:

• Text - sends a .txt file to the specified e-mail address

• XML - sends a .xml file to the specified e-mail address

6 Click Save. A Save As dialog box displays.

7 Navigate to where you want the report saved and click Save.
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Diagnostic Ticket Report

Whenever the Scalar LTFS Appliance is not performing as designed, 
diagnostic tickets are generated to help you identify what is not 
working correctly with the system. The Diagnostic Ticket Report screen 
displays all the tickets generated by the Scalar LTFS system. You can set 
up filters to show more specific types of tickets and you can email or 
download the report as well.

A customized report may be created by reordering the columns by 
selecting the column and dragging it to the desired position. Columns 
may be hidden by clicking the X in the column header. The report is 
generated as the data is displayed on the screen. 

From the navigation panel, click Reports > Diagnostic Ticket. The 
Diagnostic Ticket Report screen displays.

Figure 40  Diagnostic Ticket 
Report screen
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8 Select a filter from the Apply Filter drop-down list. A list of 
diagnostic tickets displays.

Create a Filter 1 From the Diagnostic Ticket Report screen, click Edit Filter. The 
Diagnostic Ticket Filters dialog box displays.

Figure 41  

2 From the Filter Type drop-down, select the type of filter you want 
to create. You can select:

• Media

• Diagnostic Tickets

3 Select Diagnostic Tickets.

4 Type a name for your filter in the Filter Name box. Filter names can 
be up to 24 characters in length and may include dashes, 
underscores and alphanumeric characters.
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5 If you want to make your filter available to other users, select the 
Public checkbox.

Note: All filters created by you, as well as any public filters, will 
display in the table. All filters owned by you will not show 
an owner, while all public filters will display the owner.

6 In the Search Criteria section, set up your filter conditionals.

a From the Select a Column drop-down, select the column you 
want to run your filter on. 

b Once a column has been selected, the Select Condition drop-
down displays. 

c Select a condition. Depending on the type of condition selected, 
the last box will either be for text or a date and time.

d Enter your final criteria details in the last box.

e If you are done, go to the Sort Results By section. If you want 
to add more criteria, click the blue plus sign at the end of the 
criteria row.

Note: If you want to get the opposite results of what you set 
up for your criteria, select the Negate search criteria 
checkbox.

7 In the Sort Result By: section, select the column you want to use to 
sort your results from the Select a Column drop-down.

8 From the next drop-down, select how you want the results sorted: 
Ascending or Descending.

9 If you are creating a new filter, click Add when finished. If you are 
editing a filter, click Update.

10 If you need to start over with your filter, click Clear and all search 
criteria are removed.

Send a Diagnostic 
Ticket Report

1 To send the diagnostic ticket report via e-mail, click Send. A dialog 
box displays.

2 Type the e-mail address and click E-Mail Report. A dialog displays 
informing you that the report has been sent.
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Save a Diagnostic Ticket 
Report

1 To save the diagnostic ticket report, click Save. The Save As dialog 
box displays

2 Navigate to where you want to save the diagnostic ticket report.

3 Click Save. A dialog displays informing you that the report has been 
saved.

Media Report

The Media Report displays all available media on your Scalar LTFS 
appliance. To view a smaller subset of media, you can create filters. If a 
filter is applied, any report sent or saved will contain only the filtered 
information.

A customized report may be created by reordering the columns by 
selecting the column and dragging it to the desired position. Columns 
may be hidden by clicking the X in the column header. The report is 
generated as the data is displayed on the screen. 

1 From the navigation panel, click Reports > Media. The Media 
Report screen displays.
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Figure 42  Media Report screen

2 Select a filter from the Apply Filter drop-down list. A list of media 
displays.

Create a Filter 1 From the Media Report screen, click Edit Filter. The Media Filters 
dialog box displays.
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Figure 43  Media Filters screen

2 From the Filter Type drop-down, select the type of filter you want 
to create. You can select:

• Media

• Diagnostic Tickets

3 Select Media.

4 Type a name for your filter in the Filter Name box. Filter names can 
be up to 24 characters in length and may include dashes, 
underscores and alphanumeric characters. 

5 If you want to make your filter available to other users, select the 
Public checkbox.

Note: All filters created by you, as well as any public filters, will 
display in the table. All filters owned by you will not show 
an owner, while all public filters will display the owner.

6 In the Search Criteria section, set up your filter conditionals.
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a From the Select a Column drop-down, select the column you 
want to run your filter on. 

b Once a column has been selected, the Select Condition drop-
down displays. 

c Select a condition. Depending on the type of condition selected, 
the last box will either be for text or a date and time.

d Enter your final criteria details in the last box.

e If you are done, go to the Sort Results By section. If you want 
to add more criteria, click the blue plus sign at the end of the 
criteria row.

Note: If you want to get the opposite results of what you set 
up for your criteria, select the Negate search criteria 
checkbox.

7 In the Sort Result By: section, select the column you want to use to 
sort your results from the Select a Column drop-down.

8 From the next drop-down, select how you want the results sorted: 
Ascending or Descending.

9 If you are creating a new filter, click Add when finished. If you are 
editing a filter, click Update.

10 If you need to start over with your filter, click Clear and the page 
returns to its initial state with one empty search and one empty sort 
row unless the page is currently displaying a filter owned by another 
user.

Note: If another user’s filter has been selected from the table, the 
clear button will only clear the filter-name & filter-owner 
and re-enables everything on the page. This allows the user 
to modify the filter and add it as one of his own. A second 
click on the clear button clears the entire page.

Copy a Public Filter Scalar LTFS allows you to open a filter made public by another user and 
copy it for your own purposes. Once copied, the filter is owned by you 
and can be modified. To copy a public filter:
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1 From the Media Report screen, click Edit Filter. The Media Filters 
dialog box displays.

2 From the filter list on the right of the Media Filters dialog box, 
select a public filter not your own. You'll notice that all fields and 
drop-downs are greyed out.

3 Click Clear. The Filter Name field is cleared and all the options are 
now available for editing.

4 Type a new name for the filter.

5 Make any further changes to the filter.

6 Click Update. The filter is added to the filter list.

Note: Clicking the Clear button twice will clear all fields for the 
filter.

Send a Media Report 1 To send the configuration record via e-mail, click Send. A dialog box 
displays.

2 Type the e-mail address and click E-Mail Report. A dialog displays 
informing you that the report has been sent.

Save a Media Report 1 To save the configuration record, click Save. The Save As dialog box 
displays

2 Navigate to where you want to save the diagnostic ticket report.

3 Click Save. A dialog displays informing you that the report has been 
saved.

Media Count Report

1 From the navigation panel, click Tools > Media Count. The Media 
Count Report screen displays.
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Figure 44  Media Count Report 
Window

The Media Count Report indicates the number of media in the 
available volume states. The report explains the total number of media 
in each state as well as the media containing data, how many are empty 
and the number of media that are unknown.

Send a Media Count 
Report

1 To send the report via e-mail, click Send. A dialog box displays.

2 Type the e-mail address and click E-Mail Report. A dialog displays 
informing you that the report has been sent.

Save a Media Count 
Report

1 To save the report, click Save. The Save As dialog box displays

2 Navigate to where you want to save the media count report.

3 Click Save. A dialog displays informing you that the report has been 
saved.

Message Summary Report

1 From the navigation panel, click Tools > Messages. The Message 
Summary Report screen displays.
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Figure 45  Message Summary 
Report Window

The Message Summary Report indicates the number of specific system 
messages that have been generated. The report explains the type of 
message, it’s description, the number of times it was generated and the 
last date it was generated.

Send a Message 
Summary Report

1 To send the report via e-mail, click Send. A dialog box displays.

2 Type the e-mail address and click E-Mail Report. A dialog displays 
informing you that the report has been sent.

Save a Message 
Summary Report

1 To save the report, click Save. The Save As dialog box displays

2 Navigate to where you want to save the message summary report.

3 Click Save. A dialog displays informing you that the report has been 
saved.

Volume Group Capacity Report

1 From the navigation panel, click Reports > Volume Groups. The 
Volume Group Capacity screen displays.
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Figure 46  Volume Group 
Capacity Window

The Volume Group Capacity Report indicates the number of media per 
volume group as well as total capacity of the volume group and the 
amount of space used and available in Mbs.

Send a Volume Group 
Capacity Report

1 To send the report via e-mail, click Send. A dialog box displays.

2 Type the e-mail address and click E-Mail Report. A dialog displays 
informing you that the report has been sent.

Save a Volume Group 
Capacity Report

1 To save the report, click Save. The Save As dialog box displays

2 Navigate to where you want to save the message summary report.

3 Click Save. A dialog displays informing you that the report has been 
saved.
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Troubleshooting

To assist you in troubleshooting a system issue, this chapter provides a 
list of frequently asked questions by category:

Detecting Problems on page 123

Library Tape Drive Issues on page 129

Note: The first step in troubleshooting any issues with the Scalar LTFS 
Appliance or its libraries is to check for any diagnostic tickets 
and follow the steps listed. Only after this has been done 
should users consult the issues detailed in this chapter or 
contact a Quantum Service Representative.

Detecting Problems

How can I detect a problem within the appliance?

When the appliance detects an issue, it generates a diagnostic 
ticket, and the status button in the top bar of the GUI displays the 
color yellow to indicated a degraded status or red to indicate an 
“error” status (as explained in Table 3 on page 33). Details about the 
diagnostic ticket are located in the GUI under Tools > Diagnostic 
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Tickets. For error detail, refer to Review and Resolve Diagnostic 
Tickets on page 93. 

Accessing Media I cannot access my media through the Scalar LTFS file system. 

There are a number of ways to troubleshoot, including:

• Check for any opened diagnostic tickets. If a ticket has been 
generated, follow the steps to resolve the issue.

• If you’re using security, verify that the host IP has been added 
and exported. Tools > Security > Access List.

If there is not an open ticket:

• On the library, ensure that your media is either LTO-5 or higher 
generation, the library partition is online and media has the 
correct six character barcode.

• Using the appliance, check to ensure that the partition is 
attached and online. Select Configuration > Partitions.

• Ensure that at least one drive is Online. Configuration > 
Partitions.

• Verify that Scalar LTFS has a license installed. Configuration > 
Licenses.

• Check the media, if it is not attached, it could be a formatting 
problem, the wrong generation, or not labeled. Operations > 
Media

Viewing Partitions Why do I still see a partition I removed or modified?

If a Scalar LTFS Appliance was originally configured for multiple 
partitions and then modified to have less partitions, a ‘ghost partition’ 
may still appear in the library. To remove this ‘ghost partition’ from 
displaying in the library:

1 From the Scalar LTFS Appliance GUI, take the partitions that were 
removed/modified offline.

2 Detach the removed partition in the Scalar LTFS Appliance GUI.

3 Go to the Scalar LTFS Appliance tape library and remove/modify the 
partition.
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4 From the Scalar LTFS Appliance GUI, bring the active partition 
online, leaving the removed/modified partition offline and 
unattached.

After a few minutes, the unattached partition will disappear from 
the Scalar LTFS Appliance GUI and the active partition will have the 
correct media and drives available.

Reservation Conflicts There are two situations where a user may see a Reservation Conflict 
message.

• The Scalar LTFS Appliance shuts down with media still in drives

• A user attempts an export from the library without taking a 
partition offline from the Scalar LTFS GUI

To remove a reservation conflict:

1 From the Scalar LTFS Appliance GUI, select the Configuration > 
Partitions menu.

2 From the Partitions screen, uncheck the Online box for the 
partition that has the reservation conflict.

3 Click Apply.

4 Wait the time set in the Idle Volume Timeout drop-down menu 
and check the Online box for the partition that was just taken 
offline.

5 Click Apply. The user should see that the media is now unmounted.

Note: Users can also select the Operations > Media menu to 
check that the partition drives are online and no longer 
contain media.

6 The reservation should be removed.

Note: If the reservation is not removed, take the partition offline 
again and from the Scalar LTFS Appliance GUI, unload or 
move media from the drive.
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Caution: In the event of a system crash, it is possible for reservations 
to be left on a drive. Taking a partition offline and then 
back online will not allow users to remove media. To 
remove media from a drive with queued reservations, users 
must power cycle the Scalar LTFS Appliance.

Volume 
Synchronization Issues

In some cases, volumes get out of sync with the disk index and media 
index. If this happens, the media will be sequestered and the user will 
receive ticket stating “volume reformatted or different volume.”

Scalar LTFS monitors the contents of media that it represents in the file 
system namespace. If at any point it detects that a medium has changed 
outside of its control, it sequesters that medium. This can occur for 
several reasons, some examples include:

• An out-of-date save-restore image has been installed

• A vaulted medium has been modified

Under these (and other similar) circumstances the medium will be 
sequestered as “volume reformatted or different volume.”

Drive License Issues I’m having issues with drive licenses. What can I do?

Drive licenses are used whenever a tape is loaded into a drive by Scalar 
LTFS. Drive licenses are freed when the tape is subsequently unloaded. In 
certain error conditions, drives licenses may not be released, affecting 
the system drive usage by reducing or even eliminating the number of 
usable drives.

If an LTFS volume appears to be stuck in a drive, perform the following 
steps, stopping when the GUI indicates that the volume has successfully 
been unloaded. Wait 10 minutes between each step, in order to allow 
the system time to unload the volume.

1 Check that the host interface (FC or SAS) cables are connected to 
the affected drive as well as the control path drive in the affected 
partition.

2 If necessary, bring the partition and drive online.
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3 If the volume is loaded in a drive, but sequestered, try attaching the 
volume via the GUI.

4 Try bringing the partition and drive offline and then back online 
again.

5 If none of the above steps work, restart the Scalar LTFS appliance.

a Stop all IO to the system. This may need to be scheduled in 
advance to let all users know that the system will not be 
available while the drive/library maintenance is performed.

b Wait for all tapes to dismount from the drives.

c Using the SLTFS GUI, restart the appliance.

d Select Operations > Logoff and click the Restart System 
button.

e When the system has restarted, all drive licenses should now be 
available.

GUI Performance Why is my GUI running so slow?

Slow GUI performance may be caused by a disconnect of a previously 
used DNS address if a system restart has not been performed recently. 
To resolve this issue, either restart Scalar LTFS or attach it to the network 
to allow a DNS resolution.

Firmware Updates Why am I getting an IO error during a firmware update?

It is possible a corrupted or invalid firmware file is detected which 
causes the firmware update to fail. In this case, a user should download 
the firmware file to another location or server and reattempt the 
firmware update.

Drive/Library 
Maintenance

I need to perform library/drive maintenance. What can I do?

To perform drive/library maintenance and get the drive(s) working 
properly, complete the following steps:
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1 Stop all IO to the system. This may need to be scheduled in advance 
to let all users know that the system will not be available while the 
drive/library maintenance is performed.

2 Wait for all tapes to unload or dismount from the drives.

3 Take the affected partition offline.

4 Perform the required drive or partition maintenance.

5 Put the affected partition back online.

Interacting with a 
Remote File Server on 
MacOS

How do I prevent .DS_Store file creation over a network connection?

Note: The following steps do not prevent the Finder from creating 
.DS_Store files on the local volume, and these steps do not 
prevent previously existing .DS_Store files from being copied to 
the remote file server.

Note: Disabling the creation of .DS_Store files on remote file servers 
can cause unexpected behavior in the Finder.

The Mac OS Finder file browser will at times generate a .DS_Store file in 
folders to store Finder specific information. On initial access of these 
folders, the Finder will automatically attempt to read this file causing an 
unexpected tape mount. To disable .DS_Store creation, complete the 
following steps:

1 Open a terminal session by navigating to Applications > Utilities.

2 Click the Terminal icon.

3 Execute the following command: 

defaults write com.apple.desktopservices 
DSDontWriteNetworkStores true

4 You can either restart the computer or log out and back in to the 
same user account.

If you want to prevent .DS_Store file creation for other users on the 
same computer, log in to each user account and perform the steps 
above-or distribute a copy of the newly modified 
com.apple.desktopservices.plist file to the ~/Library/
Preferences folder of other user accounts.
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Library Tape Drive Issues

Use the following tools to run diagnostic test on a tape drive:

• IBM tape drive - Run the ITDT diagnostic tool. Instructions for 
downloading and using the tool are included on the CS Web site. 

• HP tape drive - Run the LTT un the ITDT diagnostic tool. Instructions 
for downloading and using the tool are included on the CS Web 
site. 

Sequestered Tape Fault In the event of a sequestered tape fault, use the following steps to 
determine if it is a drive or media issue:

1 Check for a diagnostic ticket DT052 - Sequestered Cartridge. There 
should also be a corresponding diagnostic ticket DT058 - Drive 
Offline. 

Note: A DT052 diagnostic ticket should not happen without a 
DT058 but a DT058 can happen without a DT052.

2 Leave the drive identified in the DT058 diagnostic ticket offline.

3 Using a different drive, attempt to reattach the sequestered 
cartridge.

4 If the tape successfully attaches, then it is likely a drive issue.

5 To verify if it is a drive issue, put the drive back online and take all 
the other drives offline.

6 Using a known good tape, attempt to access data via the file system 
and see if it is successful.

7 If the data cannot be retrieved from the known good tape, it is likely 
a drive issue.

Note: If the tape cannot be attached, it is likely a problem with 
the media. In this case, there is the potential for data loss 
on the tape and users should contact their customer service 
representative.
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Sequestered Volume 
Corruption

What do I do if my media will not attach?

Note: Before running the SLTFSCK utility, try a media to media copy.

In the event of a media attach failure, run the SLTFSCK utility and 
complete the following steps:

Note: Ensure media is not set to write-protected and assigned to 
partition.

1 If the issue is not resolved, from service port, login as:

• User: sltfs

• Password: 5ltf5c73

2 Enter number: 1 (mount media - must have empty drive).

3 Enter volser (000011). Drive information is scanned and displayed.

4 Enter number: 0 (recover volume).

Note: Use option 0 to recover as much data as possible on the 
tape.

5 Type: volser (000011) and press Enter. The volume scan begins.

The following information displays:

• Scan drive=256 (HP /Ultrium 5-SCSI /Serial Number) 000011

6 The scan completes and returns the following information:

• 1st run
Generation Date Time Zone SelfPtr > BackPTR

201: 2012-07-16 19:41:57.840684348 MDT (1, 74288)->(1, 73806)

(2012-07-17 01:41:57.840684348 UTC)

202: 2012-07-16 19:45:23.654327825 MDT (1, 74292)->(1, 74288)

(2012-07-17 01:45:23.654327825 UTC)

203: 2012-07-23 08:37:13.243013376 MDT (0, 5)->(1, 74296)

(2012-07-23 14:37:13.243013376 UTC)

 203: 2012-07-23 08:37:13.243013376 MDT (1, 74296)->(1, 74292)

(2012-07-23 14:37:13.243013376 UTC)

First run gets available indexes, second run performs recovery
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7 Once finished, the screen returns with the Main Menu > Complete.

8 Enter number: 2 (dismount volume).

9 Enter volser (000011): Scan drive information displayed.

10 Enter number: 99 (Quit).

11 Attach volume in the partition.
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Appendix A
User Roles

Based on your login credentials as a user or administrator, you can 
perform the following functions by role:

Table 8  Administrator Role 
Matrix

Administrator
Permission Level

User
Permission Level Function by Window

Add, change View Configuration > System

Add, change View Configuration > Notifications

Add View Configuration > Licenses

Add, change View Configuration > Date and Time

Add, change View Configuration > Networks

Add, change, delete View, change password Configuration > Users

Add, change View Configuration > Partitions

Change View, attach, sequester Operations > Media

Execute Execute Operations > Logoff

Execute View Operations > Media Copy
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Table 9  Service Role Matrix Service roles have some of the permissions listed in Table 8 on page 133 
plus the permissions listed below.

Execute None Tools > Capture Snapshot

Execute None Tools > Save or Restore

Execute None Tools > Security

Execute None Tools > Update Firmware

Execute View Tools > Diagnostic Tickets

Send, save Send, save Reports > Component Information

Send, save None Reports > Configuration Record

Send, save Send, save Reports > Diagnostic Ticket

Send, save Send, save Reports > Media

View View Help > About Scalar LTFS

Execute None Help > Register Appliance

Administrator
Permission Level

User
Permission Level Function by Window

Service
Permission Level

Admin
Permission Level Function by Window

Execute None Service > Clear to Ship

Execute None Service > Reset Factory Defaults
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A Auto Slot   Allows the user to configure the SLTFS appliance to 
automatically attach newly found media in the library. If this is 
disabled the user has to manually attach new media.

D DNS   A hierarchal identification system that translate domain names 
into IP addresses.

Discovered Pool   Volumes imported into SLTFS via the Library. These 
volumes can be assigned to a volume group or they can be 
formatted into scratch media for expanding a volume group's 
capacity. The discovered pool is displayed on the GUI as the 
[discovered media] volume group.

F Fibre Channel   A high-speed data transfer technology. Using optical 
fibre to connect devices, Fibre Channel primarily transports SCSI 
traffic between computers and I/O.

File Collision   Situation where there are already existing filenames in a 
volume group and there is an attempt to either merge a 
volume(s) into the volume group or to attach a sequestered 
volume that is in the volume group that has the same 
pathname. 

File Spanning   Spanning of files across multiple media/volumes.
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L LTFS   An acronym for Linear Tape File System, a file system that 
provides access to files on the latest generations of LTO tape 
technology as if the files were on the user’s local disk.

P Partition   (A logical subset of an underlying physical library that may 
present a different personality, capacity, or both to the host. It is 
a representation of real physical elements, combined to create a 
grouping that is different from the physical library. Also a logical 
portion of the physical library that is viewed by the host as if it is 
a complete library. Partitions present the appearance of 
multiple, separate libraries for purposes of file management, 
access by multiple users, or dedication to one or more host 
applications.

R Diagnostic Ticket   A ticket that alerts the user of an issue with the 
appliance. Diagnostic tickets identify which appliance 
components are causing an issue. When possible, the diagnostic 
ticket provides instructions for resolving the issue.

S SAS   (Serial Attached SCSI)) A SCSI interface standard that provides 
for attaching HBAs and RAID controllers to both SAS and SATA 
disk and tape drives, as well as other SAS devices.

Scalar LTFS   Scalar LTFS (Linear Tape File System) is a Quantum-
proprietary software stack that implements a file system that 
complies with the Linear Tape File System (LTFS) Format 
Specification, using automated tape libraries to allow users to 
see and use files contained within multiple, independent LTFS 
volumes as a single collection, as if the files were on the user’s 
local disk.

Scratch Pool   Volumes formatted and then available to be auto-
attached by SLTFS for expanding a volume group's capacity. The 
scratch media pool is displayed on the GUI as the [scratch 
media] volume group. 

Setup Wizard   A tool for initially configuring the appliance. It appears 
the first time the user configures the appliance via the service 
port connection.
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Sequester   A media state that removes all metadata from the system, 
such that the tape, and it's data, will no longer be seen in the 
file system. At this point a user can either physically remove it 
from the system, reformat it or reattach it.

Software Stack   A collection of software that serves a single purpose.

U URB (User Request Broker)   A component that services UTI requests as 
well as internal ALTFSD requests. Requests are generally job 
requests.

V Vaulted Media   A media state indicating that volumes have been 
exported from the system but the system still retains their 
metadata.

Volume Group   A volume group is a collection of one or more media 
that is presented to end users and applications as a directory in 
the file system.
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