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About This Guide and Your Product
This manual contains reference information and instructions for setting up, installing, and upgrading the 
Scalar Distributed Library Controller (Scalar DLC) software. This guide is intended for customers, customer 
engineers, and administrators who use the Scalar DLC software.

Explanation of Symbols and Notes

The following symbols appear throughout this document to highlight important information.

Other Documents You Might Need

The following documents are also available for this product. These documents can be found on the product

CD or at www.adic.com/manuals:

• Scalar DLC Installation Guide

• Scalar DLC Release Notes (6-00335-xx)

• DAS Administration Guide (6-00345-xx)

• DAS/ACI Interfacing Guide (6-00346-xx)

• Scalar 10K SCSI Reference Guide

• Scalar 1000 SCSI Reference Guide

WARNING
INDICATES A POTENTIALLY HAZARDOUS SITUATION WHICH, IF NOT 
AVOIDED, COULD RESULT IN DEATH OR BODILY INJURY.

CAUTION
Indicates a situation that may cause possible damage to equipment, loss of 
data, or interference with other equipment.

Note Indicates important information that helps you make better use of your system.
Scalar DLC Installation Guide 1
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• SCSI Primary Commands 2 (SPC-2)

• SCSI Primary Commands 3 (SPC-3)

• ROBAR Interfacing Guide

• Scalar 10K Operator Guide

• Scalar 1000 Operator Guide

• RMU Reference Guide

Getting More Information or Help

More information about this product is available on the Customer Service Center website at 
www.adic.com/csc. The Customer Service Center contains a collection of information, including answers to 
frequently asked questions (FAQs). You can also access software, firmware, and drivers through this site.

For further assistance, or if training is desired, contact ADIC:

ADIC Technical assistance center (ATAC) in the USA: 800-827-3822

ADIC Technical assistance center (ATAC) in Europe and Japan: 00-800-9999-3822

For additional contact information: www.adic.com/contact

To open a Service Request: www.adic.com/techsup
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System Description
The Scalar DLC software runs as a service under Windows 2000 / 2003. It serves as a centralized library 
management tool that simplifies and automates the tracking and management of all system resources for 
optimal performance and maximum availability. The Scalar DLC software provides network and Systems 
Administrators with a Java-based interface that allows library monitoring from anywhere on the Web. 

It also allows administrators to select parameters that define which library events provide notifications to 
customers and ADIC Technical Assistance Center (ATAC) via email and Simple Network Management 
Protocol (SNMP) alerts.

The main working tool of the Scalar DLC software is the Management GUI. All the actions of management 
and configuration are executed via this tool. Refer to the Scalar DLC Reference Guide for the details.

Figure 1 illustrates the structure of a typical Scalar DLC system.

Figure 1 Scalar DLC Structure

Figure 2 on page 4 illustrated the data flow and the Scalar DLC components.

Note If a firewall is being used, outside access by Web browsers might be denied.
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Figure 2 Scalar DLC Components

As shown on Figure 2, the client (user/backup application) sends the request/command to the Scalar DLC 
host (server) via the client interface; several interfaces are used (SCSI/FC, DAS, and ROBAR).

Depending on the request, the Scalar DLC either should search the information in the database and send 
the response back to the client, or transfer the command to the library via the library interface.

After the library has executed the requested operation, the response is sent back to the Scalar DLC 
indicating that the operation was executed.

The Scalar DLC server updates the database according to the information received from the library and 
transfers the response (operation executed) back to the client.

The Management GUI serves as the configuration tool to create a working configuration for clients, and also 
as the monitoring tool for the Administrator when it is necessary to watch the system activity.

The details for using Management GUI and other tools of the Scalar DLC software are described in the 
Scalar DLC Reference Guide.

Platforms

The Scalar DLC software can be installed on the operating systems (platforms) listed in Table 1.

The OS update with the required hot fixes and/or service packs is performed on regular basis, see Securing 
the Scalar DLC on page 135.

Table 1 Scalar DLC platforms 

OS/Platform Service 
Pack Referred as

32-bit Windows Server 2003 Enterprise Edition SP1 Windows 2003 Server

32-bit Windows Server 2003 Standard Edition SP1 Windows 2003

Windows 2000 Advanced Server SP4 Windows 2000 Advanced 
Server

Windows 2000 Server SP4 Windows 2000

Windows 2000 Professional SP4 Windows 2000
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Solutions

According to the customer requirements, the Scalar DLC introduce a basic (standard) solution or a failover 
(redundant, cluster) solution. The latter can be provided in plain version and in self-domain version, also 
called the self-domain solution. See Standard Solution on page 5, Failover Solution on page 5, and Self-
Domain Solution on page 6.

Depending on the library used by the customer, the solution and system configuration should be selected, 
as shown in Table 2.

Standard Solution
The Scalar DLC standard (basic) solution keeps all Scalar DLC components (server, database) on a single 
host / PC that is connected to both the library and client(s). The client can work with the library when the 
Scalar DLC software is started and the library is online.

The Scalar DLC standard solution requires a single PC, the library, and the interface cables to provide the 
connection between PC (Scalar DLC host) and library. Additional cabling may be required to provide the 
client connections (SCSI/FC) and using SNC.

For the requirements and installation instructions see Setting Up the Standard Solution on page 7.

Failover Solution
The Scalar DLC Failover (redundant, cluster) solution is provided for the clients using the Microsoft Cluster 
service. This solution allows the user to have a shared disk with the Scalar DLC database and two hosts 
containing the installed components of Scalar DLC software; for the redundancy reasons, one host is online 
and the other is offline. If an error occurs and the online Scalar DLC host turns offline, the other host is 
immediately online, so the user may not even notice there has been a problem with the host, and the 
customer engineer can work under the problem host without stopping the work of Scalar DLC software.

The Scalar DLC failover solution requires two identical PCs, a RAID system, the library, and the interface 
cables to provide the connections between PCs (Scalar DLC hosts), RAID (shared database), and library. 
Additional cabling may be required to provide the client connections (SCSI/FC) and using SNC.

For the requirements and installation instructions see Setting Up the Failover Solution on page 13.

Table 2 Libraries, Solutions, and OS

Library Scalar DLC Solution OS/Platform

Scalar 1000 Failover / Self-domain Windows 2000 Advanced Server
Windows 2003 Server

Standard Windows 2000 (all platforms)
Windows 2003 (all platforms)

Scalar 10K Failover / Self-domain Windows 2000 Advanced Server
Windows 2003 Server

Standard Windows 2000 (all platforms)
Windows 2003 (all platforms)

Scalar 10K dual-aisle 
(DA)

Failover / Self-domain Windows 2000 Advanced Server
Windows 2003 Server

Standard (only as an exception) Windows 2000 (all platforms)
Windows 2003 (all platforms)
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Self-Domain Solution
Up from version 2.5, Scalar DLC offers also so-called self-domain solution. This configuration of the Scalar 
DLC acts the same way as plain Failover solution and has the same hardware requirements, however it is 
installed without an external domain controller, so its setup does not exactly duplicate the failover solution 
instructions.

In terms of the network security, the self-domain solution is the most reliable method that Scalar DLC 
currently can provide.

For the details see Setting Up the Self-Domain Solution on page 33.

Compatibility Matrix

The Scalar DLC compatibility with other hardware and third-party applications is described in Table 3.

Table 3 Scalar DLC Compatibility Matrix

Software/Hardware SW/FW Level

Scalar 10K (both single- and dual-aisle models) 310A

Scalar 1000 641A

SNC 5100 4.45.18

Scalar DLC 2.6

RMU 210

AMC 4.4

SNMS (StorNext Management System) 2.7

LTO-1 5AU1 (SCSI/FC)

LTO-2 5AT0 (SCSI/FC) 

LTO-3 64D0 (FC)

AIT-2 0200_CY10

AIT-3 0209_0001

DLT8000 V80

SDLT 220 V87

SDLT 320 V87

3590 D0IF_26E

3592 D310_825

TS1120 D3I1_6E1
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Setting Up the Scalar DLC
Depending on the configuration used, follow the setup instructions:

• Setting Up the Standard Solution on page 7.

• Setting Up the Failover Solution on page 13.

• Setting Up the Self-Domain Solution on page 33.

Review also Common Setup Notes on page 44. Some instructions are for Failover and Self-domain 
solutions only, the other are for all solutions.

Setting Up the Standard Solution

The Scalar DLC standard solution can be installed on any Windows 2000 or Windows 2003-based system.

• Check the system requirements. Depending on the tape device used with the Scalar DLC, Single-
aisle Requirements on page 7 is for the single-aisle library, and Dual-aisle Requirements on page 
8 is for the dual-aisle library.

• Follow the Setup Roadmap on page 9 to set up the Scalar DLC.

Single-aisle Requirements

Figure 3 Scalar DLC Basic Solution: Single-aisle

The minimum PC system hardware requirements are summarized in following list.

• A single PC:

• 1G MHZ or faster Intel Xeon or equivalent CPU 

• 512 MB RAM 

• Dual 18Gb SCSI Hard Drives

• Single On-Board NICS (build-in Ethernet)

• CD-RW
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• 3.5” inch Diskette Drive

• Redundant AC Power

• 15" or greater SVGA Display

• Standard keyboard & mouse

• NT/2000 compliant LVD/HVD SCSI initiator adapter, library connection

• 1 middle length (2-3 m) SCSI cable (68 pins) for the library connection.

• Recovery CD (Windows 2000 or 2003)

The following hardware (not shown on the scheme) is optional.

• SCSI/FC target adapter(s)

• Appropriate SCSI/FC cable(s)

• Fibre Channel switch

• SNC

Dual-aisle Requirements

Figure 4 Scalar DLC Basic Solution: Dual-aisle

The minimum PC system hardware requirements are summarized in following list.

• A single PC:

• 1G MHZ or faster Intel Xeon or equivalent CPU 

• 512 MB RAM 

• Dual 18Gb SCSI Hard Drives

• Single On-Board NICS (build-in Ethernet)

• CD-RW

• 3.5” inch Diskette Drive

CAUTION
Do not use anteries (brand) SCSI adapters that do not allow setting reset on 
startup via BIOS.

CAUTION
Adaptec 39160 is an LVD/SE adapter, so note Table 16 on page 71 when 
choosing SCSI adapter for the library.

Note Although it is not recommended to use DA libraries in a Scalar DLC standard solution, 
this configuration is possible.
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• Redundant AC Power

• 15" or greater SVGA Display

• Standard keyboard & mouse

• NT/2000 compliant LVD/HVD SCSI initiator adapter, library connection

• 1 middle length (2-3 m) SCSI cable (68 pins) for the library connection.

• 1 middle length (4-5 m) SCSI cable (68 pins) for the aisle connection. 
The total length of two SCSI cables required for the dual-aisle library connection (see Figure 4 on 
page 8) must not exceed 12 m for LVD adapters and 25 m for HVD adapters.

• 2 SCSI Y-block connectors (Y-cable) to terminate the SCSI Bus on library.

• 1 SCSI Terminator, LVD/HVD for the library connection.

• Recovery CD (Windows 2000 or 2003)

The following hardware (not shown on the scheme) is optional.

• SCSI/FC target adapter(s)

• Appropriate SCSI/FC cable(s)

• Fibre Channel switch

• SNC

Setup Roadmap
Complete the following steps to set up the basic solution.

1 Collecting Setup Data on page 9.

2 Setting Up the Host on page 10.

3 Installing the Scalar DLC Software on page 12.

4 Configuring the Logical Library on page 12.

For the optional additional activity, see Setting Up the Library on page 123, Building Client Connections on 
page 131, and Host/Library Communication using Fibre Channel and SNC on page 127. See also Upgrade, 
Remove, Repair on page 81.

Collecting Setup Data
Collect the following information before starting setup.

• Computer

• computer name (max 14 symbols)

• public IP address

CAUTION
Do not use anteries (brand) SCSI adapters that do not allow setting reset on 
startup via BIOS.

CAUTION
Adaptec 39160 is an LVD/SE adapter, so note Table 16 on page 71 when 
choosing SCSI adapter for the library.
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• public Subnet mask

• public default Gateway

• public preferred DNS

• public Alternate DNS

• public Primary WINS

• public Secondary WINS

• private IP address

• private subnet mask

• Local administrator login name and password

• Scalar DLC serial number

• Domain

• domain name

• domain admin login name and password

Setting Up the Host

Step 1 Set up the host hardware (network adapters, SCSI and FC adapters if required). Note Table 18 
on page 72.

Step 2 Connect the PC to a local network. Install Windows 2000 / 2003. Resolve the network name 
and TCP/IP. Join the PC to the domain, if required (domain admin password is required).

Step 3 Install all required software services, for example, antivirus packages and firewall. Install all 
required device drivers (for example, initiator SCSI and RAID). Install the latest Microsoft 
Service Pack (SP4 for Win2000 and SP1 for Windows 2003 is required).

Step 4 When the operation system is installed successfully, reboot and ensure all services work 
correctly.

Table 4 Standard Solution: Installation Time

Installation procedure Time

Provide cabling and setup for PC system 10 min

Set IP address and computer name 10 min

Install Scalar DLC on PC 50 min

Note Enter BIOS. Go to Chipset section. Hyper threading parameter should be disabled.

Note Unplug the target card SCSI cable if the server has trouble booting (may be a termination 
problem).
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Configuring SCSI for Library

Step 1 Configure the SCSI ID's for the LVD/HVD adapter connected to the library.

• Set termination mode to automatic

• Set Reset SCSI Bus parameter to disabled

• Set the SCSI ID of this board to 5

Step 2 Log on. Update drivers (Adaptec, QLA, etc.) as described in Updating Drivers on page 110.

Step 3 Reboot host PC.

Setting Up IP Address, Host Name, and Joining Domain

Step 1 Log in host PC as administrator.

Step 2 Set up Public network.

• <pause> Right click “My Network Places” and select “Properties”.

• Right click “Local Area Connection” and rename in to ‘Public’. Select “Properties”.

• Select “Show Icon in the Task Bar when Connected”.

• Select “Internet Protocol (TCP/IP)” and select “Properties”.

• Select “Use the Following IP Address”

• Set IP Address (208.230.5.100 in lab)

• Set Subnet Mask to 255.255.255.0

• Set Preferred DNS Server to 208.230.5.4 (in lab)

• Press “OK” and “OK”.

Step 3 Join computer to the domain

• Right click “My Computer” and select “Properties”.

• (on Windows 2000) Open “Network Identification” and select “Properties”.

• (on Windows 2003) Open Computer Name > Change > More. Ensure that the checkbox 
‘Change primary DNS suffix when domain membership changes’ is enabled (see Figure 5 
on page 12). Press OK.

Note Adapter ID must not overlap with the single aisle LIBRARY SCSI ID.

Adapter ID must not overlap with the either of the LIBRARY SCSI IDs for the dual-aisle 
libraries.

Any number could be used as SCSI IDs as long as it follows the rules above.

Note Also enter any additional customer networking information (additional DNS, WINS etc.).
Installation Guide 11



Figure 5 Windows 2003: DNS suffix enabled

• Set “Computer name” (SDLC)

• Select “Domain” and enter <domain name without postfix> and OK (“domain” for lab)

• Enter domain admin name and password and OK (“adicuser” and “pa$$w0rd”)

• Wait for Welcome to domain.

• Press “OK” and “OK” to reboot and “OK” and “Yes”.

Step 4 ‘Yes’ to reboot now. Wait until reboot.

Installing the Scalar DLC Software

Step 1 Log in as administrator or as a domain user with the local administration rights.

Step 2 Set up the library media changer unless it has been already done. See Setting Up the Library 
on page 123.

Step 3 Install the Scalar DLC software with all required components (see Installing the Scalar DLC on 
page 45).

Configuring the Logical Library

Step 1 Log in as administrator or as a domain user with the local administration rights and start the 
Scalar DLC software if it is not started automatically.

Step 2 Double click the Scalar DLC Manager icon to start the Scalar DLC Management GUI from a 
local computer. From a remote computer, use 
http://ScalarDLC-machine-name in current browser.

Step 3 The first start of the Scalar DLC Management GUI launches the configuration engine. Select 
either the Automatic or Manual configuration option to configure the logical library 
automatically, or Advanced configuration option in case of more then one logical library should 
be created. Refer to the Configuration chapter of the Scalar DLC Reference Guide for the 
instructions.

CAUTION
Computer name must not be longer than 14 symbols.
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Setting Up the Failover Solution

The Scalar DLC Failover (Redundant, Cluster) solution can be installed only on a Windows 2000 Advanced 
Server or Windows 2003 Server because it uses the Microsoft Cluster Service that is not available under 
Windows 2000 Professional, Windows 2000 Server, and Windows 2003.

• Check the system requirements. Depending on the tape device used with the Scalar DLC, Single-
aisle Requirements on page 13 is for the single-aisle library, and Dual-aisle Requirements on page 
14 is for the dual-aisle library.

• Follow the Setup Roadmap on page 15 to set up the Scalar DLC.

Single-aisle Requirements

Figure 6 Scalar DLC Failover Solution: Single-aisle

The minimum PC system hardware requirements are summarized in following list.

• Two PCs with identical hardware and software:

• 1G MHZ or faster Intel Xeon or equivalent CPU 

• 512 MB RAM 

• Dual 18Gb SCSI Hard Drives

• PERC3-DI, 128MB Battery Backed Cache, two Internal Channel - Embedded RAID Controller 
(1, 2 Drives connected to on-board RAID)

• Dual On-Board NICS (build-in Ethernet)

• CD-RW

• 3.5” inch Diskette Drive

• Redundant AC Power

• 15" or greater SVGA Display

• Standard keyboard & mouse

• NT/2000 compliant LVD SCSI initiator adapter, RAID connection

• NT/2000 compliant LVD/HVD SCSI initiator adapter, library connection

CAUTION
Do not use anteries (brand) SCSI adapters that do not allow setting reset on 
startup via BIOS.
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• 1 ArrayMasStor P-Series ADTX RAID System.

• 1 Network cross cable (twisted-pair) (~1 m), for the internal cluster network.

• 2 short (~1 m) SCSI cables (68 pins), for the RAID connections.

• 2 middle length (2-3 m) SCSI cable (68 pins), for the library connections.

• 2 Y-Block connectors to terminate the SCSI Bus on library.

• 2 LVD SCSI Terminators for the RAID connections.

• 2 LVD/HVD SCSI Terminators for the library connections.

• Recovery CD (Windows 2000 Advanced Server or 2003 Server)

The following hardware (not shown on the scheme) is optional.

• SCSI/FC target adapter(s)

• Appropriate SCSI/FC cable(s)

• Fibre Channel switch

• SNC

Dual-aisle Requirements

Figure 7 Scalar DLC Failover Solution: Dual-aisle

The minimum PC system hardware requirements are summarized in following list.

• Two PCs with identical hardware and software:

• 1G MHZ or faster Intel Xeon or equivalent CPU 

• 512 MB RAM 

• Dual 18Gb SCSI Hard Drives

• PERC3-DI, 128MB Battery Backed Cache, two Internal Channel - Embedded RAID Controller 
(1, 2 Drives connected to on-board RAID)

CAUTION
Adaptec 39160 is an LVD/SE adapter, so note Table 16 on page 71 when 
choosing SCSI adapter for the library.

CAUTION
The hardware configuration of both cluster nodes must be identical, and they 
must remain identical. For example, all cards/adapters must be identical and 
need to be placed in identical slots.
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• Dual On-Board NICS (build-in Ethernet)

• CD-RW

• 3.5” inch Diskette Drive

• Redundant AC Power

• 15" or greater SVGA Display

• Standard keyboard & mouse

• NT/2000 compliant LVD SCSI initiator adapter, RAID connection

• NT/2000 compliant LVD/HVD SCSI initiator adapter, library connection

• 1 ArrayMasStor P Series ADTX RAID System.

• 1 Network cross cable (twisted-pair) (~1 m), for the internal cluster network.

• 2 short (~1 m) SCSI cables (68 pins), for the RAID connections.

• 2 middle length (2-3 m) SCSI cable (68 pins), for the library connections.

• 2 middle length (4-5 m) SCSI cable (68 pins), for the aisle connections. 
The total length of two SCSI cables required for the dual-aisle library connection (see Figure 7 on 
page 14) must not exceed 12 m for LVD adapters and 25 m for HVD adapters.

• 4 Y-Block connectors to terminate the SCSI Bus on library.

• 2 LVD SCSI Terminators for the RAID connections.

• 2 LVD/HVD SCSI Terminators for the library connections.

• Recovery CD (Windows 2000 Advanced Server or 2003 Server)

The following hardware (not shown on the scheme) is optional.

• SCSI/FC target adapter(s)

• Appropriate SCSI/FC cable(s)

• Fibre Channel switch

• SNC

Setup Roadmap
Complete the following steps to set up the Failover solution.

1 Collecting Setup Data on page 16.

CAUTION
Do not use anteries (brand) SCSI adapters that do not allow setting reset on 
startup via BIOS.

CAUTION
Adaptec 39160 is an LVD/SE adapter, so note Table 16 on page 71 when 
choosing SCSI adapter for the library.

CAUTION
The hardware configuration of both cluster nodes must be identical, and they 
must remain identical. For example, all cards/adapters must be identical and 
need to be placed in identical slots.
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2 Installing the Nodes on page 17.

3 Installing ADTX RAID on page 18.

4 Configuring SCSI for RAID and Library on page 20.

5 Setting Up IP Address, Node Name, and Joining Domain on page 22.

6 Setting Up the RAID on page 24.

7 Configuring Cluster Service on page 26

8 Installing Scalar DLC Software on page 28.

9 Configuring the Logical Library on page 31.

For the optional additional activity, see Setting Up the Library on page 123, Building Client Connections on 
page 131, Installing SCSI/FC Target Adapters on a Live Machine on page 134, and Host/Library 
Communication using Fibre Channel and SNC on page 127. See also Upgrade, Remove, Repair on page 
81.

Collecting Setup Data
Collect the following information before starting setup.

• Nodes

• Node1 computer name (14 symbols max)

• Node1 public IP address

• Node2 computer name (14 symbols max)

• Node2 public IP address

• public Subnet mask

• public default Gateway

• public preferred DNS

• public alternate DNS (optional)

• public primary WINS (optional)

• public secondary WINS (optional)

• Node1 private IP address

• Node2 private IP address

• private subnet mask

• Local administrator login name and password (same on both nodes)

• Scalar DLC serial number (same on both nodes

• Cluster

• name (14 symbols max)

• IP address

• Subnet mask = public subnet mask

• Domain

• name

• domain admin name and password

• directory services restore mode password
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Active Directory Account Information
Contact the local network administrator and ensure that the following settings are performed.

• User account created with domain admin rights and the following options:

• User must not change password under next logon.

• User cannot change password.

• Password never expires.

• All other options are disabled.

• Logon hours for this user are set to 24/7.

• Log on rights are set either to all computers or to all Scalar DLC nodes.

Installing the Nodes

Step 1 Turn off external RAID.

Step 2 Insert the RAID SCSI HBA into the PCI slot of Node1 according to Table 18 on page 72. 
Connect it and RAID SCSI channel (S11) with the short SCSI cable. Terminate the second 
RAID SCSI channel (S21) with the SCSI terminator (see Figure 8 on page 18).

Step 3 Insert the RAID SCSI HBA into the PCI slot of Node2 according to Table 18 on page 72. 
Connect it and RAID SCSI channel (S12) with the short SCSI cable. Terminate the second 
RAID SCSI channel (S22) with the SCSI terminator (see Figure 8 on page 18).

Table 5 Failover Solution: Installation Time 

Installation procedure Time

Provide cabling and setup for dual PC failover system 30 min

SCSI configuration for RAID and library 20 min

Set IP addresses and computer names 30 min

Configure primary and secondary domain controllers 45 min

Setup RAID 10 min

Configure cluster service 20 min

Install Scalar DLC on both PC 120 min
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Figure 8 RAID SCSI cabling

Step 4 Connect the monitor, keyboard, mouse, and KVM.

Step 5 Boot Node1. Log on (administrator / password).

Step 6 <pause> select “I will configure the server later” and press Next. Unselect “Show This Screen 
on Startup” and close window.

Step 7 Shutdown Node1.

Step 8 Repeat steps 4 to 7 for Node2.

Step 9 Connect ethernet cables LAN 1 (public network) and LAN 2 (private network).

Installing ADTX RAID

Step 1 Power on RAID.

Step 2 Set SCSI ID.

• The default setting is SCSI ID 0 for both channels. In order to verify the SCSI ID for both 
channels use the Operator Panel on the RAID. 
RAID SUBSYSTEM

• MAIN MENU

• [MAIN MENU]

• SYSTEM INFO

• [MAIN MENU]

• VIEW CONFIG

Note Enter BIOS. Go to Chipset section. Hyper threading parameter should be disabled.
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• [VIEW CONFIG]

• SCSI

• [SCSI]

• CHANNEL 1
• SCSI ID

• 0 
The same steps for channel 2.

• In order to change the SCSI ID for both channels use the following steps. 
RAID SUBSYSTEM

• MAIN MENU

• [MAIN MENU]

• SYSTEM INFO

• [MAIN MENU]

• CHANGE CONFIG

• ENTER PASSWORD 1234

• [CHANGE CONFIG]

• SCSI

• [SCSI]

• CHANNEL 1
• SCSI ID

• SET 0 
The same steps for channel 2.

Step 3 Change the RAID 'WRITE CACHE' setting.

• In order to change the RAID 'WRITE CACHE' setting via Operator Panel use the following 
steps. 
RAID SUBSYSTEM

• MAIN MENU

• [MAIN MENU]

• SYSTEM INFO

• [MAIN MENU]

• CHANGE CONFIG

• ENTER PASSWORD 1234

• [CHANGE CONFIG]

• OPTION SETTING

• [OPTION SETTING]

• CACHE SETTING

• [CACHE SETTING]

• WRITE CACHE

• [WRITE CACHE]

• SET 'DISABLE'
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Step 4 Reset RAID by turning it off.

Configuring SCSI for RAID and Library

Step 1 Plug the SCSI cable directly in to the RAID vhdci connector.

Step 2 Power on RAID, then power on Node1.

Step 3 <Ctrl>+A to enter Bios for Adaptec SCSI card at Bios 3.10.0 (see Figure 9).

Figure 9 Adaptec SCSI Bios

• Select B for RAID configuration.

• Select SCSI disk utilities to scan for RAID device.

• Press “Esc”.

• Select “Configure / view SCSI settings”.

• Set SCSI controller ID (14 for Node1 and 15 for Node2).

• Set SCSI termination to Automatic.

• Go to Advanced configuration.

• Set “Reset SCSI bus at IC Initialization” to Disabled.

• Set “SCSI controller Int 13 Support“ to Disabled: NOT scan.

• Press “Esc”.

• Go to “SCSI device configuration” (see Figure 10 on page 21).
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Figure 10 Adaptec SCSI Bios: SCSI Device Configuration

• Set “Sync Transfer Rate” to 40

• Set “Start unit command” to No for #0.

• Set “Include in Bios scan” to Yes for Node1 and No for Node2 for #0.

• Press “Esc”, and “Esc”, and “Save changes”.

• Press “Esc”.

• Select A for library configuration

• Select “Configure / view SCSI settings”

• Set termination to Automatic

• Go to Advanced configuration

• Set “Reset SCSI bus at IC Initialization” to Disabled
• Press “Esc”, and “Esc”, and “Save changes”.

• Press “Esc”, and “Esc”, and exit utility.

Step 4 Configure the SCSI ID's for the LVD/HVD adapters (connected to the library) on the cluster 
nodes.

• Enter the LVD/HVD SCSI BIOS Setup on Node1 for the adapter connected to the library:

• Set termination mode to automatic

Note Rate is 160 for L and P series RAIDs
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• Set Reset SCSI Bus parameter to disabled

• Set the SCSI ID of this board to 5

• Enter the LVD/HVD SCSI BIOS Setup on Node2 for the adapter connected to the library.

• Set termination mode to automatic

• Set Reset SCSI Bus parameter to disabled

• Set the SCSI ID of this board to 6

Step 5 Log on. Update drivers (Adaptec, QLA, etc.) as described in Updating Drivers on page 110.

Step 6 Shutdown Node1.

Step 7 Repeat steps 2 - 5 using Node2 instead of Node1.

Setting Up IP Address, Node Name, and Joining Domain

Step 1 Power on Node1 and log in.

Step 2 Set up Public network.

• <pause> Right click “My Network Places” and select “Properties”.

• Right click “Local Area Connection” and rename in to ‘Public’. Select “Properties”.

• Select “Show Icon in the Task Bar when Connected”.

• Select “Internet Protocol (TCP/IP)” and select “Properties”.

• Select “Use the Following IP Address”

• Set IP Address (208.230.5.100 for Node1 and 208.230.5.200 for Node2 in lab)

• Set Subnet Mask to 255.255.255.0

• Set Preferred DNS Server to 208.230.5.4 (in lab)

• Set Public default Gateway to 208.230.5.4 (in lab)

• Press “OK” and “OK”.

Note Both adapters must have different SCSI IDs.

Adapter IDs must not overlap with the single aisle LIBRARY SCSI ID.

Adapter IDs must not overlap with the either of the LIBRARY SCSI IDs for the dual-aisle 
libraries.

Any number could be used as SCSI IDs as long as it follows the rules above.

Note “HDD changed” message may appear. F1 to enter setup and esc and ok.

During logging in ignore duplicate name message if it appears.

Note Also enter any additional customer networking information (additional DNS, WINS etc.).
22 Setting Up the Scalar DLC



Step 3 (This step is for Windows 2000 system only. On Windows 2003 follow the Step 4) 
Right click “Public” and “Disable” then right click and “Enable”. A new item “Local Area 
Connection 2” will appear.

Step 4 Set up Private network

• Right click “Local Area Connection 2” and rename it to ‘Private’. Select “Properties”

• Select “Show Icon in the Task Bar when Connected”

• Select “Internet Protocol (TCP/IP)” and select “Properties”

• Select “Use the Following IP Address”

• Set IP Address to (10.10.10.1 and 10.10.10.2 in lab) (use here a completely different IP 
than for “Local Area Connection”).

• Set Subnet Mask to 255.0.0.0.

• Press “OK” and “OK”.

Step 5 (This step is for Windows 2000 system only. On Windows 2003 follow the Step 6) 
Right click “Local Area Connection 2” and “Disable” then right click and “Enable”.

Step 6 Join node to the domain

• Right click “My Computer” and select “Properties”.

• (on Windows 2000) Open “Network Identification” and select “Properties”.

• (on Windows 2003) Open Computer Name > Change > More. Ensure that the checkbox 
‘Change primary DNS suffix when domain membership changes’ is enabled (see Figure 
11). Press OK.

Figure 11 Windows 2003: DNS suffix enabled

• Set “Computer name” (sdlc1 for Node1 and sdlc2 for Node2)

• Select “Domain” and enter <domain name without postfix> and OK (“domain” for the computers 
in lab)

• Enter domain user name and password and OK (“adicuser” and “pa$$w0rd”)

• Wait for Welcome to domain.

• Press “OK” and “OK” to reboot and “OK” and “Yes”.

CAUTION
Both Node1 and Node2 names must not be longer than 14 symbols.
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Step 7 ‘Yes’ to reboot now. Wait until reboot.

Step 8 Repeat steps 1 to 6 for Node2. ‘No’ to reboot now.

Step 9 Shutdown both nodes.

Setting Up the RAID
Same on both Windows 2000 and Windows 2003 unless the other specified.

Step 1 Power up Node1 and log in as Administrator for SDLC1 (this computer)

Step 2 Prepare to Format RAID disk

• Right click “My Computer” and select “Manage”.

• Select Device Manager and open Disk Drives. Scan for new devices (see Figure 12).

Figure 12 Device Manager: Disk Drives

• Verify that the ADTX RAID is present.

CAUTION
Using Start > Run do the following:
From Node2 run: ping <Node1 public IP address>
From Node2 run: ping <Node1 private IP address>
From Node1 run: ping <Node2 public IP address>
From Node1 run: ping <Node2 private IP address>
From Node1 or Node2 run: ping <Domain name>
If any of these commands returns “Request timed out“ response, that means 
the network settings are configured incorrectly, for example, the network 
connection that has been configured as ‘public’, is in fact internal cluster 
(private) network connection.
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• Select “Disk Management”. Write Signature Wizard should start. Press “Next”.

• Select “Disk 1” to write a Signature and press “Next”.

• Unselect “Disk 1” to Upgrade (Convert on Windows 2003), press “Next” and then “Finish”.

Step 3 Format RAID

• Right click unallocated space and select “Create Partition”. Create Partition Wizard starts. Click 
Next.

• Select “Primary Partition” and press “Next”.

• Set maximum value in “Amount of Disk Space to Use” and press “Next”.

• Select “Assign a Drive Letter” and select “R:” and press “Next”.

• Select “Format this Partition with the Following Settings”

• Set “File System” to “NTFS”

• Set “Allocation Unit Size” to “Default”

• Set “Volume Label” to “RAID”

• Select “Perform A Quick Format” (see Figure 13)

Figure 13 Format RAID Partition

• Press “Next” and “Finish” and let format complete.

• Shutdown Node1, turn RAID off.

Step 4 Power up Node2 and log in as Administrator for SDLC2 (this computer). Turn RAID on and wait 
for it to come ready.

Step 5 Join RAID disk

• Right click “My Computer” and select “Manage”.

• Select Device Manager and open Disk Drives. Scan for new devices.

• Verify that the ADTX RAID is present.

• Select “Disk Management”. Right click “RAID”. Select “Change Drive Letter and Path”.
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• Select “Edit” and “Assign Drive Letter” to “R”. Press OK. Press “Yes” to confirm.

• Shutdown Node2.

Configuring Cluster Service
Under WIndows 2000 and Windows 2003 the cluster is installed differently.

Windows 2000

Step 1 Power up Node1 and log in as Administrator to SDLC1 (this computer)

Step 2 Configure Cluster Service on Node1.

• Select Start > Settings > Control panel > Add/Remove Programs > Add/Remove Windows 
Components >> Cluster Service. Press Next.

• Insert Windows 2000 Advanced Server SP4 CD and press OK. Cluster Service Configuration 
Wizard will start. Press “Next”.

• Click “I Understand” and “Next”.

• Select “The First Node in the Cluster” and “Next”.

• Set cluster name to SDLC-CLUSTER and “Next”.

• Set User Name to “adicuser” and Password to “pa$$w0rd”. Set Domain to <domain> and 
“Next”.

• Click “Yes” to adding account to the Administrators Group.

• Ensure that “R: Raid” is in managed disks and “Next”.

• Select “R: Raid” and “Next” and “Next”.

• Set up Cluster Network,

• For Network Name “Public” select “Enable this Network for Cluster Use”.

• Select “All Communications (mixed network)” and “Next”.

• For Network Name “Private” select “Enable this network for cluster use”.

• Select “Internal Cluster Communications Only (Private Network)” and “Next”.

• Ensure that “Private” is at the top of Networks list and “Next”

• Set “Cluster IP address” to <ip address> (208.230.5.3 in lab)
• Set “Subnet Mask” to 255.255.255.0
• Set “Network” to “Public” and “Next”.

• “Finish” and “OK” to Cluster Service Started Successfully.

• Finish and eject CD and close all windows.

Step 3 Power up Node2 and log in as Administrator for SDLC2 (this computer)

Step 4 Configure Cluster Service on Node2.

CAUTION
The cluster name must not be longer than 14 symbols.
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• Select Start > Settings > Control panel > Add/Remove Programs > Add/Remove Windows 
Components >> Cluster Service. Press Next.

• Insert Windows 2000 Advanced Server SP4 CD and press OK.

• Cluster Service Configuration Wizard will start and Next

• Click “I Understand” and “Next”.

• Select “Second or Next Node in the Cluster” and “Next”.

• Set cluster name as SDLC-CLUSTER

• Select “Connect to Cluster As”.

• Set User Name to “adicuser” and Password to “pa$$w0rd”.

• Set Domain to <domain> and “Next”.

• Set password as “pa$$w0rd” and “Next”.

• “Yes” to Specified Account not a Member 

• “Finish” and “OK” and “Finish”.

Step 5 Remove CD and close all windows.

Step 6 Verify Cluster service.

• On Node2 select Start > Settings > Control Panel > Administrative Tools > Cluster 
Administrator.

• Select Groups > Cluster Group

• Select File > Move Group to verify the cluster is working properly

• Move group again and return ownership to Node1

Windows 2003

Step 1 Power on Node1. Log on as Administrator.

Step 2 Create Cluster on Node1.

• Start > Administrative Tools > Cluster Administrator

• Choose 'Create new cluster' and OK. Next. Enter cluster name (SDLCCLUSTER2003) and 
Next.

• Review Node1 name and Next. The wizard will analyze an existing configuration.

• Next. Enter cluster IP (static, unique) and Next.

• Enter domain user account & password. Next.

• Review cluster summary and Next. Wizard creates a cluster.

• Next and Finish.

Step 3 Join Node2 to Cluster

CAUTION
The cluster name must not be longer than 14 symbols.
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• Power on Node2 and wait till it comes up. Wait circa 5 min until the virtual cluster name will 
be available from Node2. Switch to Node2.

• Start > Administrative Tools > Cluster Administrator. Choose 'Open Connection to cluster' 
and enter the cluster name (SDLCCLUSTER2003).

• OK. Then Fine > New > Node. Add new Node wizard starts.

• Next. Add, then Next. The wizard will analyze an existing configuration.

• Enter domain user account & password. Next.

• Review cluster summary and Next. Wizard adds node to a cluster.

• Next and Finish. The cluster is ready.

Step 4 Ensure the cluster works.

• Select Start > Administrative Tools > Cluster Administrator

• Select Groups > Cluster Group

• Select File > Move Group to verify the cluster is working properly

• Move group again and return ownership to Node1.

Installing Scalar DLC Software
Same on both Windows 2000 and Windows 2003 unless the other specified.

Step 1 Set up the library media changer unless it has been already done. See Setting Up the Library 
on page 123.

Step 2 Install Scalar DLC on Node1.

• Log in as the domain admin.

• Insert Scalar DLC 2.6 CD. Select Scalar DLC Install to install the Scalar DLC with all required 
components (see Installing the Scalar DLC on page 45).

• Set SQL Destination to “R:”.

• Specify Scalar DLC settings, as required for Scalar DLC Software on page 50.

• Set SDLC User Name to <SDLC user name>. Set password to <SDLC user password>. 
Select domain account and “Check”. Wait (~5 min) and Submit.

• Set Database Name as “SDLC”. Select Compact Database Weekly, Backup Database 
None.

• Unselect “Turn On Email Notifications”.

• Select “Complete”.

• Select “Install immediately” for Target Drivers (if required).

• Install.

• Java 2 install: “I accept” and “Next” and “Typical” and “Next” and “Finish”.

• Apache install: “Next” and “I accept” and “Next” and “Next”.

Note As the SDLC user is a domain account, the user name and password should match the 
local network security policy. Contact the local network administrator for the details.
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• MSDE2000 install: “No”, then “Yes“.

• Set Network Domain as <domain name>. Set Server name as <computer name>.<domain 
name>. Set Administrators Email as “admin@<domain name>. Set “Run as a service for 
all Users” and “Next”.

• Select “Complete” and “Next” and “Next” and “Install” and “Finish”. “OK” to “the system 
being restarted now” and restart (15 min for SQL).

• OK to restart and wait for <ctrl><alt><del>. Remove Scalar DLC Install disk from Node1.

Step 3 Install Scalar DLC on Node2.

• Power on Node2. Log in as the domain admin.

• Insert Scalar DLC 2.6 CD. Select Scalar DLC Install to install the Scalar DLC with all required 
components (see Installing the Scalar DLC on page 45).

• Set SQL Destination to “R:”.

• Specify Scalar DLC settings, as required for Scalar DLC Software on page 50.

• Set SDLC User Name to <SDLC user name>. Set password to <SDLC user password>. 
Select domain account and “Check”. Wait (~5 min) and Submit.

• Set Database Name as “SDLC”. Select Compact Database Weekly, Backup Database 
None.

• Unselect “Turn On Email Notifications”.

• Select “Complete”.

• Select “Install immediately” for Target Drivers (if required).

• Install.

• Java 2 install: “I accept” and “Next” and “Typical” and “Next” and “Finish”.

• Apache install: “Next” and “I accept” and “Next” and “Next”.

• MSDE2000 install: “No”, then “Yes“.

• Set Network Domain as <domain name>. Set Server name as <computer name>.<domain 
name>. Set Administrators Email as “admin@<domain name>. Set “Run as a service for 
all Users” and “Next”.

• Select “Complete” and “Next” and “Next” and “Install” and “Finish”. “Ok” to “the system 
being restarted now” and restart (15 min for SQL).

• Remove Scalar DLC Install disk from Node2.

Step 4 Finish installing Scalar DLC on Node1

• Load Scalar DLC Install disk on Node1. Log in as the domain admin; installation should 
continue. Cancel immediately.

• Open Cluster Administrator and go to Groups > Cluster Group. Verify that Node1 has 
ownership now.

• Manually run <CD>:\autorun. Select Scalar DLC Install. Next and I Accept and Next and Next.

• Specify Scalar DLC settings

Note As the SDLC user is a domain account, the user name and password should match the 
local network security policy. Contact the local network administrator for the details.
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• Set user name to ADIC User and organization to ADIC. Enter serial number. Select Anyone 
(all Users) and “Next”

• Set SDLC User Name to <SDLC user name>. Set password to <SDLC user password>. 
Select domain account and “Check”. Wait (~5 min) and Submit.

• Look for successful component registration and “Next”.

• Set Database Name as “SDLC”. Select Compact Database Monthly, Backup Database 
Weekly, set backup file “SDLC_backup” in folder “R:\MSSQL\Backup” and Next

• Unselect “Turn On Email Notifications” and “Next”.

• Select “Complete” and “Next”.

• Select “Do not Install” for Target Drivers and “Next”. Install.

• Install Scalar DLC.

• Enter Registration Information and Next

• Unselect Send License request to ADIC Now and Next. Unselect Read Installation Summary 
Now and Finish.

• Remove Scalar DLC Installation CD. “Yes” to restart Node1. Wait for <ctrl><alt><del> screen.

Step 5 Finish installing Scalar DLC on Node2

• Load Scalar DLC Install disk on Node2. Log in as the domain admin; install should continue. 
Cancel immediately.

• Open Cluster Administrator and go to Groups > Cluster Group. Verify that Node2 has 
ownership now.

• Manually run <CD>:\autorun. Select Scalar DLC Install. Next and I Accept and Next and Next.

• Specify Scalar DLC settings

• Set user name to ADIC User and organization to ADIC. Enter serial number. Select Anyone 
(all Users) and “Next”.

• Set SDLC User Name to <SDLC user name>. Set password to <SDLC user password>. 
Select domain account and “Check”. Wait (~5 min) and Submit.

• Look for successful component registration and “Next”.

• Set Database Name as “SDLC”. Select Compact Database Monthly, Backup Database 
Weekly, set backup file “SDLC_backup” in folder “R:\MSSQL\Backup” and Next

Note As the SDLC user is a domain account, the user name and password should match the 
local network security policy. Contact the local network administrator for the details.

Note The Backup directory is to be created manually.

Note As the SDLC user is a domain account, the user name and password should match the 
local network security policy. Contact the local network administrator for the details.
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• Select “Use Existing Database” and Next. Do not choose “Create new database“ or the 
Scalar DLC will not function.

• Select “Do not Install” for Target Drivers and “Next”. Install.

• Install. Cancel License wizard.

• Unselect “Read Installation Summary Now” and “Finish”.

• Remove Scalar DLC Install CD. “Yes” to restart Node2. Wait for <ctrl><alt><del> screen

Step 6 Install Target Drivers (optional, only for SCSI/FC clients with Scalar DLC. If no SCSI/FC Client 
will be used with the Scalar DLC software, proceed to Step 7)

• Insert Scalar DLC install CD in Node1. Autorun will start.

• Follow the installation sequence for Installing the SCSI/FC Target Drivers on page 74.

• Remove CD and reboot Node1.

• Insert Scalar DLC install CD in Node2. Autorun will start.

• Follow the installation sequence for Installing the SCSI/FC Target Drivers on page 74.

• Remove CD and reboot Node2.

• On Node1 enable Target mode for the adapter, see Activating Target Mode on page 77. Then 
reboot Node1.

• On Node2 enable Target mode for the adapter, see Activating Target Mode on page 77. Then 
reboot Node2.

Step 7 Set Scalar DLC to Failover (cluster) mode

• Log in as the domain user with local admin rights.

• Insert Scalar DLC Install CD. Close Autorun. Run 
<CD>:\Scalar_DLC\Cluster\SDLC_ClusterConfig.exe

• Verify that both nodes show as up in the SDLC Cluster Configurator.

• Click Make SDLC Cluster Configuration.

• “OK” when complete and close all windows.

• Reboot Node1 and Node2.

Configuring the Logical Library

Step 1 Using any node, log in as administrator or as a domain user with the local administration rights 
and start the Scalar DLC software if it is not started automatically.

Step 2 Double click the Scalar DLC Manager icon to start the Scalar DLC Management GUI from a 
local computer. From a remote computer, use 
http://ScalarDLC-machine-name in current browser.

Note The Backup directory is to be the same one as for Node1.
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Step 3 The first start of the Scalar DLC Management GUI launches the configuration engine. Select 
either the Automatic or Manual option to configure the logical library automatically, or Advanced 
option in case of more then one logical library should be created. Refer to the Configuration 
chapter of the Scalar DLC Reference Guide for further instructions.

Post-install checklist
• Nodes

• Node1 computer name (14 symbols max)

• Node1 public IP address

• Node2 computer name (14 symbols max)

• Node2 public IP address

• public Subnet mask

• public default Gateway

• public preferred DNS

• public Alternate DNS (optional)

• public Primary WINS (optional)

• public Secondary WINS (optional)

• Node1 private IP address

• Node2 private IP address

• private subnet mask

• Local administrator login name and password (same on both nodes)

• Scalar DLC serial number (same on both nodes

• Cluster

• name (14 symbols max)

Note It is strongly recommended to use the virtual Cluster name here (for example, 
SDLC-CLUSTER).

CAUTION
The operating system and its service packs on both cluster nodes must be 
identical and they must remain identical. Otherwise it may cause cluster 
service malfunctions.

Note If the network parameters are changed, the cluster service will not function and should 
be repaired or re-configured manually. See Renaming and Repair on page 97.

Note Never turn the RAID shared disk off. Otherwise, the Scalar DLC will not work.

Never load off the SCSI terminators from RAID or library. This will put the Scalar DLC to 
malfunction.
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• IP address

• Subnet mask = public subnet mask

• Domain

• name

• domain admin name and password

• directory services restore mode password

• Configuration

• library SN

• backup to RAID

• backup to floppy

• clients configured and tested

• hardware configured and tested

• email address settings

• contact information

• client type(s)

• target card model

• License

• Node1 SID

• Node1 license string

• Node2 SID

• Node2 license string

Setting Up the Self-Domain Solution

Installing the Failover solution as Self-domain system, without an external domain controller, means that the 
Scalar DLC will be installed on both the Primary Domain Controller and the Backup Domain Controller. This 
configuration is possible but requires the extended setup, not the same as for the plain Failover solution that 
described in details in Setting Up the Failover Solution on page 13.

Setup Roadmap
1 Collecting Setup Data on page 34.

2 Installing the Nodes on page 34.

3 Installing ADTX RAID on page 35.

4 Configuring SCSI for RAID and Library on page 35.

5 Setting Up Network, IP Address and Computer Names on page 35.

6 Configuring Domain Controllers on page 36.

7 Setting Up the RAID disk on page 40.

8 Configuring Cluster Service on page 40.

9 Installing Scalar DLC Software on page 43.
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For the optional additional activity, see Setting Up the Library on page 123, Building Client Connections on 
page 131, Installing SCSI/FC Target Adapters on a Live Machine on page 134, and Host/Library 
Communication using Fibre Channel and SNC on page 127. See also Upgrade, Remove, Repair on page 
81.

Collecting Setup Data
• Nodes

• Node1 computer name (14 symbols max)

• Node1 public IP address

• Node2 computer name (14 symbols max)

• Node2 public IP address

• public Subnet mask

• public default Gateway = Node1 public IP

• public preferred DNS = Node1 public IP

• public alternate DNS = Node2 public IP

• Node1 private IP address

• Node2 private IP address

• private subnet mask

• private preferred DNS = Node1 private IP

• private alternate DNS = Node2 private IP

• Local administrator login name and password (same on both nodes)

• Scalar DLC serial number (same on both nodes

• Cluster

• name (14 symbols max)

• IP address

• Subnet mask = public Subnet mask

• Domain

• name (14 symbols max; a compound name must be used, for example, SDLCDOMAIN.INT; 
the 14-symbol-length limit does not include postfix .INT)

• domain admin name and password

• directory services restore mode password

• Contact information of IT person for connection questions

Installing the Nodes
First all the same as in plain Failover solution. See Installing the Nodes on page 17.

Then copy NewSID

• Copy newsid program into a directory on the C: drive.

• Run newsid /a

• Node1 will reboot. Shutdown Node2
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Installing ADTX RAID
Same as in plain Failover solution. See Installing ADTX RAID on page 18.

Configuring SCSI for RAID and Library
Same as in plain Failover solution. See Configuring SCSI for RAID and Library on page 20.

Setting Up Network, IP Address and Computer Names
The procedure is more or less the same on both Win2000 and Win2003.

Step 1 Power on Node1 and log in (ignore duplicate name message).

Step 2 Set up Public network.

• On Windows 2000, right click “My Network Places” and select “Properties”. 
On Windows 2003, use Start > Control Panel > Network Connections (right-click) > Open.

• Right click “Local Area Connection”. Rename it to ‘Public’. Right-click and select “Properties”.

• Select “Show Icon in the Task Bar/Notification Area when Connected”. Select “Internet Protocol 
(TCP/IP)” and select “Properties”.

• Select “Use the Following IP Address”

• Set IP Address (192.168.0.220 for Node1 and 192.168.0.221 for Node2 in lab)

• Set Subnet Mask to 255.255.255.0

• Set Default gateway to same as static IP of Node1 (192.168.0.220)

• Set Preferred DNS to same as static IP for Node1 (192.168.0.220)

• Set Alternate DNS to static IP of Node2 (192.168.0.221)

• Press “OK” and “OK”. (OK and Close on Windows 2003).

Step 3 (This step is for Windows 2000 system only. On Windows 2003 follow the Step 4) 
Right click “Public” and “Disable” then right click and “Enable”. A new item “Local Area 
Connection 2” will appear.

Step 4 Set up Private (cluster) network.

• Rename Local Area Connection 2 to ‘private’.

• Right click “Private” and select “Properties”.

• Select “Show Icon in the Task Bar when Connected”. Select “Internet Protocol (TCP/IP)” and 
select “Properties”

• Select “Use the Following IP Address”

• Set IP Address to (10.0.0.1 for Node1 and 10.0.0.2 for Node2 in lab) (use a completely 
different IP than Local Area Connection that is on a higher subnet)

• Set Subnet Mask to 255.0.0.0

• Set preferred DNS to static IP of Node1 (10.0.0.1)

• Set alternate DNS to static IP of Node2 (10.0.0.2)

• Press “OK” and “OK” (OK and Close on WIndows 2003).
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Step 5 Set computer name.

• Right click “My Computer” and select “Properties”.

• (on Windows 2000) Open “Network Identification” and select “Properties”.

• (on Windows 2003) Open Computer Name > Change > More. Ensure that the checkbox 
‘Change primary DNS suffix when domain membership changes’ is enabled (see Figure 11 
on page 23). Press OK.

• Set “Computer name” (sdlc1 for Node1 and sdlc2 for Node2)

• Press “OK” and “OK” to reboot and “OK” and “No” to reboot server.

Step 6 Shutdown Node1.

Step 7 Repeat steps 1 to 6 for Node2.

Configuring Domain Controllers
Under WIndows 2000 Advanced Server and Windows 2003 Server, this procedure is not quite the same.

Windows 2000

Step 1 Configure Primary domain controller (Node1)

• Power on Node1 and log in. In “Configure your server” window select “Active Directory”.

• Select “Start the Active Directory Wizard” and “Next”.

• Select “new domain” and “next”.

• Select “create new domain tree” and “next”.

• Select “create new forest of domain trees” and “next”.

• Enter domain name (sdlcdomain.int) and next.

• Accept short NetBIOS name and next

• Accept default locations and next.

• Accept default folder location and next

• OK to unable to find DNS server

CAUTION
Both Node1 and Node2 names must not be longer than 14 symbols.

CAUTION
Using Start > Run do the following:
From Node2 run: ping <Node1 public IP address>
From Node2 run: ping <Node1 private IP address>
From Node1 run: ping <Node2 public IP address>
From Node1 run: ping <Node2 private IP address>
If any of these commands returns “Request timed out“ response, that means 
the network settings are configured incorrectly, for example, the network 
connection that has been configured as ‘public’, is in fact internal cluster 
(private) network connection.
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• Yes to install DNS and next

• Select permissions “compatible only with windows 2000 servers” and “Next”. Set directory 
services restore mode password. Confirm and Next and Next

• Insert Windows 2000 Advanced Server CD and OK and Finish.

• Unselect show this screen at startup in Configure your server window.

• Remove CD.

• Restart Node1.

Step 2 Bring Node2 to the domain

• Power on Node2 and log in

• Right click My Computer and select Properties.

• Open Network Identification and Properties

• Select Domain and enter <domain name> and OK (sdlcdomain)

• Enter user name and password and OK (administrator and password)

• Wait for Welcome to domain and OK and OK to reboot and OK and Yes.

• Log on to domain as administrator.

Step 3 Set up Backup Domain Controller (Node2)

• In the Configure your server window select Active Directory.

• Select Start the Active Directory Wizard and Next

• Select “additional domain controller” and next

• Enter user name and password (administrator and password) and Next

• Accept domain name and next

• Accept default locations and next

• Accept default folder location and next

• Set “directory services restore mode password” (password). Confirm and Next.

• Finish and unselect Show this Screen at startup in Configure your server window. Restart.

• After restart, launch Start > Settings > Control panel > Add/Remove Programs > Add/Remove 
Windows Components > Networking Services > Details

• Select Domain Name System and OK and next

• Insert Windows 2000 Advanced Server SP4 CD and OK and Finish.

• Remove CD.

• Restart Node2.

Step 4 Review network settings on both nodes (Public and Private). Restore DNS to the values 
described in Step 2 on page 35 and Step 4 on page 35.

Step 5 Review the Domain Operations mode, it should be ‘Native’. Change if required.

Note Make changes to domain user account information on Node1 at this time.
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• On Node1 open Start > Programs > Administrative Tools > Active Directory Domains 
and Trusts.

• Right-click <Domain name> > Properties > General.

• If Domain operation mode is Native, just close the dialog pane, otherwise press Change 
mode button and then Yes to confirm changing mode.

Windows 2003

Step 1 Configure Primary domain controller (Node1)

• Power Up Node1. Insert Windows 2003 Server CD. Start > Manage Your Server

• Add or remove a role

• Next. The wizard will detect network settings.

• Typical configuration for first server and Next

• Enter full DNS name for new domain (SDLCDOMAIN.INT) and Next. Next to confirm

• Select 'No, it should not forward queries' and Next.

• Review summary and Next.

• Press OK to confirm restart when needed.

• Choose 'Public' network.

• Unselect "Enable security on the selected interface”. Next.

• (for the PC with three and more network interfaces) Select ‘Private’ and Next.

• Finish.

• When the ‘ready-to-shutdown’ window appears remove Windows 2003 Server CD. Node1 
will auto-restart and continue the setup.

• Next. Finish, Close 'Manage Your Server'.

• Correct Network Settings for Node1, as described in Step 4 on page 37.

Step 2 Join Node2 to domain.

• Power up Node2. Start > My Computer (right-click) > Properties > Computer name.

• Add description (optional) and press Change.

• Choose domain and enter domain name (SDLCDOMAIN). OK. The domain admin login is 
required.

• OK. wait till the Node2 joins to domain.

• OK. 'You must restart' and OK. 

• OK, OK, and Yes for restart Node2.

Step 3 Configure Backup Domain Controller on Node2

• After Node2 is power up log on into SDLCDOMAIN domain (Options button, change Node2 
name SDLCCLUST2 to domain name SDLCDOMAIN) as domain admin.

• Start > Manage Your Server > Add or remove a role

• Next. The wizard will detect network settings.

• Choose Domain Controller (Active DIrectory) and Next.
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• Summary and Next and Next and Next.

• Choose 'Additional domain controller' and Next.

• Enter domain admin name/password and Next. Next.

• Review the active directory DB and log folders (do NOT change unless necessary). Next.

• Review the System Volume folder (do NOT change unless necessary). Next.

• Enter domain admin password and confirm. Next.

• Review summary and Next. The wizard will install Active Directory service. Finish. Restart 
Now to complete.

• Finish configure Backup Domain Controller. Node2 is restarted. Log on as domain admin, then 
Finish.

• Insert Windows 2003 Server CD. Start > Manage Your Server > Add or remove a role.

• Next. The wizard will detect network settings.

• Choose DNS Server and Next.

• Summary and Next and Next.

• Select 'Create forward lookup zone for small networks' and Next

• Select 'An ISP maintains the zone...', as the Node2 is the secondary DNS, and Next.

• Enter the zone name (any user-friendly, for example, SDLCZONE2) and Next.

• Enter Master DNS (Node1 IP - 192.168.0.201), press Add, then Next.

• Select 'No, it should not forward queries' and Next.

• Finish, and Finish.

• Remove Windows 2003 CD and restart Node2.

Step 4 Review the Domain functional level, it should be ‘Windows 2000 native’. Change if required.

• On Node1 open Start > Programs > Administrative Tools > Active Directory Domains 
and Trusts.

• Right-click <Domain name> > Raise Domain Functional Level.

• If Current domain functional level is Windows 2000 native, just close the dialog pane, 
otherwise select ‘Windows 2000 native’ level and then OK and OK to confirm changing 
level.

• Restart Node1.

CAUTION
Windows2003 contains advanced security that strictly declines plain 
passwords like 'password', 'qwerty123', etc. The password must contain both 
letters and numbers or other symbols like '+' or '_' and its length must be at 
least 8 symbols.

CAUTION
An error window appears: ‘No it should not forward queries”; Error name: 
DNS, the configure a DNS server wizard could not configure root hints’.
Press OK.
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Setting Up the RAID disk
Same on both Windows 2000 and WIndows 2003.

Step 1 Power up Node1 and log in as Administrator for SDLCCLUSTER (cluster)

Step 2 Prepare to Format RAID disk

• Right click “My Computer” and select “Manage”

• Select “Disk Management”. Write Signature Wizard should start. Press “Next”.

• Select “Disk 0” to write a Signature and press “Next”.

• Unselect “Disk 0” to Upgrade, press “Next” and then “Finish”.

Step 3 Format RAID

• Right click unallocated space and select “Create Partition”. Create Partition Wizard starts. Click 
Next.

• Select “Primary Partition” and press “Next”.

• Set maximum value in “Amount of Disk Space to Use” and press “Next”.

• Select “Assign a Drive Letter” and select “R:” and press “Next”.

• Select “Format this Partition with the Following Settings”

• Set “File System” to “NTFS”

• Set “Allocation Unit Size” to “Default”

• Set “Volume Label” to “Cluster Raid”

• Select “Perform A Quick Format”

• Press “Next” and “Finish” and let format complete.

Step 4 Shutdown Node1 after the RAID is formatted. Power up Node2 and log in as Administrator for 
SDLCCLUSTER (cluster).

Step 5 Join RAID disk

• Right click “My Computer” and select “Manage”

• Select “Disk Management”.

• Right click “Cluster Raid”. Select “Change Drive Letter and Path”.

• Select “Edit” and “Assign Drive Letter” to “R”.

• Press OK. Press “Yes” to confirm.

Step 6 Shutdown Node2. The RAID is on.

Configuring Cluster Service
Windows 2000 Advanced Server and Windows 2003 Server require completely different procedures.

Windows 2000

Step 1 Power up Node1 and log in as Administrator to SDLC1 (this computer)
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Step 2 Configure Cluster Service on Node1

• Select Start > Settings > Control panel > Add/Remove Programs > Add/Remove Windows 
Components >> Cluster Service. Press Next.

• Insert Windows 2000 Advanced Server SP4 CD and press OK. Cluster Service Configuration 
Wizard will start. Press “Next”.

• Click “I Understand” and “Next”.

• Select “The First Node in the Cluster” and “Next”.

• Set cluster name to SDLCCLUSTER and “Next”.

• Set User Name and Password (“administrator” and “password”). Set Domain to “sdlcdomain” 
and “Next”.

• Ensure that “R: Cluster Raid” is in managed disks and “Next”

• Select “R: Cluster Raid” and “Next” and “Next”.

• Set up Cluster Network

• For Network Name “public” select “Enable this Network for Cluster Use”.

• Select “All Communications (mixed network)” and “Next”.

• For Network Name “private” select “Enable this network for cluster use”.

• Select “Internal Cluster Communications Only (Private Network)” and “Next”.

• Ensure that “private is at the top of Networks list and “Next”

• Set “Cluster IP address” to <ip address> (192.168.0.222 in lab)

• Set “Subnet Mask” to 255.255.255.0

• Set “Network” to “public” and “Next”.

• “Finish” and “OK” to Cluster Service Started Successfully.

• Finish and eject CD and close all windows and shutdown Node1

Step 3 Power up Node2 and log in as Administrator for SDLC2 (this computer)

Step 4 Configure Cluster Service on Node2.

• Select Start > Settings > Control panel > Add/Remove Programs > Add/Remove Windows 
Components >> Cluster Service. Press Next.

• Insert Windows 2000 Advanced Server SP4 CD and press OK.

• Power on Node1 and wait for <ctrl><alt><del> (log in) screen.

• On Node2 Cluster Service Configuration Wizard will start and Next

• Click “I Understand” and “Next”.

• Select “Second or Next Node in the Cluster” and “Next”.

• Set cluster name as SDLCCLUSTER

• Select “Connect to Cluster As”.

CAUTION
The cluster name must not be longer than 14 symbols.
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• Set User Name and Password (“administrator” and “password”). Set Domain to “sdlcdomain” 
and “Next”.

• Set password as “password” and “Next”.

• “Finish” and “OK” and “Finish”.

Step 5 Remove CD and close all windows.

Step 6 Ensure the cluster works.

• Select Start > Programs > Administrative Tools > Cluster Administrator

• Select Groups > Cluster Group

• Select File > Move Group to verify the cluster is working properly

• Move group again and return ownership to Node1.

Step 7 Shutdown Node2

Windows 2003

Step 1 Power on Node1. Log on as self-domain admin.

Step 2 Create Cluster on Node1.

• Start > Administrative Tools > Cluster Administrator

• Choose 'Create new cluster' and OK. Next. Enter cluster name (SDLCCLUSTER2003) and 
Next.

• Review Node1 name and Next. The wizard will analyze an existing configuration.

• Next. Enter cluster IP (static, unique) and Next.

• Enter domain admin account & Password. Next.

• Review cluster summary and Next. Wizard creates a cluster.

• Next and Finish.

Step 3 Join Node2 to Cluster

• Power on Node2 and wait till it comes up. Wait circa 5 min until the virtual cluster name will 
be available from Node2. Switch to Node2.

• Start > Administrative Tools > Cluster Administrator. Choose 'Open Connection to cluster' 
and enter the cluster name (SDLCCLUSTER2003).

• OK. Then File > New > Node. Add new Node wizard starts.

• Next. Add, then Next. The wizard will analyze an existing configuration.

• Enter domain user account & password. Next.

• Review cluster summary and Next. Wizard adds node to a cluster.

• Next and Finish. The cluster is ready.

CAUTION
The cluster name must not be longer than 14 symbols.
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Step 4 Ensure the cluster works.

• Select Start > Administrative Tools > Cluster Administrator

• Select Groups > Cluster Group

• Select File > Move Group to verify the cluster is working properly

• Move group again and return ownership to Node1.

Installing Scalar DLC Software
Same as in plain Failover solution. See Installing Scalar DLC Software on page 28.

Post-install Checklist
• Nodes

• Node1 computer name (14 symbols max)

• Node1 public IP address

• Node2 computer name (14 symbols max)

• Node2 public IP address

• public Subnet mask

• public default Gateway = Node1 public IP

• public preferred DNS = Node1 public IP

• public alternate DNS = Node2 public IP

• Node1 private IP address

• Node2 private IP address

• private subnet mask

• private preferred DNS = Node1 private IP

• private alternate DNS = Node2 private IP

• Local administrator login name and password (same on both nodes)

• Scalar DLC serial number (same on both nodes

• Cluster

• name (14 symbols max)

• IP address

• Subnet mask = public Subnet mask

• Domain

• name

• domain admin name and password

• directory services restore mode password

Note If required the user security policy can be modified on Primary domain controller 
(Node1) via Start > Administrative Rules > Domain security policy; choose 
Account policies > Password policies. 
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• Configuration

• library SN

• DB backup to RAID

• DB backup to floppy

• clients configured and tested

• hardware configured and tested

• email address settings

• contact information

• client type(s)

• target card model

• License

• Node1 SID

• Node1 license string

• Node2 SID

• Node2 license string

Common Setup Notes

• If changes are made to the RAID or it is powered off/on a Hard Disk Changed message may appear 
during reboot.

• F1 to enter bios

• Esc without making changes

• OK

• The above will also happen when using a Jump Drive.

• If a Jump Drive is in the USB during boot up an invalid disk error may happen

• Reset the time when finished with the installation.

• If the RAID is not new initialize it before starting it. The whole procedure takes approximately 6 
hours.

• WinZip needs to be installed and is not by default

• Leave RAID off for a minimum of 20 seconds before powering back on

• Hang on boot up at ATI Rage SDRAM Bios is not an uncommon condition

• Immediately after the install is finished, if the cluster groups do not move from Node1 to Node2, 
shutdown Node1 and restart Node2. Make sure that Scalar DLC goes online for Node2, then restart 
Node1.

• Set the event logs to overwrite when necessary. They will fill up often otherwise.

• If the Ethernet card is installed with Wake on Lan Feature, disable it.

• Typical user account security policy requires the password more than 6 symbols long and contained 
both numbers and letters in both small and capital.
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Installing the Scalar DLC
The Scalar DLC software must be installed on a PC running Windows 2000 / 2003. The Management GUI 
is installed as a part of the Scalar DLC software. After the software is installed, a remote user can connect 
to the Scalar DLC host.

During the installation process, all required components are installed. System restart may be necessary 
after the installation of certain components. The system will warn the user that the restart is required, and 
the installation process will continue until all files have been installed.

• Before installing the Scalar DLC perform the Solution Checkup on page 45.

• Using the Scalar DLC setup engine install the required Software Components on page 45.

• After this is finished, install Scalar DLC Software on page 50.

Solution Checkup

Make sure the appropriate solution is set up before installing the Scalar DLC.

See Setting Up the Standard Solution on page 7, Setting Up the Failover Solution on page 13, and Setting 
Up the Self-Domain Solution on page 33.

Software Components

Figure 14 on page 46 shows the components that are to be installed during the Scalar DLC setup process. 
The required components that are currently not installed are marked automatically for the installation.

Note To install the Scalar DLC software and all required components, local administrator 
rights are required.

The cluster solutions (both failover and self-domain) require the domain user with either 
local or domain administrator rights.
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Figure 14 Scalar DLC Setup Components

The following components must be installed and configured for the proper performance of the Scalar DLC 
software service:

• Microsoft Windows 2000 Service Pack 4 (only for Windows 2000)

• Microsoft Internet Explorer ver. 6.0 or newer (only for Windows 2000)

• Java 2 Runtime Environment (Java 2) 1.4.2_09

• Apache Web Server ver.1.3.27

• Secure Socket layer (SSL), optional

• Microsoft SQL Server 2000 Desktop Engine (MSDE 2000)

• MSDE 2000 Service Pack 4

Silent Mode
When a customer selects silent mode, all information that is required for the selected installation must be 
entered before the install process starts.

The install process continues until everything is complete, including automatically restarting the computer 
and logging on.

Note that the complete installation of both the required components and Scalar DLC software will take some 
time (circa 15-30 minutes).

Note ADIC does not recommend using silent mode when installing Scalar DLC failover / self-
domain solution.
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Windows Service Pack
The SP4 for Windows 2000 operating system must be used with the Scalar DLC software. After the service 
pack is installed, a restart is required. Then the system will configure the installed tools and services.

Microsoft Internet Explorer
The Scalar DLC software is compatible with the MS IE browser 6.0 or newer version. ADIC offers the MS 
IE 6.0 installation kit. After the MS IE is installed, a restart is required. After rebooting, the system continues 
to configure the installed Internet Explorer tools and services.

Java 2 Runtime Environment
The Java2 component installs over an existing Java runtime environment without producing a warning 
message. By default, the Java2 is installed in the 
<%SystemDrive%>\Program Files\Java\j2re1.4.2_09\ directory. An advanced user can install 
the Java2 to any directory desired, but ADIC recommends against this action.

Remove

Removing Java is performed via standard Windows Add/Remove Programs engine. A restart may be 
required afterwards.

Apache HTTP Server
ADIC does not recommend installing the Scalar DLC software on a machine with a previously installed copy 
of Apache Server. During installation, the configuration file overwrites any configuration file present on the 
hard drive without providing a warning. By default, the Apache HTTP Server is installed in the 
<%SystemDrive%>\Program Files\Apache Group\Apache\ directory. An advanced user can install 
the Apache HTTP Server in any desired directory.

If the default Apache directory exists, the installation provides a warning message.

Note ADIC supports the Win2000 SP4 developed by the Microsoft. This service pack can be 
used with all versions of Windows 2000 (Professional, Server, Advanced Server, etc.).

The SP1 for Windows 2003 is required for the Scalar DLC but not included onto the 
Scalar DLC Install CD. It must be installed with WIndows 2003.

Note The installation of MS IE 6.0 under Windows 2003 is not required.

Note The Java2 installation may ask for a restart. ADIC recommends rebooting the PC.

Note It is recommended also to check <%SystemDrive%>\Program Files\ afterwards. If 
Java folder is not removed, remove it manually.
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Figure 15 Warning: Apache

Secure Socket Layer
The Secure Socket Layer (SSL) protocol encrypt the data that has been sent/received via the web. The SSL 
family of protocols includes also Transport Layer Security (TLS).

The SSL is built into all major browsers (Internet Explorer, Netscape), so implementing the SSL component 
into the Scalar DLC activates this feature when a customer launches the Scalar DLC Management GUI as 
the browser applet. Also the SSL encryption feature is activated when a customer launches the Java-based 
application Scalar DLC Manager which represents the same Management GUI. The details on 
Management GUI are described in the Scalar DLC Reference Guide, Configuration chapter.

The following are characteristics of SSL/TLS: 

• Generic enough to be incorporated into many applications 

• Provides security between the transport (TCP protocol) and upper application layer protocol such 
as HTTP, FTP, or TELNET. 

• Supports encryption, authentication, and key exchange 

• Encrypts data so that anyone who intercepts is unable to read it. 

• Assures clients that they are dealing with the server they intend to connect to. 

• Prevents any unauthorized clients from connecting to the server. 

• Prevents anyone from meddling with data going to or coming from the server. 

• Three protocol capabilities: authentication, encryption, and key exchange 

Remove
Removing Apache is performed via standard Windows Add/Remove Programs engine. It is recommended 
to Stop the Apache service before (Start > Programs > Apache HTTP Server > Control Apache Server 
> Stop) and then remove the Apache itself.

Note It is recommended also to check <%SystemDrive%>\Program Files\ afterwards. If 
Apache folder is not removed, remove it manually.
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Microsoft SQL Server Desktop Engine 2000
If the Microsoft SQL Server 2000 is installed already, it is not required to install the MSDE 2000. If there is 
either MSDE 7.0, or MS SQL Server 7.0 installed on the PC, the installation upgrades it for the MS SQL 
system service remains workable.

By default, the MSDE 2000 is installed in the 
<%SystemDrive%>\Program Files\Microsoft SQL Server\ directory. An advanced user can 
install the MSDE 2000 in any desired directory. After the MSDE 2000 installation is completed, re-start the 
system if required.

If the Scalar DLC should be installed as a Failover solution, the MS SQL 2000 should be installed on a 
shared disk (RAID - R:) to the ‘specified’ folder that must be shared, too.

Figure 16 MSDE 2000 Installation

MSDE 2000 Service Pack 4
The SP4 for MSDE 2000 was designed to fix bugs and security holes found in the basic version of the 
software (MSDE 2000). Because the Scalar DLC uses the SQL database to store all system information this 
service pack is required for the correct performance of the Scalar DLC software.

Remove
Removing MSDE with the service pack is performed via standard Windows Add/Remove Programs engine. 
The MSDE SP4 separately cannot be removed. Restart is not required.

Note If there is no MSDE 2000 but complete MS SQL 2000 installed, do not install this service 
pack. Go to the http://www.microsoft.com instead, download the Service Pack 4 for MS 
SQL 2000, and install it manually

CAUTION
ADIC recommends installing Service Pack 4 for MSDE 2000. Otherwise a 
security hole in MSDE 2000 remains open and could be used by internet 
viruses or worms (for example, Slammer).
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Scalar DLC Software

All Setup windows contain the following buttons:

• Back

• Next

• Cancel

Follow the directions on the Setup Start window to install the Scalar DLC software.

Figure 17 Start Setup

Figure 18 Licensing

To continue the Scalar DLC Installation, accept the ADIC License Agreement. Click Next to proceed to the 
next screen (a copy of Figure 14 on page 46).

Proceed only after all of the required components are installed. Otherwise, the Scalar DLC Installation 
should be cancelled and launched again after the missing software is installed.
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Click Next to proceed to the following screen.

Figure 19 Personal Information

Next, the installation process creates an account and registers the Scalar DLC internal components. See 
Figure 20 for the local account, see Figure 21 on page 53 for the domain account, and see Figure 23 on 
page 54 for the registration.

Table 6 Personal Information

Name Operation Description

User name Enter The user name (PC owner, by default).

Organization Enter The organization name (PC owner organization, by default)

Scalar DLC serial 
number

Enter The Scalar DLC serial number (5 digits). This number is shown 
on the back of the Scalar DLC Installation CD.
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Figure 20 Create Local User Account

Enter the user account settings.

Table 7 Create User Account 

Name Operation Description

User name Enter User account name, ‘SDLC’ by default

User 
password

Enter User account password.

Confirm Enter Password must be confirmed.

User account 
to be created

Select Local specifies the account type as local (default).

Domain specifies the account type as domain.

On host Supplied Local host name.

Domain Supplied The domain name (not editable for the local account).

Enter The domain name (editable for the domain account).

Server Supplied The domain server name, not editable.

Check (for 
domain 
account only)

Click Check the rights on the domain. For a domain admin, the Next button 
appears; otherwise, domain account installation is not available.
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Figure 21 Create Domain User Account

The user account should be entered in this window. Refer to Table 7 for the details. Click Next to proceed.

If the account name already exists and the password does not match the existing account’s password, the 
User Account warning appears. See Figure 22 on page 53. Otherwise, if the user account is created 
successfully, the Component Registration window appears. See Figure 23 on page 54.

Figure 22 User Account Warning

Go back and specify another user account or enter the correct password.

Note Domain administrator rights are required to install Scalar DLC under a domain account.
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Figure 23 Component Registration

Figure 24 Database Information

See Table 8 for the additional information.

Note Do not use system tools to change the Scalar DLC user account created during 
installation. If a change is made, the Scalar DLC system will not start. To correct this 
situation, launch the Scalar DLC Add/Remove engine in the Repair mode.

Table 8 Database Information 

Name Operation Description

SDLC Database 
name

Enter The default Scalar DLC database name, ‘SDLC’, will be used 
unless the user specifies another name.

MS SQL Server Supplied The default host name where the database should be created.
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Specify the database name and backup/compact schedules, and press Next to proceed.

If the specified Scalar DLC database already exists, either keep it or create a new, clean database. See 
Figure 25 on page 55. If the database was created by an older version of Scalar DLC software, either update 
it or create a new, clean database. See Figure 26 on page 56. 
If a new database is installed, the next window, Email Notifications settings, appears. See Figure 27 on page 
57.

Figure 25 Selecting Database: Create or Keep

If a new database is created, click Next to proceed to the Figure 27 on page 57; otherwise, proceed to the 
final screen.

Compact Select The Compact Database schedule can be set here.

Backup Select The Backup Database schedule can be set here.

Backup file Enter Default database backup file, ‘SDLC_backup’ by default.

In folder Select Default database backup folder. The default is 
%SystemDrive%\Program Files\Microsoft SQL 
Server\ (for standard solution) and 
%RAIDDrive%\Program Files\Microsoft SQL 
Server\ (for failover or self-domain solution).

Note The schedules for Backup and Compact jobs are described in more detail in the 
Database Utility section of the Scalar DLC Reference Guide. The backup and compact 
schedules can be changed later, as the database backup folder and filename, though 
the database name itself cannot be changed.

Note The old database may be used only with the same version of the Scalar DLC.

Table 8 Database Information (Continued)

Name Operation Description
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Figure 26 Selecting Database: Create or Upgrade

See Table 9 for the additional information.

If a new database is created, click Next to proceed to Figure 27 on page 57; otherwise, proceed to the final 
screen.

Table 9 Database Upgrade

Old Scalar DLC Version Additional activity

2.1 Reconfigure SCSI Target manually after the database 
upgrade. See Upgrading the Scalar DLC on page 86.

2.2, 2.2 SP1, 2.2 SP2, 2.2 SP3 Upgrade database.

2.3, 2.3 SP1, 2.3 SP2 Upgrade database.

2.4 Upgrade database.

2.5, 2.5 SP1, 2.5 SP2 Upgrade database.

2.6 Use existing database.
56 Installing the Scalar DLC



Figure 27 Email Notification Settings

Enter the email settings. See Table 10 for details.

Click Next to proceed to the figure below.

Table 10 Email Notification Settings

Name Operation Description

Support service email 
address (To:)

Supplied The email address for ADIC Scalar DLC technical 
support: ‘watchman@adic.com’. Not changeable.

Local email address (From:) Enter The email address shown in the From: field of emails.

Outgoing mail server: Name Enter The SMTP mail server name.

Outgoing mail server: Port Enter The SMTP mail server port.

Turn on email notifications Check Turn the email notifications on if the box is checked.

Note If the email settings are not properly configured, notifications will not be sent via email. 
The email parameters cannot be changed after the Scalar DLC is installed. 
Sending of email notification itself (on/off) can be changed later in Management GUI 
(Main Menu > Extended Service > Registration Information)
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Figure 28 Setup Type

There are two types of Scalar DLC software installations: Complete and Custom. 

The Complete Setup requires more disk space than various types of custom installs and places all Scalar 
DLC software components in the default directory: <%SystemDrive%>\Program Files\ADIC\SDLC\.

The Custom Setup allows to choose both the destination directory and the internal Scalar DLC software 
features that will be installed (if some features are not required, for example, Scalar DLC SCSI Client 
support). See Figure 29 for details.

Specify the installation type and click Next to proceed.

Figure 29 Custom Setup
58 Installing the Scalar DLC



Specify the components to install and the destination folder, and click Next to proceed.

Table 11 Custom Setup

Name Operation Description

Scalar DLC 
Components

Supplied Mark/unmark the component for installation.

 Kernel Supplied The kernel of Scalar DLC software. Installed always.

 Clients Supplied GUI The Scalar DLC Management GUI, main administrator 
tool. Installed always.

Check SCSI The SCSI Client support. Installed optionally.

Check DAS and 
NobleNet

The DAS Client support. Installed optionally.

Check ROBAR The ROBAR Client support. Installed optionally.

Physical 
Libraries

Supplied Scalar 10K The support of Scalar 10K single-aisle library. Installed 
always.

Supplied Scalar 10K 
DA

The support of Scalar 10K dual-aisle library. Installed 
always.

Supplied Scalar 1000 The support of Scalar 1000 library. Installed always.

Feature 
Description

Supplied The component name and disk space requirements.

Install to Supplied The current destination folder where the Scalar DLC should be 
installed. The default is 
%SystemDrive%\Program Files\ADIC\SDLC\

Change Click Change the destination folder.

CAUTION
If the Scalar DLC destination folder already exists ensure that it is empty. 
Never put any files in this folder because they will be removed with the Scalar 
DLC when the software is to be removed. See Add/Remove Scalar DLC 
Software on page 81.
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Figure 30 Install SCSI Target Driver

When the SCSI Client component is selected for installation in either the Complete or Custom Setup, the 
installation process requests to install the SCSI and Fibre Channel Target driver. If this option is accepted, 
the SCSI Target Mode Driver installation proceeds after the Scalar DLC software is installed successfully. 
Otherwise the Scalar DLC software installation proceeds but the SCSI Target software features remain not 
operable if no SCSI Target driver is present in the system (for example, from a previous installation).

This request is shown every time the Scalar DLC SCSI Client component is selected for the installation. 
ADIC recommends accepting the option and installing the drivers. If the drivers are installed already, decline 
this option. The drivers may be installed later manually as well.

For the details on SCSI Target Mode Driver installation and configuration process, see Installing the SCSI/
FC Target Drivers on page 74.

After the Scalar DLC components are installed, enter the registration information. See Figure 31 on page 61.

Note The SCSI/Fibre Channel Target drivers are needed to operate additional hardware (the 
SCSI card or FC card) required for using the Scalar DLC SCSI Target features. If this 
card is physically absent, the driver can be installed, but the Scalar DLC SCSI Target 
features will not work.
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Figure 31 Registration Form

For licensing purposes, enter the registration information. Fields marked with the asterisk must contain valid 
information.

Table 12 Registration Form 

Name Operation Description
Company name Enter The company’s name.
Company address Enter The company’s mailing address.
Contact name Enter The contact person’s name.
Contact email * Enter The contact email address.
SMTP Server * Enter The SMTP server name.
Port * Enter The SMTP server port.
Contact telephone Enter The contact phone number.
Contact fax Enter The contact fax number.
Service contract Check Marks the service contract feature as ‘signed’ if 

checked.
Site ID Enter The site ID (for the signed service contract).
Scalar DLC S/N Supplied The Scalar DLC serial number.
Scalar DLC location Enter The Scalar DLC location.
Scalar DLC dial-in number Enter The Scalar DLC dial-in number.
ATAC contact Select The Scalar DLC ATAC contact region (North America or 

Europe)

Note The registration information can be changed later via the Management GUI (Main Menu 
> Extended service > Registration information).
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After entering the data, click Next to proceed. Review the information and make changes if necessary. See 
the following figure.

Figure 32 Review Registration Form

The request form can be printed out and/or send via email to ADIC customer support to obtain a license. 
See Table 13 for additional information.

Figure 33 Email Registration Form

The email can be sent to any number of recipients. See Table 14 on page 63 for details.

Table 13 Review Registration Form

Name Operation Description

Send license request Check If checked, sends license request to ADIC.

Print now Click Print the registration form for mail or fax delivery.

Send email Click Send the registration form via email (see Figure 33).
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The Scalar DLC software is installed successfully. If no additional configuration steps are required, re-start 
the computer.

All activity concerning removing Scalar DLC software is described in Add/Remove Scalar DLC Software on 
page 81

Table 14 Email Registration Form

Name Operation Description

From: Enter ‘From’ email address

To: Enter ‘To’ email address (list of addresses)

Subject Supplied Not changeable. Email ‘Subject’.

SMTP Server Enter The SMTP server name must be set here

Port Enter The SMTP server port must be set here.

Send Click Send email.

Exit Click Return to the previous dialog without sending email.
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DAS Client
The DAS Client software allows the customer to use DAS interface with the Scalar DLC.

Installing DAS Client

The DAS Client software will be completely functional after the following configuration steps.

Step 1 Install the Scalar DLC software with the DAS support on the server PC. See Scalar DLC 
Software on page 50. The server PC requires a restart.

Step 2 Start the Management GUI. Create the library configuration that the client requires. Create the 
required mailboxes and clean/scratch pools. Create a DAS client and assign it to the created 
library. Refer to the Scalar DLC Reference Guide, Configuration chapter.

Step 3 Install the client application on the client PC.

• Figure 34 shows the DAS Client components selection during the installation of Scalar DLC DAS 
Client software.

Figure 34 Select Scalar DLC DAS Client Components
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• The installation will place the selected components in the 
<%SystemDrive%>\Program Files\ADIC\SDLC\ directory. Change the destination folder if it 
is required.

• The DAS Administration Utility should be installed on a PC that will run the DAS Client software. 
See Installing the DAS Administration Utility on page 67.

• If there is a firewall between the Scalar DLC (server) host and the client host, the DAS/ACI firewall 
software should be installed on a PC inside the firewall. See Installing the DAS/ACI Firewall on page 
68.

• Figure 35 illustrates the typical network structure.

Figure 35 Scalar DLC DAS Client Network

• The installation configures appropriate server, client, and media type values (see Table 15).

Note The DAS/ACI firewall software can be installed directly on Scalar DLC host. In case of 
the Redundant solution, it should be installed on both cluster nodes.

Table 15 DAS Variables

Variable Explanation

DAS_SERVER Network names (TCP/IP) of the server which are accessed by the dasadmin 
program. Both names are entered separated by a comma, only when installing 
dual DAS. The names must be resolvable on the computer into TCP/IP 
addresses.
For the firewall connection, the DAS/ACI Firewall PC name is used here.

DAS_PORT A port being used to send DAS commands (for the firewall connection only).

DAS_CLIENT Name of the client under which the DAS PC is to access the server. The name 
must be defined in the Scalar DLC database. 

ACI_MEDIA_TYPE Default media type selected when using dasadmin if the parameter -t is omitted 
from the command. See DAS Administration Guide for the details.

Note These variables can be also set manually. This is very useful when several DAS Clients 
have to share one client host.
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• Once the variables are set, the restart is requested. ADIC recommends accepting the restart so that 
the Scalar DLC DAS-Client software works properly.

Step 4 After the configuration is complete, the Scalar DLC software is ready to accept commands from 
a DAS client.

Installing the DAS Administration Utility
The connection settings must be entered during the installation of the dasadmin software. See Figure 36 for 
a firewall-based connection and see Figure 37 on page 68 for a direct (firewall-free) connection.

Figure 36 DAS Client Connections Using Firewall

Property Operation Description

DAS Client 
connection

Select Not using firewall should be selected if there is no firewall between the 
client host and the Scalar DLC host.

Using DAS/ACI firewall should be selected if a firewall exists between 
the client host and the Scalar DLC host.

DAS/ACI 
firewall 
server name

Enter Name of the PC where the DAS/ACI Firewall software is installed 
(shown for Using DAS/ACI firewall selection only).

Port Enter The firewall port (shown for Using DAS/ACI firewall selection only).

Scalar DLC 
server name

Enter The Scalar DLC server name (shown for Not using firewall selection 
only).

DAS Client 
name

Enter The default DAS Client name. Refer to Table 15 on page 66.

ACI Media 
type

Select The default ACI media type. Refer to Table 15 on page 66.
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Figure 37 DAS Client Connection without Firewall

Installing the DAS/ACI Firewall
If there is a firewall between the Scalar DLC host and the client host, the DAS/ACI firewall software should 
be installed on the PC inside the firewall; this PC can be the Scalar DLC host itself. See Figure 35 on page 
66.

Launch the DAS Client installation and when the component selection screen appears (see Figure 34 on 
page 65), select a DAS/ACI Firewall component. See Figure 38 on page 69 for a DAS/ACI Firewall settings 
screen.

Note If the connection type is specified incorrectly, the DAS Client software will install 
successfully but the connection with the Scalar DLC host cannot be established.

Note The DAS/ACI firewall software can be launched only under Windows or OS/2 platforms.
68 DAS Client



Figure 38 DAS/ACI Firewall

After the DAS/ACI firewall is installed, the restart is requested. A new software service DAS-ACI Firewall 
appears in system services list.

Removing DAS Client

Using Add-Remove Software, launch Scalar DLC DAS Client and remove the software.

Property Operation Description

Scalar DLC host name Enter The Scalar DLC server name.

Port Enter The firewall port to receive client commands.
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SCSI/FC Target Drivers
The Scalar DLC software uses some SCSI and/or Fibre Channel adapters in Target mode to provide the 
customer access to the Scalar DLC via the SCSI.

SCSI and Fibre Channel Hardware

The SCSI and/or Fibre Channel adapters must be installed into the PCI-type slots as shown in Table 18 on 
page 72.

Before connecting SCSI Initiator (Scalar DLC / client host) and Target (Medium changer / Scalar DLC host) 
adapters with the SCSI cable, be sure that they match each other. See Table 16 for a description of adapters 
that are currently supported and see Table 17 on page 72 for a match description.

CAUTION Connecting two adapters that do not match will cause hardware damage.

Table 16 SCSI and Fibre Channel Adapters

Adapter Type Connection (external) Max cable length, m

LSI 20860 SCSI 50-pin high density SE 5

LSI 8751D SCSI 68-pin high density HVD 25

LSI 8951U
LSIU80LVD

SCSI 68-pin very high density 
LVD/SE

12(LVD)
5(SE)

QLA 2200 Fibre Channel SC duplex multi-mode -

QLA 2300
QLA 2310
QLA 2340
QLA 2342

Fibre Channel Small form factor multi-mode 
optic LC

-

Local SCSI a

a. The driver is designed by ADIC to execute the SCSI backup applications right on the PC where the Scalar DLC software 
is installed. No SCSI/FC hardware is required in this case.

SCSI - -
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The supported Fibre Channel adapters do match each other.

Two-channel Adapters
Some adapters are designed as two-channel model so they are recognized by OS as two single-channel 
adapters. Device Manager shows two adapters, their Properties are, for example, PCI slot 2, Bus 1, 
Function 0 and PCI slot 2, Bus 1, Function 1 (note that the only difference is Function value).

For the Scalar DLC it means that it is technically possible to use single two-channel SCSI/FC adapter in 
both Initiator mode (Channel A / Port 1 - Function 0) to connect to the library medium changer, and in Target 
mode (Channel B / Port 2 - Function 1) to connect to the SCSI Client host (see Figure 39 on page 73). And 
of course, such two-channel adapters can be used for two different SCSI Clients, as if these clients were 
connected to the two different SCSI/FC target adapters, or as two single-channel initiator adapters if 
required.

Note The Local SCSI Target driver (powered by ADIC) is added for emulation the SCSI Target 
features on a PC without appropriate SCSI adapter. In the Management GUI, under the 
SCSI Target tab, the Local SCSI Target port appears, so the Target objects can be 
created and assigned to the SCSI Clients. 
However, this port is not reflected in the SCSI Target Port Tool because this utility shows 
only adapters that could operate either as Initiators or as Targets. Local SCSI Target 
only emulates the adapter port and sure cannot operate in Initiator mode.

Table 17 Parallel SCSI Match 

Adapter Class Matched

Single-ended (SE) SE, SE/LVD

Low voltage differential (LVD) LVD, SE/LVD

SE/LVD SE, LVD, SE/LVD

High voltage differential (HVD) HVD

Table 18 SCSI/FC Adapters and PCI slots

Controller PN Slot 1 Slot 2 Slot 3

Standard 
3-01632-01

Adaptec 39160 
(library)

Any target adapter (see Table 
16 on page 71)

Dual 
3-01632-02

Adaptec 39160 
(RAID and library) a

a. Adaptec 39160 is a two-channel SCSI adapter (see Two-channel Adapters on page 72) that is not used in Target mode.

Any target adapter (see Table 
16 on page 71)

Standard 
3-01632-03

Adaptec 39160 
(library)

QLA 2340 / 42 Any target adapter (see Table 
16 on page 71)

Dual 
3-01632-04

Adaptec 39160 
(RAID)

QLA 2342 (library) Any target adapter (see Table 
16 on page 71)
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Figure 39 Two-channel Adapter used for both library and client

The following adapters that Scalar DLC supports in Target mode are two-channel:

• QLA 2342

Using FC adapters as Initiators to connect to the library medium changer requires additional setup which is 
described in Host/Library Communication using Fibre Channel and SNC on page 127.

Initiator Driver

The Initiator driver can be installed before installing Scalar DLC software of after this operation as well. 
However, it should be done before installing SCSI Target drivers.

For each SCSI adapter found during the Windows setup and/or startup, the operating system usually installs 
the Initiator mode driver. However, for the newest adapter models, there can be trouble finding an 
appropriate driver because they are not present in a standard driver library. If such a problem encountered, 
follow the steps below.

Step 1 Be sure that you have a manufacturer disk with the appropriate software driver for your adapter, 
or you have downloaded this driver from the manufacturer’s web-site to the temporary folder. 
ADIC also offers all the required drivers at the 
<%Scalar DLC Install_CD%>\Drivers\Initiator folder.

Step 2 During setup/startup, the Windows 2000 / 2003 system opens Found New Hardware wizard. 
Follow the wizard steps. Specify a driver location (disk or temporary folder) so that the system 
can install it.

Step 3 After Windows 2000 / 2003 startup, right-click on My Computer desktop icon, select Manage 
and launch Device Manager system tool. Locate the Other Devices group and the SCSI 
adapter. Open the properties for the required device, select Driver tab and click Update Driver. 
Follow the Upgrade Device Driver Wizard steps. Specify a driver location (disk or temporary 
folder) so that the system can update it.

Step 4 Repeat the steps above for each SCSI and Fibre Channel adapter that is not properly 
configured by the system.

Step 5 Re-start the PC if it is required.

The Target mode drivers now can be installed. Refer to Installing the SCSI/FC Target Drivers on page 74.

Note Follow the instructions only if there is no proper Initiator mode driver(s) present in the 
system. When everything works, there is no need to re-install the drivers manually.
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Installing the SCSI/FC Target Drivers

The SCSI Target Mode Driver installation installs the Target driver for the SCSI/Fibre Channel Adapter(s) 
present on PC.

Figure below shows the Setup Start window of the SCSI Target software.

Figure 40 SCSI Target Start Setup

Click Next to proceed.

Note If the SCSI Target Mode Driver installation is launched on a PC with the installed target 
drivers from a previous version (for example, 2.4), the install engine will remove the old 
drivers. See Add/Remove SCSI Target Drivers on page 78.

CAUTION
If there is a Virtual SCSI Target Mode Driver installed, it should be removed before 
the SCSI Target Mode Driver installation. This can be done from Control Panel > 
Add-Remove Programs.

Note There should be the Initiator driver(s) activated in the system before the Target driver(s) 
are installed. See Initiator Driver on page 73 for the details.
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Figure 41 SCSI Target Licensing

Accept the ADIC License Agreement and click Next to proceed.

Figure 42 Personal Information

Enter the customer’s personal information. See Table 6 on page 51 for the meaning and required operation 
of the fields. Click Next to proceed.
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Figure 43 Driver Selection

Click the driver to select it. See Table 19 for driver selection details and Table 16 on page 71 for SCSI and 
Fibre Channel adapters.

When the Local SCSI Target driver is installed, the following warning screen appears.

Figure 44 Local SCSI Target: No SIgnature

Press Yes and continue the installation: ADIC Local SCSI Target driver is not certified by Microsoft, no other 
failures in it are known currently.

Table 19 Driver Selection

Name Operation Description

Drivers Check Mark/unmark the driver for installation.
See Table 16 on page 71 for a description of SCSI and Fibre 
Channel adapters that could be used in the system.

Feature Description Supplied Driver name and disk requirements.
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After the successful installation, if no additional configuration steps are required, the computer must be 
restarted.

Activating Target Mode

On the toolbar there will be a small three-penguin icon. Right click this icon and select Tools > Scalar DLC 
SCSI Target Port Tool.

Figure 45 Access to SCSI Target Port Tool

The SCSI Target Port tool opens. 

Figure 46 SCSI Target Port Tool: adapter disabled

Click Enable to enable the required SCSI Adapter(s) (as in the figure below).

Note After rebooting, the adapters that should operate in Target mode are disabled. To enable 
them, use the SCSI Target Port Tool. See Activating Target Mode on page 77.

Note The two-channel adapters are shown in the SCSI Target Port Tool as two different 
single-channel adapters. See Two-channel Adapters on page 72.
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Figure 47 SCSI Target Port Tool: adapter enabled

(only for the Fibre Channel) Click Advanced to resolve the virtual World-Wide Name (WWN) and make the 
adapter available for the Failover (cluster) mode work if it is required.

Figure 48 FC Adapter Advanced properties

After enabling the adapter(s) and exiting the SCSI Target Port Tool, reboot if it is prompted.

Figure 49 Reboot after change SCSI Target properties

Add/Remove SCSI Target Drivers

To remove, modify, or repair the installed Target drivers, use the Add/Remove build-in system engine 
(Control Panel > Add/Remove Programs > SCSI Target Mode Drivers).

The same engine should be used in order to perform an upgrade of the SCSI Target Mode Drivers from a 
previous version.

Step 1 Load the Scalar DLC Install CD. The autostart screen will appear.

Step 2 Launch the SCSI Target driver installation. The Add/Remove SCSI Target wizard will appear.

Note Before removing Target drivers, return the appropriate SCSI adapters to the Initiator 
mode, that is, disable them as Targets via the SCSI Target Port Tool. Refer to SCSI 
Target Port Tool section in the Utilities chapter of the Scalar DLC Reference Guide.
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Step 3 Select Remove to delete old target drivers installed on PC. Proceed until the remove engine will 
request to restart PC.

Step 4 After reboot, open the autostart screen again. Launch the Scalar DLC installation (see Scalar 
DLC Software on page 50) to install both the Scalar DLC software and appropriate SCSI Target 
drivers. 
If the Scalar DLC is installed already, launch only the SCSI Target driver installation (see 
Installing the SCSI/FC Target Drivers on page 74).
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Upgrade, Remove, Repair
• Add/Remove Scalar DLC Software on page 81 holds the basic instructions on Update, Remove, or 

Repair the Scalar DLC software.

• Upgrading the Scalar DLC on page 86 contains the detailed Upgrade instructions.

• Renaming and Repair on page 97 contains the detailed Repair instructions.

Add/Remove Scalar DLC Software

To add/remove the Scalar DLC software components launch: Control panel > Administrative Tools > 
Add-Remove Programs > Scalar DLC. This will run the Scalar DLC Add/Remove engine used to repair, 
modify, or remove the Scalar DLC software installed on the PC.

CAUTION
For the Failover and Self-domain solution make sure that the Add/Remove is 
launched on the active node. If not, cancel the operation, move Cluster group 
ownership to the current node, and start Add/Remove engine again.

Note Before removing Scalar DLC software from any cluster node, launch SDLC Cluster 
Configurator and remove cluster configuration from the Scalar DLC resources (Remove 
button).

Note Local administrator rights are required to execute this procedure. Domain administrator 
rights are required if the Scalar DLC is installed under domain account and/or as the 
failover or self-domain solution.

Note The additional Repair instructions can be found at Renaming and Repair on page 97.
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Figure 50 Starting the Scalar DLC Add/Remove

Click Next to proceed to the following screen.

Figure 51 Modify/Repair/Remove

Specify the activity type and click Next to proceed.

Remove

The Remove process deletes all of the Scalar DLC software features except for the Scalar DLC account 
name and password that were set up during installation.

CAUTION
After removing the Scalar DLC software, always remove its SCSI Target 
drivers, too. See Add/Remove SCSI Target Drivers on page 78.
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Figure 52 Saving the Database

The Scalar DLC database can be either removed, or saved for future use. Click Next to proceed to the 
remove and the final screen.

Software programs such as Java2, Apache, MS IE, MSDE 2000, and so forth, are not removed and should 
continue to function normally. The Remove process also restores the old web server configuration software.

Repair
The Repair process allows the user to repair the damaged Scalar DLC configuration without re-installing the 
software.

Figure 53 Repair Options

Note To remove the software packages that are required by the Scalar DLC, use Control 
panel > Add-Remove Programs.
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Choose either the Server option to repair damaged Scalar DLC software components (see Server on page 
84), or Database option to repair the damaged Scalar DLC database (see Database on page 85). Click Next 
to proceed.

Server

The Repair Scalar DLC Server process allows to re-register the Scalar DLC software components under 
new user account without re-installing them. This section has been added to avoid problems concerning the 
changes of user account name/password. This section also allows to repair the installed Scalar DLC 
software after the PC is renamed.

Figure 54 Repair Server Options

Select the repair options and click Next to proceed. See Table 20 for details.

If the Computer renaming mode is selected, the Repair checks all needed software components. If no 
software upgrade needed, the Repair process proceeds to the user account section. See User Account on 
page 84.

User Account

The repair user account screens look exactly the same as the user account creation screens appear during 
the Scalar DLC installation. See Figure 20 on page 52 for the local account, and Figure 21 on page 53 for 
the domain account.

See Table 7 on page 52 for the user account settings.

Table 20 Repair Options

Name Operation Description

Computer 
renaming

Check Repair the Scalar DLC software after the computer has been renamed. 
The Scalar DLC user account is also repaired.

Repair user 
account

Check Repair the damaged Scalar DLC user account. See User Account on 
page 84.
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If the account name already exists and the password does not match the existing account’s password, the 
User Account warning appears. See Figure 22 on page 53. Go back and specify correct password, or 
another user account.

If the account is repaired successfully, the Component Registration window appears. See Figure 23 on page 
54.

Database
The Repair Scalar DLC Database process allows the user to repair the damaged Scalar DLC database. It 
contains the same database upgrade engine as the Scalar DLC installation and offers the same 
functionality.

Figure 55 Repair Database

Choose either the “recreate database” option to acquire the new, clean database, or “upgrade” option to 
update existing database according to current standards (the upgrade details are described at Table 9 on 
page 56). Click Next to proceed to the upgrade and the final screen.

Modify
The Modify process allows to add or remove a number of Scalar DLC software features and to install the 
necessary software drivers. All changes will be applied only after system restart.

Note To repair the Scalar DLC installed under a domain account, the domain administrator 
rights are required.
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Figure 56 Modifying the System

During the installation process, all files are written to the hard drive but do not appear at startup on the 
configuration list. All of these files can be accessed and activated in the Modify process mode. It is allowed 
to add, register, or un-register the Scalar DLC software features that are the parts of the SCSI, or ROBAR, 
or DAS-interface. The un-register procedure leaves the software written on the hard drive but makes it 
inaccessible to the user.

After Add/Remove process is finished, ADIC recommends restarting the PC.

Upgrading the Scalar DLC

Although the upgrade engine is a part of Scalar DLC installation, some additional actions may be required. 
Depending on the configuration used, see Simple Upgrade on page 88 or Advanced Upgrade on page 92. 
The instructions on which upgrade type is more preferable are located in Using Database from a Previous 
Version on page 86 and Upgrading from 2000 to 2003 on page 87. Note also the Upgrade Issues on page 
96.

Using Database from a Previous Version

If the customer has worked before with the older version of the Scalar DLC software, an upgrade must be 
performed in order to import the old database content to the new version. Use Table 21 to select the correct 
upgrade method.

Note The SCSI Client software feature cannot be installed completely without SCSI hardware 
(the SCSI/FC adapter) being present on the PC.

Note The Advanced Upgrade can be used always, however sometimes it is possible to use 
the Simple Upgrade method.
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Upgrading from 2000 to 2003
Plain upgrading the Scalar DLC from 2000 to 2003 platform is not supported, so if the customer wants to 
perform such operation, the setup order should be following:

Step 1 Backup the database to RAID disk, network resource or floppy (see Back up Scalar DLC 
Database).

Step 2 Install the Scalar DLC 2.6 from scratch on Windows 2003 platform (see Setting Up the Scalar 
DLC on page 7). Note that RAID needs no initialization in this case.

Step 3 Perform Recover database from old backup on page 115.

Table 21 Database Upgrade Methods 

Old Database Version Old Solution New 
Solution Preferable Upgrade Method

2.1
Standard Standard Advanced Upgrade on page 92.

Failover Advanced Upgrade on page 92.

2.2, 2.2 SP1, 2.2 SP2, 2.2 
SP3

Standard Standard Advanced Upgrade on page 92.

Failover Advanced Upgrade on page 92.

2.3, 2.3 SP1, 2.3 SP2

Standard Standard Advanced Upgrade on page 92.

Failover Advanced Upgrade on page 92.

Failover Standard Advanced Upgrade on page 92.

Failover Advanced Upgrade on page 92.

2.4

Standard Standard Simple Upgrade on page 88.

Failover Advanced Upgrade on page 92.

Failover Standard Advanced Upgrade on page 92.

Failover Simple Upgrade on page 88.

2.5, 2.5 SP1, 2.5 SP2

Standard Standard Simple Upgrade on page 88.

Failover Advanced Upgrade on page 92

Failover Standard Advanced Upgrade on page 92

Failover Simple Upgrade on page 88.

2.6

Standard Standard Simple Upgrade on page 88.

Failover Advanced Upgrade on page 92

Failover Standard Advanced Upgrade on page 92

Failover Simple Upgrade on page 88.
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Simple Upgrade
Follow this sequence to install the Scalar DLC on the host where the older version of the Scalar DLC 
software is working.

Step 1 (For Scalar DLC ver. 2.1 only; for other versions, skip this step.) 
Verify the current SCSI Target assignment. Log into the Scalar DLC Manager GUI (Start > 
Programs > ADIC Distributed Library Controller > Scalar DLC Manager) and look under 
SCSI Target > SCSI Management. Note which SCSI target cards are assigned to SCSI target 
IDs.

Step 2 (For Failover solution only; for Standard solution, skip this step.) 
Remove Scalar DLC Cluster configuration.

• Insert Scalar DLC Install CD. Close Autorun. Run 
<CD>:\Scalar_DLC\Cluster\SDLC_ClusterConfig.exe.

• Click Remove SDLC Cluster Configuration button. “OK” when complete

Step 3 Using Add-Remove Programs remove all following components.

• Remove all Scalar DLC Hot Fixes (mentioned separately from Scalar DLC itself) in descending 
order. Do not reboot now.

• Remove DAS Client software (if installed), as described in Removing DAS Client on page 69, and 
SCSI Target Drivers, as described in Add/Remove SCSI Target Drivers on page 78. Do not reboot 
now.

• Initiate the install process for Scalar DLC. This will start by removing old release. During this 
process the system prompts, “Delete the Scalar DLC MS SQL Server database ‘SDLC’.” Select 
“No.” (see Figure 57). This will preserve the configuration currently running on the Scalar DLC 
machine. Be sure to save the database so that it can be applied to the new release. Do not reboot.

CAUTION
It is strongly recommended to backup the Scalar DLC database to a file on a 
network resource or a floppy disk before launching Scalar DLC removing. If 
the Simple upgrade procedure fails, this backup file can be later used for the 
Advanced upgrade, as described in Advanced Upgrade on page 92.

Note The instruction below is applied for both Standard and Failover solutions. Unless the 
other is specified, each operation is assumed to be executed on Node1.
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Figure 57 Remove old Scalar DLC: do not delete the database

• (optional) Remove Apache and Java. The newer/latest versions will be installed with the Scalar 
DLC 2.6.

• Reboot.

Step 4 (For Failover solution only; for Standard solution skip this step.) 
Repeat Step 3 on page 88 for the Node2.

Step 5 Insert Scalar DLC 2.6 Install CD. Install the Scalar DLC and all required components, as 
described in Installing the Scalar DLC on page 45.

• Follow the Scalar DLC installation sequence.

• During the installation of latest release the system informs that a database exists and requests 
whether the existing ‘SDLC’ database should be upgraded. Select “Upgrade” (see Figure 58) and 
proceed.

• (For Failover solution only; for Standard solution skip this substep.) 
When the Scalar DLC is installed on Node2, select “Use existing database“ and proceed.

Note It is recommended also to check <%SystemDrive%>\Program Files\ afterwards. If 
Java and Apache folders are not removed, remove them manually.
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Figure 58 Install Scalar DLC: Upgrade database

• (optional) Install the required SCSI Target drivers (see Installing the SCSI/FC Target Drivers on 
page 74). Then configure/activate the SCSI/FC Target adapter(s) via SCSI Target Port Tool, as 
described in Activating Target Mode on page 77.

• (optional) Install DAS Client software if required (see Installing DAS Client on page 65).

• Reboot the PC.

Step 6 (For Failover solution only; for Standard solution skip this step.) 
Repeat Step 5 on page 89 for the Node2.

Step 7 (For Failover solution only; for Standard solution skip this step.) 
Restore Scalar DLC Cluster configuration.

• Insert Scalar DLC Install CD. Close Autorun. Run 
<CD>:\Scalar_DLC\Cluster\SDLC_ClusterConfig.exe

• Click Make SDLC Cluster Configuration button. “OK” when complete.

Step 8 Launch the Scalar DLC Manager (Start > Programs > ADIC Distributed Library Controller 
> Scalar DLC Manager).

Step 9 (For upgrade from Scalar DLC ver. 2.1 only, otherwise skip this step.) 
Resolve Port-Target assignment.

• Log on as ‘admin’. Above the main Management GUI the SCSI configuration pop-up screen 
appears.
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Figure 59 SCSI Configuration Screen

• Set the associations between Targets and Ports. Use the << button to associate Target with Target 
port. Remember that the customer may have multiple SCSI Targets. 
Each Target will have LUN 0; in case when a SCSI client exist for the target, the LUN 0 will be active 
with a client assigned to it.

Figure 60 SCSI configuration: assign target(s) to port(s)

• After this is completed, click OK. A pop-up confirmation window opens.

Figure 61 Confirmation to Restart Scalar DLC

• Close the Scalar DLC Manager. Right-click on the three-penguin icon on the toolbar and select 
‘Stop Scalar DLC’.

Figure 62 Access to Stop Scalar DLC

Note The two-port adapters are shown in the Management GUI as two different single-port 
adapters.
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• The Scalar DLC software service will be stopped.

Figure 63 Scalar DLC is successfully stopped

• Re-start Scalar DLC using the Scalar DLC icon on the toolbar.

Figure 64 Access to Start Scalar DLC

• After a successful start an appropriate message displays.

Figure 65 Scalar DLC is successfully started

Step 10 When the upgrade is complete verify that all target cards are correctly assigned and work ok.

Advanced Upgrade

Follow these steps to perform the upgrade of the Scalar DLC software on any PC and/or to restore the 
Scalar DLC configuration from an old version of the software.

Step 1 Before removing the old release: backup an old database and keep it.

• On the toolbar there will be a small Three Penguin Icon. Right click this icon and select Tools > 
Scalar DLC DB Tool.

Note Only the Advanced upgrade procedure can restore the Scalar DLC configuration from 
standard (basic) to failover (redundant) solution, or vica verse.

Note The instruction below is applied for both Standard and Failover solution. Unless the 
other is specified, each operation is assumed to be executed on Node1.
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Figure 66 Access to DB Tool

• Launch Scalar DLC DB Tool and log on (see Figure 67). If the Scalar DLC database has been 
installed under Trusted connection, only the local admin rights are required. If the Scalar DLC 
database has been installed under user account, either the SQL administrator logon name/
password, or the Scalar DLC SQL user name/password are required.

Figure 67 DB Tool Log On

• Backup the database to file (for example, "OldSDLC.db"). Keep this file in any temporary folder or 
at floppy disk.
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Figure 68 Backup Database

Step 2 (For Failover solution only; for Standard solution skip this step.) 
Remove Scalar DLC Cluster configuration.

• Insert Scalar DLC Install CD. Close Autorun. Run 
<CD>:\Scalar_DLC\Cluster\SDLC_ClusterConfig.exe

• Click Remove SDLC Cluster Configuration button. “OK” when complete

Step 3 Using Add-Remove Programs remove all following components.

• Remove all Scalar DLC Hot Fixes (mentioned separately from Scalar DLC itself) in descending 
order. Do not reboot now.

• Remove DAS Client software (if installed), as described in Removing DAS Client on page 69, and 
SCSI Target Drivers, as described in Add/Remove SCSI Target Drivers on page 78. Do not reboot 
now.

• Remove the old release of Scalar DLC with the database. Do not reboot now.

• Remove Apache, Java, and MS SQL 7.0. The newer/latest versions will be installed with the Scalar 
DLC 2.6.

• Reboot the PC.

Note It is recommended also to check <%SystemDrive%>\Program Files\ afterwards. If 
Java and Apache folders are not removed, remove them manually.
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Step 4 (For Failover solution only; for Standard solution skip this step.) 
Repeat Step 3 on page 94 for the Node2.

Step 5 Insert Scalar DLC 2.6 Install CD. Install the Scalar DLC and all required components, as 
described in Installing the Scalar DLC on page 45.

• Install Java and Apache. Install MSDE 2000 if required (note that MSDE must be installed on RAID 
disk for the failover solution, use ‘specified’ and ‘R:”).

• Follow the Scalar DLC installation sequence till the Scalar DLC is installed with a new, clean 
database.

• (For Failover solution only; for Standard solution skip this substep.) 
When the Scalar DLC is installed on Node2, select “Use existing database“ and proceed.

• (optional) Install the required SCSI Target drivers (see Installing the SCSI/FC Target Drivers on 
page 74). Then configure/activate the SCSI/FC Target adapter(s) via SCSI Target Port Tool, as 
described in Activating Target Mode on page 77.

• (optional) Install DAS Client software if required (see Installing DAS Client on page 65).

• Reboot the PC.

Step 6 (For Failover solution only; for Standard solution skip this step.) 
Repeat Step 5 on page 95 for the Node2.

Step 7 (For Failover solution only; for Standard solution skip this step.) 
Restore Scalar DLC Cluster configuration.

• Insert Scalar DLC Install CD. Close Autorun. Run 
<CD>:\Scalar_DLC\Cluster\SDLC_ClusterConfig.exe

• Click Make SDLC Cluster Configuration button. “OK” when complete.

Step 8 Restore the Database from Backup.

• Stop Scalar DLC supervisor (see Figure 62 on page 91). Launch Scalar DLC DB Tool (see Figure 
66 on page 93).

• Log on the DB Tool (see Figure 67 on page 93). Open Restore tab and restore database from 
device (that is, from backup file "OldSDLC.db"), as shown in Figure 69 on page 96.
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Figure 69 Restore Database from Backup file

• Launch Add/Remove Scalar DLC > Repair > Repair database mode (see Figure 55 on page 85). 
Select "Upgrade".

• When upgrade is finished, restart PC.

Step 9 Launch Scalar DLC Management GUI. If required, re-configure SCSI targets and LUNs (see 
Figure 59 on page 91 and Figure 60 on page 91).

Upgrade Issues
When the upgrade is performed always check whether all names are correctly mapped and all SCSI adapter 
models used in previous versions of the Scalar DLC software are still supported. Remove old SCSI client(s) 
and create new client assigned to an old library if it is required. Executing the complete inventory is strongly 
recommended afterwards to maintain the database integrity.

Installing Scalar DLC Service Packs
The Scalar DLC service pack usually comes on its own CD with its own build-in autorun.

Note that the service pack may contain fixes with features not documented in the Scalar DLC Reference 
Guide, so always check the readme and release notes that can be found on the Scalar DLC Service Pack 
CD.

Note Do not start Scalar DLC software at this time. It will not be functional.
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Standard Solution

Step 1 Close Management GUI and Event log. Stop Scalar DLC.

Step 2 Select Start > Programs > Apache HTTP Server > Control Apache server >> Stop.

Step 3 Insert CD for Scalar DLC Service Pack. Select Install and Next and Next

Step 4 Select Yes to restart and Finish.

Step 5 Remove Scalar DLC SP CD. Restart.

Failover and Self-Domain Solution

Step 1 Shutdown Node2. Close Management GUI and Event log on Node1. Take Scalar DLC offline.

Step 2 Select Start > Programs > Apache HTTP Server> Control Apache server >> Stop.

Step 3 Insert CD for Scalar DLC Service Pack. Select Install and Next and Next. Select Yes to restart 
and Finish.

Step 4 Remove Scalar DLC SP CD. Shutdown Node1.

Step 5 Start Node2. Repeat steps 2 - 4 for Node2.

Step 6 Start up Node1 then start up Node2.

Renaming and Repair

ADIC strongly recommend against renaming the PC or rebuilding the PC network configuration after the 
Scalar DLC is successfully installed and configured. Such actions, however, may be necessary, and require 
the update of most software installed on the appropriate hosts.

When the Scalar DLC Standard solution is installed, after the PC is renamed and/or the network 
configuration is changed, launch the Scalar DLC Repair engine. See Add/Remove Scalar DLC Software on 
page 81 and Repair on page 83.

For the Scalar DLC Failover and Self-domain solution the following additional procedures are required:

• Change Cluster IP Address and Domain Name on page 98.

CAUTION Install only the latest Service Pack, as it includes the previous, too.

Note The data in this section is valid for all latest Service Pack that will come after the released 
version of Scalar DLC. The latest version is 2.6.

CAUTION
After the Scalar DLC Database is restored from a backup file created before 
the service pack installation, always re-install the service pack again. 
Otherwise the Scalar DLC will not be functional.
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• Change Scalar DLC Node Names on page 100.

• Change Cluster Name on page 102.

Note also the following

• Startup and Shutdown on page 108.

• Back up Scalar DLC Database on page 109.

• Restore Scalar DLC Database on page 109.

• Updating Drivers on page 110.

• Failure Recovery on page 112.

Change Cluster IP Address and Domain Name

Step 1 Shutdown both nodes then power on Node1 and log in as Administrator for SDLC1 (this 
computer)

Step 2 Set public (mixed network) properties on Node1.

• Right click My Network Places and select Properties. Right click “public” and select properties. 
Select Internet Protocol (TCP/IP) and select Properties.

• Set IP Address to <new ip address> (208.230.5.1 in lab).

• Set Subnet mask.

• Set Preferred DNS Server to <new DNS ip address> (208.230.5.4 in lab)

• OK and OK.

• (For Windows 2000 only; for Windows 2003 skip this substep.) 
Right click “public” and “Disable” then right click and “Enable”. Rename “public” if necessary.

• Right click My Computer and select Properties. Select Network Identification tab and Properties. 
Select “More Box” and Remove the “Primary DNS” suffix and “OK”.

• Enter Domain Name without postfix and OK (customerdomain)

• Enter name and Password for Domain user Account and OK (customeracct and customerpass)

• OK when welcome to domain appears

• OK to reboot computer to take affect.

• OK in System Properties and Yes to restart computer

Step 3 Manage New Account on Node1.

• Log on Node1 as Administrator for SDLC1 (this computer)

• Right click My Computer and select Manage.

CAUTION
After either the DNS, or the name of cluster, or the names of cluster nodes 
are changed, and after the Scalar DLC software is successfully started, 
inform the customers who use the client interfaces (DAS or ROBAR) to work 
with the Scalar DLC as a server. The client environment variables (for 
example, DAS_SERVER) may require an update.

The SCSI-based clients do not require update and can start the work as soon 
as the Scalar DLC configuration is complete.
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• Select “Local Users and Groups” and “Groups”. Right click Administrators and select Add to Group 
and Add.

• Look in <domain name.com>.

• Connect as <UserName> and <Password> and OK (customeracct in lab)

• Select <username [username@domainname.com]> (customeracct 
[customeracct@customerdomain.com]). Add and OK.

• Apply and Close and Shutdown Node1

Step 4 Power on Node2 and log in as Administrator for SDLC2 (this computer)

Step 5 Set ‘public’ (mixed network) properties on Node2.

• Right click My Network Places and select Properties. Right click “public” and select properties. 
Select Internet Protocol (TCP/IP) and select Properties.

• Set IP Address to <new ip address> (208.230.5.2 in lab).

• Set Subnet mask.

• Set Preferred DNS Server to <new DNS ip address> (208.230.5.4 in lab)

• OK and OK.

• (For Windows 2000 only; for Windows 2003 skip this substep.) 
Right click “public” and “Disable” then right click and “Enable”.

• Right click My Computer and select Properties. Select Network Identification tab and Properties. 
Select “More Box” and Remove the “Primary DNS” suffix and “OK”.

• Enter Domain Name without postfix and OK (customerdomain)

• Enter name and Password for Domain user Account and OK (customeracct and customerpass)

• OK when welcome to domain appears

• OK to reboot computer to take affect.

• OK in System Properties and Yes to restart computer

Step 6 Manage New Account on Node2.

• Log on Node2 as Administrator for SDLC2 (this computer)

• Right click My Computer and select Manage.

• Select “Local Users and Groups” and “Groups”. Right click Administrators and select Add to Group 
and Add.

• Look in <domain name.com>.

• Connect as <UserName> and <Password> and OK (customeracct in lab)

• Select <username [username@domainname.com]> (customeracct 
[customeracct@customerdomain.com]). Add and OK.

• Apply and Close and Shutdown

Step 7 Set Cluster Account on Node1.

• Power on Node1 and log in as Administrator for SDLC1 (this computer)

• Open My computer > Control Panel > Administrative tools > Services. Right click Cluster Service 
and select Properties and select Log On tab
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• Set This Account to customerdomain\customeracct. Set Password and Apply

• OK to granted rights to log on and OK

• Right click cluster service and Select Start.

Step 8 Set Cluster Account on Node2.

• Power on Node2 and log in as Administrator for SDLC2 (this computer)

• Open My computer > Control Panel > Administrative tools > Services. Right click Cluster Service 
and select Properties and select Log On tab

• Set This Account to customerdomain\customeracct. Set Password and Apply

• OK to granted rights to log on and OK

• Right click cluster service and Select Start.

Step 9 Set Cluster IP Address

• On Node1 select Start > Programs > Administrative tools > Cluster administrator

• Select groups and cluster group. Right click Cluster IP Address and Properties and Parameters tab

• Set IP to <cluster IP address> (208.230.5.3 in lab)

• Set subnet mask

• Set Network to “public” and Apply

• Yes to validate subnet mask and OK

• Right click Cluster IP address and Bring Online

• Right click Cluster Name and Bring Online

Change Scalar DLC Node Names

Step 1 Have both Scalar DLC computers powered up. Use the Passive node (SDLC2).

Step 2 Rename Node2

• Right click My Computer and select Properties. Select Network Identification tab and Properties.

• Enter New computer name and OK (SDLC22). Enter name and password for User account 
(customeracct/customerpass)

• OK and OK to reboot OK to System Properties and Yes to restart now

• On Active Node1 select Start > Programs > Administrative Tools > Cluster Administrator. Open 
Cluster. Right click Node2 and “Evict node”. Yes to Evict.

• Shutdown Node1. Log on Node2 as Administrator for SDLC2 (this computer)

• Open My Computer > Control panel > Add/Remove Programs > Add/Remove Windows 
Components.Unselect Cluster Services and Next and Finish and Yes to restart

Step 3 Join Renamed Host to Cluster

• Log on Node2 as Administrator for SDLC22 (this computer). Right click My Computer and select 
Manage > Disk Management. Verify that R: Cluster Raid is available.

• Open My Computer > Control Panel > Add/Remove Programs > Add/Remove Windows 
Components > Cluster Service and Next.
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• Insert Windows 2000 Advanced Server / Windows 2003 Server CD and OK and Next and I 
Understand and Next. Select The Second Node and “Next”.

• Power on Node1 and log on as Administrator for SDLC1 (this computer). Select Start > Programs 
> Administrative Tools> Cluster Administrator. Verify that Cluster Service is started on Node1

• On Node2 enter cluster name to join.

• Select Connect to Cluster as:

• Set User name and password (customeracct/customerpass) 

• Set Domain name and Next

• Reenter password and Next and Finish

• When gathering required hangs press <ctrl><alt><del> and select task manager and select 
applications. Select Microsoft SQL Server Desktop Engine and End Task. End Now and close Task 
Manager and finish

• Select Add/Remove windows components and next and finish. Close add/remove programs and 
reopen add/remove programs. Select Add/remove windows components.

• Select configure for cluster service and next and I understand and Next Select second node and 
Next. Enter cluster name and select Connect to cluster as:. Set user name and password 
(customeracct/customerpass). Set domain name and Next.

• On Node1 right click Node2 and “Evict” from cluster administrator. Yes to evict node

• On Node2 reenter password and Next. Finish and OK ---pause---

Step 4 Rename Node1

• On Node1 right click My Computer and select Properties > Network Identification tab > Properties. 
Enter New computer name (SDLC 11) and OK. Enter name and password for domain User account 
(customeracct\customerpass).

• OK and OK to reboot OK to System Properties and Yes to restart now

• Restart Node2 and log on as Administrator for SDLC22 (this computer)

• Select Start Button > Programs > Administrative Tools > Cluster Administrator. Open cluster. Right 
click Node1 and Evict node. Yes to Evict.

• Eject CD. Shutdown Node2

• Log on Node1 as Administrator for SDLC11 (this computer). Open My Computer > Control panel > 
Add/Remove Programs >Add/Remove Windows Components. Unselect Cluster Services and Next 
and Finish and Yes to restart.

Step 5 Join Renamed Node1 to Cluster

• Log on Node1 as Administrator for SDLC11 (this computer). Right click My Computer > Manage > 
Disk Management. Verify that R: Cluster Raid is available.

• Open My Computer > Control Panel > Add/Remove Programs > Add/Remove Windows 
components > Cluster Service. Press Next.

• Insert Windows 2000 Advanced CD and OK and Next. Select I Understand and Next. Select The 
Second Node and Next

• Power on Node2, log on as Administrator for SDLC22 (this computer). Select Start > Programs > 
Administrative Tools > Cluster Administrator. Verify that Cluster Service is started on Node2.

• On Node1 enter cluster name to join.

• Select Connect to Cluster as:
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• Set User name and password (customeracct/customerpass) 

• Set Domain name and Next

• Reenter password and Next and Finish

• When gathering required information hangs press <ctrl><alt><del> and select task manager and 
select applications. Select Microsoft SQL Server Desktop Engine and End Task.End Now and close 
Task Manager and finish.

• Close add/remove programs and reopen add/remove programs. Select Add/Remove windows 
components > Configure Cluster Service. Next and I understand and Next. Select The Second 
Node and Next. Enter cluster name to join. Select Connect to Cluster as: Set domain user account 
and password (customeracct\customerpass). Set domain and Next

• On Node2 right click Node1 and Evict from cluster administrator. Yes to evict node

• On Node1 reenter password and Next and Finish ---pause---

• Ok to cluster service started successfully

Step 6 Repair Scalar DLC on both nodes.

• On Node2 open My computer > Control panel > Add/Remove programs > Scalar DLC > Change. 
Press Next.

• Select Repair and Next. Select Scalar DLC Server and Next. Select Computer Renaming and Next

• Leave entries alone and Check and Next. Verify successful component registration and Next and 
Install and Finish.

• OK to Fatal Error and Close

• In Cluster administrator select groups > cluster group. Right click SDLC Supervisor and bring 
Online.

• Shutdown Node2 and restart Node1.

• On Node1 open My computer > Control panel > Add/Remove programs > Scalar DLC > Change. 
Press Next.

• Select Repair and Next. Select Scalar DLC Server and Next. Select Computer Renaming and Next

• Leave entries alone and Check and Next. Verify successful component registration and Next and 
Install and Finish.

• OK to Fatal Error and Close

• In Cluster administrator select groups > cluster group. Right click SDLC Supervisor and bring 
Online.

• Eject CD. Start Node2. Restart Node1.

Change Cluster Name

Step 1 Open Cluster administrator > Groups > Cluster group.

Step 2 Right click cluster name and select Properties > Parameters > Rename.

Step 3 Set Cluster Name to <cluster name> and OK

Step 4 Apply and Ok to changes stored and OK.

Step 5 Cycle cluster name offline then online.
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Replacing Old RAID
The following instruction is to be used in order to replace old ADTX RAID (J-series) with the new (P-series) 
hardware without removing Scalar DLC system.

Initializing RAID

• Start from Main Menu and Press O

• Down arrow to Change Config and Press O

• Password is 1234

• Down arrow to Raid Config and Press O

• Down arrow to LU and Press O

• Down arrow to Initialize LU and Press O

• Select LU0 and Press O

• “Data will be lost” message shows and Press O

• Down arrow to Yes and Press O, press O

• Press X five times to show progress

Preparing RAID for Installation

• Power on RAID and wait for ready light.

• Press O to enter Main Menu

• Down arrow to Change Config and press O

• Password is 1234

• Down arrow to SCSI and Press O

• Channel 1 and Press O

• Set to 0 and Press O

• Answer Yes and Press O

Table 22 Swapping RAID Time Schedule 

Procedure Time

Initializing RAID on page 103 6 hr

Preparing RAID for Installation on page 103 15 min

Preparing Scalar DLC for RAID Replacement on page 104 15 min

Swapping Hardware on page 105 30 min

Configuring New External RAID on page 106 1 hr

Verify Correct RAID Changeover on page 108 10 min

CAUTION
The step is to be performed only for the hardware than is NOT fresh-from-
factory. Not required when the RAID is clean and never used before.
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• Press O three times

• Down arrow to Channel 2

• Press O

• Set to 0 and Press O

• Answer Yes and Press O three times

• Down arrow to Option Settings and Press O

• Down arrow to Cache Settings and Press O

• Down arrow to Write Cache and Press O

• Change to Disabled and Press O

• Answer Yes and Press O two times

• Press X four times until back at Main Menu

• Down arrow to Shutdown

• Press O

• Turn off RAID

Preparing Scalar DLC for RAID Replacement
Prerequisites

• Windows 2000 Advanced Server CD / Windows 2003 Server CD

• Scalar DLC 2.6 CD (it also contains latest Adaptec drivers for Windows)

• Domain User account and password. Domain Administrator account is NOT needed.

• Terminate Backup application access to Scalar DLC or disconnect Scalar DLC from the library.

• Cluster data (Cluster name, Cluster IP Address, Subnet mask) - use Cluster Administrator to obtain.

Instructions

• Make Node1 active. Switch to that console if needed. Close Scalar DLC management GUI and Log 
Viewer. Take Scalar DLC offline.

• Remove Cluster Configuration

• Insert the Scalar DLC 2.6 CD into active node's CD-ROM drive.

• Close the installation pop-up window by clicking OK.

• Run <cd-drive>:\Scalar_DLC\Cluster\SDLC_ClusterConfig.exe (The <cd-drive> is typically d:).

• Click on the button "Remove SDLC Cluster Configuration" that is contained in the "SDLC 
Cluster Configurator" window popup.

• Close the "SDLC Cluster Configuration" window.

• Remove Scalar DLC CD from the CD-Drive.

• Verify that the Scalar DLC is not in Cluster mode

• Open (start) cluster administrator.

• Click on Groups > Cluster Group

• Verify that only the following three items appear

• Cluster IP Address

• Cluster Name
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• Disk <Raid Disk> (This is typically R:)

• Create copy of RAID data

• Create RAID directory on C: drive.

• Copy MSSQL and Program Files folders from R:\ (RAID) to C:\RAID (on Node1).

• Use Cluster Administrator to make Node2 active

• Right Click on Cluster Group

• Select move cluster

• Switch to Node2

• Create RAID directory on C: drive.

• Copy MSSQL and Program Files folders from R:\ (RAID) to C:\RAID (on Node2).

• Remove Cluster Service

• On Node2 launch Start > Settings > Control panel > Add/remove programs > Add / remove 
windows components.

• Remove check mark to unselect Cluster Service.

• Click on the Next button.

• Click on the Finish button. When prompted, select "NO" to restarting the computer.

• Power off Node2

• Click on the "Start" menu on the tool bar

• Select "Shutdown"

• On the popup window, select "Shutdown"

• Click on "OK"

• Turn off the power switch.

• Switch to Node1 console. Launch Start > Settings > Control panel > Add/remove programs > 
Add / remove windows components.

• Remove check mark to unselect Cluster Service.

• Click on the Next button.

• Click on the Finish button. When prompted, select "NO" to restarting the computer.

• Power off Node1

• Click on the "Start" menu on the tool bar

• Select "Shutdown"

• On the popup window, select "Shutdown"

• Click on "OK"

• Turn off the power switch.

Swapping Hardware

• Turn off existing external RAID.

• Remove SCSI cables from each node to the old external RAID. These cables will not be used in the 
new RAID.

• Replace the old RAID with the new P-series RAID.
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• Use the new vhdci cables to connect each node to new RAID.

• Connect Node1 to SCSI channel 1.

• Connect Node2 to SCSI channel 2.

• Add terminators to each SCSI channel.

Configuring New External RAID

Step 1 Power on Node1. Prepare to set up RAID.

IGNORE the BIOS messages until the Adaptec Bios message appear.

Almost immediately, another Adaptec message for the 39160 SCSI HBA is displayed. Enter the Bios for the 
Adaptec 39160 using <Ctrl-A>.

• At the "Channel Select" menu, select B bus and press <Enter>. The external RAID is typically on 
the B bus.

• From the "Options" menu, select "Configure / View SCSI controller settings" and press <Enter>

• From this menu, scroll down to "SCSI Controller Termination". If this is NOT set to Automatic, 
change it as follows:

• Press <Enter> to bring up a changes menu.

• Scroll up to "Automatic"

• Press <Enter> to save the changes. This should return back to the "Configuration Menu"

• Scroll down to SCSI device configuration and press <Enter>.

CAUTION Do NOT power on the external RAID now.

CAUTION
IGNORE this message.

On NEI PC's, the following Adaptec message will appear:
Adaptec I2O Bios
© Copyright Adaptec Inc, 
Hit <Ctrl-A> for Adaptec Setup, waiting for Devices

Then it will change to something like the following:
Adaptec I2O Bios
© Copyright Adaptec Inc, 
Controller: 0xFe700000   IRQ11  2015S FW 3B05 
Cyls.hds.sec
    Drive: (0,0,0) Adaptec   RAID-1
    Proc: (0,6.0)  Super      GEM318   0
Hit <Ctrl-A> for Adaptec Setup

Note Be careful at this point NOT to enter the configuration for the on-board NEI SCSI RAID 
controller. This does not apply to Dell Server PC's.
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• Set sync transfer rate to 160 for ALL table entries.

• Press <Enter> on any "SYNC Transfer Rate" not at 160 to bring up a menu.
• Select 160 from menu using arrow keys.
• Press <Enter> when done.

• Repeat as needed to change any/all sync transfer rates.

• Exit this menu using the <Esc> key

• Press <Esc> to exit the Configuration Menu.

• In the "Save Changes Made" popup, select "Yes" and press <Enter> to continue.

• Press <Esc> to exit the "Options" menu".

• Press <Esc> to exit the "Channel Select" menu.

• On the "Exit Utility" popup menu, select "Yes" and press <Enter> to exit.

On NEI PC's, the HDD change message will appear. Clear this by:

• Pressing <F1> to enter the NEI System Bios

• Press <Esc> then OK.

Let the PC boot to Windows and Log in to Node1. Install the latest Adaptec SCSI HBA drivers (see Updating 
Drivers on page 110).

Step 2 Format RAID disk, as described in Setting Up the RAID on page 24 section from Step 2 on page 
24 to Step 3 on page 25.

Step 3 From the "Start" button on the tool bar, shutdown the Node1 PC. Turn the RAID off. Power on 
Node2. Repeat Step 1 on page 106 for Node2.

Step 4 Turn on the RAID and wait for the ready light. Join RAID to Node2, as described in Step 5 on 
page 25.

Step 5 Shutdown Node2. Power up Node1 go to it and log on. Configure Cluster service, as described 
in Step 2 on page 26.

Step 6 After Cluster service starts successfully press Finish, eject CD, power up Node2 and log in. 
Configure Cluster service, as described in Step 4 on page 26.

CAUTION
Right after setting up the Cluster Network settings, the system starts Cluster 
service, recognizes that the SQL server is already set up, and requests to 
upgrade the MS SQL to Cluster MS SQL.

• Cancel the SQL Install while still at the "Preparing to Install" stage.
• Cancel the SQL install two MORE times QUICKLY.

CAUTION
Right after connecting to the Cluster as domain user, the system starts Cluster 
service, recognizes that the SQL server is already set up, and requests to 
upgrade the MS SQL to Cluster MS SQL.

• Cancel the SQL Install while still at the "Preparing to Install" stage.
• Cancel the SQL install two MORE times QUICKLY.
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Step 7 After Cluster service starts successfully Finish, remove CD, and Verify the Cluster service, as 
described in Step 6 on page 27.

Step 8 Finish RAID Swapping

• Restore RAID data.

• copy MSSQL and Program Files folders from C:\RAID to R:\ (RAID)

• Restore Scalar DLC Cluster Configuration

• Insert Scalar DLC 2.6 CD.
• Close the autorun popup install window.
• Run <CD:>\Scalar_DLC\Cluster\SDLC_ClusterConfig.exe
• Click Make SDLC Cluster Configuration 
• OK when complete
• Close SDLC Cluster Configurator and remove Scalar DLC CD.

• Restart both nodes.

Verify Correct RAID Changeover

• Start Cluster Administrator program

• From the menu, select Groups -> Cluster Group

• Verify that the following resources are shown.

• Cluster IP Address

• Cluster Name

• Disk R:

• MSSQLSERVER

• Noblenet Portmap

• SDLC Supervisor

• SQLSERVERAGENT

• Start Scalar DLC Manager

• Verify that the library configuration is correct.

Startup and Shutdown
The starting up and shutting down the Redundant Scalar DLC must be executed as follows.

Startup

Step 1 Power on RAID and wait for 30 seconds

Step 2 Power on Node1 and wait for windows starting message

Step 3 Power on Node2

Shutdown

Step 1 On passive node (Node2) launch Start > Shutdown > Shutdown > OK
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Step 2 On active node (Node1) launch Start > Shutdown > Shutdown > OK

Step 3 Wait for both nodes to power down completely

Step 4 Turn off RAID.

Back up Scalar DLC Database
There are two almost equivalent methods, use either one. See Scalar DLC Reference Guide, Tools and 
Utilities, Database Tool for more details.

Backup to a local file

Step 1 On active node right click the penguins in the toolbar. Select Tools > Scalar DLC DB tool, then 
OK.

Step 2 Select Backup tab, Manual backup, and “...” in the Destination area.

Step 3 Specify a temp location on the C: drive. Enter file name and select Save.

Step 4 Execute and OK to successful completion and Exit the DB Tool.

Step 5 Go to temp location and zip the newly created file.

Step 6 Copy and paste zipped file either onto floppy disk or folder on RAID disk or network resource.

Save to archive file

Step 1 On active node right click the penguins in the toolbar. Select Tools > Scalar DLC DB tool, then 
OK.

Step 2 Select Save tab and “...” in the Destination area.

Step 3 Specify a destination location (both local and network resources are allowed). Enter file name 
and select Save.

Step 4 Save and OK to successful completion and Exit the DB Tool.

The zipped database file is stored on the location specified. Move or copy it anywhere if required.

Restore Scalar DLC Database

Step 1 Copy and paste archive file from either floppy disk or folder on RAID disk or network resource 
to the temp location (both local and network resources are allowed, using “C:\temp“ is 
preferrable).

Step 2 On the active node right click the penguins in the toolbar. Take Offline (or Stop) Scalar DLC and 
OK.

Step 3 Right click the penguins in the toolbar. Select Tools > Scalar DLC DB tool.

Step 4 Select Restore tab and select From Device.
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Step 5 Select “...” in Device Name section. Select the <temp location> \ <database file> to use and 
Open.

Step 6 Set the Move to physical file names to “R:\Program Files\...” (if not set by default).

Step 7 Select Restore and Restore and OK and Exit.

Step 8 Right click the penguins in the toolbar. Bring Online (or Start) Scalar DLC and OK.

Updating Drivers
The following drivers may require an update during installing or upgrading the Scalar DLC and/or installing 
the new hardware.

Step 1 Download the latest driver(s). They can be found on Scalar DLC Install CD in the directory 
Scalar_DLC\Drivers\Adaptec and Scalar_DLC\Drivers\Initiator\QLA234x.

Step 2 Update drivers using: My Computer > (right click) > Manage > Device Manager > SCSI and 
RAID controllers > (select adapter and right click) > Properties > Driver > Update Driver. 
(on WIndows 2000 also “Driver Details“ button)

Note that for Adaptec and QLA 2342 there are two channels, both are to be updated.

Note If the backup is performed from the previous version of Scalar DLC, follow the Recover 
database from old backup on page 115.

Note Check the version of the existing driver(s). Update only when the current version is 
lower than required, or when the driver is not installed at all.

Table 23 Drivers to Update

Hardware Required version

Adaptec 39160 (SCSI for RAID) 6.4.630.100

QLA 2340 (Fibre Channel for library) 9.1.0.11

QLA 2342 (Fibre Channel for library) 9.1.0.11
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Figure 70 RAID Adaptec 39160 Driver: Win2000

Figure 71 RAID Adaptec 39160 Driver: Win2003
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Figure 72 Update Adaptec Driver

Next. Insert Scalar DLC 2.6 CD. Select “Install driver from a list or specific location“.

The 2003 wizard shall find the driver on CD, the 2000 needs to be updated manually (Display a list of 
known drivers > Have disk > (browse for a folder) > select driver).

Step 3 Reboot if required.

Failure Recovery
The following steps are user in case of disk failure on Scalar DLC server.

One disk fails on server

On both Standard and Failover solution:

Step 1 Remove failed disk

Step 2 Insert new disk.

Step 3 Rebuild begins.

No failover or downtime. Approximate rebuild time is 20 minutes

Two disks fail in a server: standard solution

The computer is not operating and must be replaced.

Step 1 Install new disks on host.

Step 2 Boot up and insert windows recovery CD. Perform clean-install-from-scratch, as described in 
Setting Up the Standard Solution on page 7.
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Step 3 Restore the Scalar DLC database from backup made on floppy or network resource, as 
described in Restore Scalar DLC Database on page 109.

Two disks fail in a server: failover and self-domain solution
The node is not operating and must be replaced. The working node is supposed NodeA, the old (failed) 
node that should be replaced is supposed NodeO, the new node that replaces NodeO is supposed NodeB.

NodeA online, RAID on, NodeO power off.

Step 1 On active node (NodeA) evict the damaged node (NodeO) from the cluster. Then run SDLC 
cluster configuration tool (from Scalar DLC CD) and remove cluster configuration.

Step 2 (For Self-domain solution only; for Failover solution skip this step.) 
Detect whether NodeB should be installed as Backup or Primary domain controller.

• On NodeA launch Start > Programs > Administrative Tools > Active Directory users and 
computers.

• Domain name (right-click) > Operations Masters. Wait ~30 sec till the dialog opens.

• Select PDC tab and check Operations Master field. 
If Operations master is <NodeA>, then NodeA is a Primary domain controller, and NodeB 
should be installed as a Backup domain controller. 
If Operations master is <NodeO>, then NodeA is a Backup domain controller, and NodeB 
should be installed as a Primary domain controller.

Step 3 (For Self-domain solution on Win2003 only. For both Failover solution and Self-domain solution 
on Win2000 skip this step.) 
On NodeA launch Start > Programs > Administrative Tools > Active Directory users and 
computers, select Domain Controllers > <NodeO>, right-click and Delete and Yes to 
confirm. Select ‘This domain controller is permanently offline and can no longer be demoted...’ 
and Delete and Yes. This will remove NodeO from the list of domain nodes.

Step 4 Shutdown NodeA, switch off RAID. Unplug all cables from old NodeO (power, network, SCSI, 
KVM). Remove NodeO (old, failed) from a rack. Remove SCSI cards from old NodeO and place 
them to a new NodeB.

Step 5 Insert new NodeB into a rack and connect all cables (power, network, SCSI, KVM).

Step 6 Start up NodeA. Install and configure Scalar DLC on NodeB as for the second node (Node2).

• For NodeB do Configuring SCSI for RAID and Library on page 20.

• (For Failover solution only; for Self-domain solution skip this substep.) 
For NodeB do Setting Up IP Address, Node Name, and Joining Domain on page 22.

Note On Windows 2000 use the same DNS name and IP address as has been used at the 
failed node.
On Windows 2003 use the same IP address as has been used at the failed node, but 
the other DNS name.

Note Backup the database to RAID or local resource, as described in Back up Scalar DLC 
Database on page 109, just to be sure that the database will not be lost during repair. 
Would the database be damaged, after the install is finished do Restore Scalar DLC 
Database on page 109.
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• (For Self-domain solution only; for Failover solution skip this substep.) 
For NodeB do Setting Up Network, IP Address and Computer Names on page 35.

• (For Self-domain solution only; for Failover solution skip this substep.) 
Set Backup domain controller on NodeB as described in Configuring Domain Controllers on 
page 36 from Step 2 on page 37 for Windows 2000, or from Step 2 on page 38 for Windows 
2003. 
If NodeB is to be set as Primary domain controller, do the following then.

• On NodeB run Start > Run > CMD and type ntdsutil.

• At the ntdsutil prompt type roles.

• At the fsmo maintenance prompt, type connections. 

• At the server connections prompt, type connect to server <NodeB name.Domain>. 

• At the server connections prompt, type quit. 

• At the fsmo maintenance prompt, type seize PDC. Then click Yes to confirm.

• At the fsmo maintenance prompt, type seize RID master. Then click Yes and Yes to 
confirm.

• At the fsmo maintenance prompt, type quit. 

• At the ntdsutil prompt, type quit. 

• Restart NodeB.

• For NodeB do Setting Up the RAID on page 24 from Step 4 on page 25.

• Start up NodeA. For NodeB do Configuring Cluster Service on page 26 from Step 4 on page 26 
(on Windows 2000) or from Step 3 on page 27 (on Windows 2003).

• On NodeA take Scalar DLC offline. On NodeB do Installing Scalar DLC Software on page 28, 
steps 3, 5 - 7.

• (optional) On NodeB do Building Client Connections on page 131.

• Take Scalar DLC online and proceed.

Scalar DLC chassis bad

Step 1 Power off failed node.

Step 2 Disconnect all cabling.

Step 3 Move all disk, SCSI cards and fibre cards to the new node.

Step 4 Reconnect cabling and power on new node.

One disk fails in the external RAID

Step 1 Remove the cover and unlock the disk.

Step 2 Remove failed disk and insert new disk

Note On Windows 2000 use the same DNS name and IP address as has been used at the 
failed node.
On Windows 2003 use the same IP address as has been used at the failed node, but 
the other DNS name.
114 Upgrade, Remove, Repair



Step 3 Reconstruction will begin. Approximate reconstruction time is 6 hours 

Step 4 Hit the up arrow until buzzer stop shows on display.

Step 5 Hit the yellow button twice

Two disk fail in the external RAID

Step 1 Replace both failed disks.

Step 2 Initialize the RAID. Initialization takes approximately 2 hours.

Step 3 Reinstall the Scalar DLC from scratch

Step 4 Restore database from the back up.

RAID controller fails

Step 1 Power down RAID

Step 2 Disconnect all cabling from RAID

Step 3 Remove all disk from failed RAID

Step 4 Insert disk into new RAID chassis

Step 5 Reconnect cabling and power on

Step 6 Run the Installation for ADTX RAID procedure

Step 7 Boot up servers 

Step 8 Reboot after new devices are installed

Recover database from old backup
When the Scalar DLC database is lost and there is only the backup from previous version of Scalar DLC 
(for example, 2.4), the recovery is possible.

Step 1 Restore the Scalar DLC database from a backup, as described in Restore Scalar DLC 
Database on page 109. 

Step 2 Launch Start > Settings > Control Panel > Administrative Tools > Add-Remove Programs 
> Scalar DLC and press Change. The Scalar DLC Add/Remove engine starts, as described in 
Add/Remove Scalar DLC Software on page 81.

Step 3 Select Repair, then Scalar DLC database, then Upgrade (see Figure 55 on page 85). The 
database will be upgraded. Restart is required thereafter.

CAUTION Do NOT start the Scalar DLC now! It will not function.
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Step 4 After the restart, log on the Management GUI and review the existing configuration. It is 
possible that manual improvement is needed. See Scalar DLC Reference Guide, Advanced 
Configuration section for more details.

Step 5 After the configuration is performed, backup the new database to a archive file on RAID or 
floppy (see Back up Scalar DLC Database on page 109) and proceed the work.

Downgrading the Scalar DLC

In case of any serious inconvenience after upgrading Scalar DLC, it is possible to downgrade the Scalar 
DLC back to previous level (database backup from this ‘previous/original level’ is required).

Do the following.

Step 1 Using Add/Remove programs remove the Scalar DLC 2.6 software (see Remove on page 82) 
removing the database, too.

Step 2 From the same Add/Remove window, remove Apache and Java software packages.

Step 3 Review <%System disk%>\Program Files folder and remove ‘SDLC’ and ‘Apache Group’ 
folders manually if they are not removed.

Step 4 Install the original Scalar DLC. Apply all necessary Service packs and hot fixes (see Installing 
Scalar DLC Service Packs on page 96).

Step 5 Restore the database as described in Recover database from old backup on page 115.

Step 6 After restarting the Scalar DLC launch the complete inventory for a library.
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Troubleshooting
This section contains useful general troubleshooting information if a customer encounters problems during 
installation or normal usage.

See Troubleshooting Applications on page 117 for information about third party applications.

See Force Restart on page 122 for the instructions on force restart the Scalar DLC PC after the installation.

See Scalar DLC Force Removing on page 122 for the instructions on force remove of the Scalar DLC 
software.

Troubleshooting Applications

The following topic describes some general troubleshooting notes.

• Scalar DLC Installation on page 117.

• Scalar DLC Database Utility on page 118

• Scalar DLC Online Help on page 119.

• SCSI and Fibre Channel Target Mode Driver on page 119.

• SQL Server on page 119.

• Client Applications on page 120.

Scalar DLC Installation
Issue: Blue screen after installing drivers for RAID or network adapter.

Solution: Drivers are installed wrong and conflict with the Windows hardware scan engine. Unplug RAID 
or network adapter, reboot, reinstall the driver, and then plug RAID/network on again.

Issue: Scalar DLC installation is launched but either not starts or shows Finish window without installing 
anything.

Solution: The registration of Install components may be broken. Launch the install fix script (<Scalar DLC 
CD:>\Scalar_DLC\Tools\installfix.cmd) and then start the Scalar DLC installation again.

Issue: Scalar DLC installation has been failed partially installing some components.

Solution: Remove all currently installed Scalar DLC components (see Software Components on page 45), 
restart the PC (restart both nodes for the failover solution), and start the installation again. On failover and 
self-domain solution ensure that the active node is used.
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Issue: "Cannot get SQL server version" or "Cannot create or access database" error during Scalar DLC 
installation.

Solution: Ensure that the network is operating (Start > Run > ping <domain name>, or try to find any 
network resource), network adapter drivers are installed (My computer (right-click) > Manage > Device 
Manager > Network adapters), and the DHCP client service is up (My computer (right-click) > Manage 
> Services and Applications > Services > DHCP).

Issue: SCSI Target Driver installation started immediately after installing Scalar DLC software is failed for 
installing ADIC Local SCSI Target driver.

Solution: Restart the computer and launch the Target Driver installation from Autorun separately.

Issue: “JSDK service has not been stopped“ error during Scalar DLC removing.

Solution: Open Services. Change JSDK Service and SDLC Supervisor service from “automatic“ to 
“manual“. Reboot. Remove Java2. Reboot if required. Then install Java manually (<Scalar DLC 
CD:>\Scalar_DLC\jre\j2re-1_4_2_09-windows-i586.msi). Then launch Scalar DLC remove.

Issue: “Error 1325: APACHEDIR is not valid short file name“ error during Scalar DLC removing.

Solution: The current node does not own the cluster group. Open Cluster Administrator, execute Move 
Group, and launch Scalar DLC removing again.

Scalar DLC Database Utility
Issue: “COM exception: 0x80040E14; cannot add, delete, or modify a job...“ error when trying to modify the 
existing backup/compact SDLC database schedule.

Solution: This is the MS SQL bug: the configured schedule can be changed only from the same node where 
it has been created. Change the active node and try to change the schedule again.

Alternative Solution (when changing active node is either not possible or not desirable): Launch the 
MS SQL job fix script (<Scalar DLC CD:>\Scalar_DLC\Tools\ChangeJobsOwnership.cmd). Then 
start the DB Tool again and change the schedule.

Issue: Backup is scheduled to a local folder but does not executed as configured.

Solution: MS SQL installed on a cluster system requires the backup folder placed on a shared resource 
(RAID), so it could be accessed from either node. Ensure that the local resource is on RAID, otherwise 
reconfigure the backup settings.

Issue: “COM exception: 0x80040E14; cannot open backup device“ error during back up or restore Scalar 
DLC database on network resource.

Solution: Sometimes network backup / restore operations are not allowed because of local network 
security restrictions. Back up to floppy or local disk is recommended in this case, and then copy the backup 
to network resource manually.

Note This issue appears only for the Failover solution.

Note This issue appears only for the Failover solution.

Note This issue appears only for the Failover solution.
118 Troubleshooting



When the error happens during restoring from a network resource, copy the backup file to floppy or local 
disk manually, and then restore it via DB tool from local/floppy resource.

Scalar DLC Online Help
Issue: Launched from a remote host, Scalar DLC Management GUI works fine but the html-based online 
help works with errors or does not work at all.

Solution: the issue may appear when the system default browser in not IE or Netscape. The current version 
of Scalar DLC has not intended to support browsers other than IE or Netscape, so make either of them the 
default browser on your system. Otherwise ADIC does not guarantee that all functions will work.

SCSI and Fibre Channel Target Mode Driver
The basic driver installation order is described in Installing the SCSI/FC Target Drivers on page 74.

PCI Slot Issues
Issue: In some cases, the SCSI Adapter installed in the PCI slot operates improperly or does not operate 
at all. The main symptoms are:

• Windows hangs on starting or works slowly.

• the installed SCSI Target driver does not start

• the driver is installed but the Management GUI does not recognize the Target port

• the logical library visible from the initiator side is unstable (bus errors, target disappears, etc.)

This situation is sometimes encountered when the PC has more than one active PCI slot, and the SCSI card 
that should operate in Target mode is installed in this slot.

Solution: Swap the SCSI Target Adapter with another PCI card in an occupied slot, or temporarily remove 
any unused PCI devices to avoid possible problems with the system interrupts.

SNC Issues
Issue: When the SCSI Clients use SNC as an interface between Initiator (client) and Target (Scalar DLC) 
host, and the command is send when the Scalar DLC is down, the Target objects mapped on SNC will 
disappear so the client cannot send the commands later even after the Scalar DLC software is up again. 
This results the SNC mapping problem.

Solution: either execute the 'ScsiRescan' issue from client side or reboot the SNC. When the Scalar DLC 
is up, the targets will be re-mapped.

Issue: SNC is used between the library (target) and Scalar DLC server (initiator). The Scalar DLC cannot 
see the library and receives ’Not connected’ error.

Solution: Reboot the SNC each time the library or one of its robots is restarted. See Host/Library 
Communication using Fibre Channel and SNC on page 127 for the details.

SQL Server
Issue: The Scalar DLC supervisor does not start automatically because SQL Server Agent does not start.

Solution: Start SQL Server Agent service manually.

Step 1 Launch Start > Settings > Control Panel > Administrative Tools > Services.

Step 2 Find the SQLSERVERAGENT service and start it manually.
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Step 3 Start Scalar DLC supervisor service either manually (from the same Services window) or via 
the Scalar DLC state icon (gray penguins) on the tool bar.

Client Applications
Mostly the settings of DAS/ACI applications and SCSI are covered here.

Legato Networker
If Legato Networker is executed from a Solaris, follow the steps here:

• Add the following four lines to the /etc/rc2.d/S95 file:

• DAS_CLIENT=clientname; export DAS_CLIENT (clientname is a name of DAS client (for 
example, Client1) representing the client application).

• DAS_SERVER=servername; export DAS_SERVER (servername is a name of Scalar DLC PC 
(for example, computer).

• ACI_MEDIA_TYPE=mediatype; export ACI_MEDIA_TYPE (mediatype is an ACI media type 
(for example, ACI_DECDLT) used by client application; use the value that corresponds the 
media present in the logical library configured by Scalar DLC; refer to DAS/ACI Interfacing 
Guide).

• DAS_MEDIUM=mediatype; export DAS_MEDIUM (mediatype is the a DAS media type (for 
example, DECDLT) used by client application; use the value that corresponds the media 
present in the logical library configured by Scalar DLC).

HP Omniback
When using Omniback, follow the step here:

• Add the following entries to the omnirc file.

• DAS_CLIENT=OMNIBACK_C1

• DAS_SERVER=host where the host is the host name of the machine executing Scalar DLC 
(shown in the Management GUI in a broad black line)

DASADMIN
Issue: DAS Client cannot connect to the Scalar DLC server host.

Solution: Ensure the DAS client is configured to work from client host with server host. Refer to Installing 
the DAS Administration Utility on page 67. Also ensure there is no firewall between the client and server 
host, and if there is, make sure the DAS client connection is firewall-based and the DAS/ACI Firewall 
software is installed and configured. Refer to Installing the DAS/ACI Firewall on page 68.

Issue: Configuring a drive to a client/logical library does not allocate the drive.

Solution: ALLOCD command must be executed from the client side before the client can access the drive. 
Refer to DAS Administration Guide.

Example: $dasadmin allocd DRIVE UP dasclent

SCSI
Issue: MOVE command fails.

Solution: Moving cartridge to the home position of any other cartridge is not allowed when there is a client 
other than SCSI assigned to either the same logical library, or to the other logical library that has one or 
more shared partitions with the first one.
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When there are only SCSI clients, the Move command that should place the cartridge to other cartridge 
home position will be accepted.

• Check whether there should be a DAS or ROBAR client for the logical library used by the SCSI 
client. If not, remove the unnecessary clients. 

• If the DAS or ROBAR clients are not to be removed, use only the slots that are empty, but not the 
home positions for the SCSI commands.

Issue: Executed on SCSI/FC client host the Test Unit Ready command returns Adapter status 1 <Failure>, 
although the adapter and connection with the Scalar DLC server are good.

Solution: Ensure that the library medium changer on the client host is disabled. See Disabling Library 
Medium Changer on page 133.

Issue: After upgrade, only one Target based on Fibre Channel adapter is active. The SCSI clients assigned 
to the not active Targets cannot access the Scalar DLC.

Solution: There has been wrong Target-LUN mapping in older versions of Scalar DLC. The newest FC 
target drivers allows only one target with 255 LUNs to be active on FC adapter operating in Target mode.

To make the SCSI Clients assigned to the non-active SCSI targets active again, do the following:

Step 1 Using the Management GUI > Configuration > SCSI Target tab, locate all FC adapters that 
contain more than one Target.

Step 2 For each such FC adapter (for example, Adapter 1), locate the Target with minimal SCSI ID (for 
example, Target 0). This will be the only active Target of the FC adapter.

Step 3 Under this active Target, create as many LUNs as there are non-active Targets at the Adapter 
1.

Step 4 Using Configuration > Clients tab, create SCSI clients based on the LUNs of active Target 0. 
Assign the logical library and check the Mode settings the same as they were for the non-active 
clients. That means, for each client based on non-active target must be created the duplicated 
SCSI client with same settings but based on the active Target (Target 0).

Step 5 Repeat Steps 1-4 for each FC adapter with multiple targets.

Step 6 After all SCSI clients are re-created, remove all SCSI clients based on non-active Targets and 
non-active Targets with their LUNs.

Now the SCSI/FC clients can access their resources.

Note The Management GUI will warn the admin if there will be an attempt to assign two 
different clients (for example, DAS and SCSI) either to one logical library, or to different 
logical libraries that has shared partitions. This assignment is not restricted, however.

Note This issue typically appears only when the Scalar DLC client host operates under 
Windows 2000 or 2003.

Note This issue can appear after upgrading the Scalar DLC database from 2.3 or 2.4. In 2.5 
the Target-LUN mapping is the same as in 2.6.
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Force Restart

Issue: The installation of Scalar DLC or another software package is finished, the dialog like “Your system 
is to be restarted now, press “yes’ to restart PC“ appears. But after pressing “yes” button the dialog vanished 
and the restart is not initiated.

Solution: Ikernel.exe object hangs. Stop it manually via Windows Task Manager (Processes > Ikernel.exe 
(right-click) > End Process). After the IKernel is stopped, restart the PC manually via Start > Shutdown > 
Restart.

Scalar DLC Force Removing

Sometimes removing the Scalar DLC by its standard way, as described in Add/Remove Scalar DLC 
Software on page 81, is not possible.

Issue: SQL server is stopped, Scalar DLC repair/update/remove fails.

Solution: Start the SQL Server Agent manually and then repeat the repair/update/remove operation.

Issue: RAID permanently goes to unplugged mode, MS SQL server cannot be started, Scalar DLC 
database cannot be accessed, Scalar DLC cannot be removed.

Solution: First remove SQL server, then remove Scalar DLC.

Step 1 Remove SQL server from Node 1 (Start > Settings > Control Panel > Administrative Tools 
> Add/Remove Programs).

Step 2 Remove Scalar DLC software from Node 1 (now the standard operation must work). Accept the 
restart.

Step 3 Repeat Steps 1 - 2 for Node 2.

Note This issue appears only for the Failover solution.
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Advanced Setup Instructions
This section contains the topic on extended setup not covered in previous chapters.

• Setting Up the Library on page 123.

• Host/Library Communication using Fibre Channel and SNC on page 127.

• Building Client Connections on page 131.

• Installing SCSI/FC Target Adapters on a Live Machine on page 134.

• Securing the Scalar DLC on page 135.

Setting Up the Library

The following instructions applies to setting up the library media changer. The procedure can be done in any 
time when setting up the Scalar DLC, but before installing the Scalar DLC software itself.

Step 1 Set up the library according to the media that will be used.

• For the 6-symbols barcode, set the Media ID to disabled. The library scanner cannot determine 
different media of a single domain (for example, DLT IV or SDLT), so the media type-default-by-
domain will be assigned (for example, all DLT media will be recognized as DLT IV). Refer to the 
library Operator Guide for the details.

• For the 7-symbols barcode, set the Media ID to enabled. The library scanner will read the media 
type directly from barcode. Use the library Operator panel, Main > Setup > Library > Media, then set:

• Volser: MEDIA ID

• Add ID: N

• Mixed: Y

• Extend: N

• ASCQ: N

CAUTION
Do not use different media of a single domain in this type of library. A 
hardware crash is otherwise possible. 
A hardware crash is also possible if the default media type is not properly 
resolved (for example, DLT media resolved as DLT IV, but the real cartridges 
are DLT III).
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Step 2 Resolve the library SCSI IDs:

• Single-aisle (Scalar 1000, Scalar 10K):

• On the library Operator panel, do the following: Main > Setup > Library > SCSI > Target ID.

• Set the SCSI IDs on both buses to 3.

• Restart the library so that the SCSI IDs take effect.

• Dual-aisle (Scalar 10K DA):

• On the Operator panel for Robot 1 do the following: Main > Setup > Library > SCSI > Target ID.

• Set the SCSI ID on both buses to 3.

• On the Operator panel for Robot 2 do the following: Main > Setup > Library > SCSI > Target ID.

• Set the SCSI ID on both buses to 4.

• Restart the library so that the SCSI IDs take effect.

Step 3 Connect the library to the host

• Single-aisle (Scalar 1000, Scalar 10K):

• Standard solution:

• Connect the SCSI cable to the respective LVD/HVD controller 1 of the library and to the 
Scalar DLC SCSI HBA card.

• On the PC, launch My Computer > Manage > Device Manager to verify that the Windows 
2000/2003 machine can see the Library "Medium Changer".

• Failover and Self-domain solution:

• Connect the SCSI cable to the respective LVD/HVD controller 1 of the library and to the 
Scalar DLC Node1 SCSI HBA card.

• Connect the SCSI cable to the respective LVD/HVD controller 2 of the library and to the 
Scalar DLC Node2 SCSI HBA card.

• On both nodes, launch My Computer > Manage > Device Manager to verify that the 
Windows 2000/2003 machine can see the "Medium Changer" device.

• Dual-aisle (Scalar 10K DA):

• Standard solution:

• Plug Y-block connector with LVD/HVD-terminator to LVD/HVD controller 1 of the Robot 2.

• Plug the Y-block connector to LVD/HVD controller 1 of the Robot 1.

• Connect two Y-block connectors of Robot 1 and Robot 2 with the SCSI cable.

• Connect the free connector of Y-block connector at Robot 1 and the Scalar DLC SCSI HBA 
card with the SCSI cable.

CAUTION
Make sure to install the proper voltage SCSI connections (see Table 16 on 
page 71).

CAUTION
Make sure to install the proper voltage SCSI connections (see Table 16 on 
page 71).
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• On the PC, launch My Computer > Manage > Device Manager to verify that the Windows 
2000/2003 machine can see two "Medium Changer" devices.

• Failover and Self-domain solution:

• Plug Y-block connector with LVD/HVD-terminator to LVD/HVD controller 1 of the Robot 2.

• Plug the Y-block connector to LVD/HVD controller 1 of the Robot 1.

• Connect two Y-block connectors of Robot 1 and Robot 2 with the SCSI cable.

• Connect the SCSI cable to the respective LVD/HVD controller 1 of the library and to the 
Scalar DLC Node1 SCSI HBA card.

• Plug Y-block connector with LVD/HVD-terminator to LVD/HVD controller 2 of the Robot 2.

• Plug the Y-block connector to LVD/HVD controller 2 of the Robot 1.

• Connect two Y-block connectors of Robot 1 and Robot 2 with the SCSI cable.

• Connect the SCSI cable to the respective LVD/HVD controller 2 of the library and to the 
Scalar DLC Node2 SCSI HBA card.

• On both nodes, launch My Computer > Manage > Device Manager to verify that the 
Windows 2000/2003 machine can see two "Medium Changer" devices.

Step 4 Make sure that the created scheme matches the example.

Step 5 (This step is for Windows 2003 system only. On Windows 2000 skip this step) 
Disable library Medium Changer (on both Nodes for failover and self-domain solution).

• Launch My Computer > Manager > Device Manager > Medium Changers. The list of medium 
changers will appear.

CAUTION
Make sure to install the proper voltage SCSI connections (see Table 16 on 
page 71).

CAUTION
Make sure to install the proper voltage SCSI connections (see Table 16 on 
page 71).

Library Solution Example

Single-aisle Standard Figure 3 on page 7

Dual-aisle Standard Figure 4 on page 8

Single-aisle Failover and Self-domain Figure 6 on page 13

Dual-aisle Failover and Self-domain Figure 7 on page 14
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Figure 73 Device Manager: Enabled Library Media Changer

• Select the media changer that represents the library device (ADIC Scalar 1000, Scalar 10K, or 
Scalar 100). By default it is enabled.

• Right-click and select Disable (or execute Menu > Action > Disable) to disable the library.

Figure 74 Device Manager: Disabled Library Media Changer

• Ensure that the library device is disabled. The Scalar DLC cannot be installed with the enabled 
media changer.

• Close Device Manager. No restart is required here.

CAUTION
Never disable the media changers that are not mentioned in the list above.
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Host/Library Communication using Fibre Channel and SNC

Usually the library use a SCSI to connect to the Scalar DLC host. However the SCSI cable length cannot 
exceed the sensibility limit (see Table 16 on page 71).

The Fibre Channel connection uses the same SCSI protocol and does not have length limitations, but most 
libraries have only SCSI adapters installed, no Fibre Channel. That is why the intermediate hardware 
between SCSI and FC is used in this case.

The Storage networking controller (SNC) can be used for both the dual-aisle and single-aisle libraries. Thus 
the distance between the Scalar DLC server and the SNC connected to the library can be far enough for 
the customer to place the hardware anywhere it would be useful.

See Table 3 on page 6 for a requirements for library, SNC, and AMC, and Table 18 on page 72 for the FC 
adapters used.

Installation and Configuration
Depending on the Scalar DLC Solution used see Standard Solution on page 129, or Failover and Self-
Domain Solution on page 130. Then see SNC Setup on page 127 for setting up the SNC.

SNC Setup
After the host(s), library and its drives are on, and all cables are properly connected, configure the SNC. 
Use ADIC Management Console (AMC) to set up the SNC, and resolve ports, IP, connection type, zoning, 
and WWN. For more details see SNC User’s Guide and AMC User Guide.

Channel Zoning

The SNC target ports (SCSI connected to the library) and initiator ports (FC connected to the Scalar DLC 
host) must be configured to use the same Channel Zoning. Otherwise the connection cannot be established.

Channel Topology

Point-to-point, Fabric, or Arbitrated loop topology can be used as Host-SNC connection.

World Wide Name

The SNC World Wide Name (WWN) must be set before it can be used for the library connection.

Failover and self-domain solution scheme with two SNC devices requires that both SNC have the same 
WWN (note that SNC messages are against such setup).

The WWN setup order is as follows.

Step 1 Connect a service terminal to the service port. Alternatively, connect a service computer to the 
network that the SNC is on or to the Ethernet port of the SNC. 
For the location of these ports and instructions for connecting a service terminal, see SNC 
User’s Guide.

Step 2 Issue the wwnGlobalSet command to establish a new base WWN. 
Using the wwnGlobalSet command will update both the node name and port names. 
The following messages are displayed:
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This command will change the WWN for Fibre Channel Ports. 
This should only be done when replacing a failed SNC. You should never 
operate 2 FC devices that are set to the same WWN. This may destabilize 
your SAN. 
The unit will be rebooted after the WWN change. 
Do you want to proceed (enter "yes" to continue) :

Step 3 Type the word yes and press Enter. 
The following message is printed:

Enter the new WWN (or q to quit):

Step 4 Enter all eight bytes of the new WWN. Each byte of the entry should be delimited by colons. For 
example, enter:

00:00:00:30:8C:02:70:21

Step 5 The first five bytes of the entry are checked. If the entry is valid, you are prompted for a 
password. Type the password OverrideWWN and press Enter. 
This causes the SNC to reboot.

Step 6 When the SNC has rebooted, issue the fcShowNames command to verify the change. 
Verify that the output in the Node Name column is correct.

If only a single FC port is to be changed, use the wwnPortSet command to set the WWPN and WWNN for 
a single FC port.

Also, AMC can be used to verify that the WWNs are detected correctly following the change. For the failover 
or self-domain solution, AMC will issue a warning message indicating duplicate WWNs have been detected. 
This means the setup is performed correct.

CAUTION
The wwnGlobalSet command requires that the first byte be entered as "00" 
even if fcShowNames displays "10" in that position.

CAUTION
When entering the WWN, the firmware will confirm that the node ID and OUI 
match the existing values. This prevents a user from accidentally making the 
SNC appear as another vendor’s device.

Note If one of the WWN fails to change, run the wwnPortSet command again.
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Standard Solution

Figure 75 Standard: SNC with the single-aisle

Figure 76 Standard: SNC with dual-aisle

Requirements

• Single Scalar DLC server (host) with (at least one) FC Initiator adapter

• SNC

• Single- or dual-aisle library.

• SCSI cables and terminators, FC cables

• Fibre Channel switch (optional)

Pre-Setup

Library is set up, the host is set up, all required services and drivers are installed. Before installing the Scalar 
SLC software. See Setting Up the Standard Solution on page 7.

Setup Roadmap

Step 1 Resolve the cabling, switch, etc. (Figure 75 and Figure 76 are examples of the whole structure). 
Note also Two-channel Adapters on page 72.

Step 2 Using AMC, set up the SNC. See SNC Setup on page 127.

Step 3 Launch My Computer > Manage > Device Manager to verify that the Windows 2000/2003 
machine can see the Library "Medium Changer"(two medium changers must be present for a 
dual-aisle library).

Step 4 Install Scalar DLC software and proceed the work. See Scalar DLC Software on page 50.

CAUTION
The FC Switch zoning feature needs to be properly set up too. Ports for Host 
and SNC must be in the same zone.
Installation Guide 129



Failover and Self-Domain Solution

Figure 77 Failover: SNC with the single-aisle, switch scheme

Figure 78 Failover: SNC with the single-aisle, two-port-scheme

Figure 79 Failover: SNC with the dual-aisle, switch scheme

Figure 80 Failover: SNC with the dual-aisle, two-port-scheme

Requirements

• Two Scalar DLC servers (hosts), Node 1 and Node 2. Each host has (at least one) FC Initiator 
adapter

• Either two SNC devices or single SNC and FC Switch

• Single- or dual-aisle library

• SCSI cables and terminators, FC cables

• Fibre Channel switch (optional)
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Pre-Setup
Library is set up, both nodes are set up, all required services and drivers are installed. Before installing the 
Scalar SLC software. See Setting Up the Failover Solution on page 13 or Setting Up the Self-Domain 
Solution on page 33.

Setup Roadmap

Step 1 Resolve the cabling, switch, etc. (Figure 77 on page 130, Figure 78 on page 130, Figure 79 on 
page 130 and Figure 80 on page 130 are examples of the whole structure). Note also Two-
channel Adapters on page 72.

Step 2 Using AMC, set up all SNC devices. See SNC Setup on page 127.

Step 3 On both nodes, launch My Computer > Manage > Device Manager to verify that the Windows 
2000/2003 machine can see the Library "Medium Changer"(two medium changers must be 
present for a dual-aisle library).

Step 4 Install Scalar DLC software and proceed the work. See Scalar DLC Software on page 50.

Notes
Each time the library or one of its robots is restarted, the SNC must be restarted too. Otherwise even after 
the library/robot is up, the SNC does not see it, and the Scalar DLC reacts to the library/robot as ‘not ready’.

Building Client Connections

Additional activity may be required for the clients to connect to the Scalar DLC software.

DAS
Install the DAS Client software on the client PC. See Installing DAS Client on page 65. Ensure that there is 
valid TCP/IP connection between client and server, and proceed the work.

Standard Solution
Use the common Scalar DLC host name as DAS_SERVER value on the client host.

If a firewall exist between client and Scalar DLC host, the DAS/ACI Firewall should be installed either on PC 
in a Scalar DLC host domain or directly on the Scalar DLC PC.

Failover and Self-domain Solution
Use the common Cluster name (for example, SDLC-CLUSTER) as DAS_SERVER value on the client host.

If a firewall exist between client and Cluster, the DAS/ACI Firewall should be installed either on PC in cluster 
domain or on both cluster nodes; in the second case, the DAS-ACI Firewall server name must be specified 
as common Cluster name (for example, SDLC-CLUSTER), too.

CAUTION
The FC Switch zoning feature needs to be properly set up too. On Figure 77 on 
page 130, all three ports must be in the same zone. On Figure 79 on page 130, 
ports for Node 1 and SNC1 must be in Zone1, and ports for Node 2 and SNC2 
must be in Zone2.
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SCSI
Additional hardware requirements exist for the SCSI Clients based on either SCSI or Fibre Channel 
connection.

Standard Solution

Figure 81 Standard solution: SCSI Client Connection

SCSI Requirements:

• 1 SCSI Target Adapter, as described in Table 16 on page 71.

• 1 middle length (2-3 m) SCSI cable (68 pins) (client connection)

Be sure that the client connection scheme matches the example (see Figure 81). The SCSI target 
adapter(s) on the Scalar DLC host must work in Target mode (see Activating Target Mode on page 77).

Note Two-channel Adapters on page 72 and Disabling Library Medium Changer on page 133.

Figure 82 Standard solution: Fibre Channel Client Connection

FC Requirements:

• 1 FC Target Adapter, as described in Table 16 on page 71.

• FC switch

• 1 FC cable (client connection)

Be sure that the client connection scheme matches the example (see Figure 82). The FC target adapter(s) 
on the Scalar DLC host must work in Target mode, but not failover (see Activating Target Mode on page 77).

Note Two-channel Adapters on page 72 and Disabling Library Medium Changer on page 133.

Note If two or more SCSI/FC Target Adapters are used, additional cables are required. All 
adapters used in Target mode must match Table 16 on page 71 and also must be 
activated as Targets, as described in Activating Target Mode on page 77.
132 Advanced Setup Instructions



Failover and Self-domain Solution

Figure 83 Failover solution: SCSI Client Connection

SCSI Requirements:

• 2 SCSI Target HBA, as described in Table 16 on page 71.

• 2 SCSI Y-Block connectors (Y-cables) to terminate the SCSI Bus.

• 1 SCSI Terminator.

• 1short (~1 m) SCSI cable (68 pins) (in-cluster connection)

• 1middle length (2-3 m) SCSI cable (68 pins) (client connection)

Be sure that the client connection scheme matches the example (see Figure 83). Both SCSI target adapters 
on the Scalar DLC hosts must work in Target mode (see Activating Target Mode on page 77).

Note Two-channel Adapters on page 72 and Disabling Library Medium Changer on page 133.

Figure 84 Failover solution: Fibre Channel Client Connection

FC Requirements:

• 2 FC Target Adapters, as described in Table 16 on page 71.

• FC switch

• 2 FC cables (client connection)

Be sure that the client connection scheme matches the example (see Figure 84). The FC target adapter(s) 
on the Scalar DLC hosts must work in Target mode, and failover (see Activating Target Mode on page 77).

Note Two-channel Adapters on page 72 and Disabling Library Medium Changer on page 133.

Disabling Library Medium Changer
After configuring the Scalar DLC and creating logical library and appropriate SCSI client (see Scalar DLC 
Reference Guide) the client machine will detect the Scalar DLC server as the real library Medium Changer. 
Disable it before starting the work with SCSI/FC client interface.

• Launch My Computer > Manager > Device Manager > Medium Changers. The list of medium 
changers will appear.
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• Select the media changer that represents the library device (ADIC Scalar 1000, Scalar 10K, or 
Scalar 100). By default it is enabled.

• Right-click and select Disable (or execute Menu > Action > Disable) to disable the library.

• Ensure that the library device is disabled. The Scalar DLC SCSI Client can not access the enabled 
media changer.

• Close Device Manager. No restart is required.

ROBAR
Install the ROBAR Client software on the client PC. If the HCC/MVS software is used, configure it, too, and 
set the appropriate ROBAR Client parameters in the Management GUI. Be sure a valid ROBAR port is 
specified. The details are described in Reference Guide, GUI Tabs chapter, ROBAR and ROBAR Client 
sections.

Standard Solution
Set the HOST parameter to the Scalar DLC host name.

Failover and Self-domain Solution
Set the HOST parameter to the Cluster name (for example, SDLC-CLUSTER).

Installing SCSI/FC Target Adapters on a Live Machine

Although ADIC recommends to install and set up all required hardware before starting the work, it is possible 
to make some changes later, too.

Step 1 Node1 passive, Node2 active. The Scalar DLC operates on Node2.

Step 2 Shutdown Node1. Install the new SCSI/FC card into a free PCI slot (note what slot it is).

Step 3 Start Node1. The Windows Device Manager will find a new device and install the SCSI/FC 
initiator driver (or request the user to install it from a manufacturer disk). See Initiator Driver on 
page 73.

Step 4 Restart Node1. Install Target driver for a new adapter. See Installing the SCSI/FC Target 
Drivers on page 74.

Step 5 Restart Node1. Launch Scalar DLC SCSI Target Port Tool and enable the new SCSI card as 
Target. For the FC card, resolve the WWN (see Activating Target Mode on page 77).

Step 6 Restart Node1. Make Node1 active, Node2 passive. The Scalar DLC will operate on Node1.

CAUTION
Never disable the media changers that are not mentioned in the list above.

Note The following instruction is valid only for Failover and Self-domain solution.
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Step 7 Repeat steps 2- 6 for Node2. The SCSI/FC adapters should be identical, and they should be 
installed in the identical PCI slots.

Step 8 Now launch Scalar DLC Management GUI at any node and configure the SCSI targets for the 
client.

The down time for the Scalar DLC software is only during changing the cluster nodes. All startup/shutdown 
operations are executed on the passive node.

Securing the Scalar DLC

Follow the linked instructions to make the Scalar DLC system secure.

• For the information on securing the Windows 2003 operating system refer to 
http://www.nsa.gov/snac/downloads_win2003.cfm?MenuID=scg10.3.1.1

• For the information on securing the Windows 2000 operating system refer to 
http://www.nsa.gov/snac/downloads_win2000.cfm?MenuID=scg10.3.1.1

• For the information on securing the Apache Web server refer to  
http://www.securityfocus.com/infocus/1694

• For the information on securing the MSDE 2000 (MS SQL) refer to  
http://www.microsoft.com/sql/techinfo/administration/2000/security/securingsqlserver.asp

The Scalar DLC itself requires the following security actions to be performed:

Step 1 Install the latest Windows Hot Fixes and service pack. The current version is Service Pack 4 for 
Windows 2000 (SP1 for Windows 2003 Server). Both the Hot Fixes and service packs can be 
downloaded on  
http://www.microsoft.com.

Step 2 Install the Apache with SSL encryption.

Step 3 Install the SP4 for MSDE 2000.

Step 4 When installing the Scalar DLC, provide the user name and password according to the 
corporative security standards.

Step 5 Set up the web browser(s) according to the corporative security standards. If the email client 
will be used on the same PC where the Scalar DLC is installed, ensure it is secured too (for 
example, binary files are not automatically opened, etc.). Contact the local network 
administrator for the details.

Antivirus Strategy
To ensure the Scalar DLC system remains virus-proof and worm-proof, perform the following security 
actions.

• After the Scalar DLC is successfully installed, install the antivirus software that matches the local 
corporative standard. ADIC typically uses the following products with the Scalar DLC:

Note If the firewall is used to secure the Scalar DLC host, the DAS client software must be 
installed with the firewall support. Refer to Installing DAS Client on page 65.
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• McAfee® VirusScan® Enterprise 8.0i (refer to: 
http://www.mcafee.com/us/products/mcafee/antivirus/desktop/vs.htm)

• McAfee® ePolicy Orchestrator® Anti-Virus Management system (refer to: 
http://isservices.tcd.ie/security/epol.php)

• After the antivirus software is successfully installed, provide the regular antivirus database update 
(either by periodical basis or automatically) to be sure the Scalar DLC system remains virus-proof. 
Install the appropriate patches and service packs when it is required.

The same actions are to be performed on the client PC (the client side of Scalar DLC software, as shown 
in Figure 1 on page 3).

Note Contact the local network administrator for the details on how to install and set up the 
antivirus software.

Note On the Scalar DLC Failover or Self-Domain solution it is recommended to launch the 
antivirus update on the passive node.
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