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Preface

Quantum® StorNext™ Advanced Reporting provides performance data 
logging and visual reporting and graphing features for StorNext 
systems.

This guide introduces StorNext Advanced Reporting and discusses the 
following topics:

• Installation

• Navigation

• Reports

Audience This guide is written for StorNext Metadata Controller (MDC) operators 
and system administrators.

Document Organization This guide contains the following chapters:

• Chapter 1, StorNext Advanced Reporting Introduction provides an 
overview of the features of StorNext Advanced Reporting.

• Chapter 2, StorNext Advanced Reporting Installation provides step-
by-step instructions for installing and running StorNext Advanced 
Reporting.
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• Chapter 3, StorNext Advanced Reporting Navigation describes how 
to access and work with the Web-based user interface of StorNext 
Advanced Reporting.

• Chapter 4, Advanced Reports describes how to view and interpret 
the available performance reports.

• Glossary provides definitions of technical terms used in this 
document.

Terminology For purposes of this document, the term StorNext MDC is used for all 
StorNext Metadata Appliances, which are treated as a single logical unit. 
The term StorNext MDC also applies to StorNext software running on 
customer-supplied MDC hardware, and both nodes of StorNext HA 
systems, which are also treated as a single, logical unit.

Notational Conventions This manual uses the following conventions:

Convention Example

User input is shown in bold font. ./install

Computer output and command 
line examples are shown in 
monospace font.

install.stornext

User input variables are enclosed in 
angle brackets.

http://<machine 
name>:<port number>

For UNIX and Linux commands, the 
command prompt is implied.

./snPreInstall 
is the same as 
# ./snPreInstall

File and directory names, menu 
commands, button names, and 
window names are shown in bold 
font.

/usr/cvfs/config

Menu names separated by arrows 
indicate a sequence of menus to be 
navigated.

Configuration > File 
Systems
x StorNext Advanced Reporting 2.0.6 User’s Guide
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The following formats indicate important information:

Note: Note emphasizes important information related to the main 
topic.

Caution: Caution indicates potential hazards to equipment or data.

WARNING: Warning indicates potential hazards to personal safety.

Related Documents For the most up to date information on StorNext Advanced Reporting, 
see:

http://www.quantum.com/ServiceandSupport/Index.aspx

Contacts Quantum company contacts are listed below.

Quantum Corporate Headquarters

To order documentation on StorNext Advanced Reporting or other 
products contact:

Quantum Corporation (Corporate Headquarters) 
1650 Technology Drive, Suite 700 
San Jose, CA 95110-1382

Quantum Home Page

Visit the Quantum home page at: 

http://www.quantum.com

Getting More 
Information or Help

StorageCare™, Quantum’s comprehensive service approach, leverages 
advanced data access and diagnostics technologies with cross-
environment, multi-vendor expertise to resolve backup issues faster and 
at lower cost. 
StorNext Advanced Reporting 2.0.6 User’s Guide xi
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Accelerate service issue resolution with these exclusive Quantum 
StorageCare services:

• Service and Support Website – Register products, license software, 
browse Quantum Learning courses, access-free online training, 
check backup software and operating system support, and locate 
manuals, FAQs, software downloads, product updates and more in 
one convenient location. Benefit today at:

http://www.quantum.com/ServiceandSupport/Index.aspx

• eSupport – Submit online service requests, update contact 
information, add attachments, and receive status updates via 
e-mail. Online Service accounts are free from Quantum. That 
account can also be used to access Quantum’s Knowledge Base, a 
comprehensive repository of product support information. Sign up 
today at:

http://www.quantum.com/osr

• StorageCare Guardian – Securely links Quantum hardware and the 
diagnostic data from the surrounding storage ecosystem to 
Quantum's Global Services Team for faster, more precise root cause 
diagnosis. StorageCare Guardian is simple to set up through the 
internet and provides secure, two-way communications with 
Quantum’s Secure Service Center. More StorageCare Guardian 
information can be found at:

http://www.quantum.com/ServiceandSupport/Services/
GuardianInformation/Index.aspx

For further assistance, or if training is desired, contact Quantum 
Customer Support Center:

United States 800-284-5101 Option 5 (toll free)

EMEA 00800 7826 8888 (toll free)
49 6131 3241 1164

APAC +800 7826 8887 (toll free)
+603 7953 3010

For worldwide support:
http://www.quantum.com/ServiceandSupport/Index.aspx
xii StorNext Advanced Reporting 2.0.6 User’s Guide
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Worldwide End-User 
Product Warranty

For more information on the Quantum Worldwide End-User Standard 
Limited Product Warranty:

http://www.quantum.com/pdf/QuantumWarranty.pdf
StorNext Advanced Reporting 2.0.6 User’s Guide xiii
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Chapter 1
StorNext Advanced 

Reporting Introduction

This chapter introduces StorNext Advanced Reporting and contains the 
following sections:

• About StorNext Advanced Reporting

• Logging Database

• Performance Impact

About StorNext Advanced Reporting

StorNext Advanced Reporting is a visual reporting tool that comes 
installed on all StorNext Metadata Appliances and optionally on 
customer-supplied MDC hardware. This tool combines comprehensive 
performance data logging with powerful visual reporting and analysis 
tools to help you identify potential problems and optimize system 
operation.

See the following sections for more information about StorNext 
Advanced Reporting:

• Extension to StorNext Remote Management

• On Demand Reports

• Historical Data
StorNext Advanced Reporting 2.0.6 User’s Guide 1
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About StorNext Advanced Reporting
Extension to StorNext 
Remote Management

StorNext Advanced Reporting is an extension to the StorNext GUI. With 
StorNext Advanced Reporting, you can view an array of performance 
statistics for a StorNext MDC and see how those statistics change over 
time. This lets you identify trends or determine when a problem began.

By showing you how various operations affect performance, StorNext 
Advanced Reporting also helps you optimize the network ecosystem 
and business procedures for data management policies, file system disk 
usage, and replication.

On Demand Reports StorNext Advanced Reporting continually works in the background to 
log performance data. To view logged data, use StorNext Advanced 
Reporting's graphical reports. Reports are available on demand through 
a Web-based interface. You can check up-to-the-minute system status or 
view data for any time period since data logging began.

StorNext Advanced Reporting reports let you view and work with a 
wealth of performance and system statistics, such as Ethernet I/O, Fibre 
Channel I/O, CPU load, File System (FS), and Memory. Each report 
includes two or more graphs. Use the report tools to zoom in on a 
graph to see just the time period you want to see, or zoom out to see 
data for a longer time period.

No matter what time period you select, all of the graphs in the report 
stay in sync. In addition, StorNext Advanced Reporting maintains the 
current time period when you select a new report. This lets you compare 
performance data between graphs in the same report or between 
different reports. For example, you can see how CPU load is affected 
during deduplication or space reclamation activities.

Figure 1 shows an example of the Memory report.
2 StorNext Advanced Reporting 2.0.6 User’s Guide
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About StorNext Advanced Reporting
Figure 1  StorNext Advanced 
Reporting Memory Report

Historical Data StorNext Advanced Reporting maintains a maximum of six years of 
logged data, so you can view historical reports for previous time 
periods.

StorNext Advanced Reporting's historical record lets you compare 
current performance to past performance. It also lets you see the effect 
of any recent changes to system and network configuration or business 
processes.
StorNext Advanced Reporting 2.0.6 User’s Guide 3
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Logging Database

StorNext Advanced Reporting records performance data in the logging 
database. The database resides on the StorNext MDC where StorNext 
Advanced Reporting is running.

See the following sections for more information about the logging 
database:

• Round Robin Database

• Database Resolution

• Performance Impact

Round Robin Database The StorNext Advanced Reportinglogging database is a round robin 
style database with a small, fixed size. The database never grows larger 
than the fixed size. As new logging data is added to the database, older 
data is overwritten as necessary, thereby maintaining the fixed size. As a 
result, the logging database has a negligible impact on storage capacity 
on the StorNext MDC.

Database Resolution The logging database records performance data at two second intervals. 
StorNext Advanced Reporting aggregates this data over time to 
maintain different resolutions for different time periods. The database 
resolution is finer (more granular) for recent events and becomes 
coarser (less granular) as you go back in time.

Table 1 lists the database resolutions that are maintained in the logging 
database for each time period.

Table 1  Logging Database 
Resolution Database Resolution Maintained For

2 seconds Data up to 7 days old

60 seconds Data older than 7 days
4 StorNext Advanced Reporting 2.0.6 User’s Guide
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Logging Database
Performance Impact StorNext Advanced Reporting logging has a negligible impact on the 
operation and performance of a StorNext MDC.

• Most data is captured once every two seconds with a typical loop 
time of only 2ms per capture.

• Total disk capacity used is limited to 2GB for the logging database.

• Disk contention is rare, and if it occurs StorNext Advanced Reporting 
logging has lower priority compared to system needs.
StorNext Advanced Reporting 2.0.6 User’s Guide 5
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Chapter 2
StorNext Advanced 

Reporting Installation

This chapter describes how to install StorNext Advanced Reporting and 
contains the following sections:

• Setting the Date and Time

• Obtaining StorNext Advanced Reporting

• Installing or Upgrading StorNext Advanced Reporting

Setting the Date and Time

Because data in the StorNext Advanced Reporting database is time 
sensitive, it is important that the date and time are correctly set on the 
StorNext MDC before using StorNext Advanced Reporting.
StorNext Advanced Reporting 2.0.6 User’s Guide 7
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Caution: When changing the date and time on a StorNext MDC, 
make sure not to change to a date in the future. For 
example, if the current date is July 30, 2011 and you 
accidentally change the date on the StorNext MDC to July 
30, 2012 (a year ahead), and then change the date back to 
the correct date of July 30, 2011, the StorNext MDC will 
not collect Advanced Reporting logging data until July 30, 
2012, even though you restored the correct date. This 
means that you would not be able to use StorNext 
Advanced Reporting until July 31, 2012.

If the date and time are not correct on the StorNext MDC, it will be 
difficult to associate StorNext Advanced Reporting data with events in 
the customer’s ecosystem.

To make sure the time and date are always correct, configure the 
StorNext MDC to use a Network Time Protocol (NTP) server. For help 
with this task, see the current StorNext User’s Guide.

Caution: Not all Windows time servers offer NTP services. If a time 
server does not support the NTP protocol, you cannot use it 
as a time source for the StorNext MDC. However, in this 
case, a third party NTP application for Windows should 
work correctly.

Obtaining StorNext Advanced Reporting

StorNext Advanced Reporting comes installed on all StorNext Metadata 
Appliances and is available for download on customer-supplied MDC 
hardware. See the following sections for more information:

• Downloading StorNext Advanced Reporting
8 StorNext Advanced Reporting 2.0.6 User’s Guide
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Downloading StorNext 
Advanced Reporting

To obtain StorNext Advanced Reporting, download the software from 
the Quantum Service and Support site:

http://www.quantum.com/ServiceandSupport/Index.aspx

Under Select Your Product, navigate to the support page for your 
StorNext MDC, click the Diagnostics tab, and go to the Product 
Training section. Then download the StorNext Advanced Reporting 
software for your system.

Note: A documentation CD is included with your StorNext MDC.

Installing or Upgrading StorNext Advanced Reporting

To install StorNext Advanced Reporting on a StorNext MDC, or to 
upgrade, upload the StorNext Advanced Reporting software to the 
StorNext MDC. For detailed steps, see Uploading the StorNext Advanced 
Reporting Software on StorNext Metadata Appliances on page 10 for 
StorNext Metadata Appliances, or Installing/Upgrading the StorNext 
Advanced Reporting Software on StorNext MDCs on page 12 for 
customer-supplied MDC hardware.

Note: Uploading the StorNext Advanced Reporting software does not 
change the system software on the StorNext MDC. You do not 
need to restart the system after installing StorNext Advanced 
Reporting, and installing StorNext Advanced Reporting does 
not affect system operation.
StorNext Advanced Reporting 2.0.6 User’s Guide 9
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Installing or Upgrading StorNext Advanced Reporting
Uploading the StorNext 
Advanced Reporting 
Software on StorNext 
Metadata Appliances

Locate the StorNext Advanced Reporting software file you downloaded 
from the Quantum Web site (or that you obtained on CD). Then perform 
the following steps:

Note: This section only applies to StorNext Metadata Appliances.

1 On a workstation that has network access to the StorNext Metadata 
Appliance, launch a supported Web browser on the workstation, 
and then log on to the StorNext GUI as an administrator.

2 From the Tools menu, click Firmware Upgrade.

The Firmware Upgrade window displays (see Figure 2).

Figure 2  Firmware Upgrade 
Window

3 Clear the Auto Upload check box.

4 Click Browse and locate the StorNext Advanced Reporting upgrade 
file that you downloaded from the Quantum Web site. 

5 Select the upgrade file, and then click Open.

6 Click Upload.
10 StorNext Advanced Reporting 2.0.6 User’s Guide
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Installing or Upgrading StorNext Advanced Reporting
The upload will continue with progress being displayed on the 
progress bar.

7 Click the radio button next to the file that you want to install.

8 Click Validate to perform a version check to make sure the upgrade 
file is valid for that system. 

A Firmware Upgrade dialog displays.

Figure 3  Firmware Upgrade 
Dialog

9 Click OK.

10 Click Apply to install the upgrade.

A warning dialog, similar to the following, displays.

Figure 4  Firmware Upgrade 
Warning Dialog

11 Click Yes to install the upgrade file.

Note: On some StorNext MDCs, an Information dialog 
displays. The dialog states that the system will restart 
and you must log in again. However, this is only true if 
you are updating the StorNext Metadata Appliance 
software. Installing StorNext Advanced Reporting will 
not affect system operation.
StorNext Advanced Reporting 2.0.6 User’s Guide 11
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The installation is complete. To access StorNext Advanced 
Reporting, see Accessing StorNext Advanced Reporting on 
page 15.

Installing/Upgrading 
the StorNext Advanced 
Reporting Software on 
StorNext MDCs

This section describes how to install or upgrade StorNext Advanced 
Reporting on a StorNext MDC.

Caution: Before you begin, Apache must be installed prior to the 
StorNext Advanced Reporting installation or upgrade, and 
mod_ssl, if installed, so that it does not conflict with 
port 443. If Apache is not installed or does not work 
properly, the installation will fail. 
 
To install Apache on n, run yum install httpd

Required Packages

The RedHat packages listed in this section must already be installed on 
your system before StorNext Advanced Reporting can be installed. 

Important! If one or more packages are not detected during the 
installation of StorNext Advanced Reporting, the 
installation will stop, and a list of missing packages will be 
displayed for your reference. You can install missing 
packages from your OS vendor CD or by download. 

RedHat 5:

• bash

• dejavu-lgc-fonts

• cairo

• glibc

• glib2

• pango

• libpng

• tcp_wrappers
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RedHat 5 (continued):

• libxml2

• perl

• perl-Filesys-Df

• perl-5.8.8

• perl-XML-Parser

• perl-XML-Simple

RedHat 6:

• bash

• dejavu-lgc-fonts

• cairo

• glibc

• glib2

• pango

• libpng

• tcp_wrappers

• libxml2

• perl

• perl-Filesys-Df

• perl-5.10.1

• perl-XML-Parser

• perl-XML-Simple 

Beginning the Installation

Follow these steps to install StorNext Advanced Reporting:

Note: On HA systems, the following steps must be performed on 
BOTH the primary and secondary nodes.
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1 If you have not already done so, download to the directory of your 
choice the StorNext Advanced Reporting installer as described in 
Downloading StorNext Advanced Reporting on page 9.

2 Log in via ssh as root, using your system password.

3 chmod 755 the downloaded file.

4 rm -rf the /tmp/stornext directory. 

Note: The /tmp/stornext directory must be empty when you 
extract the files to install. If the directory is not empty, 
extraction will fail with an error message.

5 Execute the installation file. 

6 When the StorNext End User License Agreement (EULA) appears, 
read and accept the agreement. (You can display the next and 
subsequent pages by pressing the space bar.)

7 cd /tmp/stornext and cd to the subdirectory created.

8 Execute the command ./install.

During installation you will see a series of messages. Look for the 
following message which indicates that the software was correctly 
installed: 

0: loggerd -u (running [loggerd process number])

9 To monitor a particular system using StorNext Advanced Reporting, 
enter the IP address of that system in the following format:  
http://<ip_address>/reports/# 

Note: You must include the pound sign (#) on StorNext MDCs.
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StorNext Advanced 

Reporting Navigation

This chapter describes how to navigate in StorNext Advanced Reporting 
and contains the following sections:

• Accessing StorNext Advanced Reporting

• Using the Report Window

• Working With Time Ranges

• Working With Graphs

• Interpreting Performance Data

Accessing StorNext Advanced Reporting

To access StorNext Advanced Reporting, you must use a Web browser 
on a workstation that is on the same network as the StorNext MDC for 
which you want to view reports.

See the following sections for more information about accessing 
StorNext Advanced Reporting:

• Supported Web Browsers

• Accessing the StorNext Advanced Reporting User Interface
StorNext Advanced Reporting 2.0.6 User’s Guide 15



Chapter 3: StorNext Advanced Reporting Navigation
Accessing StorNext Advanced Reporting
Supported Web 
Browsers

StorNext Advanced Reporting is designed to run in any modern Web 
browser that supports the Adobe Flash Player plug-in version 10.x and 
higher. Web browser software is not included with StorNext Advanced 
Reporting. You must obtain and install it separately.

You must also install the correct version of the Adobe Flash Player plug-
in for your operating system and browser. StorNext Advanced Reporting 
requires Adobe Flash Player version 10.x or higher. To download and 
install Flash Player, go to: http://www.adobe.com

Note: You can also use the StorNext installation CD to install the 
Adobe Flash Player plug-in. If your site does not allow Internet 
access from the StorNext MDC, this is another method to install 
the software.

Caution: StorNext Advanced Reporting does not support the 64-bit 
version of the Flash Player plug-in on Linux. Instead, use 
the 32-bit Flash Player plug-in and a 32-bit browser.

Installing Flash Using the Software CD

If your site does not allow Internet access, use an installation CD to 
install the Adobe Flash Player plug-in.

Note: If you cannot find the CD or cannot obtain the Flash software 
online, call customer support for a new installation CD.

To install Flash Player:

1 Insert the StorNext Advanced Reporting Software CD in the CD-ROM 
drive of your computer.

2 On the CD, open the plugins directory, and then open the directory 
for your operating system.

3 (Windows only) Open the activex directory (Internet Explorer) or 
open the plugin directory (other browsers).

4 Double-click the Flash Player installer, and then follow the onscreen 
instructions.
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Accessing the StorNext 
Advanced Reporting 
User Interface

Follow these steps to access the StorNext Advanced Reporting user 
interface:

1 Log on to the StorNext MDC.

2 From the StorNext GUI, click the Tools menu, and then select 
Advanced Reporting (see Figure 5).

Figure 5  Accessing StorNext 
Advanced Reporting

The StorNext Advanced Reporting user interface displays. The user 
interface is also referred to as the report window (see Figure 6).
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Figure 6  StorNext Advanced 
Reporting User Interface

Using the Report Window

The report window displays the performance graphs for the currently 
selected report (see Figure 7). When you first access StorNext Advanced 
Reporting, the Ethernet I/O report displays.

The report window includes the following features:

• StorNext Advanced Reporting Menus

• Toolbar

• View Controls

• Graphs
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Figure 7  Report Window

Note that at the bottom of every report window is a link that provides a 
URL reference to the current report (see Figure 8). The URL can be 
copied and sent to a third party, such as a coworker, and then viewed in 
a different browser.

Help

Menu

Toolbar

System Information

Button Bar

View Controls

Report Graphs

Timeline
StorNext Advanced Reporting 2.0.6 User’s Guide 19



Chapter 3: StorNext Advanced Reporting Navigation
Using the Report Window
Figure 8  URL Reference

StorNext Advanced 
Reporting Menus

The following menu options display at the top of the StorNext 
Advanced Reporting window:

• Reports – Use the Reports menu to select a report to display (see 
Figure 9).

URL reference
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Figure 9  Reports Menu

StorNext Advanced Reportingmaintains the currently selected time 
range when you choose a new report. For example, if you are 
currently viewing the most recent day of logging for the Overview 
report, StorNext Advanced Reporting displays data for that same 
time range when you select a new report. This makes it easy to 
compare different performance statistics for the same time range.

Note: For more information about time ranges, see Working With 
Time Ranges on page 24. For a description of the available 
reports, see Advanced Reports on page 37.

• View – Use the View menu to show or hide the button bar 
(Buttons), system information (Info), the timeline (Span), the 
toolbar (Toolbar), or the view controls (View Controls).

By default, all of these items are enabled except for Span.

• Actions – Use the Actions menu to perform graph actions.

• Update - Updates the graphs in the currently displayed report 
with the latest logging information.

• Scroll Up - Scrolls the graph order up by one graph.

• Scroll Down - Scrolls the graph order down by one graph.

• Show All Legends - Shows the title and legend on all graphs in 
the report.

• Hide All Legends - Hides the title and legend on all graphs in 
the report.
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• About – Use the About menu to display version and license 
information for StorNext Advanced Reporting (see Figure 10).

Figure 10  About Menu

Toolbar The toolbar displays below the menu and includes the following 
options:

• Buttons - Shows hides the button bar. (By default, the button bar is 
hidden.)

• Info - Shows or hides the system information. (By default, the 
system information is visible.)

The system information includes the StorNext model, serial number, 
software version, and the current date, time, and time zone.

• Span - Shows or hides the timeline. (By default, the timeline is not 
visible.)

• Controls - Shows or hides the view controls. (By default, the view 
controls are visible.)
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• Update - Updates the graphs in the currently displayed report with 
the latest logging information.

• Up - Scrolls the graph order up by one graph.

• Down - Scrolls the graph order down by one graph.

• Show All - Shows the title and legend on all graphs in the report.

• Hide All - Hides the title and legend on all graphs in the report.

• User Menu - Displays the user that is currently logged on to 
StorNext Advanced Reporting.

Note: To hide the toolbar, click the arrow on the right edge of the 
toolbar. Click the arrow again to show the toolbar.

View Controls The view controls display on the left edge of the report window and 
include the following options:

• Scroll Up - Scrolls the graph order up by one graph.

• Show All Legends - Shows the title and legend on all graphs in the 
report.

• Hide All Legends - Hides the title and legend on all graphs in the 
report.

• Scroll Down - Scrolls the graph order down by one graph.

Graphs Each report is made up of one or more graphs that show performance 
data for the selected time range (see Figure 11). Customize the 
appearance of a report by arranging the graphs in a different order.

• To change the order of the graphs, drag a graph by its title bar and 
move it before or after another graph.

• To minimize a graph, click the Minimize (–) graph button on the 
right side of the graph title bar. To restore the graph to full size, click 
the minimized title bar, located towards the bottom of the window.

• To export a screen capture (.JPG or .PNG image) of the graph, click 
the Export as Image button on the right side of the graph title bar, 
located next to the Minimize button.
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• To display or hide the graph title and legend, click the Show/Hide 
Legend and Title button (magnifying glass) on the right side of the 
graph title bar.

Note: If you log off of StorNext Advanced Reporting, the graphs are 
restored to their default appearance the next time you log on.

Figure 11  Arranging Graphs

Working With Time Ranges

A time range is like a window through which you view performance 
data. Each report displays performance data for the time range you 
choose. All graphs in a report display data for the same time range.

By default, StorNext Advanced Reporting displays data for the most 
recent seven days of logging. To view logged data for a different time 
range, use the tools at the top of the report window. You can move the 
time range backward and forward in time, and you can make the time 
range longer or shorter.

When you change the time range, StorNext Advanced 
Reportingautomatically adjusts the resolution of performance data. For 
example, the resolution is finer (more granular) for shorter time ranges 
and is coarser (less granular) for longer time ranges.

Drag title bar to arrange

Selected time range

Show/Hide Legend and Title button

Export as Image button

Minimize graph button
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Note: No matter how long the time range is, StorNext Advanced 
Reporting scales all graphs in the report so that the time range 
uses the entire width of each graph.

Changing the Time 
Range

To view performance data for a different time range, use one of the 
following methods:

• Using the Timeline

• Selecting a Preset Time Range

• Moving Forward and Backward

• Zooming With the Dynamic Zoom Feature

• Zooming With the Preset Zoom Buttons

• Specifying Start and End Times

• Resetting the Time Range

Note: The button bar displays the starting date and time and the 
ending date and time of the current time range, as well as the 
total length of the time range. It also displays the time zone of 
the StorNext MDC. If the button bar is not visible, select View 
> Buttons.

Using the Timeline

To move the time range forward or backward in time, use the timeline 
at the top of the report window (see Figure 12). The timeline displays 
the current time range used for the report.

Note: If the timeline is not visible, select View > Span.

• To move the time range backward or forward in time, drag the 
timeline to the left or right. Then double-click the timeline to apply 
the new time range to the report.

• To make the time range longer or shorter, drag the left and right 
selection handles. Then double-click the timeline to apply the new 
time range to the report.
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Figure 12  Using the Timeline

Selecting a Preset Time Range

To quickly display performance data for a different time range, use the 
time range presets on the timeline (see Figure 13). Click a preset to 
display data for 1 hour (1h), 4 hours (4h), 12 hours (12h), 1 day (1d), 
1 week (1w), 1 month (1m), or 1 year (1y). After you click a preset, 
double-click the timeline to apply the new time range to the report.

Note: If the timeline is not visible, select View > Span.

When you apply a preset, StorNext Advanced Reporting resizes the time 
range while maintaining the center of the time range. For example, if 
you are currently viewing a one week time range that goes from Sunday 
to Saturday, applying the 1d preset displays performance data for 
Wednesday.

Note: You can also use the button bar to apply time range presets. If 
the button bar is not visible, select View > Buttons.

Figure 13  Selecting a Preset 
Time Range

Moving Forward and Backward

Move the time range forward or backward in time using the navigation 
buttons on the left or right of the button bar (see Figure 14). StorNext 
Advanced Reporting shifts the time range while maintaining the length 
of the time range.

Drag handles to resize timeline

Drag timeline to move, or 
double-click to apply new time range

Click a preset time range to apply it
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Note: If the button bar is not visible, select View > Buttons.

Table 2 describes the functions of the navigation buttons.

Figure 14  Using the 
Navigation Buttons

Table 2  Navigation Button 
Functions

Zooming With the Dynamic Zoom Feature

Use the dynamic zoom feature to select the part of a graph you want to 
zoom in on and see in more detail (see Figure 15).

To zoom in on part of a graph:

1 Click and drag over the part of the graph you want to zoom in on.

StorNext Advanced Reporting highlights the selected part of the 
graph.

2 (Optional) Drag the left and right selection handles to adjust the 
size of the selection, or drag the selection area to move it.

3 Double-click the selection area.

StorNext Advanced Reporting zooms in on the time range so that 
the selected area takes up the entire width of the graph.

To cancel the action and start over, click Clear on the upper left of 
the graph.

Navigation buttons

Button Description

<<< or >>> Moves the time range back or forward an amount 
equal to the current time range.

<< or >> Moves the time range back or forward an amount 
equal to one half of the current time range.

< or > Moves the time range back or forward an amount 
equal to one quarter of the current time range.
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Figure 15  Click and Drag to 
Zoom

Zooming With the Preset Zoom Buttons

Use the preset zoom buttons on the button bar to zoom in or zoom out 
on a report by a fixed factor (see Figure 16). Click a preset zoom button 
to specify a zoom factor of x0.25, x0.5, x2.0, or x4.0. When you zoom 
in, StorNext Advanced Reporting displays a shorter time range. When 
you zoom out, StorNext Advanced Reporting displays a longer time 
range. StorNext Advanced Reporting maintains the current center of the 
time range when you zoom.

Note: If the button bar is not visible, select View > Buttons.

Figure 16  Using the Preset 
Zoom Buttons

Specifying Start and End Times

The Start and End boxes on the button bar display the starting date and 
time and the ending date and time for the current time range.

To change the time range using exact values, specify a new date and 
time in the Start and End boxes, and then click reload. StorNext 

Click to clear the selection

Double-click to apply the selection

Click a preset zoom to apply it

Click to reset the time range to the 
most recent seven days of logging
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Advanced Reporting adjusts the time range to reflect the start and end 
times you entered.

Note: Specify the starting or ending time in hours, minutes, and 
seconds using a twenty four hour clock.

Note: If the button bar is not visible, select View > Buttons.

Resetting the Time Range

To reset the time range back to its original position, click reset range on 
the button bar (see Figure 16). StorNext Advanced Reporting adjusts the 
time range to display the most recent seven day of logging.

Note: If the button bar is not visible, select View > Buttons.

Working With Graphs

In StorNext Advanced Reporting, each report is made up of one or more 
graphs. Each graph shows a particular type of performance data for the 
current time range. For example, the Self report includes the following 
graphs: CPU Load Average, CPU Stats in %, and Logging Loop Time.

The horizontal axis of each graph represents time and displays the 
current time range. The vertical axis varies depending on the graph. It is 
often a capacity or data amount, but can also be a calculated value such 
as a ratio, average, or percentage.

Below each graph is a color-coded legend. Use the legend to help read 
and interpret the graph. For example, according to the legend for the 
Memory Usage graph, bright green represents free memory, red 
represents used memory, and yellow represents cached memory on the 
StorNext MDC (see Figure 17).
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Figure 17  The Graph Legend

See the following sections for more information about graphs:

• Selecting the Base

• Gaps in Graphs

• Stacked and Layered Graphs

• The Zero Line

Selecting the Base Different StorNext MDCs report data usage in different ways.

• Data can be reported using a base of 1000 bytes per kilobyte, or in 
TB. (Similar to disk and tape drives.) 

• Data can be reported at 1024 bytes per kilobyte, or in TiB. (Similar 
to most backup applications.) 

This difference results in a disparity of over 10% in reported data sizes at 
the terabyte level. For example, 27.3TiB reported at base 1024 becomes 
30.0TB when reported at base 1000. Backup applications typically 
report summaries in units of 1024. Tape drives, tape cartridges, and disk 
drives report capacities in units of 1000.

StorNext Advanced Reporting is flexible and allows you to select 
whichever base quantity you want. To display data using a different 
base, select it in the Base list on the button bar (see Figure 18). StorNext 
Advanced Reporting adjusts all report data to reflect the selected base.

Note: If the button bar is not visible, select View > Buttons.

Graph legend
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Figure 18  Selecting a Base

Gaps in Graphs A white gap in a graph indicates an absence of logging data for a period 
of time. This can occur for the following reasons:

• A system reboot occurred.

• No StorNext Advanced Reporting logging took place because the 
system was busy.

• StorNext Advanced Reporting logging was turned off.

Stacked and Layered 
Graphs

StorNext Advanced Reporting often displays data for multiple variables 
on the same graph. This lets you see the interaction between different 
variables.

StorNext Advanced Reporting uses two different methods for placing 
multiple variables on the same graph:

• Layered Graphs

• Stacked Graphs

Layered Graphs

StorNext Advanced Reporting uses layered graphs to compare related 
variables. A layered graph superimposes data for two or more variables 
on top of one another. StorNext Advanced Reporting assigns a different 
color to each variable, so you can see how the values for each variable 
differ over time.

For example, in the FS Space graph, StorNext Advanced Reporting 
displays a separate value line for the variables Bytes used and Bytes free.

Note: StorNext Advanced Reporting always displays the smaller 
variable in front of the larger variable. Because of this, shifts in 
the color pattern in a graph can occur if the variable that was 
smaller becomes larger at some point in time.

Base list
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Figure 19  Layered Graph

Stacked Graphs

StorNext Advanced Reporting uses stacked graphs to display aggregate 
performance. A stacked graph adds together values for two or more 
variables to arrive at a total value. StorNext Advanced Reporting assigns 
a different color to each variable, so you can see the contribution that 
each variable makes to the total.

For example, in the Ethernet Activity graph, values for each Ethernet 
port are added together to reach a total value for each point in the time 
range.

Figure 20  Stacked Graph

The Zero Line StorNext Advanced Reporting uses graphs with a zero line to show 
when the StorNext MDC is being written to or being read from.

• Positive values (above the line) represent data being written to the 
StorNext MDC.

• Negative values (below the line) represent data being read from the 
StorNext system.
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By using a zero line, StorNext Advanced Reporting can show data reads 
and writes on the same graph, for example, on the Ethernet Activity 
graph (see Figure 21).

Figure 21  Graph With a Zero 
Line

Interpreting Performance Data

The power of StorNext Advanced Reporting is that it lets you compare 
different types of performance data for the same time range. This lets 
you see patterns and trends and helps you identify relationships 
between events.

Keep in mind the following general concepts as you work with graphs in 
StorNext Advanced Reporting:

• Correlating Information Across Graphs

• Looking For Interactions Between Events

• Understanding the Effects of Time Resolution

Data writes appear above the zero line

Data reads appear below the zero line
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Correlating Information Across Graphs

When you view a report, try to correlate information in one graph with 
information in the other graphs.

Remember that all graphs in a report display the same time range and 
always remain in sync. That means an event that happens in the center 
of one graph can be correlated with an event that happens in the center 
of another graph in the same (or in a different) report.

In other words, if you can draw a straight vertical line between events in 
two graphs, then the events happened at the same time.

Looking For Interactions Between Events

As you work in StorNext Advanced Reporting, look for interactions 
between events in different graphs.

While correlation is not the same as causation, if you consistently see 
that events in one graph happen at the same time as events in another 
graph, there is a strong possibility that the two types of events are 
related.

Understanding the Effects of Time Resolution

StorNext Advanced Reporting displays graphs with 960 data points 
(pixels) along the horizontal axis. However, the logging database usually 
contains more than 960 data points for the currently selected time 
range (depending on the length of the time range).

StorNext Advanced Reporting uses aggregation to convert the 
resolution of the database to the resolution of the graph. This means 
that, in many cases, each pixel in the graph is an aggregate of multiple 
data points in the database. Depending on how many data points are 
aggregated to create each pixel in the graph, the resulting value can 
change.

For example, consider a transfer on the Ethernet Activity graph that 
lasts for 6 seconds. First it is displayed in a 32 minute time range, and 
then in a 128 minute time range (see Figure 22).

• In the first example, the graph shows the transfer within a time 
range of 32 minutes or 1,920 seconds. In this case, each pixel in the 
graph represents 2 seconds of time. As a result, the transfer takes 
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up 3 pixels in the graph and displays a peak amplitude of 2.1MB/
second.

• In the second example, the graph shows the transfer within a time 
range of 128 minutes, or 7,680 seconds. In this case, each pixel in 
the graph represents 8 seconds of time. Even though the transfer is 
only 6 seconds long, it cannot take up less than 1 pixel in the graph. 
As a result, the transfer amount is averaged over 8 seconds, 
resulting in a lower peak amplitude of 0.9MB/second.

Figure 22  Amplitude Changes 
With Resolution

The only difference between the two examples is the time resolution. 
The underlying data did not change. The difference in amplitude is due 
to the different number of data points StorNext Advanced Reporting 
aggregates when calculating the value for each pixel in the graph. Be 
aware of this effect as you work with graphs and time ranges in 
StorNext Advanced Reporting.

32 Minute time range: Peak amplitude is 2.1MB/second

128 Minute rime range: Peak amplitude is 0.9MB/second
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Note: StorNext Advanced Reporting always uses the finest resolution 
of data available in the database. Finer-grained data is available 
for more recent time ranges as opposed to time ranges further 
in the past. This affects the number of data points StorNext 
Advanced Reporting aggregates when displaying a graph, and 
in turn can affect amplitude.
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This chapter provides information to help you interpret the reports 
available in StorNext Advanced Reporting and contains the following 
sections:

• Reports and Graphs

• Report Descriptions

Reports and Graphs

To access the StorNext Advanced Reporting reports, click the Reports 
menu on the StorNext Advanced Reporting user interface (see 
Figure 23).
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Figure 23  Reports Menu

Each report available in StorNext Advanced Reporting is made up of two 
or more graphs. Some graphs appear in more than one report. Table 3 
lists the graphs included in each report. For information about 
interpreting each report, see Report Descriptions on page 39. For 
information about viewing reports, see Using the Report Window on 
page 18.

In Table 3, reports are designated as (L) for layered graphs or (S) for 
stacked graphs. This distinction does not apply to graphs that report 
only a single variable.

Table 3  StorNext Advanced 
Reporting Reports and Graphs Report Graphs

Ethernet I/O Report • Ethernet Activity (S)
• ethn Activity

Fibre Channel I/O Report • Fibre Channel Activity (S)

• FCn Activity
(These reports are available for StorNext 
Metadata Appliances only.)

CPU load Report • CPU Load Average
• CPU stats in % (S)
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Report Descriptions

This section describes the graphs included in the following reports 
available in StorNext Advanced Reporting:

• Ethernet I/O Report on page 39

• Fibre Channel I/O Report on page 41 (for StorNext Metadata 
Appliances only)

• CPU load Report on page 43

• Memory Report on page 45

• FS Reports on page 47

• Self Report on page 51

Ethernet I/O Report The Ethernet I/O report displays detailed information about the amount 
of data passing through the Ethernet ports in the system. The report 
contains the following graphs:

• Ethernet Activity

Memory Report • Memory usage (always base 1024) (S)
• Swap usage (always base 1024) (S)

FS Reports • Space (S)
• inodes (S)
• Connections (L)
• CPU usage in % (L)
• Size (L)

Self Report • CPU Load Average
• CPU stats in % (S)
• Logging Loop Time (S)

Report Graphs
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• ethn Activity

View the Ethernet I/O report when you need to monitor writes to and 
reads from the system using the Ethernet ports. For example, if you have 
replication configured on the system, you should view this report daily 
to make sure you see replication traffic occurring at the correct times.

If you don’t have replication configured, you will see minor heartbeat 
and web management traffic and then occasional spikes for metadata 
requests, allocations, and deletes.

To access the Ethernet I/O report, select Reports > Ethernet I/O.

Ethernet Activity

The Ethernet Activity graph (see Figure 24) displays the amount of data 
passing through all of the Ethernet ports in the system.

Figure 24  Ethernet Activity 
Graph

Use the Ethernet Activity graph to monitor writes to and reads from 
the system using the Ethernet ports.

• The graph shows each port in a different color.

In the example above, the symmetry between the four ports 
indicate the Ethernet ports are bonded (not segmented) and traffic 
is balanced across the ports.

• Write activity (above the zero line) indicates target replication to the 
system (if configured), web management activity, heartbeat traffic, 
and metadata traffic.

• Read activity (below the zero line) indicates source replication from 
the system (if configured), web management activity, heartbeat 
traffic, or metadata traffic.
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ethn Activity

The ethn Activity graph (see Figure 25) displays the amount of data 
passing through Ethernet port n. A graph appears for each Ethernet 
port in the system, for example, eth0, eth1, eth2, and eth3.

Figure 25  ethn Activity Graph

Use the ethn Activity graph to monitor writes to and reads from the 
system using Ethernet port n.

• Write activity (above the zero line) indicates target replication to the 
system (if configured), web management activity, heartbeat traffic, 
and metadata traffic.

• Read activity (below the zero line) indicates source replication from 
the system (if configured), web management activity, heartbeat 
traffic, or metadata traffic.

Fibre Channel I/O 
Report

The Fibre Channel I/O report displays detailed information about the 
amount of data passing through the Fibre Channel ports in the system.

Note: The 2 Fibre Channel I/O report graphs apply to StorNext 
Metadata Appliances only.

The report contains the following graphs:

• Fibre Channel Activity

• FCn Activity

Fibre Channel Activity

The Fibre Channel Activity graph (see Figure 26) displays the amount 
of data passing through all of the Fibre Channel ports in the system.
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Figure 26  Fibre Channel 
Activity Graph

Use the Fibre Channel Activity graph to monitor writes to and reads 
from the system using the Fibre Channel ports.

• The graph shows each port in a different color.

• Fibre Channel write activity (above the zero line) occurs during 
backups.

• A regular backup schedule results in repeating patterns.

• A high amplitude left edge indicates that a large number of 
client backups start at the same time.

• Fibre Channel read activity (below the zero line) occurs during VTL 
restore operations.

• Symmetrical read and write activity (that is, mirrored patterns above 
and below the zero line) indicate Tivoli Storage Manager (TSM) tape 
reclamation.

• An orange line at the top of the graph indicates a Fibre Channel 
abort occurred.

FCn Activity

The FCn Activity graph (see Figure 27) displays the amount of data 
passing through Fibre Channel port n. A graph appears for each Fibre 
Channel port in the system, for example, port 4, port 5, and so on.
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Figure 27  FCn Activity Graph

Use the FCn Activity graph to monitor writes to and reads from the 
system using Fibre Channel port n.

• Fibre Channel write activity (above the zero line) occurs during 
backups.

• A regular backup schedule results in repeating patterns.

• A high amplitude left edge indicates that a large number of 
client backups start at the same time.

Fibre Channel read activity (below the zero line) occurs during VTL 
restore operations.

CPU load Report The CPU Load report displays information about the usage of CPU 
resources in the system. The report contains the following graphs:

• CPU Load Average

• CPU stats in %

To access the CPU load report, select Reports > CPU load.

CPU Load Average

The CPU Load Average graph (see Figure 28) displays the one minute 
load average for the system.

Figure 28  CPU Load Average 
Graph
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Use the CPU Load Average graph to determine if the system has 
adequate CPU resources.

• The load average represents the average number of processes, in a 
one minute time period, that were running on a CPU or that were 
waiting to run on a CPU.

• A load average higher than the number of CPU cores in the system 
indicates that the system is CPU limited.

For example, StorNext Metadata Appliances have four CPUs. In this 
case, a load average of greater than four means that some 
processes had to wait for an available CPU before running. In 
contrast, a load average of less than four means no processes had 
to wait for a CPU.

CPU stats in %

The CPU stats in % graph (see Figure 29) displays the relative CPU 
usage for seven categories of processes (see Table 4).

Figure 29  CPU stats in % 
Graph

Table 4  Categories of 
Processes in the CPU stats in % 
Graph

Process 
Category Description

iowait
(red)

The CPU is waiting for an I/O device to respond 
(for example, the system is waiting on a disk).

irq
(gold)

The CPU is handling an interrupt request related 
to I/O (for example, network, Fibre Channel, disk, 
keyboard, or serial port activity).

softirq
(brown)

The CPU is handling a high level I/O task (for 
example, timer interrupts or packets in the  
TCP/IP stack).
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Use the CPU stats in % graph to see how CPU resources are allocated 
among different categories of processes. The amount of CPU activity 
consumed by each category of process is expressed as a percentage. The 
percentages (including the value for idle, which is not shown in the 
graph) total to 100%.

If a system has a high CPU load average (see CPU Load Average on 
page 43), then consider the following guidelines:

• A high percentage of system (green) and user (blue) activity 
indicates the system is CPU limited. Add more CPUs to improve 
system performance.

• A high percentage of iowait (red) activity indicates the system is I/O 
limited. Add more disks or arrays to improve system performance.

Memory Report The Memory report displays information about StorNext MDC memory 
usage. You can view this report to make sure the cache settings are 
configured to maximize system performance.
The report contains the following graphs:

• Memory usage

• Swap usage

system
(green)

The CPU is handling a kernel process (for 
example, filesystem operations related to the 
StorNext or blocklet filesystems).

nice
(black)

The CPU is handling processes that have lower 
priority (for example, background processes).

user
(blue)

The CPU is handling processes that are not 
owned by the kernel (for example, deduplication 
as well as some space management and 
replication activities).

idle
(not shown)

The CPU is not handling one of the other process 
categories.

Process 
Category Description
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Note: In the following examples, some of the data in the Memory 
graphs may not be accurate.

To access the Memory report, select Reports > Memory.

Memory usage

The Memory usage graph (see Figure 30) monitors the amount of 
physical memory (RAM) used during system operation.

Note: For newly configured systems, you will see mostly free memory 
(light green). As the system increases the number of file 
systems and clients, monitor this graph often to make sure that 
there is as little free memory available as possible. This means 
the cache settings are configured to maximize performance.

Figure 30  Memory usage 
Graph

In the Memory usage graph:

• Values are in GB. The graph always displays values in base 1024, no 
matter what base is selected in the Base list (see Selecting the Base 
on page 30).

• For standard memory (4 KB) pages, the graph displays the amount 
of memory that is free (green) and used (red). The graph also 
displays the amount of memory used for caching (yellow). Memory 
used for caching can be easily freed up, therefore it usually can be 
treated as available even though it is not free.

• For huge memory (2 MB) pages, the graph displays the amount of 
memory that is free (light blue) and used (dark blue).
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Swap usage

The Swap usage graph (see Figure 31) monitors the amount of virtual 
memory used during system operation.

Figure 31  Swap usage Graph

In the Swap usage graph:

• Values are in GB. The graph always displays values in base 1024, no 
matter what base is selected in the Base list (see Selecting the Base 
on page 30).

• The graph displays the amount of the disk swap file that is free 
(light blue) and used (dark blue).

FS Reports The File System (FS) reports provide file system statistics pertaining to 
the primary and secondary system nodes. Statistics on the primary and 
secondary nodes are monitored independently and they differ since the 
passive node doesn't run the FS processes for the user file systems and 
the one process (FS1) that runs on both nodes has a larger footprint on 
the active node.
Each FS report shows a single file system server process running on the 
StorNext MDC Node. The StorNext MDC can have up to four of these 
processes running. These processes will have unique FS names.

Note: The FS names depend on the names that users give their file 
systems. The name would follow the FS_file system name 
convention. For example, if a StorNext system has two 
configured file systems named filesystem1 and filesystem2, 
two reports will display from the Reports menu named 
FS_filesystem1 and FS_filesystem2. StorNext Advanced 
Reporting displays reports for up to 10 file systems.
StorNext Advanced Reporting 2.0.6 User’s Guide 47



Chapter 4: Advanced Reports
Report Descriptions
The FS reports display detailed statistics about the configured file 
systems in the StorNext MDC. Each FS report contains the following five 
graphs:

• FS Space

• FS inodes

• FS Connections

• FS CPU usage in %

• FS Size

To access the FS reports, select Reports > FS_Name, where Name is the 
name of the file system.

FS Space

The FS Space graph displays the number of bytes of data space 
currently in use or available for use by file system clients. This graph 
shows you exactly when file system clients started to quickly fill space in 
the file system.

This graph is a stacked graph, meaning the graph superimposes data for 
two or more variables on top of each another. A different color is 
assigned to each variable, so you can see how the values for each 
variable differ over time.

Figure 32  FS Space Graph

• Bytes Free (light green) — Displays the number of bytes of data 
space available for use by StorNext file system clients. As the level of 
free data space gets low, expanding the data space for the given file 
system should be considered.

• Bytes Used (blue) — Displays the number of bytes of data space 
currently in use by StorNext file system clients.
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FS inodes

The FS inodes graph displays the number of inodes that are currently 
available or are in use by the selected file system.

A large number of inodes in use in the file system indicates that either 
the file system contains a lot of files or that it contains a lot of 
fragmented files.

Figure 33  FS inodes Graph

• inodes free (light green) — Displays the number of free inodes 
available. These inodes are available for use in allocating files in the 
selected StorNext file system. This value should not reach zero 
unless all of the StorNext metadata space has been consumed. 
Inodes are allocated dynamically.

• inodes used (blue) — Displays the number of inodes allocated. 
These inodes are in use by the StorNext file system. This graph will 
show the growth in the number of files used in the StorNext file 
system.

FS Connections

The FS connections graph displays the number of StorNext DLC and 
SAN clients that are connected to the selected file system.

Use this graph to view the history of your client connections. The 
number of connections will remain steady if the client computers are 
left running all the time.
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Figure 34  FS Connections 
Graph

• Proxy Connections (light green) — Displays the number of StorNext 
DLC clients connected to this StorNext file system.

• Connections (blue) — Displays the number of StorNext SAN clients 
connected to this StorNext file system.

FS CPU usage in %

The FS CPU usage in % graph displays the percentage of CPU resources 
consumed by the FS process for the selected file system.

Figure 35  FS CPU Usage in % 
Graph

FS Size

The FS size graph displays the total amount of physical and virtual 
memory in use by the selected file system.

If the file system’s performance degrades, then check this graph for an 
increase of physical memory (size) in use. This could indicate that 
runaway processes are doing lots of busy work (thrashing) or that 
caching is set too high.

A rapid increase in physical memory usage (for example, the file system 
was using around 200 MB of memory suddenly shot up to 2 GB) may 
indicate a client or caching issue. If this occurs, you should check the 
cvlogs to see what happened at the time of the increase.
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Figure 36  FS Size Graph

• Size (light green) — Indicates the total amount of physical memory 
in use by the by the file system. High levels of memory consumption 
by the StorNext FS process could lead to performance if virtual 
memory swapping once contention for memory resources is seen.

• Vsize (blue) — Indicates the total amount of virtual memory in use 
by the file system. The virtual memory size will display the total 
process footprint for the file system.

Self Report The Self report displays information about the CPU resources used by 
the system and by the StorNext Advanced Reporting for Service logging 
database. The report contains the following graphs:

• CPU Load Average

• CPU stats in %

• Logging Loop Time (logarithmic scale)

CPU Load Average

See CPU Load Average on page 43.

CPU stats in %

See CPU stats in % on page 44.

Logging Loop Time (logarithmic scale)

The Logging Loop Time graph (see Figure 28) displays how long it 
takes StorNext Advanced Reporting for Service to gather performance 
data and write it to the logging database.
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Figure 37  Logging Loop Time 
Graph

Use the Logging Loop Time graph to determine the impact of StorNext 
Advanced Reporting for Service logging on system performance.

• The graph displays loop times in milliseconds on a logarithmic scale.

• The time to gather data (red) and update the database (blue) is 
typically about 2 milliseconds.

• Loop time can increase during periods of high CPU usage.
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A Adaptive Deduplication   The mode of deduplication which allows 
data deduplication to run concurrent with the backup being 
ingested. The deduplication process will adapt to the speed of 
the ingest.

B Bit    The basic unit of data in a binary numbering system (binary 
digit), represented by a 0 or a 1. Eight bits equals one byte.

Block   During deduplication, data is divided into variable length blocks 
(also called blocklets). Redundant blocks are removed and 
replaced with pointers to the original copy of the block.

Blockpool   See Deduplication Pool.

Byte    The basic unit of computer memory which is large enough to 
hold one character.

C Compress   A process of removing fine-grained redundancy from data 
prior to storing or transmitting it. The granularity may vary, but 
generally compression deals with redundancy in grains of a few 
bytes.

Continuous Replication   Data replication is the process of creating 
and managing duplicate versions of your data. Once a data set 
StorNext Advanced Reporting 2.0.6 User’s Guide 53



Glossary
has been deduplicated, it may be replicated (nonredundant 
data is transmitted from a source system to a target system). 
Deduplication tags representing files with a high probability of 
being replicated (for example, NAS share marked for replication) 
are queued for replication after deduplication is complete 
without regard to the replication schedule. This continuous 
transmission of data is an optimization allowing replication to 
be used with low bandwidth networks.

D Deduplicate   A process of removing coarse-grained redundancy from 
data prior to storing or transmitting it. The granularity may vary, 
but generally deduplication deals with redundancy in grains of 
several kilobytes.

Deduplication Pool   The term used to refer to the collection of unique 
data stored in a StorNext MDCwith deduplication enabled. The 
size of the deduplication pool is reported as the After Reduction 
statistic on the StorNext GUI and is a measure of the disk space 
occupied by all data backed up to the StorNext MDC after the 
data has been deduplicated and compressed.

Deferred Deduplication   The mode of deduplication which begins 
only after the deferred deduplication window. Typically, 
deferred deduplication begins after the backup ingest is 
complete.

Deferred Deduplication Window   A defined window during which no 
deduplication will take place. This allows maximum system 
resources to be devoted to data ingest thus allowing a faster 
backup. The deferred deduplication window applies only to the 
share/partition for which it is defined. It is possible to define a 
second share/partition and perform backups that overlap the 
same time period. The data written to the share without a 
defined deferred deduplication window will be subjected to 
adaptive deduplication.

F File or Cartridge Replication   File or cartridge replication (FCR) 
extends continuous and namespace replication from operating 
at a share/partition level and zooms in to the file-directory/
virtual cartridge level. FCR can be used to synchronize the 
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content of a share or partition that is concurrently accessible on 
both source and target StorNext MDC.

I Ingest   The process of writing data from an external system or 
application to disk in a StorNext MDC.

Inline deduplication   The removal of redundancies from data before 
or as it is being written to a backup device.

L LUN   Logical Unit Number. A logical storage unit that corresponds to 
a storage volume. A storage array can be partitioned into 
multiple LUNs.

N Namespace   The term that applies to metadata required to reconstruct 
deduplicated data back into its native application format. It is 
used in phrase combinations such as “namespace replication” 
or “synchronize the namespace.”

Namespace Replication   When a replication set is scheduled for 
transmission, the system scans the files comprising the 
replication set and a namespace file is created. A namespace 
file contains the complete set of deduplication tags for the 
replication set. Data that is active (a NAS file that is open) or 
data that is not yet deduplicated is not included in the 
namespace file. The namespace file is then deduplicated and 
transmitted to the target system after the data transmission of 
the replication set is complete. Once both the replication set 
and namespace file have been transmitted to the target 
system, the replication can be recovered.

NTP   Network Time Protocol. A protocol used to synchronize time 
between devices over a network.

P Partition   A StorNext storage destination for data transferred by FC or 
iSCSI where the structure is considered to be a virtual tape 
library (VTL) and the content is written to virtual tape cartridges.
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R Recover   The StorNext procedure to make replicated and namespace 
data accessible on the StorNext MDC to which it had been 
replicated. If a share was replicated, then a share is recovered. If 
a partition is replicated, then a partition is recovered. It is not 
possible to convert a share to a partition (or vice-versa) during 
the recovery procedure.

S Share   A StorNext storage destination for data transferred by NAS 
where the content is treated as files and directories.

Source   The term often applied to the StorNext MDC that is sending a 
copy of deduplicated data to a second StorNext MDC.

Space Reclamation   A multi phase process used to recover disk space 
on a StorNext MDC. During space reclamation, the system 
searches for redundant blocks that were not captured during 
deduplication. The system also deletes blocks associated with 
expired virtual tape cartridges (VTCs) and files that have been 
deleted from NAS shares.

T Tag   A united of ingested data. During deduplication, a tag is divided 
into variable length blocks (also called blocklets).

Target   The label often applied to the StorNext MDC that is receiving a 
copy of deduplicated data.

Truncation   A process used to recover disk space on a StorNext MDC. 
When deduplicated data is truncated, only the metadata is 
available on the filesystem. This reduces the amount of capacity 
required in the filesystem. Once truncated, the file must be 
reconstituted using its tag before you are able to access the file.

V Virtual Tape Cartridge (VTC)   An emulation of a real, physical tape 
cartridge, including a type, any nonvolatile memory associated 
with the case housing, and that recording medium. Also 
referred to as a virtual tape volume or a virtual volume.
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